Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



7 страниц V   1 2 3 > » 

>  раскраска строки FormEX
4andriy
Отправлено: 01.04.24, 14:44


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


denis84 @ Сегодня, 14:07 * ,
довідник співробітників
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178676 · Ответов: 6 · Просмотров: 911
 

>  раскраска строки FormEX
4andriy
Отправлено: 01.04.24, 13:26


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


тільки там не ТекущийДокумент, а Текущая строка
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178673 · Ответов: 6 · Просмотров: 911
 

>  раскраска строки FormEX
4andriy
Отправлено: 01.04.24, 8:05


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


для 1с 7.7
для раскраски использую FormEx
надо раскрасить текущую строку
выделеная ячейка сейчас синяя, а надо что-бы ячейка была одним цветом, а строка другим

если пишу такой код тогда красит всю таблицу:
Если ПустоеЗначение(ТекущийЭлемент().Наименование)=0 Тогда Возврат "BRUSH[" + ПолучитьЦвет(200,200,100) + "]"; КонецЕсли;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178663 · Ответов: 6 · Просмотров: 911
 

>  список элементов без каталогов
4andriy
Отправлено: 27.03.24, 17:45


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


1с 7.7 Предприятие
при использовании в коде:
СписокЭлементов.ДобавитьЗначение(Сотрудники.ТекущийЭлемент());


почему-то в списке сотрудников показывает еще группы, например:
кадри
офис
грузчики
Иванов И.И
Петров И.И
Сидоров И.И

от чего зависит что-бы не показывало группы, а только сотрудников?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178647 · Ответов: 1 · Просмотров: 760
 

>  работа с временем
4andriy
Отправлено: 31.10.23, 13:10


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


1с 7.7 Предприятие.
Мне нужно определить время между операциями.

время1=ТекущееВремя();
Собщить(время1);
...
время2=ТекущееВремя();
Собщить(время2);
...
время3=время2-время1;
Собщить(время3);


ошибка:
Операция вычитания не определена для строковых величин
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177888 · Ответов: 3 · Просмотров: 757
 

>  окно на весь екран
4andriy
Отправлено: 16.10.23, 14:07


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


denis84 @ Сегодня, 15:00 * ,
я перепутал - это журнал ОБЩИЙ открывается не на весь екран
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177817 · Ответов: 6 · Просмотров: 1236
 

>  окно на весь екран
4andriy
Отправлено: 16.10.23, 13:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


denis84 @ Сегодня, 14:49 * ,
проблема в том, что если нажать эти кнопки без скрипта выходит такое меню (нажать Alt + пробел) :

Restore - активно (скидает окно)
Move - не активно
Size - не активно
Minimize - активно
Mazimize - не активно
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177815 · Ответов: 6 · Просмотров: 1236
 

>  окно на весь екран
4andriy
Отправлено: 16.10.23, 12:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


1с 7.7
при открытии формы надо всегда нажимать "на весь екран" (квадратик)
а как сделать что-бы форма всегда открывалась на весь екран?
причем все формы открываются не на весь екран(

нашел такие варианты но они не работают:

вариант 1:

Если Форма.МодальныйРежим() = 1 Тогда 
  Окна = СоздатьОбъект("Окна");
  Окна.Максимизировать(Форма);
КонецЕсли;


вариант 2:

WSHShell = СоздатьОбъект("WScript.Shell"); 
WSHShell.SendKeys("%");
WSHShell.SendKeys("{LEFT}{DOWN 5}{ENTER}");
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177812 · Ответов: 6 · Просмотров: 1236
 

>  управление текстом програмно
4andriy
Отправлено: 22.09.23, 17:36


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


volodya1122 @ 19.09.23, 16:54 * ,
Насчет слова "Счет" на самой форме документа. Можно сделать несколько вариантов надписи в разных цветах, и по условию показывать нужное.

а как показывать на форме и скрывать по условию?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177729 · Ответов: 7 · Просмотров: 1151
 

>  управление текстом програмно
4andriy
Отправлено: 18.09.23, 14:56


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


volodya1122 @ Сегодня, 14:43 * ,
журнал документов - новая строка - выбор документа - например СЧЕТ - дальше открывается сам счет. нужно что-бы если в документе есть ошибка слово "СЧЕТ" был написан красным до распечатывания. в идеале хочу запрограмировать что-бы он светился) хочу добавить в 1с немного визуального оформления. ничего по функционалу - только красота.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177718 · Ответов: 7 · Просмотров: 1151
 

>  управление текстом програмно
4andriy
Отправлено: 18.09.23, 10:24


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


AnryMc @ Сегодня, 11:00 * ,
форму умею, я хочу что-бы текст типа "Акт" или "Счет" вверху формы документа можно было раскрашивать вручную без перехода в конфигуратор

4andriy @ Сегодня, 11:11 * ,
на форме элемента
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177716 · Ответов: 7 · Просмотров: 1151
 

>  управление текстом програмно
4andriy
Отправлено: 16.09.23, 13:26


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


в конфигураторе можно изменять размер и цвет шрифта
нужно менять без конфигуратора сразу на форме, например кнопкой
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177713 · Ответов: 7 · Просмотров: 1151
 

>  реализация простой статистики
4andriy
Отправлено: 15.09.23, 21:53


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


denis84 @ Сегодня, 22:03 * ,
в справочник мне проще записать

4andriy @ Сегодня, 22:10 * ,
надо куда-то записать и дату и значение, как его добавить в один периодический не знаю
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177712 · Ответов: 3 · Просмотров: 907
 

>  реализация простой статистики
4andriy
Отправлено: 15.09.23, 19:03


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


нужно записать значение среднего зароботка на определенную дату, что-бы в конце месяца или за период вывести статистику по дням
в идеале потом вывести эти значения в графике

пример:
дата - значение
14.09.2023 - 100
15.09.2023 - 200
... и т.д.

на данный момент значение каждый раз перезаписываются и данные за предидущий день удаляются
//------------------------------------------------------------------
Процедура ЗПСредняя()
ПодсчетЗПСредняя(); //считаем значение СуммаЗПДень за день
ДатаЗП=ТекущаяДата();
СуммаЗП=СуммаЗПДень;
Записать();
КонецПроцедуры
//------------------------------------------------------------------
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177710 · Ответов: 3 · Просмотров: 907
 

>  Ошибка отбора: УстановитьОтбор - Неверное имя реквизита
4andriy
Отправлено: 11.09.23, 8:56


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


4andriy @ Вчера, 16:09 * ,
Работает. Надо было добавить Группу отбора "Контрагент".
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177684 · Ответов: 3 · Просмотров: 725
 

>  Ошибка отбора: УстановитьОтбор - Неверное имя реквизита
4andriy
Отправлено: 10.09.23, 15:09


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


//******************************************************************************
Процедура ПриВыбореВидаОтбора()
    ТекущийВидОтбора = СписокВидовОтбора.ПолучитьЗначение(СписокВидовОтбора.ТекущаяСтрока());
...
    ИначеЕсли ТекущийВидОтбора = "ПоКонтрагенту" Тогда
        Форма.СписокЗнач.Видимость(1);
        Форма.СписокВидовДокументов.Видимость(0);
        Форма.СписокЗнач.НазначитьТип("Справочник.Контрагенты");
...
    КонецЕсли;
    ПриВыбореЗнач();
КонецПроцедуры // ПриВыбореВидаОтбора
//******************************************************************************


При выборе по контрагенту пусто.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177683 · Ответов: 3 · Просмотров: 725
 

>  Ошибка отбора: УстановитьОтбор - Неверное имя реквизита
4andriy
Отправлено: 10.09.23, 13:04


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


4andriy @ Вчера, 21:25 * ,
ошибки уже нет, работает выборка по фирме, автору, а по контрагенту нет
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177682 · Ответов: 3 · Просмотров: 725
 

>  Ошибка отбора: УстановитьОтбор - Неверное имя реквизита
4andriy
Отправлено: 09.09.23, 20:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


//******************************************************************************
//
Процедура ПриВыбореЗнач()
    ТекущийВидОтбора = СписокВидовОтбора.ПолучитьЗначение(СписокВидовОтбора.ТекущаяСтрока());
    Если ТекущийВидОтбора = "ПоФирме" Тогда
        Форма.СписокВидовДокументов.Видимость(0);
        УстановитьОтбор("Фирма", СписокЗнач);
        ВидыОтбора("");
    ИначеЕсли ТекущийВидОтбора = "ПоКонтрагенту" Тогда
        Форма.СписокВидовДокументов.Видимость(0);
        УстановитьОтбор("Контрагент", СписокЗнач);
        ВидыОтбора("");
    ИначеЕсли ТекущийВидОтбора = "ПоАвтору" Тогда
        Форма.СписокВидовДокументов.Видимость(0);
        УстановитьОтбор("Автор", СписокЗнач);
        ВидыОтбора("");
    ИначеЕсли ТекущийВидОтбора = "ПоВидуДокумента" Тогда
        Форма.СписокЗнач.Видимость(0);
        ПриВыбореВидаДокумента();
    КонецЕсли;
КонецПроцедуры // ПриВыбореКонтрагента


Из списка выбираю контрагента, и тогда ошибка отбора:

УстановитьОтбор("Фирма", СписокЗнач);
{Журнал.Общий.Форма.ФормаСписка.Модуль(16)}: Неверное имя реквизита!
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #177681 · Ответов: 3 · Просмотров: 725
 

>  проблема адаптации обработки
4andriy
Отправлено: 05.10.22, 10:18


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


при открытии сторонней обработки были ошибки в строках, я поправил обрабока открылась, но не работают другие функции, подозреваю что неправильно адаптировал
//ИдентификаторКонфигурации = глИдентификаторКонфигурации(); - было с (), поставил без () и ошибка пропала
ИдентификаторКонфигурации = глРедакцияКонфигурации;
//СуммаЭксп = СокрЛ(Формат(глПересчет(Сумма,Валюта,Гривна,Курс,ДатаДок),"Ч17.2.")); - Курс и ДатаДок пришлось убрать но наверно из-за этого не работает сама обработка
СуммаЭксп = СокрЛ(Формат(глПересчетВалютыПоКурсу(Сумма,Валюта,Гривна),"Ч17.2.")); - тут может быть ошибка
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176401 · Ответов: 0 · Просмотров: 966
 

>  не могу передать значение с таблицы
4andriy
Отправлено: 28.09.22, 11:07


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


4andriy @ Сегодня, 10:52 * ,
Приклад:
set App = CreateObject("Medoc.ZApplication")
orgId = App.SeekOrg("11223344", "")
set pd= App.GetPrimaryDocs()
set Doc = pd.OpenOrCreateDocument(orgId ,"1С82АВР", "4", "24.11.2020", "1234", 0)
Приклад заповнення таблиці маршрутів для багатостороннього первинного документа:
set rsRoute = Doc.DataSets("TAB9000")
rsRoute.Edit()
rsRoute.Fields.Item("DOCROUTE_POSITION").Value = 0
rsRoute.Fields.Item("DOCROUTE_EDRPOU").Value = "11223344"
rsRoute.Fields.Item("DOCROUTE_NAME").Value = "Продавець"
rsRoute.Append()
rsRoute.Edit()
rsRoute.Fields.Item("DOCROUTE_POSITION").Value = 1
rsRoute.Fields.Item("DOCROUTE_EDRPOU").Value = "11110000"
rsRoute.Fields.Item("DOCROUTE_NAME").Value = "Покупець1"
rsRoute.Append()
rsRoute.Edit()
rsRoute.Fields.Item("DOCROUTE_POSITION").Value = 2
rsRoute.Fields.Item("DOCROUTE_EDRPOU").Value = "22220000"
rsRoute.Fields.Item("DOCROUTE_NAME").Value = "Покупець2"
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176369 · Ответов: 5 · Просмотров: 1735
 

>  не могу передать значение с таблицы
4andriy
Отправлено: 28.09.22, 9:52


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


Vofka @ Вчера, 9:58 * ,
rsMain.Fields.Item("TAB1_OV_NAME").Value = спДанные.Получить(ТекСтрока + "Единица");
- убрал строку и заработало TAB1_OV_NAME не существует



на даный момент ошибка:

Doc = pd.OpenOrCreateDocument(orgId,Бланк,,,ДокИД,0);
{C:\1C\ВИГРУЗКА ДОКУМЕНТIВ З 1С В М.Е.ДОК (V.7).ERT(1247)}: Плохой тип переменной


сам код:
//=====================================================================================
Процедура ВигрузитиОЛЕ_ВидатковаНакладна(App, pd, orgId, док, ДокИД)
    
    //pd = "2";
    //ДокИД= "1";
    //док="2";
    //додав orgid
    orgId = ВыбФирма;
    Бланк = "1С77ВН";
                    
    спДанные = СоздатьОбъект("СписокЗначений");
    ЗаповнитиРеквізити(спДанные, док);
    Doc = pd.OpenOrCreateDocument(orgId,Бланк,,,ДокИД,0);


4andriy @ Сегодня, 10:43 * ,
описание по методу:
OpenOrCreateDocument( orgId As Long, charCode As String, num As String, docDate As Date, ExDocID As
String, reWrite As Boolean ) As IZDocument
Повертає документ за вказаними параметрами, якщо документа не існує - то вібувається створення нового
документа. Якщо документ існує та вказано reWrite = true - то виконується перезапис існуючого документа.
Вхідні параметри:
orgId - внутрішній ідентифікатор організації в M.E.Doc, в якій необхідно створити документ. Для
отримання скористайтесь методом SeekOrg();
charCode – чаркод шаблону первинного документа;
num – номер документа;
docDate – дата документа;
ExDocID – зовнішній ідентифікатор документа;
reWrite – ознака виконання повторного створення існуючого документа при співпадінню ExDocID -
true/false (1/0).
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176368 · Ответов: 5 · Просмотров: 1735
 

>  доработка интеграции
4andriy
Отправлено: 23.09.22, 19:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


4andriy @ Сегодня, 18:11 * ,
исправлено, теперь ошибка:
Плохой тип переменной


4andriy @ Сегодня, 20:38 * ,
Відкриття або створення документу розділу "Реєстр електронних документів"
OpenOrCreateDocument( orgId As Long, charCode As String, num As String, docDate As Date, ExDocID As
String, reWrite As Boolean ) As IZDocument
Повертає документ за вказаними параметрами, якщо документа не існує - то вібувається створення нового
документа. Якщо документ існує та вказано reWrite = true - то виконується перезапис існуючого документа.
Вхідні параметри:
orgId - внутрішній ідентифікатор організації в M.E.Doc, в якій необхідно створити документ. Для
отримання скористайтесь методом SeekOrg();
charCode – чаркод шаблону первинного документа;
num – номер документа;
docDate – дата документа;
ExDocID – зовнішній ідентифікатор документа;
reWrite – ознака виконання повторного створення існуючого документа при співпадінню ExDocID -
true/false (1/0).
  Форум: Корзина · Просмотр сообщения: #176357 · Ответов: 2 · Просмотров: 765
 

>  доработка интеграции
4andriy
Отправлено: 23.09.22, 17:11


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


здравствуйте, при доработаке интеграции под свою конфигурацию
Інтеграція

такая ошибка:
Doc = pd.OpenOrCreateDocument(orgId, Бланк,,, ДокИД, 0);
Типы не совпадают


код:

Процедура ВигрузитиОЛЕ_АктВиконанихРобіт(App, pd, orgId, док, ДокИД) 
    
    Бланк = "1С77АВР";
    
    спДанные = СоздатьОбъект("СписокЗначений");
    ЗаповнитиРеквізити(спДанные, док);
    
    Doc = pd.OpenOrCreateDocument(orgId, Бланк,,, ДокИД, 0);
    Doc.DisableScripts();
    rsMain = Doc.DataSets();
    Если rsMain.Fields.Count() > 0 Тогда
        rsMain.Edit();
    Иначе
        rsMain.Append();
    КонецЕсли;
  Форум: Корзина · Просмотр сообщения: #176355 · Ответов: 2 · Просмотров: 765
 

>  Інтеграційна стиковка для 1С 7.7 та M.E.Doc
4andriy
Отправлено: 23.09.22, 17:04


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


fastiv @ 17.05.21, 18:34 * ,

Doc = pd.OpenOrCreateDocument(orgId, Бланк,,, ДокИД, 0);


Типы не совпадают это что значит?
  Форум: Отчеты / Обработки · Просмотр сообщения: #176354 · Ответов: 69 · Просмотров: 51483
 

>  не могу передать значение с таблицы
4andriy
Отправлено: 23.09.22, 17:00


Завсегдатай
****

Группа: Пользователи
Сообщений: 177
Регистрация: 25.07.11
Пользователь №: 10636


    КоличествоСтрок = спДанные.Получить("КоличествоСтрок");
    Для ном = 1 По КоличествоСтрок Цикл
        ТекСтрока = "R" + Прав("000" + ном,4);
        rsMain.Fields.Item("TAB1_A1").Value = ном;
        rsMain.Fields.Item("TAB1_NOMENKLATURA_NAME").Value = спДанные.Получить(ТекСтрока + "ТоварНаименование");
        rsMain.Fields.Item("TAB1_OV_NAME").Value = спДанные.Получить(ТекСтрока + "Единица");
        rsMain.Fields.Item("TAB1_A3").Value = спДанные.Получить(ТекСтрока + "Количество");
        rsMain.Fields.Item("TAB1_A5").Value = спДанные.Получить(ТекСтрока + "ЦенаБезНДС");
        rsMain.Fields.Item("TAB1_A6").Value = спДанные.Получить(ТекСтрока + "Сумма");
        rsMain.Post();
        Если ном <> КоличествоСтрок Тогда
            rsMain.Append();
        КонецЕсли;
    КонецЦикла;


ошибка:

rsMain.Fields.Item("TAB1_OV_NAME").Value = спДанные.Получить(ТекСтрока + "Единица");
Неизвестная ошибка


заработало
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176353 · Ответов: 5 · Просмотров: 1735
 

7 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 20.05.24, 15:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!