Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



11 страниц V   1 2 3 > » 

>  Связка Вин 2008 + SQL + 1C 7.7
Sharzem
Отправлено: 13.11.20, 11:20


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Язик в SQL Кирилиця ?
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #168215 · Ответов: 4 · Просмотров: 189
 

>  Добавить поле ручного ввода. Бухгалтерский учёт для Украины 7.70.252
Sharzem
Отправлено: 01.11.20, 10:25


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(graf.vorontsov @ 28.10.20, 18:39) *
Поле это должно быть в каждой строке ТМЦ

05040.gif
Текстові поля в табличній частині документів, як правило, призводять до збільшення об'єму інфомаційної бази, якщо вона файлова... Для SQL - не принципово. Вам потібно було це врахувати. Зі своєї практики: подібне поле було в документі "Банківська виписка", прийшлося грохнути його, але був затачений час допоки з'ясували проблему.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #167856 · Ответов: 6 · Просмотров: 587
 

>  Как создать ссылку на определенную строку ТаблицыЗначений? 1с 7.7 конф 7.7.003
Sharzem
Отправлено: 23.09.20, 8:56


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ Вчера, 17:12 * ,
Намагання в циклах знаходити потрібне значення - несінитниця.
Ваш код:
А=ТЗ.ТекущаяСтрока();// ЗАПОМИНАЕМ СТРОКУ И ПРИСВАИВАЕМ ЕЕ ПЕРЕМЕННОЙ А
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 Цикл
    Если (ТЗ.ЗАКАЗ=Расх.НомерЗаказа) Тогда
        ТЗ.СуммаАкс =  Расх.Итог("СуммаСНДС");
    КонецЕсли;
КонецЦикла;

Можете замінити на:
    лпНомерЗаказа = Расх.НомерЗаказа;
    лпНомерИскомойСтроки = "";
    Если ТЗ.НайтиЗначение(лпНомерЗаказа,лпНомерИскомойСтроки,"ЗАКАЗ") = 1 Тогда
        //Якщо потрібно вставити в поточну (нову) строку, використовуєте:
        ТЗ.СуммаАкс = Расх.Итог("СуммаСНДС");
        //Але якщо потрібно вставити в лпНомерИскомойСтроки, потрібно:
        ТЗ.УстановитьЗначение(лпНомерИскомойСтроки,"СуммаАкс",Расх.Итог("СуммаСНДС"));
    КонецЕсли;

При використанні метода НоваяСтрока(), ТекущаяСтрока() = "" і визначати її потрібно за допомогою ТЗ.НомерСтроки або ТЗ.КоличествоСтрок().
Позиціонування через ПолучитьСтрокуПоНомеру() може спрацьовувати не вірно, оскільки в процесі обробки даних може відбуватися "зміщення"
(як приклад, видалення стрічок) і ТекущаяСтрока() вже <> КоличествоСтрок().
Користуйтеся методами НайтиЗначение(), ПолучитьЗначение() та УстановитьЗначение(). Уявляйте собі що у Вас не 200 стрічок та 200 документів,
а по 200 000 тих і тих, тоді модель ВыбратьСтроки() и Пока ПолучитьСтроку() = 1 Цикл використовуватимете лише тільки один раз.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #166691 · Ответов: 6 · Просмотров: 215
 

>  Мини ФП 54.01 кроме X отчета ничего не работает
Sharzem
Отправлено: 22.07.20, 13:30


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Irinel @ Вчера, 14:51 * ,
faceoff.gif
СтрокаКоманды = "execute_report;x1;12321;";
Чому?:
СтрокаКоманды = "cashier_registration;1;0;";

Не зрозуміли ?
Потрібно: СтрокаКоманды = "cashier_registration;1;12321;";

У Вас не відбувається ідентифікація, тому воно і мовчить, і нічго не працює.

Sharzem @ Сегодня, 13:23 * ,
Вийшло ? Чи ще ні ?
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #164952 · Ответов: 10 · Просмотров: 584
 

>  v7: Ресурсы числовой кнопки выбора в 1crcrus.dll
Sharzem
Отправлено: 04.07.20, 7:51


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(jahhh @ 02.07.20, 22:51) *
я хочу отыскать и отредактировать всю форму с циферками

Питання: А чому не можна просто збільшити шрифт форм для тих хто цього потребує ?
"Сервис" => "Параметры" => "Интерфейс" => "Формы" => "Выбрать шрифт"
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164459 · Ответов: 10 · Просмотров: 365
 

>  Выбор минимальной даты в ТаблицеЗначений 1С 7.70.003 торговля склад для Украины?
Sharzem
Отправлено: 25.06.20, 15:08


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


denis84 @ Сегодня, 14:18 * ,
Результат той самий. Добавити лише Прервать. Сам так роблю іноді.
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    МинДата = ТЗ.ПолучитьЗначение(номерСтроки,номер или идентификатор колонки);
    Сообщить(МинДата);
    Прервать;
КонецЦикла;

На ДБФ відпрацює однаково. Мала затримка на виборці.
Можна ще так:
ТЗ.ВыбратьСтроки();
Если ТЗ.ПолучитьСтроку() = 1 Тогда
    МинДата = ТЗ.ПолучитьЗначение(номерСтроки,номер или идентификатор колонки);
    Сообщить(МинДата);
КонецЕсли;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164215 · Ответов: 5 · Просмотров: 423
 

>  Как создать таблицу с данными, которая отдельно может храниться 1с 7.7 конф 7.7.003
Sharzem
Отправлено: 25.06.20, 14:21


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ Вчера, 21:52 * ,
Якщо розмова про Загальний журнал документів:
ЗакладкиОтбора(<ИмяОтбора>,<ФлагОтбораЗначенийВИнтервалеЖурнала>,<ФлагУстановкиЗначенияОтбора>,<ЗначениеОтбора>)
Назначение:
Установить в форме журнала закладки для интерактивного осуществления отбора.
Параметры:
<ИмяОтбора - строка с именем отбора;
<ФлагОтбораЗначенийВИнтервалеЖурнала> -:
1 - значения отбора выбираются по документам в установленном интервале журнала,
0 - значения отбора выбираются по всем документам журнала;
<ФлагУстановкиЗначенияОтбора> -:
1 - сразу выбирается отбор по параметру <ЗначениеОтбора>,
0 - отбор устанавливается на первое существующее значение;
<ЗначениеОтбора> - значение отбора.
Замечание:
Метод доступен только в контексте Модуля формы журнала.

Якщо вести мову про SQL, то Вам спочатку сюди: Мова SQL
Описати "по швидкому" не зможу. Маэ бути розуміння.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164213 · Ответов: 7 · Просмотров: 644
 

>  Как создать таблицу с данными, которая отдельно может храниться 1с 7.7 конф 7.7.003
Sharzem
Отправлено: 24.06.20, 13:14


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(mut @ 23.06.20, 18:34) *
В 7.7 регистры так не работают

icon_beer17.gif Підтримую.
Цитата(ZUBR @ 22.06.20, 23:35) *
Я хочу создать отдельную таблицу, в которой бы хранились ссылки на все документы

Таке реально якщо у Вас SQL. Навіть зміни в конфігурацію вносити не потрібно. Створюємо там відповідні таблиці і там зберігаємо і звідти дістаємо.
Чи зможете Ви таке реалізувати ? Якщо не знаєте механізм прямих запитів, не думаю...

Цитата(ZUBR @ 22.06.20, 23:35) *
Чтобы каждый раз не перебирать все документы.

Відбір в Загальному журналі документів. Хоча запит по "Статусу" також відпрацює швидко від початку тисячоліття.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164174 · Ответов: 7 · Просмотров: 644
 

>  сравнить много значений
Sharzem
Отправлено: 11.06.20, 13:21


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(volodya1122 @ 11.06.20, 11:13) *
Спеціально для мене заморочились?

Зайнятися немає чим. Радий, що оцінили.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163778 · Ответов: 7 · Просмотров: 477
 

>  сравнить много значений
Sharzem
Отправлено: 11.06.20, 8:59


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(volodya1122 @ 10.06.20, 14:20) *
проверяю в табличной части документа на дубли контрагентов

А мені не подобається Ваш код...
Я б реалізував би так:
    лпПустоеЗначение = ПолучитьПустоеЗначение("Справочник.Контрагенты");
    
    лпТаблЧасть = СоздатьОбъект("ТаблицаЗначений");//Копія табличної частини для отримання номерів строк
    лпТаблЗнач = СоздатьОбъект("ТаблицаЗначений");//Місце пошуку дублів
    
    ВыгрузитьТабличнуюЧасть(лпТаблЧасть,"Контрагент");
    лпТаблЗнач.Загрузить(лпТаблЧасть);
    
    лпТаблЗнач.НоваяКолонка("Количество");//Для підрахунку кількості дублів
    лпТаблЗнач.Заполнить(1,,,"Количество");
    лпТаблЗнач.Свернуть("Контрагент","Количество");
    лпТаблЗнач.Сортировать("Количество");//Сортуємо
    
    лпКвоСтрок = лпТаблЗнач.КоличествоСтрок();
    Для лпСчетчик = 1 По лпКвоСтрок Цикл
        лпНомСтроки = (лпКвоСтрок+1)-лпСчетчик;//Йдемо знизу вверх
        лпКвоПовтор = лпТаблЗнач.ПолучитьЗначение(лпНомСтроки,"Количество");
        Если лпКвоПовтор = 1 Тогда// Продовжувати пошук не потрібно, вище дублів немає
            Прервать;
        КонецЕсли;
        лпКонтрагент = лпТаблЗнач.ПолучитьЗначение(лпНомСтроки,"Контрагент");
        Если ПустоеЗначение(лпКонтрагент) = 1 Тогда//Може бути і таке, це не основне завдання.
            Продолжить;
        КонецЕсли;
        лпИскомаяСтрока = "";
        лпТекст = "";
        Пока лпТаблЧасть.НайтиЗначение(лпКонтрагент,лпИскомаяСтрока,"Контрагент") = 1 Цикл
            Если ПустаяСтрока(лпТекст) = 1 Тогда
                лпТекст = " разів в стрічках № "+лпИскомаяСтрока;
            Иначе
                лпТекст = лпТекст+", "+лпИскомаяСтрока;
            КонецЕсли;
            лпТаблЧасть.УстановитьЗначение(лпИскомаяСтрока,"Контрагент",лпПустоеЗначение);//Затираємо знайденого
            лпИскомаяСтрока = "";
        КонецЦикла;
        Сообщить("Дублюється контрагент "+СокрЛП(Строка(лпКонтрагент))+" "+лпКвоПовтор+лпТекст,"!");
    КонецЦикла;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163767 · Ответов: 7 · Просмотров: 477
 

>  сравнить много значений
Sharzem
Отправлено: 10.06.20, 12:42


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


4andriy @ Сегодня, 10:37 * ,
Ще можна так:
Функция ВернутьЗначенияДляСравнения()
    лпЧетные = 2;
    лпНечетные = 3;
    лпСписЗнач = СоздатьОбъект("СписокЗначений");
    Для лпНомСписка = 1 По 20 Цикл
        Если лпНомСписка % 2 = 0 Тогда
            лпСписЗнач.ДобавитьЗначение(лпЧетные);
        Иначе
            лпСписЗнач.ДобавитьЗначение(лпНечетные);
        КонецЕсли;
    КонецЦикла;
    Возврат лпСписЗнач;
КонецФункции

//======================================================================
Процедура СравнитьЗначения(прСписЗнач,прНомер)
    лпЗначениеКотороеНужноСравнить = прСписЗнач.ПолучитьЗначение(прНомер);
    лпРазмерСписка = прСписЗнач.РазмерСписка();
    Для лпНомСписка = 1 По лпРазмерСписка Цикл
        Если лпНомСписка = прНомер Тогда
            Продолжить;
        КонецЕсли;
        лпЗначение = прСписЗнач.ПолучитьЗначение(лпНомСписка);
        Если лпЗначениеКотороеНужноСравнить = лпЗначение Тогда
            Сообщить("Значение в списке № "+лпНомСписка+" = искомому значению № "+прНомер+" т.е. = "+лпЗначение);
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры // СравнитьЗначения

//======================================================================
Процедура Сформировать()
    лпСписЗнач = ВернутьЗначенияДляСравнения();
    лпРазмерСписка = лпСписЗнач.РазмерСписка();
    Для лпНомСписка = 1 По лпРазмерСписка Цикл
        СравнитьЗначения(лпСписЗнач,лпНомСписка);
    КонецЦикла;
КонецПроцедуры // Сформировать
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163734 · Ответов: 7 · Просмотров: 477
 

>  Как сделать реквизит видимым только в одном слое расходной накладной? 1с 7.7 конф 7.7.00
Sharzem
Отправлено: 16.05.20, 16:23


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ Вчера, 23:17 * ,

Погоджуюся з volodya1122.
Мається на увазі додаткова перевірка:
Если Значение = "ДругаЗакладка" Тогда
    Если (НазваниеНабораПрав() <> "Администратор") Тогда // КОРИСТУВАЧІ НЕ БАЧАТЬ
            Форма.Спл.Видимость(0);
    Иначе
            Форма.Спл.Видимость(1);
    КонецЕсли;
Если Значение = "ТретяЗакладка" Тогда // НЕ БАЧИТЬ НІХТО
     Форма.Спл.Видимость(0);
ИначеЕсли Значение = "ПершаЗакладка" Тогда // БАЧАТЬ УСІ
     Форма.Спл.Видимость(1);
КонецЕсли;

Це збочення звичайно, але як варіант може бути, оскільки йде управління кожною закладкою окремо...

Я б рекомендував приводити усе до єдиного, так як радить denis84. Оскільки сидіти з часом і довбатися в цьому "гімнокоді" прийдеться таки в першу чергу Вам.
Тому, якщо будете використовувати варіант запропонований volodya1122, візьміть усе це й винесіть в окрему процедуру УстВидимостьРеквизитов(Значение).
Наприклад:
Процедура ПриВыбореЗакладки(Номер,Значение)        
    Форма.ИспользоватьСлой(" Совместный,"+Значение,2);
    УстДоступность();
    УстДоступностьКнопок();
    глУстановкаРеквизитаТип(Контекст);
    УстВидимостьРеквизитов(Значение);//Окрема процедура для збочення з реквізитами
КонецПроцедуры;

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163054 · Ответов: 4 · Просмотров: 307
 

>  Как создать документ из справочника контрагентов?
Sharzem
Отправлено: 27.03.20, 10:13


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(4andriy @ 25.03.20, 16:24) *
выбрать контрагента из справочника и выписать документ

Цитата(4andriy @ 26.03.20, 19:53) *
задача скопіювати вже створений перед тим заповнений документ і тоді тільки поправити

Це все зовсім різне.
Цитата(4andriy @ 26.03.20, 19:53) *
додав в ПриОткрытии код щоб дані виділеного контера переносились

Реалізовано не вірно, оскільки ТекущийЭлемент() для документу в процедурі ПриОткрытии() не є напередвизначеним параметром, доступ до нього можливий лише через Форма.Параметр.
Цитата(4andriy @ 26.03.20, 19:53) *
ОткрытьФорму("Документ.Накладная.7140",ТекущийЭлемент());

Повна несінитниця...
Цитата(Prospero @ 26.03.20, 21:57) *
в моем примере и подразумевают часть кода, заполняющего документ данными из справочника...

Та Ви що.... 47067070.gif

4andriy @ 25.03.20, 16:24 * ,
Опишіть в чому полягає суть завдання. З того, що Ви нагородили вже нічого не зрозуміло.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161707 · Ответов: 9 · Просмотров: 650
 

>  Как создать документ из справочника контрагентов?
Sharzem
Отправлено: 26.03.20, 10:29


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Prospero @ Вчера, 22:30 * ,
Ні, не вірно. В Вашому прикладі будуть створюватися пусті документи які будуть нікому не потрібні.
По перше, в документі в процедурі ПриОткрытии() необхідно:
Процедура ПриОткрытии()
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
        Если ТипЗначения(Форма.Параметр) = 11 Тогда
            Контрагент = Форма.Параметр;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

По друге, визивати з модуля довідника потрібно наступним чином:
    Если ТекущийЭлемент().ЭтоГруппа() = 0 Тогда
        ОткрытьФорму("Документ.Ваш_документ",ТекущийЭлемент());
    КонецЕсли;

При такому розвитку, введення Нового документу можливо припинити, оскільки відсутній метод Документ.Записать().
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161669 · Ответов: 9 · Просмотров: 650
 

>  Мария 301 МТМ «Невозможно открыть COM порт»
Sharzem
Отправлено: 21.03.20, 9:19


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Номер порта в конфігурації чи в налаштуваннях зазначено вірно?
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #161515 · Ответов: 4 · Просмотров: 461
 

>  Добавить графу в журнале счетов
Sharzem
Отправлено: 12.03.20, 9:51


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(aldem @ 05.03.20, 16:23) *
Как сделать, чтобы только после оплаты в этой графе появлялся номер подчинённой накладной

Якщо кількість підзвітних документів буде більше 1, а кількість стрічок у Вас = 1, як Ви збираєтесь їх туди засунути? Та й для чого ?
Правою кнопкою миші клацаєте на потрібному документі. У випавшому меню вибираєте "Подчиненные документы" і все.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161248 · Ответов: 3 · Просмотров: 1921
 

>  Создать обновление цен в накладной при копировании старой
Sharzem
Отправлено: 11.03.20, 13:30


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


denis84 @ Сегодня, 11:44 * ,
Цитата(denis84 @ 10.03.20, 9:02) *
получать последнюю цену товара на дату документа

Якщо такого в конфігурації немає на те є певна причина.

Цитата(Danaza @ 09.03.20, 14:42) *
поменять можно только вручную

Невідомо який там принцип товарного обліку, якщо є така можливість.

Цитата(denis84 @ 11.03.20, 11:44) *
Автор спросил, можно сделать, я ответил что можно!

Цитата(denis84 @ 10.03.20, 9:02) *
Можно сделать кнопку "пересчет цен"

Якщо вже на те пішло і немає партійного обліку, навіщо кнопка ?

Дивимося процедуру ВводНового() та задаємо умови:
Процедура ВводНового(ПризнакКопирования)
    Если ПризнакКопирования = 1 Тогда
        ПересчитаемТабличнуюЧасть()
    КонецЕсли;
КонецПроцедуры

Також, не забуваємо про зміну дати в документі, туди також слід навішати процедуру. Крім того, необхідно встановити недоступність зміни дати проведених документів.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161195 · Ответов: 5 · Просмотров: 484
 

>  Создать обновление цен в накладной при копировании старой
Sharzem
Отправлено: 11.03.20, 10:16


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(denis84 @ 10.03.20, 9:02) *
Можно сделать кнопку "пересчет цен"

Да ? А якщо облік по партіям ?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161191 · Ответов: 5 · Просмотров: 484
 

>  Как создать поиск клиента по номеру телефона
Sharzem
Отправлено: 11.03.20, 9:17


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Danaza @ 09.03.20, 14:56 * ,
Потрібно в довіднику Ваших "Клієнтів" перевірити усі номери телефонів, щоб вони відповідали одному формату. Тобто, як наприклад, довжина номеру телефону не повинна перевищувати 10 цифр і має починатися з 0. Це необхідно виконати "руцями", оскілльки там можуть бути пробіли або символи (, ), +, починатися з 3 або 8. Можна і автоматом, але це потрібно дивитися.
В процедурі ПриЗаписи(), в модулі довідника необхідна перевірка на коректність (відповідність) номеру потрібному формату.
Приклад:
Функция РазобратьСтрокуНаЧисла(прСтрока)
    лпСтрока = прСтрока;
    лпКолСимв = СтрДлина(лпСтрока);
    лпИвлЧисла = "1234567890";
    лпСтрВозврата = "";
    Для к = 1 По лпКолСимв Цикл
        лпСимв = Сред(лпСтрока,к,1);
        Если Найти(лпИвлЧисла,лпСимв) <> 0 Тогда
            лпСтрВозврата = лпСтрВозврата+Строка(лпСимв);
        КонецЕсли;
    КонецЦикла;
    Если Лев(лпСтрВозврата,1) = "3" Тогда
        лпСтрВозврата = Сред(лпСтрВозврата,2,СтрДлина(лпСтрВозврата));
    КонецЕсли;
    Если Лев(лпСтрВозврата,1) = "8" Тогда
        лпСтрВозврата = Сред(лпСтрВозврата,2,СтрДлина(лпСтрВозврата));
    КонецЕсли;
    Если (Лев(лпСтрВозврата,1) <> "0") или (СтрДлина(лпСтрВозврата) <> 10)  Тогда
        лпСтрВозврата = "";
    ИначеЕсли (Лев(лпСтрВозврата,2) = "02") или (Лев(лпСтрВозврата,2) = "03") Тогда
        лпСтрВозврата = "";
    КонецЕсли;
    Возврат лпСтрВозврата;
КонецФункции // РазобратьСтрокуНаЧисла

Процедура ПриЗаписи()
    Если ПустаяСтрока(РазобратьСтрокуНаЧисла(Телефон)) = 1 Тогда    
        Сообщить("Введен некорректный номер телефона !");
    КонецЕсли;
КонецПроцедуры

Далі в процедурі, що відповідає за пошук дисконтної карти по номеру добавити пошук клієнта по номеру телефона, якщо не знайдена дисконтна карта.
Можна наприклад, побудувати запрос:
    лпТекст = "
    |Телефоны = Справочник.Клиенты.Телефоны;
    |Клиент = Справочник.Клиенты.ТекущийЭлемент;
    |Группировка Клиент без групп;
    |Условие (ПустаяСтрока(Телефоны) = 0);
    |Условие(Лев(Телефоны,лпСтрДлина) = лпКод);";

    Запрос = СоздатьОбъект("Запрос");
    лпТаблЗнач = СоздатьОбъект("ТаблицаЗначений");
    Если Запрос.Выполнить(лпТекст) = 1 Тогда
        Запрос.Выгрузить(лпТаблЗнач,1,0);
        лпТаблЗнач.ВыбратьСтроку();
    КонецЕсли;

В загальному це все, але це тільки приклад.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161189 · Ответов: 2 · Просмотров: 524
 

>  Какую 1с вибрать
Sharzem
Отправлено: 15.01.20, 15:17


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(Dll @ 07.01.20, 1:19) *
ТиС для України 7.70.026. Но я так понял, что ето очень древняя штука, конторах уже отжила


Ще не вмерла...
І буде жити допоки існуватимуть "древние" контори, бо задовільняє усі потреби. Поки є люди чиї руки виросли звідки потрібно ніхто нічого змінювати не буде.
Я навіть не знаю який має вигляд 8х crazy.gif
  Форум: Помогите подобрать конфигурацию · Просмотр сообщения: #159367 · Ответов: 3 · Просмотров: 516
 

>  не могу обработать значение
Sharzem
Отправлено: 15.01.20, 15:02


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(4andriy @ 13.01.20, 14:45) *
Многострочная часть

Цитата(4andriy @ 13.01.20, 14:45) *
ТекущийЭлемент().Сум


ТекущийЭлемент у Вас довідник, який швидше за все має реквізит Сум. Значення цього реквізиту = ПустоеЗначение() тому і не працює.
Швидше за все має бути Количество * Цена. Я так вважаю.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #159366 · Ответов: 4 · Просмотров: 513
 

>  Как текст на форме сделать невидимым? Проблема 1С 7.70.003 торговля склад для Украины?
Sharzem
Отправлено: 25.10.19, 7:17


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ Вчера, 23:04 * ,
Цитата
Як при виборі закладок викликати СПЛАЧЕНО?

Процедура Сплачено()                   
    Если Спл=0 тогда
        Форма.СПЛАЧЕНО.Видимость(0);
    Иначе
        Форма.СПЛАЧЕНО.Видимость(1);
    КонецЕсли;
КонецПроцедуры

Процедура ПриВыбореЗакладки(Номер,Значение)
       .......
       Сплачено();
КонецПроцедуры

Процедура ПриОткрытии()
       ......
       ПриВыбореЗакладки(1,"Основной");
КонецПроцедуры

Все.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156888 · Ответов: 14 · Просмотров: 1009
 

>  Как текст на форме сделать невидимым? Проблема 1С 7.70.003 торговля склад для Украины?
Sharzem
Отправлено: 24.10.19, 17:30


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(volodya1122 @ 24.10.19, 10:14) *
В 1с7 повноцінних закладок немає

44000000.gif
Цитата(volodya1122 @ 24.10.19, 10:14) *
Попробую пояснити те що написала nysysimara

Цитата(volodya1122 @ 24.10.19, 10:14) *
Процедура ПриВыбореЗакладки виконується пільки при відкритті форми справочника (в даному випадку) і при виборі закладки.

Цитата(volodya1122 @ 24.10.19, 10:14) *
4. При відкритті форми флажок "Спл" мав би дорівнювати нулю (якшо інше не задано прорамою. Або це не реквізик справочника.

Цитата(volodya1122 @ 24.10.19, 10:14) *
5. Коли на формі ви міняєте значення флажка тоді потрібно на флажок повісити виклик процедури ПриВыбореЗакладки(1,"Основной") або іншої, яка б міняда видимість/доступність іншого реквізиту.

faceoff.gif
12201689.gif
Еххх, Вова, Вова... Нагородив городу... Це Вам не найвища математика. Тут людині потрібно при відкритті викликати ПриВыбореЗакладки() та при виборі закладки викликати Сплачено()... А Ви стільки всього нагородили.....

Nysysimara також... Мабуть, 7.7. вже забули...
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156862 · Ответов: 14 · Просмотров: 1009
 

>  Можно ли сделать автоматическое обновление отчета? 1с 7.7 конф 7.7.003
Sharzem
Отправлено: 20.10.19, 8:48


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ Вчера, 19:29 * ,
Можна виконувати постійне оновлення звіту через певний проміжок часу... Постійно потрібно опитувати відкриті в даний час вікна і при активації форми сформованого звіту оновити його якщо сплив потрібний час. Без компоненти Formex та його об'єктів "РасширениеФормы" та "Окна" не обійтися. Це буде таке собі збочення. Простіше натискати кнопочку.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156698 · Ответов: 4 · Просмотров: 834
 

>  Как изменить реквизит ВыбратьПериод в 1с 7.7 конф 7.7.003
Sharzem
Отправлено: 23.09.19, 7:18


Оратор
Иконка группы

Группа: Местный
Сообщений: 274
Регистрация: 09.02.12
Пользователь №: 14875


44000000.gif
Виборкою чи запитом при таких умовах... це жах. Якщо воно так Вам конче потрібно - створіть новий документ, назвіть його "Видача видаткових накладних", він підпорядкується Видатковій (вим) накладній (ним) і з ним далі вже працюйте... Тоді Ви зможете отримати необхідний Вам функціонал без спотворювання форми самої Видаткової накладної, а також будувати звіти на тему: хто, коли, з ким, де, кому видав ТМЦ по видатковій накладній.

1. На сьогодні Ви постійно теліпаєте Видаткову накладну, змінюєте реквізити, перепроводжуєте.
2. Той реквізит про який йде мова, краще діставати прямим запитом, але при величезній кількості документів це все одно буде займати час.

Краще, на мою думку, створити новий документ.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155861 · Ответов: 18 · Просмотров: 1684
 

11 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 26.11.20, 23:00
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!