Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



2 страниц V   1 2 >

>  Вывести счет учета в Документе ЗаказПоставщику в табл. части Товары при добавлении Номенклатуры
jojojoba2
Отправлено: 28.11.19, 9:05


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Подскажите пожалуйста, как в В 1С 8.3 УПП Вывести СчетУчета в Документе ЗаказПоставщику в табл. части Товары при добавлении Номенклатуры.
Как составить запрос, ведь в справочнике Номенклатура нету поля СчетУчета. Может есть какой-то еще метод для данной задачи.

Заранее спасибо.
  Форум: Корзина · Просмотр сообщения: #158043 · Ответов: 2 · Просмотров: 105
 

>  Вывести номер счета из плана счетов хозрасчетный в табличную часть формы документа
jojojoba2
Отправлено: 26.11.19, 18:12


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 18:10 * ,

При заполнении номенклатуры в справочнике не указывается номер счета (в плане счетов хозрасчетный). Как запросом вытащить номер счета для номенклатуры?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157960 · Ответов: 6 · Просмотров: 251
 

>  Вывести номер счета из плана счетов хозрасчетный в табличную часть формы документа
jojojoba2
Отправлено: 26.11.19, 17:59


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 17:39 * ,
А по какому полю связывать номенклатуру и плана счетов хозрасчетный?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157958 · Ответов: 6 · Просмотров: 251
 

>  Вывести номер счета из плана счетов хозрасчетный в табличную часть формы документа
jojojoba2
Отправлено: 26.11.19, 17:22


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

В 1С 8.3 УПП нужно вывести номер счета из плана счетов хозрасчетный в поле СчетУчетаБУ табличной части товары формы документа Заказ Поставщику при добавлении новой номенклатуры. Реквизит в документе уже был создан, но в модулях никаких процедур я не нашел. Подскажите пожалуйста :

---- Какой процедурой и каким методом это лучше реализовать( если можно пример кода)
---- Как связать номенклатуру и план счетов, если в номенклатуре не заполняется номер счета. Как делать запрос?
-----В документе Поступление товаров и услуг в табличной части товары это уже реализовано разработчиками 1С. Пытался скопировать процедуры ,по примеру этого документа ---ничего не получилось(((

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157955 · Ответов: 6 · Просмотров: 251
 

>  Ошибки при импорте файла клиент-банка
jojojoba2
Отправлено: 05.11.19, 10:00


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Конфигурация 1С 8.3 УПП

При импорте данных обработки "Обмен данными с системами клиент-банк" из файла v191104.zzz возникает ошибка:

{ВнешняяОбработка.КлиентБанк.МодульОбъекта(1506)}: Ошибка при вызове метода контекста (Записать)
спрБанкСчет.Записать();
по причине:
Значение "9" поля "Код" не уникально

Помогите исправить.Где и что править?

Спасибо.

Поставил 99, ругается Значение "99" поля "Код" не уникально. В чем прикол?

jojojoba2 @ Сегодня, 10:00 * ,
Поставил 99, ругается Значение "99" поля "Код" не уникально. В чем прикол?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157225 · Ответов: 1 · Просмотров: 1199
 

>  Как в выборке результата запроса сравнить значение(ВалютаДокумента)
jojojoba2
Отправлено: 28.10.19, 19:16


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Всем спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156977 · Ответов: 9 · Просмотров: 397
 

>  Как в выборке результата запроса сравнить значение(ВалютаДокумента)
jojojoba2
Отправлено: 28.10.19, 16:56


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите пожалуйста начинающему программисту. Как сравнить в результате запроса ВалютуДокумента и вывести параметр на макет :
Код
Процедура КнопкаСформироватьНажатие(Кнопка)
    ТабДок = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("Макет");
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ПлатежноеПоручениеВходящее.Ссылка,
        |    ПлатежноеПоручениеВходящее.Номер,
        |    ПлатежноеПоручениеВходящее.Дата,
        |    ПлатежноеПоручениеВходящее.Проведен,
        |    ПлатежноеПоручениеВходящее.ВалютаДокумента,
        |    ПлатежноеПоручениеВходящее.Оплачено,
        |    ПлатежноеПоручениеВходящее.Контрагент,
        |    ПлатежноеПоручениеВходящее.ДатаОплаты,
        |    ПлатежноеПоручениеВходящее.СуммаДокумента,
        |    ПлатежноеПоручениеВходящее.СтатьяДвиженияДенежныхСредств,
        //|    ПлатежноеПоручениеВходящее.Заказ,
        |    ПлатежноеПоручениеВходящее.РасшифровкаПлатежа.(
        |        СуммаНДС
        |    ) как   СуммаНДС
        |ИЗ
        |    Документ.ПлатежноеПоручениеВходящее КАК ПлатежноеПоручениеВходящее
        |ГДЕ
        |    ПлатежноеПоручениеВходящее.ДатаОплаты = &Дата
        |    И ПлатежноеПоручениеВходящее.Проведен =истина
        |    И ПлатежноеПоручениеВходящее.СтатьяДвиженияДенежныхСредств = &СтатьяДвиженияДенежныхСредств
        |    И ПлатежноеПоручениеВходящее.Оплачено = &Оплачено";
          
    Запрос.УстановитьПараметр("Дата", ЗаДату);
    Запрос.УстановитьПараметр("Оплачено", Оплочено);
    //Запрос.УстановитьПараметр("Проведен", "истина");
    Запрос.УстановитьПараметр("СтатьяДвиженияДенежныхСредств", стДвиженияДС);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    Область = Макет.ПолучитьОбласть("Детали");
    РасшифровкаПлатежаОбластьПодвалТаблицы = Макет.ПолучитьОбласть("РасшифровкаПлатежаПодвалТаблицы");
    РасшифровкаПлатежаОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("РасшифровкаПлатежаДетали");
    ТабДок.Очистить();
    ОбластьЗаголовок.Параметры.ДатаОплаты=ЗаДату;
    Номер="ФСМ " +Лев(Строка(ЗаДату),2)+"_" +Сред(Строка(ЗаДату),4,2)+ "/"+Сред(Строка(ЗаДату),9,2);
    ОбластьЗаголовок.Параметры.Номер=Номер;
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    //ТабДок.НачатьАвтогруппировкуСтрок();
    Выборка = РезультатЗапроса.Выбрать();
    СуммаСОбщ=0; СуммаБезОбщ=0; СуммаВознОбщ=0;
    Пока Выборка.Следующий() Цикл
        Область.Параметры.Заполнить(Выборка);
        Область.Параметры.Заказ=Выборка.Ссылка.РасшифровкаПлатежа[0].Сделка;
        НДС =  Выборка.Ссылка.РасшифровкаПлатежа[0].СуммаНДС;
        
        
        
        Если  Область.Параметры.ВалютаДокумента = "дол" Тогда  
            СуммаС = Выборка.СуммаДокумента * 24;
         Иначе
        
        СуммаС = Выборка.СуммаДокумента+НДС;
        КонецЕсли;
        
        
        СуммаВозн= Выборка.СуммаДокумента*ПроцентВН/100;
        СуммаСОбщ=СуммаСОбщ+СуммаС;
        СуммаБезОбщ= СуммаБезОбщ+ Выборка.СуммаДокумента;
        СуммаВознОбщ=СуммаВознОбщ+СуммаВозн;
        Область.Параметры.СуммаВозн=СуммаВозн;
        Область.Параметры.СуммаС=СуммаС;
        //Область.Параметры.СуммаС=СуммаС;
        ТабДок.Вывести(Область, Выборка.Уровень());
        ТабДок.НачатьГруппуСтрок();
        ТабДок.ЗакончитьГруппуСтрок();
    КонецЦикла;
    ОбластьПодвал.Параметры.СуммаСОбщ=СуммаСОбщ;
    ОбластьПодвал.Параметры.СуммаБезОбщ=СуммаБезОбщ;
    ОбластьПодвал.Параметры.СуммаВознОбщ=СуммаВознОбщ;
    ТабДок.Вывести(ОбластьПодвал);
    ТабДок.Показать();
КонецПроцедуры


Это не заработало:
Если  Область.Параметры.ВалютаДокумента = "дол" Тогда  
    СуммаС = Выборка.СуммаДокумента * 24;
Иначе
    СуммаС = Выборка.СуммаДокумента+НДС;
КонецЕсли;


Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156971 · Ответов: 9 · Просмотров: 397
 

>  Вывод реквизитов табличной части формы списка на печатную форму.
jojojoba2
Отправлено: 24.10.19, 11:34


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите разобраться с выводом реквизитов табличной части на печатную форму. В документе(реквизиты каторого тянутся с другого ДокументСписок-Платежное поручениеВходящее) на форме списка есть колонки в которые выводятся данные с табличных частей документа :

Код
Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
   Если ДанныеСтроки = Неопределено Тогда
        Возврат;
   КонецЕсли;
   Если ДанныеСтроки.Ссылка.РасшифровкаПлатежа.Количество() > 0 Тогда
        ОформлениеСтроки.Ячейки.ОстатокПоЗаказу.Значение = ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].Сделка;
        ОформлениеСтроки.Ячейки.Сумма.Значение = ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].СуммаВзаиморасчетов + ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].СуммаНДС;

   Конецесли;
КонецПроцедуры

Пытаюсь создать печатную форму с выводом реквизитов с табличной части -  сделка , данные не выводятся.Выводятся только реквизиты документа.


Процедура Печать1(Элемент,ДанныеСтроки)
ТабДок = Новый ТабличныйДокумент;
Макет = Документы.ПлатежноеПоручениеВходящее.ПолучитьМакет("СчетЗаказ");
        
Выборка = Документы.Справки_расчеты_роялти.Выбрать();
Реквизиты = Макет.ПолучитьОбласть("Реквизиты");
Пока Выборка.Следующий() Цикл
Реквизиты.Параметры.Заполнить(Выборка);

ТабДок.Вывести(Реквизиты);
КонецЦикла;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
КонецПроцедуры


Как вывести на печать данные со всех колонок формы списка документа?
Можно ли как - то прикрутить что-то подобное на "вывести список" из меню документа?
И как сделать вывод документов с отбором по дате?

Спасибо.


 ! 

Правила: 9
 
  Форум: Корзина · Просмотр сообщения: #156848 · Ответов: 1 · Просмотров: 186
 

>  Запрос вывода данных с табличной части в форму списка документа
jojojoba2
Отправлено: 18.10.19, 11:15


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

1с8.3 УПП. Необходимо создать запрос чтобы вывести информацию о заказе покупателя (документ-Платежное поручение исходящее) в колонку формы списка.



МассивЗаказов = Новый Массив;
Для Каждого Стр Из ОформленияСтрок Цикл
МассивЗаказов.Добавить(Стр.ДанныеСтроки.Ссылка);
КонецЦикла;
// Формируем запрос к остаткам заказов
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Справки_расчеты_роялти.РасшифровкаПлатежа.(
| Сделка
| )
|ИЗ
| Документ.Справки_расчеты_роялти.РасшифровкаПлатежа КАК Справки_расчеты_роялти
|ГДЕ
| Справки_расчеты_роялти.Сделка В(&МассивСсылок)";



Запрос.УстановитьПараметр("МассивСсылок", МассивЗаказов);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Выборка.Следующий();

Для Каждого Стр Из ОформленияСтрок Цикл
Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка;
КонецЦикла

КонецПроцедуры


1С ругается - поле Сделка не найдено.



--- может кто знает Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка; правильно ли для вывода данных в ячейку с запроса.

--- как правильно составить запрос для табличной части и механизм вывода в колонку

---Для Каждого Стр Из ОформленияСтрок Цикл
Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка;
КонецЦикла

Этого достаточно или еще нужны какие-то параметры


Программист я начинающий, помогайте кто чем может.
Спасибо.



  Форум: Корзина · Просмотр сообщения: #156641 · Ответов: 1 · Просмотров: 115
 

>  Вывод данных из поля табличной части в дополнительное поле формы списка документа
jojojoba2
Отправлено: 17.10.19, 13:14


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 14:00 * ,

Я тестирую вывод данных конкретно в ячейку , и мне интересно ТекОформление.Ячейки.ЗП.Значение(правильное значение) вообще выведет информацию? ТекОформление.Ячейки.ЗП.правильный метод
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156598 · Ответов: 6 · Просмотров: 554
 

>  Вывод данных из поля табличной части в дополнительное поле формы списка документа
jojojoba2
Отправлено: 17.10.19, 12:45


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 13:28 * ,


А можно пожалуйста пример вывода данных , у меня подозрение что :

ТекОформление.Ячейки.ЗП.Значение(ВыборкаЗП.НайтиСледующий(ОтборВыборки)); - неправильно

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156593 · Ответов: 6 · Просмотров: 554
 

>  Вывод данных из поля табличной части в дополнительное поле формы списка документа
jojojoba2
Отправлено: 17.10.19, 12:16


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Есть задача в 1С8.3 в форму списка документа Платежное поручение входящее добавить новое поле ЗаказПокупателя и в него вывести данные с табличной части РасшифровкаПлатежа из поля сделка(в котором отображается заказ покупателя). Помогите пожалуйста разобратся начинающему програмисту :

Код
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
     ЭтотОбъект = Документы.ПлатежноеПоручениеИсходящее;
    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
                  |    ЗаказПокупателя.Ссылка
                  |ИЗ
                  |    Документ.ЗаказПокупателя КАК ЗаказПокупателя
                  |ГДЕ
                  |    ЗаказПокупателя.Ссылка = &ТекущийДокумент";
    
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);
    Результат = Запрос.ВыполнитьПакет();
    ВыборкаЗП = Результат.Выбрать();
    
    ОтборВыборки = Новый Структура("Заказ");
    Для Каждого ТекОформление Из ОформленияСтрок Цикл
        ОтборВыборки.ЗаказПокупателя = ТекОформление.ДанныеСтроки.Ссылка;
        
         ТекОформление.Ячейки.ЗП.Значение(ВыборкаЗП.НайтиСледующий(ОтборВыборки));
        
    КонецЦикла;
КонецПроцедуры


ЗП ---это колонка в форме списка в которую нужно вывести данные


При запуске выдает ошибку:


Документ.Справки_расчеты_роялти.Форма.ФормаСписка.Форма(132)}: Поле объекта не обнаружено (СсылкаНаОбъект)
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);

----- Как правильно задать параметры колонки ЗП (поле ввода или указать данные реквизита )
----- Правильный запрос вывода значения с табличной части этого документа(я попытался через ссылку на заказ покупателя)
----- Правильный метод вывода значения в колонку формы списка.


Если можно , сбросьте пример.

Заранее всем спасибо.


 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156590 · Ответов: 6 · Просмотров: 554
 

>  Редактирование печатной формы счета в1с7.7
jojojoba2
Отправлено: 08.10.19, 11:54


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


nik389 @ Сегодня, 12:53 * ,
Спасибо.Буду пробовать.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156319 · Ответов: 4 · Просмотров: 637
 

>  Редактирование печатной формы счета в1с7.7
jojojoba2
Отправлено: 08.10.19, 11:44


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


nik389 @ Сегодня, 12:19 * ,

Если можно напишите,пожалуйста, пример.


jojojoba2 @ Сегодня, 12:35 * ,

Дело в том, что реквизита Р/р и Найменование банка нету в документе счет-фактура. Его нужно "подвязать" из справочника контрагенты.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156316 · Ответов: 4 · Просмотров: 637
 

>  Редактирование печатной формы счета в1с7.7
jojojoba2
Отправлено: 08.10.19, 10:56


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите начинающему программисту и просьба не судить строго))). Я изучаю программирование в 1С 8 . Поставили задачу по 1с 7.7 Предприятие (Бухгалтерский учет по Украине) - доработать печатную форму документа счет-фактура. Начал разбиратся и увидел что 7 очень сильно отличается от 8. Есть внешний макет каторый лежит в \1cv77_db\Management\ExtForms\PrnForms SF3_ukr.mxl. В печатной форме нужно вывести р/р и банк контрагента. В документе счет-фактура нашел процедуру ПЕЧАТЬ

Код
Процедура Печать()
    //----
    Ф=_глПолучитьИмяФайлаПечатнойФормы("SF3",Метаданные.Документ(Вид()).Представление());
    
    ЕстьСкидка = 1;
    фУкр = ?(Константа.ФормыНаУкраинском = Да, 1, 0);
    Если (Константа.ИспользоватьСкидку<>Да) Или (ЧтоПродаем<>Перечисление.ЧтоПродаем.ТМЦ) Тогда
        ЕстьСкидка = 0;
    КонецЕсли;
    
    Таб = СоздатьОбъект("Таблица");
    Если ПустоеЗначение(Ф)=0 Тогда
        Таб.ИсходнаяТаблица(КаталогИБ()+"ExtForms\PrnForms\"+Ф);
    Иначе
        Таб.ИсходнаяТаблица("Таблица"+?(Константа.ФормыНаУкраинском = Да,"_Укр",""));
    КонецЕсли;
    
    Если Заказ.Выбран() = 1 Тогда
        Номер = Заказ.НомерДок;
        Если Заказ.Вид() = "Договор" Тогда
            Если ПустоеЗначение(Заказ.НомерДоговора) = 0 Тогда
                Номер = Заказ.НомерДоговора;
            КонецЕсли;
        КонецЕсли;
        тЗаказ = глУкр(Заказ.ПредставлениеВида()) + " № " +СокрЛП(Номер) + ?(фУкр = 1, " від "," от ") + Заказ.ДатаДок;;
    Иначе
        тЗаказ = ?(фУкр = 1,"Без замовлення","Без заказа");
    КонецЕсли;

    глУстПропись(Валюта);
    Таб.ВывестиСекцию("Шапка");
    Ном = 1;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
        ЕдИзм = ?(ТМЦ.Вид()="ТМЦ",Ед,ТМЦ.БазЕдиница);
        Таб.ВывестиСекцию("Строка");
        Если ФКомп = 1 Тогда
            СпрКомп = СоздатьОбъект("Справочник.СоставКомплекта");
            СпрКомп.ИспользоватьВладельца(ТМЦ);
            СпрКомп.ВыбратьЭлементы();
            Пока СпрКомп.ПолучитьЭлемент() = 1 Цикл
                Таб.ВывестиСекцию("Составляющая");        
            КонецЦикла;
        КонецЕсли;
        Ном = Ном+1;
    КонецЦикла;
    Если ЕстьСкидка=1 Тогда
        Таб.ВывестиСекцию("Скидка");
    КонецЕсли;
    Если (ВидНДС.Код = "БезНДС") Тогда      
        Таб.ВывестиСекцию("БезНДС");        
    Иначе
        Таб.ВывестиСекцию("ДноНДС");        
    КонецЕсли;
    Таб.ВывестиСекцию("Дно");
    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,,);
    Таб.Показать("ПЕЧАТЬ: Счет-фактура","");
КонецПроцедуры


Я не могу понять где в коде и в каких модулях выводятся параметры и шаблоны печатной формы каторые есть на форме . Где код с запросами по выводу данных. Искал во всех модулял в конфигурации,не нашел. Может есть какой-то внешний модуль?Где он может находиться? Как правильно в 1с7.7 прописать новый параметр в коде?

Помогите разобраться.Если можно скиньте примеры или какую-то инструкцию. Смотрел видео - там редактируют печатную форму вместе с макетом и с модулем *.ert . У меня внешний только макет *.xml.

Заранее спасибо.


 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156312 · Ответов: 4 · Просмотров: 637
 

>  Как вывести значение булево(да или нет) в колонку Формы списка документа
jojojoba2
Отправлено: 13.09.19, 16:04


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый деннь!
1С8.3 УПП

Подскажите подалуйста, как вывести значение булево(да или нет) в колонку Формы списка(обычную) документа.
Я создал реквизит типа булево. На форме списка создал колонку,подвязал реквизит к колонке. Выводит в строках формы значение - "Нет".

Как сделать чтобы при определенных условиях(если в структуре подчиненных документов есть НалоговаяНакладная) выводилось значение "Да".

Я в событии формы списка при открытии Создал процедуру :

Процедура ПриОткрытии(ОформленияСтрок)    
    МасЗаказы = Новый Массив;
    Для Каждого Стр Из ОформленияСтрок Цикл
        ДанныеСтроки = Стр.ДанныеСтроки;
        МасЗаказы.Добавить(ДанныеСтроки.Ссылка);
    КонецЦикла;
    //
    зЗапрос = Новый Запрос;
    Запрос.Текст =

          "ВЫБРАТЬ
          |    СвязанныеДокументы.Ссылка
          |ИЗ
          |    КритерийОтбора.СвязанныеДокументы(&ЗначениеКритерияОтбора) КАК СвязанныеДокументы";
    
          Запрос.УстановитьПараметр("ЗначениеКритерияОтбора",ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока);
                                                                
    Результат = Запрос.Выполнить();  
    
  
    Для Каждого Стр Из ОформленияСтрок Цикл
        тд = Стр.ДанныеСтроки;        
        Выборка.Сбросить();
        Если Выборка.НайтиСледующий(тд.Ссылка, "НалоговаяНакладная") Тогда


   ОформлениеСтроки.Ячейки.Флаг = Истина;     как правильно написать эту строку ???????????????? Выдает ошибку :


Документ.ЗаказПокупателя.Форма.ФормаСписка.Форма(104)}: Значення не є значенням об`єктного типу (Ячейки)

Подскажите пожалуйста как правильно написать код : если значение запроса = нужное значение то в строке напротив документа поставить значение "ДА"

Спасибо за любую помощь.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155609 · Ответов: 1 · Просмотров: 415
 

>  Вывести флажок в поле формы списка
jojojoba2
Отправлено: 13.09.19, 11:48


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


sava1 @ Сегодня, 12:29 * ,

Спасибо огромное!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155600 · Ответов: 6 · Просмотров: 365
 

>  Вывести флажок в поле формы списка
jojojoba2
Отправлено: 13.09.19, 11:23


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


sava1 @ Сегодня, 11:12 * ,
8.3 УПП

sava1 @ Сегодня, 11:12 * ,
Обычная форма

fly @ Сегодня, 11:36 * ,
Спасибо! Буду разбираться.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155597 · Ответов: 6 · Просмотров: 365
 

>  Вывести флажок в поле формы списка
jojojoba2
Отправлено: 13.09.19, 10:04


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Есть задача - необходимо в документе ЗаказПокупателя в поле ввода колонки формы списка вывести флажок напротив документа если в структуре подчиненных документов, есть Реализация и Налоговая накладная.

Подскажите каким методом, запросом это возможно сделать?
Как правильно настроить колонку в свойствах?
В каком событии лучше писать процедуру?

Если есть пример кода буду благодарен.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155592 · Ответов: 6 · Просмотров: 365
 

>  Вывод структуры подчиненности в заказах покупателя
jojojoba2
Отправлено: 30.08.19, 11:41


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


sava1 @ Сегодня, 12:08 * ,

Спасибо! Буду пробовать.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155162 · Ответов: 3 · Просмотров: 314
 

>  Вывод структуры подчиненности в заказах покупателя
jojojoba2
Отправлено: 30.08.19, 10:53


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!
Может кто-то знает как вывести структуры подчиненности в заказах покупателя. То есть чтобы на форме списка рядом со строками справа при активизации строки появлялась структура подчиненных документов.

Сделать типа так:


Какой элемент управления вставить в форму списка для отображения формы структуры подчиненных документов? В каких событиях запускать вывод этой формы при активизации строки?

Буду благодарен за любую помощь.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155158 · Ответов: 3 · Просмотров: 314
 

>  Заполнение формы списка данными Документов и реквизитами на основании другого документа
jojojoba2
Отправлено: 28.08.19, 15:40


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 16:26 * ,

Спасибо
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155094 · Ответов: 5 · Просмотров: 271
 

>  Заполнение формы списка данными Документов и реквизитами на основании другого документа
jojojoba2
Отправлено: 28.08.19, 14:57


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 12:24 * ,
более подробно на примерах, там, Док1 с Реквиз1, Реквиз2 и ТЧ1 перенести данные в Док2 с Реквиз1, Реквиз2 и ТЧ1+еще значения реквизитов нужно обработать с помощью формул(Сумма С НДС, Без НДС)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155092 · Ответов: 5 · Просмотров: 271
 

>  Заполнение формы списка данными Документов и реквизитами на основании другого документа
jojojoba2
Отправлено: 28.08.19, 11:08


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите советом,как можно вывести список (определенных отбором) документов и их реквизитов+реквизитов табличных частей в форму списка из одного объекта конфигурации(документа) в другой объект.
Я копировал документ(объект_конфигурации) с которого нужно выводить данные и в нем менял в реквизитах формы путь к документу, с которого нужно выводить данные. Дальше в форме списка добавлял реквизиты. Это решение правильно не заработало(((.
Я находил похожие решения с заполнением документа на основании но информация разбросана. Я запутался(((.

Пожалуйста,подскажите правильный метод (алгоритм) решения такого задания,что за чем выполнять и в каких модулях прописывать код.

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155086 · Ответов: 5 · Просмотров: 271
 

>  Как значение из реквизита таб. части документа вывести в форму списка
jojojoba2
Отправлено: 23.08.19, 11:20


Общительный
**

Группа: Пользователи
Сообщений: 47
Регистрация: 18.02.19
Пользователь №: 64372


pablo @ Сегодня, 12:12 * ,

Это обычный режим. А в нем как можно?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154959 · Ответов: 4 · Просмотров: 373
 

2 страниц V   1 2 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 27.01.20, 3:00
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!