Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Выгрузка Акта сверки в Медок, ошибка при вызове метода контекста (Edit)          
Мичман Харитонов Подменю пользователя
сообщение 10.10.19, 11:30
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 152
Из: м. Кам'янське
Спасибо сказали: 23 раз
Рейтинг: 17.5

Платформа 8.3.7,
Конфигурация самописная.
Переделываю на основе выгрузки для налоговых документов...

Код
Процедура ВыполнитьПередачуНакладных(Результат, ЭлементыФормы) Экспорт
    Попытка
        App = Новый COMОбъект("MEDOC.ZApplication");
    Исключение
        Сообщить("Приложение M.E.DOC не запущено!");
        Возврат;
    КонецПопытки;
    СведенияОПоставщике  =  УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Организация,  ТекущаяДата());
    КодПоЕДРПОУ  =  СокрЛП(СведенияОПоставщике.КодПоЕДРПОУ);
    ЭлементыФормы.Состояние.Заголовок = "Осуществляется передача Актов Сверки...";
    Передано = 0;
    Для каждого Стр Из Результат Цикл
        Если Стр.Передавать = Ложь Тогда
            Продолжить;
        КонецЕсли;
        
        PDate = Дата(Год(Стр.Ссылка.Дата), Месяц(Стр.Ссылка.Дата), День(Стр.Ссылка.Дата));
        
        
        ИД = Строка(Стр.Ссылка.УникальныйИдентификатор());
                
         Бланк = "1C82A3";  
         Формирование_АктаСверки(App,  Стр.Ссылка,  Бланк,  PDate,  ИД)
        
    КонецЦикла;
    App.RefreshRstDoc();
    ЭлементыФормы.Состояние.Заголовок = "Передача Актов сверки завершена успешно.";
    Сообщить("Передано " + Передано + " документ(ов) ");
    
КонецПроцедуры

Функция Формирование_АктаСверки(App,  Документ,  Бланк,  PDate,  ИД)
Doc  =  App.OpenOrCreateByExDocID(Бланк, 0, PDate,  , ИД, 0);
rsMain = Doc.DataSets("MAIN");
            //rsMain = Doc.DataSets();
            rsMain.Edit();
....


На rsMain.Edit(); спотыкается, выдает ошибку

Сообщение отредактировал Vofka - 10.10.19, 11:52

Petre Подменю пользователя
сообщение 10.10.19, 12:05
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2672
Из: Київ, Україна
Спасибо сказали: 750 раз
Рейтинг: 731.6

Мичман Харитонов @ Today, 11:30 * ,
Возможно документ уже существует.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Inkognito Подменю пользователя
сообщение 25.10.19, 8:23
Сообщение #3

Почти ветеран
******
Группа: Пользователи
Сообщений: 713
Из: Украина
Спасибо сказали: 435 раз
Рейтинг: 7.5

Неправильно создаете первичный документ. Правильно использовать иную функцию создания первички:
pd =  App.GetPrimaryDocs(); 
Doc  =  pd.OpenOrCreateDocument(orgId,  Бланк, , ,  ИД,  0);
rsMain = Doc.DataSets();                     
rsMain.Edit();              
rsMain.Append();
rsMain.Post();


Сообщение отредактировал Vofka - 25.10.19, 8:29

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.02.20, 13:41
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!