Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> ошибка при открытии обработки          
4andriy Подменю пользователя
сообщение 22.09.22, 18:31
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 159
Спасибо сказали: 1 раз
Рейтинг: 1

ИдентификаторКонфигурации = глРедакцияКонфигурации();

Спр = СоздатьОбъект("Справочник.Пользователи");
Если ИдентификаторКонфигурации = "UBUTK" Тогда //Бухгалтерский учет для Украины    
    Если Спр.НайтиПоНаименованию(ИмяПользователя(), 1) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UBUOUSL" Тогда //"Бухгалтерия+Торговля+Склад+Зарплата+Кадры" для Украины
    спВидиДокументів.ВставитьЗначение(5,"Т_РасходнаяНакладная","Видаткова накладна (товари)");
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UManf" Тогда //Производство+Услуги+Бухгалтерия для Украины
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UOUTK" Тогда //Торговля+Склад для Украины
    ОказаниеУслугНом = спВидиДокументів.НайтиЗначение("ОказаниеУслуг");
    Если ОказаниеУслугНом > 0 Тогда
        спВидиДокументів.УдалитьЗначение(ОказаниеУслугНом);
    КонецЕсли;
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
Иначе
    ТекущийПользователь = "";
КонецЕсли;


в глобальном модуле есть:
Перем глРедакцияКонфигурации Экспорт;//это для сравнения редакции конфигурации и константы "РедакцияКонфигурации"


ошибка:
ИдентификаторКонфигурации = глРедакцияКонфигурации<<?>>();
...: Функция не обнаружена (глРедакцияКонфигурации)

denis84 Подменю пользователя
сообщение 22.09.22, 19:11
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

4andriy @ Сегодня, 19:31 * ,
Там объявлено как переменная. А обращаетесь как к функции

Спасибо сказали: 4andriy,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 07.12.22, 4:17
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!