Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику BeLuY ::: Спасибо сказали: 4 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
26.05.21, 12:00 Флажок в табличной части
Нашел решение:

1. В таблицу на форме добавляем колонку, назовем ее "Выбор", ЭлементУправления устанавливаем "Поле выбора"
2. В таблице на форме (в моем случае Товары) создаем обработчики ПриВыводеСтроки и ПриИзмененииФлажка
3. В модуль формы, в раздел оглашения глобальных переменных добавляем переменную ВыбраннаяНоменклатура, в самом конце модуля инициализируем эту переменную ВыбраннаяНоменклатура = Новый Соответствие

В итоге, модуль формы должен содержать:

// Глобальные переменные
Перем ВыбраннаяНоменклатура;

//------------------------------------------------------

// Описание обработчика "ПриВыводеСтроки"
Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    // Отображаем флажок в ячейке с именем "Выбор"
    ОформлениеСтроки.Ячейки.Выбор.ОтображатьФлажок = Истина;    
    
    // Производим поиск соответствия "ВыбраннаяНоменклатура" текущей строки    
    Если ВыбраннаяНоменклатура[ДанныеСтроки] = Неопределено Тогда
        // Если соответствие не найдено - флажок снят
        ОформлениеСтроки.Ячейки.Выбор.Флажок = Ложь;
    Иначе
        // Иначе устанавливаем флажок
        ОформлениеСтроки.Ячейки.Выбор.Флажок = ВыбраннаяНоменклатура[ДанныеСтроки];
    КонецЕсли;    
КонецПроцедуры

// Описание обработчика "ПриИзмененииФлажка"
Процедура ТоварыПриИзмененииФлажка(Элемент, Колонка)
    // Если состояние флажка меняется в ячейке с именем "Выбор"
    Если Колонка.Имя = "Выбор" Тогда
        // Производим поиск соответствия "ВыбраннаяНоменклатура" текущей строки
        Если ВыбраннаяНоменклатура[Элемент.ТекущаяСтрока] = Неопределено Тогда
            // Если соответствие не найдено - создаем новое соотвотствие
            ВыбраннаяНоменклатура[Элемент.ТекущаяСтрока] = Истина;
        Иначе
            // Иначе, если соответствие найдено - удаляем его
            ВыбраннаяНоменклатура.Удалить(Элемент.ТекущаяСтрока);
        КонецЕсли;    
    КонецЕсли;    
КонецПроцедуры

//------------------------------------------------------

// Инициализация глобальной переменной
ВыбраннаяНоменклатура = Новый Соответствие;


Немного колхоз, но мне помогло)

Спасибо за внимание)

PS: к модератору - а я могу данное решение внести в первое сообщение темы? Кнопка "Редактировать" отсутствует...
Vofka,
13.10.20, 14:22 Количество знаков в поле "Количество" налоговой накладной
Цитата(sava1 @ 13.10.20, 14:51) *
в поле Формат есть значок лупы ?


Снимаю шляпу! Я и подумать не мог, что в том поле тоже может быть "разделение по языкам", вот и не удосужился посмотреть...

Спасибо большое за помощь - все получилось =))
Inkognito,
28.05.20, 10:20 При переходе с БУ 1.2 на BAS КОРП система заблокировала старые документы
Вопрос снят. Необходимо перейти в Операции -> Сервис -> Даты запрета изменения данных, и в открывшемся окне, в поле Дата запрета указать дату, до которой данные, введенные ранее, не будут доступны для изменения. В моем случае установил значение начала текущего года.

Интересно то, что в моей копии, кнопка Даты запрета изменения данных не отображалась, да и не было заблокированных документов. Видимо из-за того, что база являлась копией (но это не точно smile.gif )

Спасибо за внимание!

Olga-lauma, Vofka,

RSS Текстовая версия Сейчас: 02.08.21, 14:41
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!