Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



13 страниц V   1 2 3 > » 

>  Заміна 1С
volodya1122
Отправлено: 05.09.22, 15:26


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(Vadim67567567 @ 05.09.22, 15:58) *
Малий та середній бізнес, вже не на 1C.. я помиляюсь?

Помиляєтесь. Якраз малий і середній бізнес на 1С (або ведуть облік в Екселі- Особисто знаю одного такого підприємця). Хто на типових, хто на самописках, так як привикли до цього і це просто і зручно, і легко підналаштовувати під свої забаганки і забаганки законодавства
  Форум: Офф-топик · Просмотр сообщения: #176283 · Ответов: 22 · Просмотров: 1666
 

>  Обычные формы: как открытое ранее окно сделать активным
volodya1122
Отправлено: 23.06.22, 10:36


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ще так можна спробувати зробити

Отч1=Отчеты.Отчет1.Создать();
Отч1.ПолучитьФорму("ФормаОтчета").Открыть();

Отч2=Отчеты.Отчет2.Создать();
Отч2.ПолучитьФорму("ФормаОтчета").Открыть();

НужнаяАктивнаяФорма=Отч1.ПолучитьФорму();
НужнаяАктивнаяФорма.Активизировать();
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #175885 · Ответов: 2 · Просмотров: 608
 

>  Обычные формы: как открытое ранее окно сделать активным
volodya1122
Отправлено: 22.06.22, 13:40


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


kserg2012 @ Сегодня, 11:23 * ,

Взагалі то не повинно бути такого. Тільки що перевірив- форми відкриваються в тому порядку як завів в процедурі ПриНачалеРаботыСистемы

Що можна ще перевірити:
1. Чи дійсно в конфігураторі вказана правильна послідовність виклику форм. Можливо нижче по коду ще раз викликається форма
2. Можливо одна форма відкривається довше іншої, і тому активно. стає не та що потрібно. Попробувати після виклику відкриття першої форми поставити невеличку паузу - для перевірки цієї версії.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #175881 · Ответов: 2 · Просмотров: 608
 

>  Архивація обєктів 1С
volodya1122
Отправлено: 10.06.22, 13:22


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(Diana1c @ 10.06.22, 10:04) *
в базі "ПАПЄРЄДНІКІ" писали іАвтор, і Ответственный два варіанта(в різних документах по різному)


Тоді виправити так частину коду


    Для Каждого Документ Из Метаданные.Документы Цикл
        Если Не Документ.Реквизиты.Найти("Автор") = Неопределено Тогда
            СтрокаАвтор=" Ссылка.Автор Как Автор ";
        ИначеЕсли Не Документ.Реквизиты.Найти("Створив") = Неопределено Тогда
            СтрокаАвтор=" Ссылка.Створив Как Автор ";
        ИначеЕсли Не Документ.Реквизиты.Найти("Ответственный") = Неопределено Тогда
            СтрокаАвтор=" Ссылка.Ответственный Как Автор ";
        Иначе
            СтрокаАвтор=Кав+" Відсутный автор"+Кав+" Как Автор ";
        КонецЕсли;
// цей пораддок можна пробувати міняти. Так як "Папереднікі" могли до одного і того самого документа прописати і Автор і Ответственного.
//А реально самого автора писати в один із реквізитів
            
        Текст = Текст + "ВЫБРАТЬ Ссылка.Дата Как Дата, "+
        Кав+ Документ.Имя+Кав+" Как Имя, "+
        СтрокаАвтор+
        //    " Ссылка.Створив Как Автор "+
        " ИЗ Документ." + Документ.Имя;
        Текст = Текст +
        " ГДЕ Ссылка.Дата МЕЖДУ &д1 И &д2 ОБЪЕДИНИТЬ ";
    КонецЦикла;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175791 · Ответов: 21 · Просмотров: 2387
 

>  Архивація обєктів 1С
volodya1122
Отправлено: 09.06.22, 17:29


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(Diana1c @ 08.06.22, 10:54) *
volodya1122 @ 27.05.22, 10:48 * ,Перемпрошую, а можливо щоб не сумувало кількість, а видало окремо дату та час і користувача. тобто: Документ, дата і час, користувач. Я розумію що це буде величезне полотно данних, але якщо можна в цьому коді поправити то буду дуже вдячна )


" Ссылка.Створив Как Автор "+ спрацює в тому виадку, якщо в кожного із документів є реквізит "Створив". Якщо у вас по інщому називається то виправити Ссылка.Створив= на Ссылка.Автор (ябо як там називається у вас в кожнім документі)

ДатаНач=НачалоГода(ДобавитьМесяц(ТекущаяДата(),-30)); // за 2 роки
    ДатаКонечн=ТекущаяДата();
    Кав="""";
    Запрос = Новый Запрос;
    Текст = " ";
    Для Каждого Документ Из Метаданные.Документы Цикл
        Текст = Текст + "ВЫБРАТЬ Ссылка.Дата Как Дата, "+
        Кав+ Документ.Имя+Кав+" Как Имя, "+
        " Ссылка.Створив Как Автор "+   //  ось тут поправити
        " ИЗ Документ." + Документ.Имя;
        Текст = Текст +
        " ГДЕ Ссылка.Дата МЕЖДУ &д1 И &д2 ОБЪЕДИНИТЬ ";
    КонецЦикла;
    
    Запрос.Текст = Лев(Текст, СтрДлина(Текст) - СтрДлина(" ОБЪЕДИНИТЬ "));
    Запрос.Текст = Запрос.Текст + "
    |    УПОРЯДОЧИТЬ ПО
    |Имя, Автор, Дата";
    
    Запрос.УстановитьПараметр("д1", ДатаНач);
    Запрос.УстановитьПараметр("д2", ДатаКонечн);
    Выборка = Запрос.Выполнить().Выгрузить();
    
    
    Построитель = Новый ПостроительОтчета;
    Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(Выборка);
    Построитель.Макет = Неопределено;
    Макет = Построитель.Макет;
    Область = Макет.Область();
    Область.ШиринаКолонки = 20;
    Построитель.Макет = Макет;
    Построитель.Выполнить();
    Построитель.Вывести();
    
Сообщить(Запрос.Текст);

Звіт буде формуватись набагато довше попереднього
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175788 · Ответов: 21 · Просмотров: 2387
 

>  Архивація обєктів 1С
volodya1122
Отправлено: 27.05.22, 15:49


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


vbi @ Сегодня, 15:44 * ,
Далеко не всі події записуються в журнал реєстрації (наприклад "Справочники" - якщо не створювати нові елементи/редагувати існуючі, - а тільки використовувати їх в документах, то в в журналі реєстрації небуде згадки про те, що цей довідник використовували. Інший приклад. Документи рухають регістри. Але по них також немає запису в журналі реєстрації)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175672 · Ответов: 21 · Просмотров: 2387
 

>  Архивація обєктів 1С
volodya1122
Отправлено: 27.05.22, 10:50


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Diana1c @ Сегодня, 11:40 * ,
Які параметри? Звичайний звіт (на формі звіту кнопка Сформировать. В обработчику кнопки Процедура: Процедура Сформировать()...... КонецПроцедури
Ось туди вставити код
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175666 · Ответов: 21 · Просмотров: 2387
 

>  Архивація обєктів 1С
volodya1122
Отправлено: 27.05.22, 10:20


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Diana1c @ Сегодня, 11:10 * ,
Так це не в консолі запитів писати. А оформити зовнішнім звітом
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175664 · Ответов: 21 · Просмотров: 2387
 

>  Архивація обєктів 1С
volodya1122
Отправлено: 27.05.22, 9:48


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Diana1c @ Сегодня, 9:36 * ,

Ось нашвидкоруч накинув код, щоб визначити які документи які зараз використовуються.
Але повторюю, потрібно добре подумати чи видалення документів, які не використовуються не вплинуть на правильність обліку по інших документах


    ДатаНач=НачалоГода(ДобавитьМесяц(ТекущаяДата(),-30)); // за 2 роки
    ДатаКонечн=ТекущаяДата();
    Кав="""";
    Запрос = Новый Запрос;
    Текст = " ";
    Для Каждого Документ Из Метаданные.Документы Цикл
        Текст = Текст + "ВЫБРАТЬ Ссылка.Дата Как Дата, "+
        Кав+ Документ.Имя+Кав+" Как Имя, "+
        " 1 Как Повторов"+
        " ИЗ Документ." + Документ.Имя;
        Текст = Текст +
        " ГДЕ Ссылка.Дата МЕЖДУ &д1 И &д2 ОБЪЕДИНИТЬ ";
    КонецЦикла;
    
    Запрос.Текст = Лев(Текст, СтрДлина(Текст) - СтрДлина(" ОБЪЕДИНИТЬ "));
    Запрос.Текст = Запрос.Текст + "
    |    УПОРЯДОЧИТЬ ПО
    |Имя, Дата";
    
    Запрос.УстановитьПараметр("д1", ДатаНач);
    Запрос.УстановитьПараметр("д2", ДатаКонечн);
    Выборка = Запрос.Выполнить().Выгрузить();
    
    КопияТЗ = Выборка.Скопировать(,"Имя,Повторов");
    КопияТЗ.Свернуть("Имя","Повторов");
    
    //    Пока Выборка.Следующий() Цикл
    //        Сообщить(""+Выборка.Дата+" "+Выборка.Имя+" "+Выборка.Повторов );
    //    КонецЦикла;
    
    Сообщить("Кількість документів за період з  "+ДатаНач+"  по  "+ДатаКонечн);
    Для Каждого Стр Из КопияТЗ Цикл
        Сообщить(Стр.Имя + " " + Стр.Повторов);
    КонецЦикла;
    Для Каждого Документ Из Метаданные.Документы Цикл
        СтрокаПоиска = КопияТЗ.Найти(Документ.Имя,  "Имя");
        Если СтрокаПоиска = Неопределено Тогда
            Сообщить(Документ.Имя + " пусто");
        КонецЕсли;
    КонецЦикла;


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175662 · Ответов: 21 · Просмотров: 2387
 

>  Архивація обєктів 1С
volodya1122
Отправлено: 26.05.22, 20:44


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Diana1c @ Сегодня, 12:55 * ,
1. Енна кілкість співробітників. Думаю мається на увазі користувачів в 1С? На роздутість бази взагалі не впливає. (це 0,0000001% від обєму бази). А щоб непотрібних не показувати при вході в програму -то їх показ можна відключити в конфігураторі (Меню- Адміністрування-Користувачі. Випрати непотрібного користувача. в Зняти помітку "Показувати в списку вибору")
2. Багато обєктів в базі. Що тут мається на увазі? Багато різних видів документів, довідників, Регістрів.......? Чи багато в базі створено докумнентів, довідників.... (мається на увазі документи , які створюють користувачі в процесі роботи з програмою)?
2.1 Якщо перше, то тут практично неможливо щось викинути, так як одні обєкти зазвичай задіяні в різних місцях програми. І просто так їх не позбутись, не переписавши половину конфігурації.
2.2 Якщо друге, то тут також не все однозначно. Наприклад документ введення залишків. Його один раз використали на початку користування програмою -ввели залишки. Більше ним не користуються. Його можна видалити? Звичайно ні. Тут тільки аналізувати очима, розмовляти з працівниками., Якщо в програмі є різні підсистеми, які ніяк не повязані між собою.Тоді документи однієї підсистеми можно видалити.
3. База дуже роздулась? В цифрах це скільки (в Мегабайтах/ Гігабайтах) База файлова чи SQL? (Зменшення обєму допомагає в Конфігураторі "Тестування і виправлення інформаційної базі" - АЛЕ ОБОВЯЗКОВО ПОТРІБНО ТАКІ РЕЧІ РОБИТИ НА КОПІЇ І НЕ ЗАБУВАТИ ПЕРЕД ТИМ РОБИКИ АРХІВНУ КОПІЮ БАЗА!!!!ЦЕ ДУЖЕ ВАЖЛИВО)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175659 · Ответов: 21 · Просмотров: 2387
 

>  выбрать период по месяцу
volodya1122
Отправлено: 26.05.22, 17:30


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


В 1с8 я б зробив так: Текст умови програмно сформував.
В циклі
1. Перевів введені дати на початок і кінець місяця. На кожній ітерації циклу добавляти рік до кожної з дат (в обидві сторони)
2. умови обєднати приблизно так: ГДЕ (Отпуск>Д1 и Отпуск<Д2) Или (Отпуск>Д1 и Отпуск<Д2) Или (Отпуск>Д1 и Отпуск<Д2) - цей текст звичайно формується програмно в циклі . Де Д1 і Д2 на кожній ітерації вже конкретні визначені в циклі значення

3. В 1с7 незнаю чи подібним методом можна сформувати умову.
Тут скоріше потрібно формувати в циклі на кожен період повнісю текст запросу і обєднати ці запроси

p.s.
Ще можливо дуже спростити, якщо в запросі можна використати функцію (Месяц(Дата1). Поді просто порівняти номера місяців
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #175657 · Ответов: 3 · Просмотров: 607
 

>  заменить НайтиПоНаименованию
volodya1122
Отправлено: 17.02.22, 11:14


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(4andriy @ 16.02.22, 18:30) *
На что и как можно заменить что-бы при поиске еще сверяло еще какое-то значение, а не брало первое.

Заменить на выборку запросом всех элементов с заданным наименованием (в поля выборки включить все дополнительные поля по которым будет еще проверяться значение). А потом обходом выборки запроса взять нужное
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #175352 · Ответов: 3 · Просмотров: 4015
 

>  дайте, пожалуйста элементарное фоновое задание
volodya1122
Отправлено: 13.12.21, 15:52


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(lolmatrix @ 13.12.21, 16:42) *
извините. ссылка не работает

Да Ё-мае. Еще нужно учить пользоваться файлообменником? По сылке открывается папка на файлообменнике. Там я закачал архив PUSTA.RAR. Вот его и скачать
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174897 · Ответов: 5 · Просмотров: 1235
 

>  дайте, пожалуйста элементарное фоновое задание
volodya1122
Отправлено: 13.12.21, 15:16


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Для керованих непідкажу. А от для звичайних форм можете подивитись. Потрібно запустити в 1С цю конфігурацію і кожні 2 хв в файл D:\test\zxzx.txt буде добавлятись текуча дата. (Диск D повинен існувати на компютері)
Ссылка на файл
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174894 · Ответов: 5 · Просмотров: 1235
 

>  Обробка для МІНІ-ФП54.01 (Бухгалтерия для Украины 1.2.)
volodya1122
Отправлено: 12.10.21, 14:42


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Gazulo, Це не до мене.
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #174442 · Ответов: 8 · Просмотров: 1194
 

>  Обробка для МІНІ-ФП54.01 (Бухгалтерия для Украины 1.2.)
volodya1122
Отправлено: 12.10.21, 13:47


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Cordelia @ Сегодня, 10:07 * ,

Я працюю з MINI-T400, але драйвер використовується той самий що і для фіскального реєстратора. Зараз якраз була Кампанія по перепрошивках Касових апаратів і реєстраторів під нові вимоги законодавства для друку штрихкодів акцизних марок.
Тому насамперед питаненя:
1. Ви перепрошивали свій реєстратор? і помилка виникла після перепрошивки?
2. Попередній драйвер видалили?
3. після цього новий драйвер зареєстрували (від імені адміністратора) (І згідно інструкціі повинен ще лежати в папці C:\olesrv)
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #174440 · Ответов: 8 · Просмотров: 1194
 

>  Алгоритм поиска Найти наименование по первым символам из "НайтиПоНаименованию" в 1с 7.7
volodya1122
Отправлено: 08.10.21, 9:51


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


anatol1c @ 28.09.21, 15:51 * ,

Найдет первый элемент который начинается на это наименование. (или с наименьшем кодом или с наименьшем внутреннем кодом базы)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #174416 · Ответов: 2 · Просмотров: 783
 

>  Глюк при запросе движений регистра
volodya1122
Отправлено: 30.06.21, 10:29


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


voroneczinna@gmail.com @ Сегодня, 10:39 * ,
4. Я Имею в виду : Меню/Операции/Проведение документов/Последовательности
Поставить на текущую дату и поставить все отметки (в "Последовательности документов")
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #173787 · Ответов: 6 · Просмотров: 1116
 

>  Глюк при запросе движений регистра
volodya1122
Отправлено: 30.06.21, 8:46


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


voroneczinna@gmail.com @ Сегодня, 9:31 * ,

Трудно сказать что может быть. Можно проверить:
1. Версия платформы надеюсь 7.70.027
2. Размер самой большей таблички *.dbf, *.cdx меньше 1 гигабайта
3. Версия ос какая? проверить работу 1С на предыдущих версиях винды (XP, Win7 (32x) )
4. Граница последовательности случайно не улетела в доисторические времена?
5. Сделать Тестирование и исправление (поставив все отметки)
6. Кодовая страница (в конфигураторе) стоит Текущая системная Установка. В сомой винде везде должен стоять Русский язык


Главное не забываем сделать копию базы перед тестами !!!!!!!
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #173784 · Ответов: 6 · Просмотров: 1116
 

>  Запись регистра сведений
volodya1122
Отправлено: 29.06.21, 9:58


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


maci @ Сегодня, 9:24 * ,
Тоисть Вы хотите сделать независимый регистр сведений, но чтобы он вел себя как регистр сведений подчиненный регистратору? Странная хотелка...
Чтобы все записи не регистра сведений не удалялись нужно снасалаОтборами получить нужнвй набор записей, которые будут перезаписыватся, потом удалить их, а в конце записать новый набор.

        НаборЗаписей=РегистрыСведений.МойНезависимыйРегистрСведений.СоздатьНаборЗаписей();
        НаборЗаписей.Отбор.Ресурс1.Установить(аааа);
        НаборЗаписей.Отбор.Ресурс2.Установить(бббб);
                НаборЗаписей.Отбор.Измерения1.Установить(ввввв);
        НаборЗаписей.Очистить();

        НабпрСвойств=НаборЗаписей.Добавить();

        ЗаполнитьЗначенияСвойств(НабпрСвойств,стр); // Из выборки по табличной части документа, если нужно
        НабпрСвойств.Период=Дата;
            НабпрСвойств.Контрагент=Ссылка;

        НаборЗаписей.Записать();


Ну и не забывать очищать Записи в регистреСведений при распроведении/удалении документа
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173778 · Ответов: 3 · Просмотров: 1165
 

>  Как загрузить счет или накладную в формате Эксель на приход в склад
volodya1122
Отправлено: 27.06.21, 21:17


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Просто агрузкаДанныхИзТабличногоДокумента.epf сущестует для обычных и для управляемых форм. Вы скорее всего скачали не ту
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #173772 · Ответов: 3 · Просмотров: 1104
 

>  Перебор одноименных элементов справочника
volodya1122
Отправлено: 25.06.21, 10:09


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


miha74 @ Сегодня, 10:49 * ,

Так тут вы ищите только совпадение с конкретным значением Наименования. В таком случае можно использовать другую выборку
 //СпрВидыКатегорий.ВыбратьЭлементы(0);
СпрВидыКатегорий.ВыбратьЭлементыПоРеквизиту("Наименование",плНаименование,0);
   Пока СпрВидыКатегорий.ПолучитьЭлемент() = 1 Цикл
        Если СпрВидыКатегорий.Комментарий=плКомментарий Тогда
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #173765 · Ответов: 12 · Просмотров: 1673
 

>  Перебор одноименных элементов справочника
volodya1122
Отправлено: 25.06.21, 9:39


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


miha74 @ Сегодня, 10:31 * ,

Сорри, не заметил что 7.7

Можно переделать легко на 7,7
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #173763 · Ответов: 12 · Просмотров: 1673
 

>  Перебор одноименных элементов справочника
volodya1122
Отправлено: 25.06.21, 9:19


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


miha74 @ Вчера, 22:14 * ,

Похожая ситуация обсуждалась. Можете попробовать применить данный метод себе
Вот тут

Или например так
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    Контрагенти.Наименование,
    |    1 КАК Повторов
    |ИЗ
    |    Справочник.Контрагенти КАК Контрагенти
    |ГДЕ
    |    Контрагенти.ЭтоГруппа = ЛОЖЬ";
    
    ТаблЗнач = Запрос.Выполнить().Выгрузить();
    ТаблЗнач.Свернуть("Наименование","Повторов");
    ТаблЗнач.Сортировать("Повторов Убыв");
    ТекСтрокаТаблицы=ТаблЗнач.Получить(0);
    МаксПовторов=ТекСтрокаТаблицы[1];
    Если МаксПовторов=1 тогда
        Сообщить("Немає повторов");
    Иначе
        Для Каждого Стр Из ТаблЗнач Цикл
            Если Стр.Повторов=1 тогда
                Прервать;
            КонецЕсли;    
            Сообщить("Повторы= "+Стр.Наименование);
        КонецЦикла;

    КонецЕсли;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #173758 · Ответов: 12 · Просмотров: 1673
 

>  Помогите найти файлик processing.ert
volodya1122
Отправлено: 24.06.21, 14:26


Оратор
Иконка группы

Группа: Местный
Сообщений: 328
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Скорее всего эта обработка из этого (Обмен данными между 1С:Предприятие 7.7 и 1С-Битрикс)
https://www.bx77.ru/download/

Может у кото-то это есть. Я этого не использую
  Форум: Прочее 1С 7.7 · Просмотр сообщения: #173753 · Ответов: 9 · Просмотров: 1631
 

13 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 30.11.22, 4:48
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!