Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику TipsyKID ::: Спасибо сказали: 160 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
19.11.19, 18:45 Де треба поставити галочку, щоб інтерфейс був компактний?
Посмотрите как тут сделано, галочки нет:
Изменение масштаба интерфейса для "Такси"

Если админы захотят, могут прикрепить файл.
audit7buh,
26.02.19, 15:06 Выгрузка табличной части документа в Excel
Vidocq05 @ Сегодня, 13:25 * ,

Как то так, разници между обработкой и просто куском кода нет, лишь то откуда брать макет из обработки, из общего макета или макета документа:

&НаСервере
Процедура ВывестиСКДВТабличныйДокумент(МакетСКД, ТабличныйДокумент, КомпоновщикНастроек = Неопределено)
    
    Если КомпоновщикНастроек = Неопределено Тогда
        КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных;
        КомпоновщикНастроек.ЗагрузитьНастройки(МакетСКД.НастройкиПоУмолчанию);        
    КонецЕсли;
    
    Настройки = КомпоновщикНастроек.ПолучитьНастройки();  
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    
    МакетКомпоновки = КомпоновщикМакета.Выполнить(МакетСКД, Настройки);
    
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);
    
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ТабличныйДокумент);
    
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    
КонецПроцедуры

&НаСервере
Процедура КомандаВывестиВТабличныйДокументНаСервере()
    
    Обработка =  РеквизитФормыВЗначение("Объект");
    Макет = Обработка.ПолучитьМакет("Макет");    
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ВывестиСКДВТабличныйДокумент(Макет,ТабличныйДокумент);
    
    ТабличныйДокумент.Записать(<ПолныйПутьКФайлу>,ТипФайлаТабличногоДокумента.XLSX);
    
КонецПроцедуры

&НаКлиенте
Процедура КомандаВывестиВТабличныйДокумент(Команда)
    КомандаВывестиВТабличныйДокументНаСервере();
КонецПроцедуры
Vidocq05,
20.02.19, 18:49 Требуется программист 1с7 и 1с8
Цитата(Dartvader111 @ 20.02.19, 16:49) *
Да годовалых детей не берем!

Чувствую себя дитем...дайте сисей:

Общие требования :

Размер от 2,5 - 3,5.
Возраст от 25 до 35 лет.
Пол женский
Образование не имеет значения, главное чтобы было.
awp, Vladal,
20.02.19, 14:15 Создать 2 вида входа на 1 компьютере
andreykyiv@bigmir.net @ Сегодня, 12:15 * ,

Скопировать роль Пользователь, назвать как то (ПользовательНеТостый), убрать "толстый клиент", в коде найти все проверки на "РольДоступна("Пользователь") и добавить через логическое ИЛИ "ПользовательНеТостый" (по идеи их не много).
Заменить у "умного" кладовщика роль пользователя на новую.

ПользовательНеТостый - шутка
andreykyiv@bigmir.net,
19.02.19, 19:15 Создать 2 вида входа на 1 компьютере
Цитата(andreykyiv@bigmir.net @ 19.02.19, 17:01) *
И обойти эту установку нельзя


льзя:


Для принудительного запуска предприятия в Обычном или Управляемом приложении используются следующие ключи:

/RunModeOrdinaryApplication запуск толстого клиента в обычном режиме, несмотря на настройки конфигурации и пользователя, от имени которого будет выполняться запуск.

/RunModeManagedApplication запуск толстого клиента в режиме управляемого приложения, несмотря на настройки конфигурации и пользователя, от имени которого будет выполняться запуск.

При указании любого из этих двух ключей отключается механизм автоматического выбора клиентского приложения кроме случаев, когда пользователь в командной строке явно указал ключ /AppAutoCheckMode (с 8.2.15)


Настройте нормально права.
andreykyiv@bigmir.net,
18.02.19, 13:31 Создать 2 вида входа на 1 компьютере
andreykyiv@bigmir.net @ Сегодня, 12:40 * ,
Роли надо нормально настроить...

andreykyiv@bigmir.net,
29.12.18, 14:31 На какую конфигурацию платформы 1С 8.3 можно перейти с Комплексной 1С 7.7 (с конвертацией всех данных)?
KriAn @ Сегодня, 13:18 * ,
Ничего, конвертация - это история о том как маленький, но гордый системный администратор выходит с важным поручением в далекую страну ради высшего блага, а приходит спустя 18 лет (или около того) с пониманием того, что
перенесенные им в путешествии раны никогда уже не затянутся, и позднее удаляется от дел. Его мучают воспоминания пережитого, неоправданное чувство вины, что его поход кончился выживанием, а не самопожертвованием, а кроме того, и тёмными искушениями


Но даже у него, для выполнения столь особого задания должны быть друзья, которые спасут его из пещеры с багами во главе с огромной паучихой, которые накормят его вкусными лепешками по щекам, что - бы он не тупил и не засыпал, которые не дадут ему переметнулся на темную сторону SAP.

С новым годом.
Найдите толковых аналитиков/программистов или обратитесь к франчам.
Перенос данных это не то на чем стоит экономить.
vitop_2020,
20.12.18, 13:33 Как удерживать ЕСВ с "Чорнобильска відпустка"?
eact @ Сегодня, 12:56 * ,
расчет расходов (сумма отпускных и начисленного на нее ЕСВ), понесенных в связи с «чернобыльским» отпуском, по форме № 3, утвержденной приказом № 391, детально тут

Добавте строчку:

ПВР = ВзносыВФонды
Вид расчета = ЕСВ ФОТ (оплата труда)
eact,
20.12.18, 13:18 Где в УТ 3.1 можно найти свойства номенклатуры?
kot488 @ Сегодня, 11:46 * ,
"Администрирование" - "Общие настройки" - "Дополнительные реквизиты и сведения" (галочка должна быть включена)
И я написал
Цитата(TipsyKID @ 19.12.18, 20:05) *
Форма элемента справочника "Номенклатура"
а не форму списка
kot488,
14.12.18, 13:23 Выод форматированного документа в табличный документ
Решил поделиться решением.
Задача: есть форматированный документ его необходимо вывести в табличный документ.
Процедуры не полностью универсальные, содержат ряд условностей, но для начала, как пища для размышлений, подойдет.

Проблемы которые пока не получилось сделать лучше:
1.Нумерованный список в нумерованном списке в нумер.... и т.д..
2.Маркированный список в маркированном списке в марки... и т.д..
3.После применения форматирования оригинальная область приходит в негодность и ее надо восстановить для дальнейшего использования
4. Выделение цветного текста происходит по последнему условному оформлению "параграфа" (беда 1с, что в табличном документе в рамках одной ячейки нельзя устанавливать разное оформление: шрифт, цвет и т.д..)

Если есть подсказки, идеи, фиксы ошибок: готов выслушать.
Кстати, тема очень актуальная, т.к. объект "Форматированный документ" - очень перспективен, но загвоздка в том, что вывести и полноценно распечатать его является проблемой, что очень сильно ограничивает область применения.

// Описание
//      Устанавливает свойства ячеек области в зависимости от элемента форматированного документа
// Параметры
//  Область -  ОбластьЯчеекТабличногоДокумента - область которую следует изменить
//  ЭлементФорматированногоДокумента -  ТекстФорматированногоДокумента - элемент по которому следует изменить область
Процедура УстановитьУсловноеФорматированиеОбласти(Область,ЭлементФорматированногоДокумента) Экспорт
    
    Если НЕ ТипЗнч(ЭлементФорматированногоДокумента) = Тип("ТекстФорматированногоДокумента") Тогда
        Возврат
    КонецЕсли;    
    
    ЗаполнитьЗначенияСвойств(Область.Области[0],ЭлементФорматированногоДокумента,,"Текст");
    
    Если ЗначениеЗаполнено(ЭлементФорматированногоДокумента.НавигационнаяСсылка) Тогда
        
        Область.Области[0].Гиперссылка = Истина;
        Область.Области[0].ЦветТекста = WebЦвета.СинеСерый;
        Область.Области[0].Шрифт = Новый Шрифт(,,,,Истина);
        
    КонецЕсли;
    
    
КонецПроцедуры //установитьУсловноеФорматированиеОбласти

// Описание
//         Добавляет в табличный документ оббласть с форматированным текстом (переносит форматирование на ячейку области)
// Параметры
//  ТабличныйДокумент -  ТабличныйДокумент - Табличный документ в который следует вставить область
//  Область -  ОбластьЯчеекТабличногоДокумента - область которую следует изменить
//  ЭлементФорматированногоДокумента -  ТекстФорматированногоДокумента - элемент по которому следует изменить область
Процедура ВывестиФорматированныйТекстВТабличныйДокумент(ТабличныйДокумент,Область,ЭлементФорматированногоДокумента) Экспорт
    
    
    УстановитьУсловноеФорматированиеОбласти(Область,ЭлементФорматированногоДокумента);
    ТабличныйДокумент.Вывести(Область);

// к сожалению, после применения форматирования оригинальная область приходит в негодность
//                                                                и ее надо восстановить для дальнейшего использования
    
//    //ЗаполнитьЗначенияСвойств(Область.Области[0],ОбластьТекстПоУмолчанию.Области[0],,"Текст,Шрифт,Заполнение,");
//    
//    Область.Области[0].Шрифт = Новый Шрифт;
//    Область.Области[0].ЦветРамки         = Новый Цвет;
//    Область.Области[0].ЦветТекста         = Новый Цвет;
//    Область.Области[0].ЦветУзора         = Новый Цвет;
//    Область.Области[0].ЦветФона         = Новый Цвет;
//    

КонецПроцедуры //ВывестиФорматированныйТекстВТабличныйДокумент

// Описание
//     Выводит в табличный документ форматированный документ
// Параметры
//  Макет - Макет - Макет
//  ОписаниеФорматированныйДокумент - ФорматированныйДокумент - форматированный документ который следует вывести
//  ТабличныйДокумент - ТабличныйДокумент -  Табличный документ в который следует вывести форматированный документ
Процедура ВывестиФорматиованныйДокументВТабличныйДокумент(Макет,ОписаниеФорматированныйДокумент,ТабличныйДокумент,ТолькоТекстКлиента,
                                                          ИмяОбластиОписание = "ОбластьОписание",ИмяОбластиКартинка = "ОбластьОписаниеКартинка") Экспорт
    
    РазмерПикселя = 0.264583333333334;//размер пикселя в миллиметрах, кто бы знал!
    
    ОбластьТекст = Макет.ПолучитьОбласть(ИмяОбластиОписание);
    ОбластьКартинка = Макет.ПолучитьОбласть(ИмяОбластиКартинка);
    
    ДокументПолучатель = Новый ФорматированныйДокумент;
    НомерцияПараграфа  = 0;
    Для Каждого Параграф Из ОписаниеФорматированныйДокумент.Элементы Цикл
        
        ЭтоМаркСписок = Параграф.ТипПараграфа = ТипПараграфа.МаркированныйСписок;
        ЭтоНумСписок = Параграф.ТипПараграфа = ТипПараграфа.НумерованныйСписок;
        ЭтоОбычныйСписок = Параграф.ТипПараграфа = ТипПараграфа.Обычный;
        
        ПриставкаПараграфа = "";
        
        Если ЭтоМаркСписок  Тогда
            ПриставкаПараграфа = " • ";
            НомерцияПараграфа = 0;
        ИначеЕсли ЭтоНумСписок Тогда
            НомерцияПараграфа = НомерцияПараграфа + 1;
        Иначе
            НомерцияПараграфа = 0;
        КонецЕсли;
        
        //Накапливаем текст / данные
        ТекущийТипПараграфа = Неопределено;
        Описание = ПриставкаПараграфа;
        ЭлементПараграфаДляОформленияОбласти = Неопределено;
        
        Для Каждого ЭлементПараграфа Из Параграф.Элементы Цикл
            
            ТекущийТипПараграфа = ?(ТекущийТипПараграфа = Неопределено,Тип(ЭлементПараграфа),ТекущийТипПараграфа);
            Если Тип(ЭлементПараграфа) = Тип("ТекстФорматированногоДокумента") Тогда
                
                Если ЭтоНумСписок Тогда
                    ПриставкаПараграфа = Лев(" " + Формат(НомерцияПараграфа,"ЧЦ=3; ЧДЦ=") + ".  ",4);//ограничем 99
                    Описание = ПриставкаПараграфа + Описание + ЭлементПараграфа.Текст;    
                Иначе
                    Описание = Описание + ЭлементПараграфа.Текст;    
                КонецЕсли;
                ЭлементПараграфаДляОформленияОбласти = ЭлементПараграфа;
                ТекущийТипПараграфа = Тип("ТекстФорматированногоДокумента");
            ИначеЕсли Тип(ЭлементПараграфа) = Тип("ПереводСтрокиФорматированногоДокумента") Тогда
                
                Если ТекущийТипПараграфа = Тип("ТекстФорматированногоДокумента") Тогда
                    ТекущийТипПараграфа = Тип("ПереводСтрокиФорматированногоДокумента");
                    
                    Если ТолькоТекстКлиента Тогда
                        ШаблоныЗаполнения.ВернутьШаблонБезТегов(Описание);
                    КонецЕсли;
                    
                    ОбластьТекст.Параметры.Описание = Описание;
                    
                    
                    ВывестиФорматированныйТекстВТабличныйДокумент(ТабличныйДокумент,ОбластьТекст,ЭлементПараграфаДляОформленияОбласти);
                    ОбластьТекст = Макет.ПолучитьОбласть("ОбластьОписание");
                    Описание = ПриставкаПараграфа;
                КонецЕсли;
                
                ОбластьТекст.Параметры.Описание = "";
                
                ТабличныйДокумент.Вывести(ОбластьТекст);
            ИначеЕсли Тип(ЭлементПараграфа) = Тип("КартинкаФорматированногоДокумента") Тогда
                Если ТекущийТипПараграфа = Тип("ТекстФорматированногоДокумента") Тогда
                    ТекущийТипПараграфа = Тип("КартинкаФорматированногоДокумента");
                    
                    ОбластьТекст.Параметры.Описание = Описание;
                    ТабличныйДокумент.Вывести(ОбластьТекст);
                    Описание = ПриставкаПараграфа;
                КонецЕсли;
                
                СтрокаURL = ЭлементПараграфа.Картинка;
                
                //Преобразовываем в полноценный base64
                ИмяHeader = "base64,";
                НомерСимволаКонца = СтрНайти(СтрокаURL,ИмяHeader) + СтрДлина(ИмяHeader) - 1;
                ДлинаСтроки = СтрДлина(СтрокаURL);
                
                СтрокаBase64 = Прав(СтрокаURL,ДлинаСтроки - НомерСимволаКонца);
                
                ДанныеКартинки = Base64Значение(СтрокаBase64);
                //Определим тип файла / картинки
                ТипФайла = Сред(СтрокаURL,СтрНайти(СтрокаURL,";") -3,3);
                ПутьКВременномуФайлу = ПолучитьИмяВременногоФайла(ТипФайла);
                ДанныеКартинки.Записать(ПутьКВременномуФайлу);
                
                Картинка = Новый Картинка(ПутьКВременномуФайлу);
                
                //Динамический вывод картинки в табличный документ
                КартинкаПечатьОрганизации = ОбластьКартинка.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                КартинкаПечатьОрганизации.Картинка = Картинка;
                КартинкаПечатьОрганизации.Верх = 0;
                КартинкаПечатьОрганизации.Высота = ЭлементПараграфа.Высота * РазмерПикселя;
                КартинкаПечатьОрганизации.Ширина = ЭлементПараграфа.Ширина * РазмерПикселя;
                КартинкаПечатьОрганизации.Лево = 25;
                КартинкаПечатьОрганизации.ГраницаСверху = Ложь;
                КартинкаПечатьОрганизации.ГраницаСлева = Ложь;
                КартинкаПечатьОрганизации.ГраницаСправа = Ложь;
                КартинкаПечатьОрганизации.ГраницаСнизу = Ложь;
                КартинкаПечатьОрганизации.РазмерКартинки = РазмерКартинки.РеальныйРазмер;
                ТабличныйДокумент.Вывести(ОбластьКартинка);
            КонецЕсли;
            
        КонецЦикла;
        
        Если НЕ Описание = ПриставкаПараграфа Тогда
            Если ТолькоТекстКлиента Тогда
                ШаблоныЗаполнения.ВернутьШаблонБезТегов(Описание);
            КонецЕсли;
            
            ОбластьТекст.Параметры.Описание = Описание;
            
            ВывестиФорматированныйТекстВТабличныйДокумент(ТабличныйДокумент,ОбластьТекст,ЭлементПараграфаДляОформленияОбласти);
            
            ОбластьТекст = Макет.ПолучитьОбласть("ОбластьОписание");
            Описание = ПриставкаПараграфа;
        КонецЕсли;
        
    КонецЦикла;
        
КонецПроцедуры //ВывестиФорматиованныйДокументВТабличныйДокумент
Vofka,
13.12.18, 16:59 Начисления и выплаты в натуральной форме
eact @ Сегодня, 16:51 * ,
Советую свериться с Подарки (доходы в натуральной форме)
А так, вроде все норм.
eact,
30.07.18, 11:13 Программное присваивание значения реквизита формы тип Картинка (1с 8.2 8.2.19.106)
Применяю колдовство шамана 8-ого уровня, читаю мыслеконтур ТС..
Обычные формы:

Процедура ПутьККартинкеНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;

    ДиалогаВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогаВыбораФайла.ПолноеИмяФайла = "";
    ДиалогаВыбораФайла.Фильтр = "Файлы (*.jpg,*.*)|*.jpg;*.*";
    ДиалогаВыбораФайла.МножественныйВыбор = Ложь;
    ДиалогаВыбораФайла.Заголовок = "Выберите файл";

    Если Не ДиалогаВыбораФайла.Выбрать() Тогда
        Возврат;        
    КонецЕсли;
    
    ПутьККартинке = ДиалогаВыбораФайла.ПолноеИмяФайла;
    НоваяКартинка = Новый Картинка(ПутьККартинке);
    ЭлементыФормы.ПолеКартинки.Картинка = НоваяКартинка;
    
КонецПроцедуры


УФ
&НаКлиенте
Процедура ПутьККартинкеНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;

    ДиалогаВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогаВыбораФайла.ПолноеИмяФайла = "";
    ДиалогаВыбораФайла.Фильтр = "Файлы (*.jpg,*.*)|*.jpg;*.*";
    ДиалогаВыбораФайла.МножественныйВыбор = Ложь;
    ДиалогаВыбораФайла.Заголовок = "Выберите файл";

    Если Не ДиалогаВыбораФайла.Выбрать() Тогда
        Возврат;        
    КонецЕсли;
    
    Объект.ПутьККартинке = ДиалогаВыбораФайла.ПолноеИмяФайла;
    НоваяКартинка = Новый Картинка(Объект.ПутьККартинке);
    АдрессВременногоХранилища = ПоместитьВоВременноеХранилище(НоваяКартинка.ПолучитьДвоичныеДанные());
    
КонецПроцедуры

andrew76,
30.05.17, 8:35 Структура. Отбор по заполненному значению - реально?
Варианты:

1. Добавить вспомогательное поле "ДокументЗаполнен", тип булево, предусмотреть его заполнение (предполагаю на сервере).
2. В обычном цикле пройтись по табличной части и насобирать строки у которых заполнен документ.

Желательно б уточнить, для чего собираются строки (если для визуального отбора на форме, то лучше такое делать через "Условное оформление"
Inkognito,
23.01.17, 11:40 Ошибка при вводе операции вручную
Дмитрий Максимов @ Сегодня, 11:04 * ,
Добрый день.
У Вас не хватает прав.
На данный РС права на чтение есть у следующий прав : "Чтение данных бухгалтерии"
Право на редактирование данного РС есть у следующих прав: "Полных права", "Добавление и изменение данных бухгалтерии".
Дмитрий Максимов,
18.10.16, 15:43 Как перенести элемент спр.ТМЦ в другую папку спр.ТМЦ
Проверено работает.

Процедура ИзменитьРодителяНоменклатуры(Номенклатура,НовыйРодитель)
    
    Если НовыйРодитель.ЭтоГруппа() = 0 тогда
        Предупреждение("Укажите группу в качестве родителя!");
        Возврат;
    КонецЕсли;
    
    Спр = СоздатьОбъект("Справочник.ТМЦ");
    Спр.НайтиЭлемент(Номенклатура);
    
    Спр.Родитель = НовыйРодитель;
    
    Попытка
        Спр.Записать();
        Сообщить("Для элемента " + Номенклатура + " был изменен родитель на " + НовыйРодитель);
    Исключение
        Сообщить("" + ОписаниеОшибки());
    КонецПопытки;
    
КонецПроцедуры
//*******************************************


Ссылка на тестовую обработку "Изменение родителя номенклатуры"
TTT,
13.10.16, 12:44 Помогите начинающему в обработке справочника
Используйте уже готовую вспомогательную обработку:
Универсальный подбор и обработка объектов

0. Сохраняете базу перед работой.
1. Открываете обработку. Выбираете необходимый справочник.
2. Нажимаете кнопку "Найти объекты"
3. Переходите на вкладку "Обработки".
4. ДОбавляете произвольный алгоритм:
Код алгоритма:
        Объект.Наименование = ТРег(Объект.Наименование);
        Объект.Записать();

5.Выполняете его.
savicus,
11.10.16, 18:12 Вывод картинки товара в поле картинки
Добавьте на форму (в табличную часть) реквизит формы "АдресКартинки".
Обратите внимание на процедуры "ПередЗаписью" и "ПередЗаписьюНаСервере".

Главная идея: не ганяем при каждом клике по строке клиента на сервер, а изначально ссылки на временные адреса храним у клиента, и только в момент записи передаем эти адреса на сервер и записываем их + при открытии апдейтим их.

Код не идеален, просто, за 15 минут, что успел -написал.

&НаКлиенте
Процедура ДобавитьИзображение(Команда)
    
    ТекСтрока = Элементы.Товары.ТекущиеДанные;
    
    Если ТекСтрока = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Режим = РежимДиалогаВыбораФайла.Открытие;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
    Фильтр = "Изображения(*.bmp,*.jpg,*.png,*.jpeg)|*.bmp;*.jpg;*.png;*.jpeg";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите файл для загрузки";
    
    ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ДобавитьИзображениеЗавершение", ЭтотОбъект, Новый Структура("ДиалогОткрытияФайла, ТекСтрока", ДиалогОткрытияФайла, ТекСтрока)));  
    
КонецПроцедуры

&НаКлиенте
Процедура ДобавитьИзображениеЗавершение(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
    
    ДиалогОткрытияФайла = ДополнительныеПараметры.ДиалогОткрытияФайла;
    ТекСтрока = ДополнительныеПараметры.ТекСтрока;
    
    
    Если Не (ВыбранныеФайлы <> Неопределено) Тогда
        
        Возврат;
        
    КонецЕсли;
    
    ПолноеИмяФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;
    
    АдресКартинки = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ПолноеИмяФайла), ЭтотОбъект.УникальныйИдентификатор);
    
    ТекСтрока = Элементы.Товары.ТекущиеДанные;
    ТекСтрока.АдресКартинки = АдресКартинки;

КонецПроцедуры

//Отображение картинки при переходе по строкам
//
&НаКлиенте
Процедура ТоварыПриАктивизацииСтроки(Элемент)
    
    ТекСтрока = Элемент.ТекущиеДанные;
    Если ТекСтрока = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    АдресКартинки = ТекСтрока.АдресКартинки;
    
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
    инд = 1;
    Для Каждого СтрокаТовары Из ТекущийОбъект.Товары Цикл
        СсылкаНаКартинку = ПараметрыЗаписи["СтрокаТовары" + Формат(инд,"ЧГ=0")];
        Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) Тогда
            СтрокаТовары.ХранилищеИзображения = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(СсылкаНаКартинку));
        КонецЕсли;
        инд = инд + 1;
    КонецЦикла;
    
КонецПроцедуры

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    инд = 1;
    Для Каждого СтрокаТовары Из Объект.Товары Цикл
        ПараметрыЗаписи.Вставить("СтрокаТовары" + Формат(инд,"ЧГ=0"),СтрокаТовары.АдресКартинки);  
        инд = инд + 1;
    КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Для Каждого СтрокаТовары Из Объект.Товары Цикл
        СтрокаТовары.АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Товары.ХранилищеИзображения", СтрокаТовары.НомерСтроки - 1 );
    КонецЦикла;    
КонецПроцедуры

vlad_,
23.09.16, 14:53 Зіштовхнувся з 1C Trade Managment
Ну, для того, что - бы мы были уверенны в реальном идиотизме кода необходимо удостоверится, что дальше в условии нет "Метки".
Ведь дальше может быть следующее (пофантазируем)

If ReturnResult = Undefined Then
        
      WriteInFile = False;
        
      If WriteInFile Then
          ~SendMessage:

          Text = "Беда не в том, что человек глуп, беда в том, что он глуп внезапно."
          StrReplace(Text,"глуп","смертен");

          Message(Text);

          WriteInFile = True; //условие выхода
      EndIf;

EndIf;

If (ReturnResult = Undefined) AND (Not WriteInFile) Then
   Goto ~SendMessage;
EndIf;


Сори, за оффтопик, да простят меня модераторы.
logist,
25.04.16, 16:13 Язык текста ячейки макета
robot1 @ Сегодня, 15:46 *,
Кладете файлик в спец. каталог.
Правка - > Редактирование текстов интерфейса
Указываете только необходимый каталог.
Действия - > Копировать тексты
(Указываете с какого на какой язык)
robot1,
15.04.16, 16:52 Загрузка данных из Excel
В событиях, перед записью объекта ( в обработке "Загрузка данных из табличного документа" ) добавте код



СтарыйОбект = Объект.Ссылка.ПолучитьОбъект();
ОбщегоНазначения.ЗагрузитьВТаблицуЗначений(СтарыйОбект[ТабличнаяЧастьИсточника],Объект[ТабличнаяЧастьИсточника]);

pqvv,
25.03.16, 15:26 Прочитать файл (двоичные данные) как строку
png и тестил на zip
Petre,
04.03.16, 17:32 Ошибка при отмене сохранения документа
Цитата(nysysimara @ 04.03.16, 14:39) *
inna.innainna84, вы лентяйка,


inna.innainna84
,
не обижайтесь на коменты в этой теме,
женщины-программисты они такие
ссылка на причину моего плоского юмора
nysysimara,
26.02.16, 15:47 Как проверить соединение с MS SQL Server (*.udl)
Бывает, что конструкция типа :
   Conn = Новый COMОбъект ("ADODB.Connection");
   Conn.Open("Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=Northwind");


вылетает с ошибкой и не понятно, не корректна сама строка соединения, что - то не так с драйверами или ошибка где - то в доступе к базе данных.

Для проверки соединения с MS SQL Server необходимо выполнить следующие действия:

1. Создать на диске файл (в любом месте) test.udl.

2. Запусть его двойным кликом мыши.

3. Появиться окно. Выбрать «Microsoft OLE DB Provider for SQL Server»

4. Перейти на закладку «Соединение».

5. Ввести все необходимые параметры (как минимум: имя сервера и логин).

6. В случае удачного соединения появиться окно. Иначе появиться сообщение об ошибке.

7. Если открыть файл test.udl в текстовом редакторе, то можно посмотреть какая строка соединения используется.



(С)
kosalex, mister-x, Vofka,
26.02.16, 15:05 Выполнение процедуры при переходе даты
Добрый день.
1-й вариант : отказаться от идеи контролировать это в рамках дня. Записывать отдельно статус сотрудника : "вошел в здание", "вышел из здания". При срабатывании карточки на пропускном пункте запрашивать последний статус и добавлять запись с противоположным значением.
2-й вариант : если есть Физ. Лицо, значит можно найти сотрудника. У сотрудника есть связь с графиком. В зависимости от графика решать начало это нового дня или окончание смены.
3-й вариант : закрывать все статусы карточек, только на время 23:59:59 и открывать в 00:00:00


P.S.Есть мнение, что слова "ихнее" нет в русском языке
Yevhenii,
26.02.16, 14:01 StartManager 1.4 – стартер для баз данных
Доброго времени суток.
Раньше пользовался "Hot Tray 1c .net".
Но "StartManager 1.4"- это комбайн на все случаи жизни, перешел на него теперь.
Ссылка на описание : StartManager 1.4 - Развитие альтернативного стартера

Функциональные особенности

Ниже перечислены основные функциональные возможности StartManager 1.4, которые отсутствуют в штатном стартере от 1С:


1. Универсальное самостоятельное приложение, не требующее дополнительных библиотек, с возможностью запуска со сменного носителя информации;
2. Все базы в одном месте: иерархический список с возможностью отображения информационных баз (ИБ) для 4-х платформ (8.1, 8.2, 8.3, 8.4) одновременно и по отдельности;
3. Список ИБ содержит дополнительные информационные колонки отображающие: версию платформы, дату изменений и размер файла ИБ;
4. Возможность использования альтернативных файлов списков информационных баз отдельно для каждой из четырех платформ;
5. Механизм интерактивного отбора в списке информационных баз по ключевой фразе содержащейся в наименовании ИБ;
6. Возможность запуска информационной базы с предварительным выбором предопределенных параметров;
7. Возможность сохранения имени пользователя и пароля раздельно для режима «Конфигуратор» и «1С:Предприятие», а так же для Хранилища конфигурации;
8. Возможность подключения программного комплекса «Snegopat» отдельного для платформы «8.2» и «8.3», для которых он должен использоваться;
9. Реализован механизм поиска информационных баз (1Cv8.1CD) в предопределенных каталогах локального диска и регистрация их в списке информационных баз;
10. Реализована возможность удаления из списка тех информационных баз, у которых отсутствует файл 1Cv8.1CD;
11. Добавлена возможность удаления зависших процессов «1С:Предприятия» из оперативной памяти:
12. Реализован механизм интеграции с проводником Windows позволяющий:
12.1. быстро зарегистрировать файл 1Cv8.1CD в списке информационных баз;
12.2. запустить файл в режиме «1С:Предприятие»;
12.3. запустить файл в режиме «Конфигуратор».
13. Изменение внешнего вида интерфейса при помощи стилей оформления (VCL Styles). Можно предопределить 5 основных стилей оформления для быстрого переключения.
14. Дополнительно к стилям оформления, для списка баз возможно:
14.1. установить свой шрифт и его размер;
14.2. настроить высоту строк списка;
14.3. настроить вид и интенсивность выделения курсора;
14.4. назначить собственный цвет текста наименования информационных баз индивидуально для каждой платформы;
14.5. назначить собственное оформление для отсутствующих информационных баз;
14.6. назначить цвет для группы из 7-и предопределённых
15. Возможность сохранения текущего состояния списков информационных баз с последующим восстановлением, включая механизм автосохранения при запуске;
16. Реализован механизм сценариев резервирования позволяющий:
16.1. Выгружать данные информационной базы (*.dt)
16.2. Выгружать структуру конфигурации (*.cf)
16.3. Архивировать данные в формате ZIP (*.zip)
16.4. Архивировать данные в формате RAR (*.rar)
17. Добавлена возможность включения и отключения механизма отображения истории запуска информационных баз;
18. Добавлена возможность - без открытия конфигуратора:
18.1. выполнить загрузку конфигурации из CF-файла;
18.2. выполнить загрузку информационной базы из DT-файла;
18.3. выполнить тестирования ИБ.
19. Добавлена возможность временной блокировки StartManager (например, на время отсутствия пользователя);
20. Добавлена возможность установки/снятия блокировки файловой информационной базы без открытия «1С:Предприятия»;
21. Встроенный механизм проверки наличия обновлений индивидуально для каждой информационной базы;
22. Новый механизм проверки обновлений «Актуальные релизы»;
23. Очистка программного или пользовательского кэш (cache) определенной информационной базы или всех информационных баз из списка, с возможностью указания пользователей системы;
24. Возможность удаления кэш (cache) оставшегося от информационных баз, ранее удаленных из списка;
25. Индивидуально для каждой информационной базы можно указать ссылку на внешнюю обработку для последующего запуска при открытии в режиме «1С:Предприятие»;
26. Механизм быстрого доступа к избранным информационным базам (с поддержкой drag&drop) включая доступ через меню в системном трее;
27. Быстрое создание ярлыка на рабочем столе для любой ИБ;
28. Назначение действия для события двойного щелчка как всех информационных баз, так и индивидуально для каждой ИБ;
29. Быстрый запуск утилиты chdbfl.exe для проверки физической целостности с указанием пути к информационной базе;
30. Сохранение копии экрана в файл по предопределённому сочетанию клавиш;
31. Автозапуск при начале работы Windows;
32. Встроенный механизм автообновления стартера.
AlexanderTiger, basforum, digesha, DmitryS, dqwerty, mister-x, nmf, svs1s, Vofka, yarf, Zaval,

4 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 04.12.20, 1:09
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!