Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



11 страниц V   1 2 3 > » 

>  Как определить в двух строковых типах большее число
volodya1122
Отправлено: 30.06.20, 9:07


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Наприклад так можна

Функция СравнитьЧисла(МояСтрока1,МояСтрока2)
МассивЧисел1=СтрРазделить(МояСтрока1,".");
МассивЧисел2=СтрРазделить(МояСтрока2,".");
Для Индекс = 0 По МассивЧисел1.Количество() - 1 Цикл
    Если число(МассивЧисел1[Индекс])> число(МассивЧисел2[Индекс]) тогда
        Возврат "Перше число більше";
        //Прервать;
    ИначеЕсли число(МассивЧисел1[Индекс])< число(МассивЧисел2[Индекс]) тогда
        Возврат "Друге число більше";
        //Прервать;
    КонецЕсли;    
КонецЦикла;
Возврат "Числа однакові";
КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #164302 · Ответов: 3 · Просмотров: 133
 

>  При работе с фаловой базой данных подтормаживает 1С 7.7
volodya1122
Отправлено: 19.06.20, 13:16


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


F.U.T.U. @ Сегодня, 14:03 *

Можно попробоапть грохнуть 1cv7.mlg или обрезать
Также грохуть файли пользователей (файлы пользователей и должны занимать несколько килобайт)
Это немного ускорит работу (может на несколько процентов).
Но оптимизировать тут больше нечего. Так что только Скуль

В папке SYSLOG только один файл журнала или есть ешще какие?
  Форум: Платформа 7.7 · Просмотр сообщения: #164020 · Ответов: 10 · Просмотров: 256
 

>  При работе с фаловой базой данных подтормаживает 1С 7.7
volodya1122
Отправлено: 19.06.20, 11:43


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


F.U.T.U. @ Сегодня, 11:37 * ,

1. какие характеристики сервера на котором стоит 1С? и какая Ось?
2. Какой размер базы? Какой размер самого большого dbf ффайла?
3. Размер файла 1cv7.mlg в папке SYSLOG
4. Размер файлов в каталогах пользователя?
  Форум: Платформа 7.7 · Просмотр сообщения: #164014 · Ответов: 10 · Просмотров: 256
 

>  сравнить много значений
volodya1122
Отправлено: 11.06.20, 11:13


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Sharzem @ Сегодня, 9:59 * ,
Спеціально для мене заморочились? Звичайно це набагато краще. (оптимізовувати код можна до бескінечності). але і буковок набагато більше писати потрібно було,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163774 · Ответов: 7 · Просмотров: 285
 

>  сравнить много значений
volodya1122
Отправлено: 10.06.20, 14:20


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Вставлю и свои 5 копеек.
Я так проверяю в табличной части документа на дубли контрагентов. Легко можно переделать на проверку на дубли в таблице значений или списке значений. Тут отработает быстрее чем цикл в цикле
   сз=СоздатьОбъект("СписокЗначений");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
        зн=Контрагент.Код;
        поз=сз.НайтиЗначение(зн);
        Если поз<>0 Тогда
            СтараСтрічка="";
            тмп=сз.ПолучитьЗначение(поз,СтараСтрічка);
            сообщить("Однаковий Контрагент: "+Контрагент+" в рядках: "+СтараСтрічка+" і "+НомерСтроки,"!");
        КонецЕсли;
        сз.ДобавитьЗначение(зн,""+НомерСтроки);
    КонецЦикла;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163735 · Ответов: 7 · Просмотров: 285
 

>  не получается загрузить табличную часть документа в табличную часть на форме обработки
volodya1122
Отправлено: 08.06.20, 8:03


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


htggth @ Сегодня, 4:13 * ,
А так переделать концовку?
Результат = Запрос.Выполнить().Выбрать();
Результат.Следующий();
РабочееМестоСТО.Счет.Загрузить(Результат.Счет);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #163668 · Ответов: 3 · Просмотров: 201
 

>  Экспорт в Excell
volodya1122
Отправлено: 05.06.20, 8:23


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


vpr.ztr@gmail.com @ Вчера, 23:14 * ,

Для начала нужно понимать что Вам возвращает запрос. Например из документа ЗарплатаКВыплатеОрганизаций вернет данные из всех документов ЗарплатаКВыплатеОрганизаций которые есть в базе. Из стравочников Вы вибираете данные. Вы уверены что там есть только одна запись в каждом из этих справочников?

И так.
1. Как понять что возвращает запрос? Я делаю так:
    ВыборкаЗарплатаКВыплатеОрганизаций = ЗапросЗарплатаКВыплатеОрганизаций.Выполнить().Выгрузить();
        Построитель = Новый ПостроительОтчета;
    Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ВыборкаЗарплатаКВыплатеОрганизаций);
    Построитель.Макет = Неопределено;
    Макет = Построитель.Макет;
    Область = Макет.Область();
    Область.ШиринаКолонки = 20;
     Построитель.Макет = Макет;
    Построитель.Выполнить();
    Построитель.Вывести();
// в итоге на экране я вижу таблицу из результатом запроса

2. Выборку из запроса нужно делать так:
ВыборкаОрганизации = ЗапросОрганизации.Выполнить().Выбрать();
Пока ВыборкаОрганизации.Следующий() Цикл
НаименованиеОрганизации=ВыборкаОрганизации.НаименованиеПолное;
//тут будут перебиратся все записи в справичнике организации, если их больше одного
КонецЦикла;



  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #163629 · Ответов: 2 · Просмотров: 238
 

>  Управление формой из другой формы
volodya1122
Отправлено: 30.05.20, 8:00


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


4andriy @ Вчера, 23:15 * ,
1. потрібно бути трішки уважнішим. я ж написав ще
ОткрытьФорму(Док,СЗ);

У вас повинно бути подібний рядок в створенні де відкривається цей документ (ОткрытьФорму або ОткрытьФормуМодально)). Потрібно туди добавити так як я написав передачу списку значень.
2. Ви написали
Спр=СоздатьОбъект("СписокЗначений");

Змінна "Спр" можливо ще десь у вас використовується, Переіменуйте так щоб вона була унікальна. І зазвичай "Спр" називають Справочники, а не списак значень.
3. Ця лінійка лишня
Форма.закрыть();

4. Тут повинно бути не так
//ЗакрФорма=Спр.Форма;
ЗакрФорма=Форма.Параметр;


5. Ще помилка
//Если Спр.Получить("ЗакрФорма")=1 Тогда
Если ЗакрФорма.Получить("ЗакрФорма")=1 Тогда
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163465 · Ответов: 6 · Просмотров: 326
 

>  Управление формой из другой формы
volodya1122
Отправлено: 29.05.20, 11:53


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


4andriy @ Сегодня, 12:27 * ,

Добре, По тій схемі як Ви написали не спрацює. Потрібно через так зване "Ложное открытие" .
В мене так працює груповий друк документу.
Отже
1. в журналі де йде створення документу написати:
    СЗ=СоздатьОбъект("СписокЗначений");
    СЗ.Установить("ВыполнитьПечать",1); // змінну можете назвати так як забажаєте
ОткрытьФорму(Док,СЗ);


2. В самому документі в ПриОткрітии() в самому цінці процедури;
        _Параметр=Форма.Параметр;
    Если ТипЗначенияСтр(_Параметр)="СписокЗначений" Тогда
        Если _Параметр.Получить("ВыполнитьПечать")=1 Тогда
    //        Печать1(1,1);        
//Записать(); Провести();;  // по вкусу добавити      
            СтатусВозврата(0);
            Возврат;
        КонецЕсли;
    КонецЕсли;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163446 · Ответов: 6 · Просмотров: 326
 

>  Управление формой из другой формы
volodya1122
Отправлено: 29.05.20, 8:00


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


4andriy @ Вчера, 22:11 * ,

А зачем вообще открывать форму документа, если програмно создается документ и програмно записываются все нужные реквизиты в нем?4andriy @ Вчера, 22:11 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163444 · Ответов: 6 · Просмотров: 326
 

>  Как правильно сравнивать два строковых реквизита? 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 27.05.20, 9:27


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Невелике пояснення до відповіді denis84.
Чому використовується СокрЛП. Тому, що для текстового поля, його значення завжди займає всі символи відведені для нього. Якшо вказали наприклад 100 символів, то незалежно від того скільки заповнили, строка для 1С буже виглядати так (наприклад Адреса: "м. Київ, вул Банківська __________________________ " - тобто допониться пробілами до 100 символів)

П.с., не по темі. Бачу ви всі повідомлення пишети вночі, А спите коли, вдень? При такій великій нагрузці можна скоро "вигоріти" на роботі
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163371 · Ответов: 4 · Просмотров: 187
 

>  Как программно выбрать и изменить один документ 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 26.05.20, 8:04


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ZUBR @ Вчера, 23:33 * ,
Не ПолучитьДокумент а Расх.НайтиДокумент(СсылкаРасх);
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163336 · Ответов: 2 · Просмотров: 181
 

>  поиск в строке
volodya1122
Отправлено: 20.05.20, 8:27


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


4andriy @ Вчера, 23:18 * ,

У Вас неправильное использование фунции "Найти"

Функция "Найти" возвращает позицию первого вхождения в строку поиска заданной подстроки.

Если не находит - возвращает число 0.
Если находит то возвращает номер первого найденного символа (это может быть как 1 так и 2 и 7 и 25...., а не всегда 1 как вы написали)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163172 · Ответов: 2 · Просмотров: 232
 

>  Как сделать реквизит видимым только в одном слое расходной накладной? 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 16.05.20, 7:56


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Як я зрозумів, потрібно при різних наборах прав керувати видимістю деяких реквізитів на формі.
В доному випадку небачу красивого рішення. Можу запропонувати два варіанти
1. Аналізувати яка закладка відкрита. І якщо відкрита закладка де є Ваш реквізит тільки тоді керувати її видимістю (назва закладки знаходиться в реквізиті Значение).
2. Замість керувати видимістю, керуйте Доступністю реквізитів (реквізит буде видно на формі, але небуде доступний для натискання/вибору). В даному випадку вже непотрібно аналізувати яка закладка відкрита.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163053 · Ответов: 4 · Просмотров: 202
 

>  Как программно очистить поле на форме РасходнойНакладной? в 1С 7.70.003 торговля склад для Украины?
volodya1122
Отправлено: 14.05.20, 14:01


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111



ZUBR @ Сегодня, 14:00 * ,
Програмно реквизит любого типа банально чистится. Типа: МойРеквизит="";
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #163001 · Ответов: 2 · Просмотров: 311
 

>  Файлы хранения конфигурации 1С
volodya1122
Отправлено: 13.05.20, 12:02


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(Maxymoff @ 13.05.20, 12:07) *
Спасибо, про объединение конфигураций почитаю, я так понимаю это что-то вроде обработки, которая сравнит одну конфигурацию с другой и даст возможность добавить отличия одной в другую.Если не затруднит, где почитать? Заранее спасибо!

Это внутренняя обработка (внутри конфигурации). В конфигураторе в меню выбрать Конфигурация- Обеденение конфигураций...
Откроется меню для вибора файло из которого хотите загрузить конфигурацию. Виберете файл 1cv7.md из своей копии где делали изменения. Система промнализирует различия между двумя конфигурациями и покажет различия. Потом просто нажать обеденить (все отметки оставить по умолчанию)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #162961 · Ответов: 9 · Просмотров: 305
 

>  Как создать ссылку в документе не другой документ 1с 7.7 конф 7.7.003
volodya1122
Отправлено: 11.05.20, 20:39


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ZUBR @ Сегодня, 13:35 * ,

1. Чтото сильно намудрили с этими документами..... я до конца так и не понял. Поясню так как понял.
2. В документе акт нужно создать реквизит (СсылкаНаДокументРасхНакл) с типом Документ.РасходнаяНакладная
3. в документе Акт после Расх.Записать(); Написать СсылкаНаДокументРасхНакл=Расх.ТекущийДокумент():- это будет ссылка в Акте на ваш созданный документ расх накуладной.
4. Для ссылки На акт из расходной накладной; Расх.СсылкаНаАктПриема = ТекущийДокумент(); (соответственно реквизит в расходной накладной должен быть типа Документ.АктПрийома).
5. Ссылка на документ Расходная накладная, возможна только после его записи (после строки Расх.Записать()wink.gif. Соответственно и обратное, передавать ссылку на документ Акт в расходную накладную нужно после записи акта (написать Записать(); перед передачей ссылки на акт)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #162893 · Ответов: 5 · Просмотров: 166
 

>  Как сделать дополнительную вкладку в документе? 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 07.05.20, 11:59


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Ну так в документе у вас уже все готовое есть просто нужно посмотреть как реализовано.
1. Переключение закладок : Процедура ПриВыбореЗакладки(Номер,Значение)
2. Установка закладок в ПриОткрытии уснанавливается визуальное отображение закладок
Форма.ИспользоватьЗакладки(1);
    Форма.Закладки.ДобавитьЗначение("Основной","Основна");
    Форма.Закладки.ДобавитьЗначение("Довереность","Довіреність");
    Форма.ИспользоватьСлой("Основной, Совместный",2);
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #162797 · Ответов: 1 · Просмотров: 187
 

>  Заполнение данных в колонку табличной части документа
volodya1122
Отправлено: 07.05.20, 10:31


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


jojojoba2 @ Вчера, 14:34 * ,

Для документу приблизно так (скопіював із своєї бази, думаю розберетесь що і до чого):
в мене це працює із модуля форми документа

СсылкаКонтрагент=Справочники.Контрагенти.НайтиПоКоду(ЕЛогин).Ссылка;
НайденнаяСтрока=ЭтотОбъект.ТабличнаяЧасть1.Найти(СсылкаКонтрагент,"Контрагент");

Если НайденнаяСтрока = Неопределено Тогда
    НоваяСтрока = ТабличнаяЧасть1.Добавить();
    НоваяСтрока.Контрагент=СсылкаКонтрагент;
    НоваяСтрока.фЛогін=СсылкаКонтрагент.Код;
    НоваяСтрока.СумаАбонплати=ЕСума;
Иначе
    НайденнаяСтрока.СумаКорегування=СумаКорег;
КонецЕсли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #162795 · Ответов: 4 · Просмотров: 202
 

>  Ошибка метода НайтиПоРеквизиту 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 06.05.20, 7:46


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ZUBR @ Сегодня, 1:10 * ,
и Мистер.ВыбратьЭлементы(); в даном случае не нужно
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #162770 · Ответов: 1 · Просмотров: 180
 

>  Печать второй пустой страницы таблицы.
volodya1122
Отправлено: 05.05.20, 15:37


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


1. На двух компах разные принтера, наверное потому на одном влазит, а на другом нет.
2. В макете печатной формы в подвале есть пустые строки - в них ничего не выводится, но они участвуют в формировании печатной формы.
3. Может быть в макете печатной формы ниже подвала еще пунктирная линия разделения страниц. тогда эти строки в макете тоже нужно удалить.
4. свой вариант
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #162740 · Ответов: 6 · Просмотров: 287
 

>  Не найден файл печатной формы 1С 7.70.003 торговля склад для Украины?
volodya1122
Отправлено: 04.05.20, 8:28


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ZUBR @ Вчера, 17:31 * ,
і чим він не подобається. Це звичайне рішення, в багатьох місцях його використовують. Для користувача взагалі ніяких відмінностей небуде.

інший вихід- таблицю значень помістити прямо на форму
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #162702 · Ответов: 8 · Просмотров: 245
 

>  Не найден файл печатной формы 1С 7.70.003 торговля склад для Украины?
volodya1122
Отправлено: 03.05.20, 12:04


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(ZUBR @ 03.05.20, 2:04) *
ZUBR @ Вчера, 21:26 * ,
Пришел к выводу, что ошибки нет, просто, когда запускается процедура не с кнопки, а с поля ввода, программа ищет таблицу в виде файла. И не находит. Можно ли обойти эту проблему?

Для виклику друку із поля вводу потрібно робити через Ложное закрытие. Здається я вже Вам раз давав як виглядає це ложне закриття.
Нагадаю:
Перем  МожноЗакрыть;

Процедура ПриОткрытии()
МожноЗакрыть=1;
КонецПроцедуры

Процедура ПечатьИзПоляВвода() // цю процедуру вішаємо на поле вводу
МожноЗакрыть = 0;
Форма.Закрыть(0);
КонецПроцедуры

    Процедура ПриЗакрытии()
    Если МожноЗакрыть = 0 Тогда
        МожноЗакрыть = 1;
        Сформувати();  // ця процедура, яку потрібно виконатити
        СтатусВозврата(0); // відмінити закриття форми
        Возврат; // протрібно якщо нижче в цій процедурі є ще якийсь код, і не потрібно щоб він виконувався
    КонецЕсли;
КонецПроцедуры


Якшо у вас на цій формі вже використовується ложне закриття для інших цілей, то використовуйте разні значення для змінної МожноЗакрыть для різних цілей, і в ПриЗакритии просто аналізуючи яке його значення виконувати потрібні дії
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #162678 · Ответов: 8 · Просмотров: 245
 

>  Отмена выбора элемента, помеченного на удаление
volodya1122
Отправлено: 29.04.20, 13:26


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


а может лучше подойти к решению вопроса с другой стороны? При выборе из документа не показывать помеченные на удаление элементы справочника.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #162605 · Ответов: 8 · Просмотров: 258
 

>  Не удается реквизит сделать периодическим 1с 7.7 конф 7.7.003
volodya1122
Отправлено: 28.04.20, 8:36


Оратор
Иконка группы

Группа: Местный
Сообщений: 276
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ZUBR @ Вчера, 23:00 * ,
Наскільки я зрозумів в довіднику Номенклатура реквізит КЗП записується тільки вручну. Ніякими документами він не міняється і небуде мінятись документами.
Тоді процес спрощується, Але роботи всеодно буде потрібно багато.
1. В довіднику поставити признак ПеріодичнийРеквізит. ИзменениеДокументом не ставити.
2. Зберегти конфігурацію і зайти в Предприятие. Перше значення періодичного реквізита повинно встановитись автоматично на дату наприклад 1 січня 1980 року. Це добре. (перевірити: права кнопка на номенклатурі-> Історія реквізиту). Якщо так поставилсь тоді все добре.
3. В довіднику контрагенти в процедурі ПриОткрытии прописати це (якщо його там немає);
        СохранениеПериодическихРеквизитов(2, "*");
    ИспользоватьДату(ТекущаяДата()); // періодичні реквізити будут завжди записуватись на сьогодні
//або ИспользоватьДату(РабочаяДата());// періодичні реквізити будуть записуватись на робочу дату (робочу дату можна міняти в (сервіс-Параметри-Общие)

При цьому 1С небуде задавати додаткових питань на яку дату записувати реквізити.
4. Тут саме цікаве. Всюди (в документах, в звітах, в макетах (печатних формах)), де використовується ваш реквізит КЗП потрібно замінити
Наприклад :
знач=Спр.КЗП: // було так
знач=Спр.КЗП.Получить(НужнаяДата): // змініти на це

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #162576 · Ответов: 8 · Просмотров: 302
 

11 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 06.07.20, 10:45
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!