Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



14 страниц V   1 2 3 > » 

>  Вызвать фоновое задание с методом в модуле внешней обработки
AnryMc
Отправлено: 08.05.24, 10:20


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


denis84 @ Сегодня, 10:52 * ,

Спасибо,

но у меня задача - без БСП :-(
и без регистрации внешней обработки в справочнике "Внешние отчеты и обработки"
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178828 · Ответов: 3 · Просмотров: 295
 

>  Вызвать фоновое задание с методом в модуле внешней обработки
AnryMc
Отправлено: 08.05.24, 8:20


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Дано:
- Внешняя обработка
- в модуле объекта - экспортная процедура СделатьПоМоему()

Нужно: из модуля формы внешней обработки запустить фоновое задание метод которого находится в модуле объекта этой внешней обработке...

Т.е. из модуля формы внешней обработки можно вызвать экспортную процедуру модуля объекта так:
РеквизитФормыВЗначение("Объект").СделатьПоМоему(НужныеПараметры)


но КАК это передать при вызове фонового задания
Задание = ФоновыеЗадания.Выполнить(
     "ВнешняяОбработка.МояВнешняяОбработка.СделатьПоМоему",
     НужныеПараметры, , "НаименованиеЗадания");


?????????????????????????????????????????????????????????????
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178826 · Ответов: 3 · Просмотров: 295
 

>  Установка min-max остатков номенклатуры
AnryMc
Отправлено: 07.05.24, 10:45


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(sava1 @ 07.05.24, 9:54) *
А в УНФ такое есть?


Это отдельно - универсальная для всех конфигураций на управляемых формах.

Должно быть на ИТС....
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #178824 · Ответов: 6 · Просмотров: 353
 

>  Установка min-max остатков номенклатуры
AnryMc
Отправлено: 07.05.24, 8:39


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(sava1 @ 07.05.24, 9:33) *
надо написать свою обработку



Уже не помню точно, но возможно писать свою (полностью) и не надо...

Вроде в типовой загрузке можно дописать "произвольный алгоритм"...

З.Ы. В типовой "Загрузка данных из табличного документы" есть режимы загрузки в:
- справочник
- табличную часть
- регистр сведений
и можно задать "выражение для значения" - т.е. простенький код...
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #178822 · Ответов: 6 · Просмотров: 353
 

>  Установка min-max остатков номенклатуры
AnryMc
Отправлено: 06.05.24, 11:05


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(Clipss @ 06.05.24, 10:54) *
Добрый день. Подскажите возможно ли установить min-max остатки на номенклатуру через Excel?


Можно / Нельзя - выберите любой...

P.S. Лично мне чтобы ответить на вопрос нужно его понимать...
Из вашей формулировки вопроса:
- можно использовать стандартную или написать под задачу обработку для загрузки из Excel

- но чтобы ответить подойдет стандартная загрузка нужно знать как в Вашем случае храниться min-max остатка номенклатуры.
Это например:
- периодический регистр сведений
- реквизит элемента номенклатуры
....
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #178819 · Ответов: 6 · Просмотров: 353
 

>  запуск 1С через RemoteApp с параметрами
AnryMc
Отправлено: 03.05.24, 8:08


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(evggrig @ 02.05.24, 21:07) *
Нет прав на запуск требуемого вида клиента


Я правильно понимаю: клиента 1С?

Цитата(evggrig @ 02.05.24, 21:07) *
только выпрыгивает окошко где можно менять путь к базе, открыть конфигуратор и тд, чего я хотел бы избежать


Если прописать "общие базы" - то удалить путь пользователь не сможет

Если у роли пользователя нет права администратора, администрирования данных, обновления, управления расширениями ... (права из корня прав) - то пусть запускает

З.Ы. Попробуйте в свойствах запуска базы установить "Основной режим запуска" не "Авто" а нужный Вам
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #178810 · Ответов: 5 · Просмотров: 385
 

>  Помилка SDBL при створення нової УТП з .cf
AnryMc
Отправлено: 02.05.24, 10:13


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718



Цитата(Talkman @ 02.05.24, 10:00) *
А з оновленням пустої бази з .cf завжди такі проблеми?


Не знаю...
Но загрузка "готовой" базы из .dt - это создание таблиц у которых структура уже определена и заполнение их данными
"Обновление" из .cf "пустой" базы - это не только создание таблиц но и их реструктуризация...

У меня постоянно обновления рабочей базы (монопольные и динамические) - обновлениями и доработками -на MS SQL - много лет уже без проблем

З.Ы, "Тьфу! Тьфу! Тьфу!" rulez.gif rulez.gif
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #178803 · Ответов: 5 · Просмотров: 333
 

>  Помилка SDBL при створення нової УТП з .cf
AnryMc
Отправлено: 01.05.24, 16:05


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Talkman @ Сегодня, 16:00 * ,

Создать файловую пустую базу.
Загрузить в конфигураторе .cf.
Запустить режим пользователя - запустится заполнение пустой базы по умолчанию...
Выгрузить в .dt

Загрузить в СУБД... из .dt
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #178801 · Ответов: 5 · Просмотров: 333
 

>  Ещё в копилку багов (фич) платформы - или моих мозгов
AnryMc
Отправлено: 30.04.24, 7:55


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(TohaMonster @ 29.04.24, 17:50) *
Это все происходит под полными правами?


Все права

Цитата(TohaMonster @ 29.04.24, 17:50) *
Такое тяжко проверить без Базы.


Демо - тоже самое. Пробовал на Business automation software for accounting CORP, edition 2.1 (2.1.13.1) и 2.1.21...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178797 · Ответов: 2 · Просмотров: 357
 

>  Ещё в копилку багов (фич) платформы - или моих мозгов
AnryMc
Отправлено: 26.04.24, 11:42


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


BAS Бухгалтерия КОРП - люба (типовая демо)
(я пробовал на 13 и 23)

Условия: Учётная политика - 8 и 9 класс - Классы 8 и 9 (элементы затрат и деятельности)

При такой настройке проводка на Дт 9 класса делится на две (через 8 класс - счет указывается в настройке статьи затрат)

В ручной операции (документ - Операция Бух) - всё работает нормально.

В любом документе если зайти в его движения и поставить галочку "Ручная корректировка" и попробовать ввести такую же проводку которая срабатывала с ручной операции - получаем системную ошибку...

Причем ошибка возникает в Обработке - Корректировка движений -
НаСервере
Процедура ЗаписатьДвижения(Отказ)
//*******
                НаборЗаписей.Записать(Истина);


При этом Модуль набора записей - Регистра бухгалтерского учета - ПровестиИЗакрыть() отрабатывает нормально - формирует две проводки с корректными данными...
Если ДелитьПроводку


Причём на момент записи регистра бухгалтерии сформированные при "делении проводок" субконто - становятся недоступными с руганью на ошибку...

Не могу понять что происходит между формированием "двойной проводки" и ошибкой записи...
Что мешает???

З.Ы. Пользователь может сформировать эти две проводки самостоятельно но при этом не формируются реквизиты регистра бухгалтерии "НомерИсходнойПроводки" и "СчетДополнительный" - которые нужны в отчетах чтобы "собрать" обороты с 9 счета через 8 с их Корреспонденцией
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178783 · Ответов: 2 · Просмотров: 357
 

>  Off: Часто ли Вам приходилось переписывать учёт ОС в типовых конфигурациях?
AnryMc
Отправлено: 25.04.24, 10:57


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(Moloko @ 25.04.24, 11:28) *
які вже роками налаштовані, перевірені, працюють, і куди самому краще не залазити. Це ЗП, ОЗ, курсові різниці, партіонний облік, «перша подія» ПДВ



Лично я переделывал (дополнял):
- ЗП (например - свои виды расчётов)
- ОЗ (компания управления активов должна была отчитываться регулятору "ежесуточно" с учётом амортизации своих, арендованных и сданных в аренду ОС)
- курсовые разницы
- партионный учет

НДС не трогал
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178782 · Ответов: 5 · Просмотров: 731
 

>  Off: Часто ли Вам приходилось переписывать учёт ОС в типовых конфигурациях?
AnryMc
Отправлено: 24.04.24, 13:35


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


AnryMc @ Сегодня, 12:56 * ,

Если ничего не меняли - как и сообщите 32542460.gif 32542460.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178778 · Ответов: 5 · Просмотров: 731
 

>  Off: Часто ли Вам приходилось переписывать учёт ОС в типовых конфигурациях?
AnryMc
Отправлено: 24.04.24, 11:56


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Добрый день!

Часто ли Вам приходилось "вмешиваться" в учет Основных средств в типовых конфигурациях?

Имеется в виду изменения в учете, переоценке, амортизации....
Не учитывается изменения в печатных форм...

Если не трудно - кратко - что меняли
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178777 · Ответов: 5 · Просмотров: 731
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 16.04.24, 13:36


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


TohaMonster @ Сегодня, 12:36 * ,

Когда то (давно - ещё на 8.0 или 8.1 - обычные формы) у клиентов наблюдал такое:

сцена 1: Вызывают, говорят: "Документ неправильно работает..."
сцена 2: разбираюсь - в документе не виден реквизит и пользователь соответственно его не заполняет...
сцена 3: в конфигураторе реквизит "виден" и не как его видимость/доступность не регламентируется...
сцена 4: у меня в копии всё "Ок" у клиента не видно...
сцена 5: сцена 6: сцена 7: .... ???? !!!!!!!
сцена Х: случайно на рабочем месте ГлавБуха открываю "проблемный" документ - реквизит "виден и доступен". Обегаю рабочие места - реквизита нет...
.... ???? !!!!!!!

В итоге оказалось - "Norton Antivirus" (на всех рабочих местах кроме ГлавБуха он стоял). Причем во всех остальных местах аналогичные реквизиты работали нормально, проблемы были только в одном документе...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178757 · Ответов: 16 · Просмотров: 1564
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 16.04.24, 10:41


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


TohaMonster @ Сегодня, 10:00 * ,

Пробовал в копии базы на другой машине...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178755 · Ответов: 16 · Просмотров: 1564
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 15.04.24, 7:54


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(alexxbely @ 15.04.24, 7:59) *
спробував на 8.3.15.1700 файлова - працює, як треба...


Мистика!!!!!!!!!!!!!!!!!!!!!!

05071.gif

Пробовал построить эту цепочку через
ВыполнитьОбработкуОповещения

- всё равно НЕ РАБОТАЕТ!!!!!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178751 · Ответов: 16 · Просмотров: 1564
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 12.04.24, 13:25


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


alexxbely @ Сегодня, 14:00 * ,

на 8.3.15.1700 - не работает - после выбора значения всё...
(в файловом и SQL -вариантах)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178749 · Ответов: 16 · Просмотров: 1564
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 12.04.24, 9:01


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(denis84 @ 12.04.24, 9:26) *
Працює - платформа 8.3.16.1148


...................
У меня 8.3.15.1700

!!!!!!!!!!!!!
Поменять не могу

icon_cuss.gif icon_cuss.gif

Причем не отрабатывает и в файловой и в серверной!

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178747 · Ответов: 16 · Просмотров: 1564
 

>  Возврат параметра при закрытии формы
AnryMc
Отправлено: 11.04.24, 15:59


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718




Цитата(AnryMc @ 11.04.24, 11:07) *
Капитально туплю сегодня - помогите!!!


Цитата(takefive @ 11.04.24, 16:22) *
Вариант с оповещением...


Что и где?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178742 · Ответов: 4 · Просмотров: 766
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 11.04.24, 15:35


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(AnryMc @ 11.04.24, 14:03) *
По отдельности работает, вместе - нет!!!


Если вынести в отдельную процедуру (через кнопку на форме) - работает...
Если выполнять после выбора из списка - НЕ РАБОТАЕТ!!!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178739 · Ответов: 16 · Просмотров: 1564
 

>  Возврат параметра при закрытии формы
AnryMc
Отправлено: 11.04.24, 14:44


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(andr_andrey @ 11.04.24, 14:10) *
Закрыть(<ПараметрЗакрытия>)



А где это "всунуть" в Обработке 2, и как поймать в Обработке 1 в обработке Оповещения?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178736 · Ответов: 4 · Просмотров: 766
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 11.04.24, 14:13


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Пример во внешней обработке

Внешняя обработка
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178735 · Ответов: 16 · Просмотров: 1564
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 11.04.24, 13:03


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


denis84 @ Сегодня, 13:18 * ,

Это всё понятно, но после

МойСписок.ПоказатьВыборЭлемента(Оповещение, "Виберіть, що додається...");


перестает раборать,..

По отдельности работает, вместе - нет!!!

AnryMc @ Сегодня, 14:02 * ,


Если подскажите "шару" - выложу внешним файлом...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178733 · Ответов: 16 · Просмотров: 1564
 

>  УФ после выбора из списка задать вопрос - не работает
AnryMc
Отправлено: 11.04.24, 11:50


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Точно не мой день...

Задача: Пользователь должен выбрать из списка значение, после чего ему задается вопрос...

КОД: (МойСписок, ВыбранноеПредставление и ВыбранноеЗначение - реквизиты формы)
Начало выполнения - КомандаВыполнить()
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ЗаполнитьМойСписок();
    
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьМойСписок()
    
    Для н = 1 По 10 Цикл
        
        нр = МойСписок.Добавить();
        
        нр.Значение = "Значение_" + СокрЛП(н);
        
        нр.Представление = "Наименование " + СокрЛП(н);
        
    КонецЦикла;
    
КонецПроцедуры

&НаКлиенте
Процедура КомандаВыполнить(Команда)
    
    Оповещение = Новый ОписаниеОповещения("ПослеВыбораИзСписка", ЭтотОбъект);
    МойСписок.ПоказатьВыборЭлемента(Оповещение, "Виберіть, що додається...");

КонецПроцедуры

&НаКлиенте
Процедура ПослеВыбораИзСписка(ВыбранныйЭлемент, СписокПараметров) Экспорт
    
    Если ВыбранныйЭлемент = Неопределено Тогда
        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Не обрано!";
        Сообщение.УстановитьДанные(ЭтотОбъект);
        Сообщение.Сообщить();
        
    Иначе
        
        ВыбраноеЗначение = ВыбранныйЭлемент.Значение;
        ВыбранноеПредставление = ВыбранныйЭлемент.Представление;
        
        ПродолжимВыполнение();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПродолжимВыполнение()
    
    ОписаниеОповещения = Новый ОписаниеОповещения("ПослеОтветаНаВопрос", ЭтотОбъект);
    ПоказатьВопрос(ОписаниеОповещения, "Дайте відповідь що небудь!", РежимДиалогаВопрос.ДаНет, 60);

КонецПроцедуры

&НаКлиенте
Процедура ПослеОтветаНаВопрос(РезультатВопроса, ДополнительныеПараметры) Экспорт
    
    Если РезультатВопроса = КодВозвратаДиалога.Да Тогда
        
        ПередадимДействиеДальше();
        
    Иначе
        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "- - - - -";
        Сообщение.УстановитьДанные(ЭтотОбъект);
        Сообщение.Сообщить();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПередадимДействиеДальше()
        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "! ! ! ! ! ! ! !";
        Сообщение.УстановитьДанные(ЭтотОбъект);
        Сообщение.Сообщить();
        
КонецПроцедуры


После выбора значения из списка вызывается ПродолжимВыполнение() но отображение вопроса не происходит
В ПослеОтветаНаВопрос() всегда РезультатВопроса = НЕТ

Как это реализовать???
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178730 · Ответов: 16 · Просмотров: 1564
 

>  Возврат параметра при закрытии формы
AnryMc
Отправлено: 11.04.24, 10:07


Оратор
Иконка группы

Группа: Местный
Сообщений: 344
Регистрация: 11.12.10
Пользователь №: 5718


Капитально туплю сегодня - помогите!!!

Форма Обработки 1
Программно открывается Обработка 2
&НаКлиенте
    
    ПараметрыФормы = Новый Структура("", "");
    
    ОписаниеОповещения = Новый ОписаниеОповещения("ЗакрытаФормаОбработки2", ЭтотОбъект, ПараметрыФормы);
    
    ОткрытьФорму("Обработка.Обработка2.Форма", ПараметрыФормы,,,,,ОписаниеОповещения);


В Обработке 2 устанавливается НужныйРеквизит

Форма Обработки 2 - закрывается

В Обработке 1 выполняется Оповещение
&НаКлиенте
Процедура ЗакрытаФормаОбработки2(Результат, ДополнительныеПараметры) Экспорт
    
    ...
//Как здесь узнать установленный в Обработке 2 НужныйРеквизит
    
КонецПроцедуры


КАК???


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178729 · Ответов: 4 · Просмотров: 766
 

14 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 20.05.24, 15:12
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!