Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



2 страниц V   1 2 >

>  Создание отчета на СКД програмно
Sirius83
Отправлено: 16.11.20, 10:26


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


sava1 @ Вчера, 18:16 * ,
Тоже самое:
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168293 · Ответов: 11 · Просмотров: 324
 

>  Создание отчета на СКД програмно
Sirius83
Отправлено: 12.11.20, 15:49


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


sava1 @ Сегодня, 16:19 * ,
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168191 · Ответов: 11 · Просмотров: 324
 

>  Создание отчета на СКД програмно
Sirius83
Отправлено: 12.11.20, 15:08


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Vofka @ Вчера, 18:29 * ,
Я пробовал выключить отборы и оставить только Параметры. Тоже самое, таблица не заполняется.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168189 · Ответов: 11 · Просмотров: 324
 

>  Создание отчета на СКД програмно
Sirius83
Отправлено: 11.11.20, 16:37


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Vofka @ Сегодня, 13:37 * ,
Цитата(Vofka @ 11.11.20, 13:37) *
если нажать на настройки в отчете, там и параметры и отбор заполнены как надо?

Да с настройками все ок:



Moloko @ Сегодня, 13:31 * ,

Цитата(Moloko @ 11.11.20, 13:31) *
Первый - это воспользоваться кнопочкой "сохранение настройки",

Так настройки сохраненные
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168157 · Ответов: 11 · Просмотров: 324
 

>  Создание отчета на СКД програмно
Sirius83
Отправлено: 11.11.20, 12:00


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Платформа 1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)
Доброго времени! Есть некий отчет по взвешиванию продукции при ручном формировании с заданными параметрами все хорошо формирует

есть задача формировать отчет программно, собственно функция формирования отчета:
Код
Функция СформироватьОтчетПрограммно(Склад)
    Таб = Новый ТабличныйДокумент;    
    
    ТекОтчет = Отчеты.Отчет_РегистрацияВзвешиваний.Создать();
    СКД = ТекОтчет.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    Настройки = СКД.НастройкиПоУмолчанию;
    НачДата = НачалоДня(ТекущаяДата()) - 1;
    НачДата = Дата(Год(НачДата),Месяц(НачДата),День(НачДата),20,0,0);
    НачальнаяДата = СКД.Параметры.Найти("НачалоПериода");
    Если НачальнаяДата = Неопределено Тогда
        
        ПараметрПериод = СКД.Параметры.Добавить();
        ПараметрПериод.Имя = "НачалоПериода";
        ПараметрПериод.Заголовок = "НачалоПериода";
        ПараметрПериод.ТипЗначения = Новый ОписаниеТипов("Дата");
        ПараметрПериод.ОграничениеИспользования = Ложь;
        ПараметрПериод.Значение = НачДата;
        ПараметрПериод.Использование =ИспользованиеПараметраКомпоновкиданных.Всегда;
        ПараметрПериод.ВключатьВДоступныеПоля = Истина;    
        НачальнаяДата = ПараметрПериод;
    КонецЕсли;
        
    КонечнаяДата = СКД.Параметры.Найти("КонецПериода");
    
    Если КонечнаяДата = Неопределено Тогда
        
        ПараметрПериод = СКД.Параметры.Добавить();
        ПараметрПериод.Имя = "КонецПериода";
        ПараметрПериод.Заголовок = "КонецПериода";
        ПараметрПериод.ТипЗначения = Новый ОписаниеТипов("Дата");
        ПараметрПериод.ОграничениеИспользования = Ложь;
        ПараметрПериод.Значение = НачДата;
        ПараметрПериод.Использование =ИспользованиеПараметраКомпоновкиданных.Всегда;
        ПараметрПериод.ВключатьВДоступныеПоля = Истина;    
        КонечнаяДата = ПараметрПериод;
        
    КонецЕсли;
    
    
    ПараметрКомпоновки = Новый ПараметрКомпоновкиДанных("НачалоПериода");
    ПараметрСКД = ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКомпоновки);
    ПараметрСКД.Значение = НачДата;
    ПараметрСКД.Использование = Истина;    
    
    КонДата = Дата(Год(ТекущаяДата()),Месяц(текущаяДата()),День(ТекущаяДата()),20,0,0);
    
    ПараметрКомпоновки = Новый ПараметрКомпоновкиДанных("КонецПериода");
    ПараметрСКД = ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКомпоновки);
    ПараметрСКД.Значение = КонДата;
    ПараметрСКД.Использование = Истина;        //Помещаем в переменную данные о расшифровке данных
        
    
    ПараметрДанных= ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода");
    ПараметрДанных.Значение = НачДата;
        
    ПараметрДанных.Использование=Истина;
    
    
    ПараметрДанных= ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода");
    ПараметрДанных.Значение = КонДата;
    
    ПараметрДанных.Использование=Истина;
    
        
    МассивН = Новый Массив;
    МассивН.Добавить(Справочники.Номенклатура.НайтиПоКоду("00000001198"));
    МассивН.Добавить(Справочники.Номенклатура.НайтиПоКоду("00000001197"));
    МассивН.Добавить(Справочники.Номенклатура.НайтиПоКоду("00000001200"));
    СЗ = Новый СписокЗначений;
    СЗ.ЗагрузитьЗначения(МассивН);
    
    тОтчет = ТекОтчет;
    
    //НастройкиКД = ТекОтчет.КомпоновщикНастроек.ПолучитьНастройки();
    НастройкиКД = Настройки;
    ВидВзвешивания = тОтчет.КомпоновщикНастроек.Настройки.Отбор.ДоступныеПоляОтбора.Элементы.Найти("ВидВзвешивания"); //поле отбора присутствует в СКД
    
    НовыйОтбор = НастройкиКД.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    НовыйОтбор.ЛевоеЗначение = ВидВзвешивания.Поле;
    НовыйОтбор.ПравоеЗначение = Перечисления.ИнтекоВидыВзвешивания.Отгрузка;
    НовыйОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    НовыйОтбор.Использование = Истина;
    
    
    Отправитель = тОтчет.КомпоновщикНастроек.Настройки.Отбор.ДоступныеПоляОтбора.Элементы.Найти("Отправитель"); //поле отбора присутствует в СКД
    
    НовыйОтбор = НастройкиКД.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    НовыйОтбор.ЛевоеЗначение = Отправитель.Поле;
    НовыйОтбор.ПравоеЗначение = Склад;
    НовыйОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    НовыйОтбор.Использование = Истина;
    
    
    Номенклатура = тОтчет.КомпоновщикНастроек.Настройки.Отбор.ДоступныеПоляОтбора.Элементы.Найти("Номенклатура"); //поле отбора присутствует в СКД
    
    НовыйОтбор = НастройкиКД.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    НовыйОтбор.ЛевоеЗначение = Номенклатура.Поле;
    НовыйОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСпискеПоИерархии;
    НовыйОтбор.ПравоеЗначение = СЗ;
    НовыйОтбор.Использование = Истина;
    
    тОтчет.КомпоновщикНастроек.ЗагрузитьНастройки(НастройкиКД);
    //
    
    ///////////////////////////////////////////////////////////////////////////////////////////////////
        ПараметрКомпоновки = Новый ПараметрКомпоновкиДанных("НачалоПериода");
    ПараметрСКД = ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКомпоновки);
    ПараметрСКД.Значение = НачДата;
    ПараметрСКД.Использование = Истина;    
    
    КонДата = Дата(Год(ТекущаяДата()),Месяц(текущаяДата()),День(ТекущаяДата()),20,0,0);
    
    ПараметрКомпоновки = Новый ПараметрКомпоновкиДанных("КонецПериода");
    ПараметрСКД = ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКомпоновки);
    ПараметрСКД.Значение = КонДата;
    ПараметрСКД.Использование = Истина;        //Помещаем в переменную данные о расшифровке данных
    
    
    ПараметрДанных= ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода");
    ПараметрДанных.Значение = НачДата;
    
    ПараметрДанных.Использование=Истина;
    
    ПараметрДанных= ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода");
    ПараметрДанных.Значение = КонДата;

    ПараметрДанных.Использование=Истина;
    
    
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
    
    
    Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных;    
    //Формируем макет, с помощью компоновщика макета
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;    
    //Передаем в макет компоновки схему, настройки и данные расшифровки
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СКД, ТекОтчет.КомпоновщикНастроек.ПолучитьНастройки(), Расшифровка);    
    ВнешниеПараметры = Новый Структура;    
    //Выполним компоновку с помощью процессора компоновки
    ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеПараметры, Расшифровка);    
    //Выводим результат в табличный документ
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(Таб);    
    ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных, Истина);  
    
    ТаблицаРезультат = Новый ТаблицаЗначений;
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;

    ПроцессорВывода.УстановитьОбъект(ТаблицаРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);

    ВОзврат Таб;    
    
КонецФункции

в результате получаем отчет, но без данных табличных частей.

Ткните пожалуйста носом, где недочет.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168132 · Ответов: 11 · Просмотров: 324
 

>  Механізм повернення виористаного ТМЦ взамін на новий
Sirius83
Отправлено: 03.09.20, 8:09


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Доброго дня всім!
Платформа 1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)

Є задача наступного характеру - При видачі нової запчастини з складу робити повернення використаної назад на склад ну і звісно це все має фіксуватись в 1С. Видачою ЗПЧ на механізм чи ОС являється документ "Накладна требование" яка списує дану ЗПЧ, тобто залишку тієї ЗПЧ вже немає відповідно і повертати немає з чого. Може в кого сь є напрацювання по даній задачі, з радістю б взяв до уваги всі пропозиції. Дякую!

  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #166151 · Ответов: 0 · Просмотров: 153
 

>  Доступ к строке табличной части через строку табличного элемента формы
Sirius83
Отправлено: 14.07.20, 8:48


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Доброго времени всем!
Есть самописный документ "Заказ на приобретение ТМЦ" в нем заполняется некая номенклатура.. количество, которую нужно закупить, а менеджер по закупкам должен заполнить колонку "Документ приход" (ДокументСсылка.ПоступлениеТоваровУслуг), подскажите пожалуйста как добавить колонку в которой бы отображалась номенклатура "Документа прихода" для выбора.



Платформа 1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #164719 · Ответов: 1 · Просмотров: 225
 

>  Автоматично зміна схеми реалізації
Sirius83
Отправлено: 13.07.20, 10:42


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Цитата(TohaMonster @ 10.07.20, 9:44) *
Совет такой:
1. Убедитесь, что у Вас в системе есть документ "УстановкаПараметровУчетаНоменклатуры". Перенесите его на какую-то дату, которая больше даты Вашего документа
2. Перезайдите в Базу(!это нужно сделать, параметр кэшируется). Попробуйте в документе перевыбрать Номенклатуру. Должна подставиться нужная Вам схема реализации

Таки так - є документ, щоправда думав, що він регулює автозаповнення в документах по рахунку, а не схему реазізації. Адже, в ньому ніде не вказується відповідність схеми реалізації до виду номенклатури.

Цитата(denis84 @ 10.07.20, 9:45) *
В новых документах при выборе номенклатуры со счетом учета 26 и с выбранной схемой реализации в УПП (демо) все работает. Как сказал Макс1С, у Вас в регистре значит есть ещё какие-то записи для продукции.


Всі записи регістру відображені в 1-му пості на скріншоті. В дійсності документ "Установка параметров учета номенклатуры" встановлює не тільки автозаповнення: виду номенклатури, податкове призначення, але ще й фіксує предопределенные значення схем реалізації.
  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #164686 · Ответов: 8 · Просмотров: 401
 

>  Автоматично зміна схеми реалізації
Sirius83
Отправлено: 10.07.20, 7:53


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Цитата(denis84 @ 09.07.20, 16:45) *
Одне,що можу сказати конфігурація застара 1.3.15.6, а платформа 8.3.13.1513.

В новій платформі та конфігурації теж саме (поставив паралельно).

Цитата(Vofka @ 09.07.20, 17:09) *
Тут показываются только предопределенные элементы.

Ось не можу зрозуміти чому відображаються тільки предопределенные елементи??? Довідник має і інші елементи.

Цитата(Макс1С @ 09.07.20, 22:13) *
После смены схемы реализации новая будет подставляться только в новые документы.

Не буде проставлятись в нових документах нова схема, оскільки при фрормуванні документа РеализауияТоваровУслуг в коді жостко получаемо назву схеми незалежно що заповнено в регістрі.
 СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Продукция; //Здесь полюбому почучаем Схему "Продукция"!!!!!!!

  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #164613 · Ответов: 8 · Просмотров: 401
 

>  Автоматично зміна схеми реалізації
Sirius83
Отправлено: 09.07.20, 15:32


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Доброго дня!
Платформа 1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)

В документі реалізації (РеализацияТоваровУслуг) бухгалтера вручну міняють схему реалізації, прийнято рішення встановити потрібну схему ("Камінь", замість "Продукція") у регістрі відомостей.


Поміняли результат - відсутній, тобто як було Схема "Продукція" так і залишилась... Далі цікавіше..

Отладчиком дивлюсь звідки отримуємо значення і бачу, що заповнюється воно жостко в СпільнийМодуль.СчетаУчетаВДокументах
Функция ПолучитьСтруктуруСчетовУчета(Номенклатура, ТаблицаСчетовУчета, ХозяйственнаяСитуация)
    
    СтруктураСчетовУчета     = ПодготовитьСтруктуруСчетовУчета();
    
    УстановленныеСчета         = ТаблицаСчетовУчета.Найти(Номенклатура, "Номенклатура");
    
    СтруктураСчетовУчета.ХозяйственнаяСитуация = ХозяйственнаяСитуация;
    
    Если УстановленныеСчета <> Неопределено Тогда
    
        //Дополним установленными счетами
        СтруктураСчетовУчета.СчетУчетаБУ                    = УстановленныеСчета.СчетУчетаБУ;
        
        СтруктураСчетовУчета.ПринадлежностьНоменклатуры        = УстановленныеСчета.ПринадлежностьНоменклатуры;
        СтруктураСчетовУчета.СчетЗатрат                           = УстановленныеСчета.СчетЗатрат;
        СтруктураСчетовУчета.НалоговоеНазначение               = УстановленныеСчета.НалоговоеНазначение;
        СтруктураСчетовУчета.НалоговоеНазначениеДоходовИЗатрат = УстановленныеСчета.НалоговоеНазначениеДоходовИЗатрат;
        СтруктураСчетовУчета.ОпределятьИзНГЗатрат               = УстановленныеСчета.ОпределятьИзНГЗатрат;
        //Счета, зависящие от установленных        
        
        Если Не УстановленныеСчета.Номенклатура.Услуга Тогда
            
            Если ЗначениеЗаполнено(УстановленныеСчета.СчетУчетаБУ) Тогда            
                Если УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.ПроизводственныеЗапасы) или УстановленныеСчета.СчетУчетаБУ = (ПланыСчетов.Хозрасчетный.ПроизводственныеЗапасы) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.ПроизводственныеЗапасы;
                ИначеЕсли УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.Полуфабрикаты) или УстановленныеСчета.СчетУчетаБУ=(ПланыСчетов.Хозрасчетный.Полуфабрикаты) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.ПроизводственныеЗапасы;
                ИначеЕсли УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.ГотоваяПродукция) или УстановленныеСчета.СчетУчетаБУ=(ПланыСчетов.Хозрасчетный.ГотоваяПродукция) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Продукция; [highlight][b]//Здесь полюбому почучаем Схему "Продукция"!!!!!!!???????[/b][/highlight]
                ИначеЕсли УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.МалоценныеИБыстроизнашивающиесяПредметы) или УстановленныеСчета.СчетУчетаБУ = (ПланыСчетов.Хозрасчетный.МалоценныеИБыстроизнашивающиесяПредметы) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Товары;
                ИначеЕсли УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.Товары) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Товары;  
                ИначеЕсли  УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.КапитальныеИнвестиции) или УстановленныеСчета.СчетУчетаБУ = (ПланыСчетов.Хозрасчетный.КапитальныеИнвестиции) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Товары;
                КонецЕсли;
            КонецЕсли;
        Иначе
            СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Услуги;        
        КонецЕсли;      
        
        
        //Если основной счет учета запасов - забалансовый,
        //то он будет использоваться в качестве счета учета принятых товаров.
        Если БухгалтерскийУчетПовтИсп.ЗабалансовыйСчет(СтруктураСчетовУчета.СчетУчетаБУ) Тогда
            СтруктураСчетовУчета.ПринятыеСчетУчетаБУ = СтруктураСчетовУчета.СчетУчетаБУ;
            СтруктураСчетовУчета.СчетУчетаДавСырья  = СтруктураСчетовУчета.СчетУчетаБУ;
        КонецЕсли;        
        
    КонецЕсли;
    
    Возврат СтруктураСчетовУчета;
    
КонецФункции


Це ще не все. Коли розраховую вираз "Справочники.СхемыРеализации" отримуємо:


А де решту записів довідника з першого скріна???
Допоможіть розібратися.
  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #164589 · Ответов: 8 · Просмотров: 401
 

>  Период в отчете на СКД в учетом времени
Sirius83
Отправлено: 02.07.20, 8:55


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Вчера наверное перегрелся или день не сложылся, короче говоря надо просто использовать в паралетрах НачалоПериода и КонецПериода вместо Периода, а я их совал в отбор.
  Форум: Система компоновки данных · Просмотр сообщения: #164380 · Ответов: 3 · Просмотров: 294
 

>  Период в отчете на СКД в учетом времени
Sirius83
Отправлено: 01.07.20, 16:04


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Vofka @ Сегодня, 15:33 * ,





Все одно дата в формате даты без времени


 ! 

Правила: 8
 
  Форум: Система компоновки данных · Просмотр сообщения: #164353 · Ответов: 3 · Просмотров: 294
 

>  Период в отчете на СКД в учетом времени
Sirius83
Отправлено: 01.07.20, 14:27


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Доброго времени всем!
Подскажыте пожалуйста как в отчете на СКД в поле отбора НачалоПериода КонецПериода которие имеют тип Стандартный период отобразить не только дату но и время (нужно для отбора).



1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)


 ! 

Правила: 8
 
  Форум: Система компоновки данных · Просмотр сообщения: #164344 · Ответов: 3 · Просмотров: 294
 

>  "Ведомость амортизации ОС" с возможностью вывода сведений "Срок полезного использования БУ"
Sirius83
Отправлено: 11.04.20, 7:25


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Доброго дня!
Платформа 1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)

Собственно говоря нужен отчет или подскажыте каким образом вывести сведения о "Сроке полезного использования ОС БУ"

Буду благодарен всем советам и помощи.

Видел есть нечто похожее на инфостате если у кого завалялось пишыте договоримся.
  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #162141 · Ответов: 1 · Просмотров: 639
 

>  Управление ролями пользователей.
Sirius83
Отправлено: 12.02.20, 16:22


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Цитата(george_smith @ 12.02.20, 15:36) *
Здравстуйте!
В документе "Реализация товаров и услуг" на вкладке "Доверенность"есть реквизиты "Отпуск разрешил" и "Отпуск произвел". Для зав скадом редактирование данного документа запрещено. Как можно ему дать возможность вносить данные только в эти два реквизита. Спасибо!


Ну на редактирование документа все-таки доступ надо дать ибо ето обэкт которим регистрирукеш изменения а обрезать доступ к данным по документу можна как-то так:

Если РольДоступна("ЗавСклад") Тогда 
        Для Каждого Стр из ЭлементыФормы Цикл
            Стр.Доступность = Ложь;    
        КонецЦикла;
        
        ЭлементыФормы.ОсновнаяПанель.Страницы.Довереность.ОтпускРазрешил.Доступность = Истина;
        ЭлементыФормы.ОсновнаяПанель.Страницы.Довереность.ОтпускПроизвел.Доступность = Истина;

КонецЕсли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #160326 · Ответов: 2 · Просмотров: 397
 

>  Автоматический макет на СКД
Sirius83
Отправлено: 13.01.20, 16:43


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Цитата(fly @ 10.01.20, 13:58) *
в настройках добавил реквизит "РазбитьРасчетныеЛистыПоСтраницам" - тип("Булево") чтоб пользователь ставил галочку

В пользовательских настройках?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #159288 · Ответов: 4 · Просмотров: 474
 

>  Автоматический макет на СКД
Sirius83
Отправлено: 10.01.20, 11:17


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Доброго времени всем!
Есть отчет РасчетныеЛисткиОрганизаций.erf на СКД все прекрасно заполняется, но есть одно но на печать выводится то по два сотрудника на лист А4 то по три, как вздумается по настройкам принтера, нужно чтобы на страницу А4 выводилось строго по две таблицы (тобиш два сотрудника) для удобства разделения бумаги пополам. Помогите выловить методику формирования или подскажыте как сделать свою для решения етой задачи.

1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)

П.С. Отчет не вижу как прикрепить в тему..

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #159191 · Ответов: 4 · Просмотров: 474
 

>  Получити значення в Запросі документа реєстратора регистра
Sirius83
Отправлено: 17.12.19, 9:49


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Доброго дня!
Платформа 1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)

Є звіт з наступною процедурою який формує заповнення таблиці

Код
Процедура СформироватьТаблицю2(ТабДокумент, Макет, НаДату, Склад)

//------------------Пробел------------------
ОбластьМакета = Макет.ПолучитьОбласть("Пробел");
ТабДокумент.Вывести(ОбластьМакета);

//------------------Шапка2------------------
ОбластьМакета = Макет.ПолучитьОбласть("Шапка2");
ТабДокумент.Вывести(ОбластьМакета);

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| уатОстаткиГСМнаТСОбороты.ТС КАК ТС,
| уатОстаткиГСМнаТСОбороты.ГСМ КАК Номенклатура,
| уатОстаткиГСМнаТСОбороты.КоличествоПриход КАК ПриходДень,
| уатОстаткиГСМнаТСОбороты.КоличествоРасход КАК РасходПроизводствоДень,
| 0 КАК ПриходМесяц,
| 0 КАК РасходПроизводствоМесяц,
| 0 КАК Остаток
|ПОМЕСТИТЬ ВТ_Обороты
|ИЗ
| РегистрНакопления.уатОстаткиГСМнаТС.Обороты(НАЧАЛОПЕРИОДА(&НаДату, ДЕНЬ), КОНЕЦПЕРИОДА(&НаДату, ДЕНЬ), , ) КАК уатОстаткиГСМнаТСОбороты
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ
| уатОстаткиГСМнаТСОстаткиИОбороты.ТС,
| уатОстаткиГСМнаТСОстаткиИОбороты.ГСМ,
| 0,
| 0,
| уатОстаткиГСМнаТСОстаткиИОбороты.КоличествоПриход,
| уатОстаткиГСМнаТСОстаткиИОбороты.КоличествоРасход,
| уатОстаткиГСМнаТСОстаткиИОбороты.КоличествоКонечныйОстаток
|ИЗ
| РегистрНакопления.уатОстаткиГСМнаТС.ОстаткиИОбороты(НАЧАЛОПЕРИОДА(&НаДату, МЕСЯЦ), КОНЕЦПЕРИОДА(&НаДату, ДЕНЬ), , , ) КАК уатОстаткиГСМнаТСОстаткиИОбороты
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| ВТ_Обороты.ТС,
| ВТ_Обороты.Номенклатура,
| ВТ_Обороты.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаИзмерения,
| СУММА(ВТ_Обороты.ПриходДень) КАК ПриходДень,
| СУММА(ВТ_Обороты.РасходПроизводствоДень) КАК РасходПроизводствоДень,
| СУММА(ВТ_Обороты.ПриходМесяц) КАК ПриходМесяц,
| СУММА(ВТ_Обороты.РасходПроизводствоМесяц) КАК РасходПроизводствоМесяц,
| СУММА(ВТ_Обороты.Остаток) КАК Остаток
|ИЗ
| ВТ_Обороты КАК ВТ_Обороты
|
|СГРУППИРОВАТЬ ПО
| ВТ_Обороты.ТС,
| ВТ_Обороты.Номенклатура,
| ВТ_Обороты.Номенклатура.ЕдиницаХраненияОстатков";

Запрос.УстановитьПараметр("НаДату", НаДату);

РезультатЗапроса = Запрос.Выполнить();

ОбластьМакетаСтрока = Макет.ПолучитьОбласть("Строка2");

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Если ВыборкаДетальныеЗаписи.Количество() Тогда

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

//------------------Строка2------------------
ОбластьМакетаСтрока.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ТабДокумент.Вывести(ОбластьМакетаСтрока);

КонецЦикла;

иначе

ТабДокумент.Вывести(ОбластьМакетаСтрока);

КонецЕсли;

КонецПроцедуры


дані вибираються з Регистру Накопления.уатОстаткиГСМнаТС реєстратором для якого являється документ уатПутевиеЛисты в даному документі є реквізит булево "Збут" при його значенні = Истина; необхідно щоб дані з значень РасходПроизводствоДень та РасходПроизводствоМесяц потраплали у РасходСбытДень та РасходСбытМесяц відповідно (див.Макет)

Якщо є можливість в даномі Запросі получити значення цього реквізиту "Збут" і умовою змінити назву значень щоб заповнялись інші колонки то будь-ласка підкажіть, а то щось мені не получається.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158585 · Ответов: 1 · Просмотров: 344
 

>  Какоё количество лицензий на 1С
Sirius83
Отправлено: 09.12.19, 16:31


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Irzik @ Сегодня, 17:14 * ,

Спасибо за информацыю теперь ясно откуда записи взялись.
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #158326 · Ответов: 9 · Просмотров: 720
 

>  Какоё количество лицензий на 1С
Sirius83
Отправлено: 09.12.19, 14:24


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


А с Вышеуказаной информации, я так понемаю количество лицензий узнать не получится?
Может у кого есть обработки на подобии етой что умеют вычислять к-во лицензий?
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #158324 · Ответов: 9 · Просмотров: 720
 

>  Какоё количество лицензий на 1С
Sirius83
Отправлено: 09.12.19, 12:45


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Цитата(vasyl_dp @ 09.12.19, 13:31) *
Sirius83 @ Сегодня, 12:40 * ,
Ломаная платформа

Врятли, покупалась оффицыально.
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #158314 · Ответов: 9 · Просмотров: 720
 

>  Какоё количество лицензий на 1С
Sirius83
Отправлено: 09.12.19, 11:40


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Доброго времени! Пожалуйста помогите разобраться с количеством клиентских лицензий на 1С на окне "Про программу"
пишет следующие:

Поточна:
81009***** клієнт ТОВ "Фірма" Україна,***********, file://C:/ProgramData/1C/licenses/20191119*****.lic, одержала клієнтська прикладна програма
Інформаційна база:
Сетевой HASP4 ORGL8 10
Локальный HASP4 EN8SA 1
Локальный HASP4 ORGL8 10
Локальний HASP4 EN8SA 1
Мережевий HASP4 ORGL8 5
Мережевий HASP4 ORGL8 10
Сетевой HASP4 ORGL8 5
81009***** клиент ТОВ "Фірма" Україна,***********,
Локальний HASP4 ORGL8 10
81009***** Client ТОВ "Фірма" Україна,***********,
Local HASP4 EN8SA 1
81014***** клієнт ТОВ "Фірма" Україна,***********,
Мережевий HASP4 ORGL8 20
Локальний HASP4 ENSR8 1
Network HASP4 ORGL8 10
81014***** Client ТОВ "Фірма" Україна,***********,
Конфігурація:
Сетевой HASP4 ORG8B 500

Со слов предшественника есть 20 клиентских лицензий, а с вышеуказанной информации вроде как больше или я ошибаюсь?
Пожалуйста, помогите с инвентаризацией лицензий.

ПС. Насколько мне известно то, 1С отображает только апаратные ключи, или ето не так?
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #158310 · Ответов: 9 · Просмотров: 720
 

>  Предпросмотр в 1С7,7 отличается от фактической печати
Sirius83
Отправлено: 06.11.19, 14:53


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Цитата(volodya1122 @ 06.11.19, 9:35) *
Sirius83 @ Вчера, 21:44 * ,

Печатается напрямую на принтер или через ПДФ Принтер? Попробуйте так и так. У меня больше нет вариантов.


И "напрямую" (через RDP прокидается принтер) и на PDF принтер одно и тоже, а на Server2003 все гууд, Может рдп клиент обновить?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #157269 · Ответов: 7 · Просмотров: 1248
 

>  Предпросмотр в 1С7,7 отличается от фактической печати
Sirius83
Отправлено: 05.11.19, 21:44


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


volodya1122 @ Сегодня, 9:40 * ,

Что "обрезать", что "Авто" одно и тоже наименование выходит за границы поля при печати.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #157233 · Ответов: 7 · Просмотров: 1248
 

>  Предпросмотр в 1С7,7 отличается от фактической печати
Sirius83
Отправлено: 05.11.19, 8:24


Общительный
**

Группа: Пользователи
Сообщений: 49
Регистрация: 21.07.12
Пользователь №: 19286


Цитата(Naghual @ 05.11.19, 0:19) *
Ответ лежит в вопросе....
Драйвера принтеров разные (или их настройки по умолчанию)

Пробовал на трёх принтерах результат один и тот-же.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #157221 · Ответов: 7 · Просмотров: 1248
 

2 страниц V   1 2 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 25.01.21, 6:38
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!