Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику AnryMc ::: Спасибо сказали: 97 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
01.05.24, 16:05 Помилка SDBL при створення нової УТП з .cf
Talkman @ Сегодня, 16:00 * ,

Создать файловую пустую базу.
Загрузить в конфигураторе .cf.
Запустить режим пользователя - запустится заполнение пустой базы по умолчанию...
Выгрузить в .dt

Загрузить в СУБД... из .dt
Talkman,
02.04.24, 14:33 Работа с объектом ДанныеФормыКоллекция 1С 8.3 (УФ)
Цитата(andrew76 @ 02.04.24, 14:58) *
Для каждого стр из РеквизитТЗ Цикл
//вот здесь отладчик пишет что стр =ДанныеФормыЭлементКоллекции
//как можно вытащить название колонки и ее значение ?
КонецЦикла


!!!
???
Не РеквизитТЗ
А РЕЗУЛЬТАТ

Для каждого стр из РЕЗУЛЬТАТ Цикл

нс = РеквизитТЗ .Добавить();

ЗаполнитьЗначенияСвойств(нс, стр);

КонецЦикла


З.Ы, Если "колонки" определены в РеквизитТЗ


ИЛИ

    ТекДок = РеквизитФормыВЗначение("Объект");
    тз_Продукты = ТекДок.ПодробностиЗапроса.Выгрузить(,);
    
    Для КАЖДОГО текПродукт ИЗ тз_Продукты Цикл
        

        
    КонецЦикла;
    
    ТекДок.ПодробностиЗапроса.Загрузить(тз_Продукты);
    ЗначениеВРеквизитФормы(ТекДок, "Объект");
andrew76,
27.03.24, 11:08 Умова ИЛИ у швидкому відборі універсального звіту
zay @ Сегодня, 10:59 * ,

Если честно, то ничего не понял...

Но:
В стандартных отборах можно создать:
1) Отборы по контрагенту (2 отбора, 2 строки отбора)
2) Выделить оба отбора (обе строки) и объединить их (через правый клик) в группу "ИЛИ"
zay,
15.03.24, 10:06 Загрузка документа в Excel. Формат файла не поддерживается

Цитата(Slon747 @ 15.03.24, 10:55) *
А как в потоке загружать данные в ТабличныйДокумент?


Цитата(AnryMc @ 15.03.24, 10:46) *
Что-то типа

ТабличныйДокумент = Новый ТабличныйДокумент;
дд = Новый ДвоичныеДанные("D:\Temp\123.xls");
ТабличныйДокумент.Прочитать(дд, СпособЧтенияЗначенийТабличногоДокумента.Значение, ТипФайлаТабличногоДокумента.XLS97);

Slon747,
12.03.24, 14:00 Нужно найти КонечнаяДата = ДатаДокумента + КоличествоДней
Shiwchik @ Сегодня, 14:31 * ,

ДОБАВИТЬКДАТЕ(ДатаДокумента, "ДЕНЬ", КоличествоДней)

З.Ы, Не обратил внимания на раздел - СКД
Shiwchik,
12.03.24, 12:12 Нужно найти КонечнаяДата = ДатаДокумента + КоличествоДней
Просто добавить количество дней в секундах

НО! Если ДатаДокумента = Начало дня

ИНАЧЕ

НачалоПериода(ДатаДокумента, "ДЕНЬ") + КоличествоДнейВСекундах

Возможно при выводе нужно будет указать формат для даты
Shiwchik,
11.03.24, 13:45 Сумма документа выводится ресурсом не правильно
Shiwchik @ Сегодня, 14:10 * ,

Наверно:

Два документа (ДокументПродажи и ДокументПродажиЗаказПокупателя) - две суммы

З.Ы,
Два запроса через "ОБЪЕДИНИТЬ" ?
Или "связать" по ним?
Shiwchik,
11.03.24, 12:47 Сумма документа выводится ресурсом не правильно
Shiwchik @ Сегодня, 13:12 * ,

Запрос всё делает правильно т.к. вы выбираете документ и строки таблицы...

Разбейте на два запроса
Shiwchik,
07.03.24, 14:55 Видимость элемента справочника по вхождению пользователя в табличную часть (RLS)
Talkman @ Сегодня, 15:19 * ,

Насколько я помню роли "складываются" по "доступ или"
т.е. если в любой из ролей есть доступ - он предоставляется
Talkman,
26.02.24, 16:51 Поиск подобных товаров по артикулам из перечня артикулов
СтрокаАртикулов = Зап.Номенклатура.Артикул;

мАртикулов = НОВЫЙ ТалицаЗначений;
мАртикулов.Колонки.Добавить("Артикул");

ЕстьРазделитель = СтрНайти(СтрокаАртикулов , "/");

Пока ЕстьРазделитель  > 0 Цикл

//выделяем текущий артикул

текАртикул = Лев(СтрокаАртикулов , ЕстьРазделитель - 1);

//Проверим и обработаем "-"

ЕстьДефис = СтрНайти(текАртикул , "-");

Если ЕстьДефис > 0 Тогда

текАртикул = Лев(текАртикул, ЕстьДефис -1);

КонецЕсли;

нс = мАртикулов.Добавить(текАртикул );

нс.Артикул = текАртикул;

СтрокаАртикулов = ПРав(СтрокаАртикулов, СтрДлина(СтрокаАртикулов) - ЕстьРазделитель;

ЕстьРазделитель = СтрНайти(СтрокаАртикулов, "/");

КонецЦикла;

//Удалим повторы артикулов
мАртикулов.Свернуть("Артикул");

//Если надо преобразуем в массив

МойМассив = мАртикулов.ВыгрузитьКолонку("Артикул")


Как то так....
Talkman,
26.02.24, 15:12 Поиск подобных товаров по артикулам из перечня артикулов
Цитата(Talkman @ 26.02.24, 15:50) *
| РегистрНакопления.ТоварыНаСкладах.Остатки(&Дата, Номенклатура.Артику ПОДОБНО ""%"" + мАртикулов"+Ном+" + ""%"") КАК ТоварыНаСкладахОстатки";



Так правильно
Ну и устанавливать параметр тоже с Ном.
Talkman,
26.02.24, 14:20 Поиск подобных товаров по артикулам из перечня артикулов
КолвоЭл = мАртикулы .Количество;

Запрос.Текст =
        "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |   ТоварыНаСкладахОстатки.Номенклатура,
        |   ТоварыНаСкладахОстатки.КоличествоОстаток,
        |   ТоварыНаСкладахОстатки.Номенклатура.Артикул
        |ИЗ
        |   РегистрНакопления.ТоварыНаСкладах.Остатки(&Дата, Номенклатура.Артику ПОДОБНО ""%"" + мАртикулов + ""%"") КАК ТоварыНаСкладахОстатки";

Запрос.УстановитьПараметр("мАртикулов", мАртикулы[0]);

Ном= 1;

Пока Ном <= КолвоЭл  Цикл

Запрос.Текст = Запрос.Текст +
        "ОБЪЕДИНИТЬ
        |ВЫБРАТЬ
        |   ТоварыНаСкладахОстатки.Номенклатура,
        |   ТоварыНаСкладахОстатки.КоличествоОстаток,
        |   ТоварыНаСкладахОстатки.Номенклатура.Артикул
        |ИЗ
        |   РегистрНакопления.ТоварыНаСкладах.Остатки(&Дата, Номенклатура.Артику ПОДОБНО ""%"" + мАртикулов + ""%"") КАК ТоварыНаСкладахОстатки";

Запрос.УстановитьПараметр("мАртикулов", мАртикулы[Ном ]);

Ном = Ном + 1;

КонецЦикла;
    
    Запрос.УстановитьПараметр("Дата", Док.Дата);

Talkman,
23.02.24, 12:26 Не могу получить макет
Цитата(alex_shkut @ 23.02.24, 12:57) *
Нету открытого Обїекта = нету Макета.
Ворос решен = ОбщийМакет;


АБСОЛЮТНО РАБОЧИЙ КОД:
//Модуль списка
&НаКлиенте
Процедура КомандаПолучитьМакет(Команда)
    
    Для КАЖДОГО текСтр ИЗ Элементы.Список.ВыделенныеСтроки Цикл
        
        ОтчетСформирован = ОбщийМодульСервер.РаспечататьНужныйМакет(текСтр);
        
        ОтчетСформирован.Показать();
        
    КонецЦикла;
    
КонецПроцедуры

//Модуль ОбщийМодульСервер
Функция РаспечататьНужныйМакет(текРКМ) Экспорт
    
    ТабДок = Новый ТабличныйДокумент;
    
    Макет = Справочники.ХХХХХХХХХХХХ.ПолучитьМакет("НужныйМакет");    
        //Макет = Документы.ХХХХХХХХХХХХ.ПолучитьМакет("НужныйМакет"); //Или что надо
    
    Шапка = Макет.ПолучитьОбласть("Шапка");

    Шапка.Область("R1C1").Текст = "Ура получилось!";

    ТабДок.Вывести(Шапка);
    
    ВОЗВРАТ ТабДок;
    
КонецФункции
andreykyiv@bigmir.net,
23.02.24, 11:18 Не могу получить макет
Цитата(alex_shkut @ 23.02.24, 12:07) *
невозможно ВНЕ открытого Объекта


текОбъект = Список.ТекущиеДанные.Ссылка.ПолачитьОбъект();
Мак = текОбъект .ПолучитьМакет("Наряд");


Объект не открыт - макет поглучен
andreydv87,
23.02.24, 10:34 Не могу получить макет
alex_shkut @ Сегодня, 10:50 * ,

Цитата(alex_shkut @ 23.02.24, 10:50) *
В модуле списка документов.


На клиенте? На сервере?

В списке нет "Объекта" к которому вы пытаетесь обратиться - там основной реквизит "Список"

Можно добираться через ТекущиеДанные.ПолучитьОбъект(), Экспортируемую функцию Модуля объекта и ещё .............

andreykyiv@bigmir.net,
20.02.24, 15:15 Настройка панели разделов (верхнее расположение) интерфейс "Такси"
andrew76 @ Сегодня, 15:21 * ,

andrew76,
15.02.24, 15:28 Как получить всех родителей элемента справочника?
kostya77 @ Сегодня, 15:23 * ,

ПолныйКод()

Синтаксис:
ПолныйКод()
Назначение:
Возвращает строку, содержащую полный код выбранного элемента справочника со всеми вышестоящими уровнями, разделенными символом /.
kostya77,
06.02.24, 14:27 Как ограничить скроллинг строк в Табличном Документе ?
Попробуйте в свойствах

АвтоМаксимальнаяВысота = Ложь;
МаксимальнаяВысота = 100; //Ваша высота

Возможно ещё - РастягиватьПоВертикали
andrew76,
30.01.24, 17:29 Переименование номенклатуры для 1С 8.3 (внешняя обработка)
Nevermore @ Сегодня, 17:37 * ,


Попробуйте скачать https://proger.com.ua/upload/iblock/ae1/fanRenamer.epf
Nevermore,
23.01.24, 16:53 Как сравнить тип документа в условном оформлении?
Цитата(kostya77 @ 23.01.24, 17:26) *
как раскарсить всю строку. а не одно ячейку?


Выбрать на название ячейки а таблицы
kostya77,
23.01.24, 16:21 Как сравнить тип документа в условном оформлении?
kostya77 @ Сегодня, 17:02 * ,

Могу предположить это для списка...

Дополнить его (невидимой колонкой, используемой всегда) - тип документа (можно например для простоты условий прямо в запросе списка, например:

ВЫБОР 
КОГДА ТИПЗНАЧЕНИЯ(МатериалыВЭксплуатацииОстаткиИОбороты.Регистратор.Ссылка) = Тип(Документ.передачаМаиериаловвЭксплуатацию) Тогда 1
........ ТОГДА 2
........
ИНАЧЕ 0
КОНЕЦ


и по ним делать оформление
kostya77,
10.01.24, 16:43 Ссылки на информационные базы для нового пользователя RDP
Slon747 @ Сегодня, 16:01 * ,

Создается файл
1cestart.cfg
указывает на файл общих баз
расположен:
C:\ProgramData\1C\1CEStart\
В НЕМ НАПРИМЕР СТРОКА
CommonInfoBases=D:\1C\СписокОбщихБаз.v8i

В D:\1C\ создается файл СписокОбщихБаз.v8i
В НЕМ ПРИМЕРНО СЛЕДУЮЩЕЕ
[BAS]
Connect=File="D:\1C\МОяБаза1С";
ID=ХХХХХ-ХХХХ-ХХХХ-ХХХХ-ХХХХХХХХХХХХХ
OrderInList=16384
Folder=/
OrderInTree=256
External=0
ClientConnectionSpeed=Normal
App=Auto
WA=1
Version=8.3

ЭТО СОДЕРЖИМОЕ МОЖНО ПОЛУЧИТЬ если при старте 1С стать на название нужной (предварительно прописаной база) и по "правому клику" - "сохранить ссылку в файл"
Slon747,
08.01.24, 9:23 как посчитать страницы в макете при выводе области в цикле
Svetas_2024 @ Вчера, 9:32 * ,

Можно задать шаблон для колонтитула и он будет выводить какая страница и сколько всего.... ("АВТОМАТИЧЕСКИ")

Svetas_2024,
29.11.23, 16:27 Не запускается distr\DOC\V8Doc.exe под Windows 11 22H2
Цитата(mokriak @ 29.11.23, 14:27) *
окно запустилось, но внутри нет содержимого



С правами Администратора - тоже?

З.Ы. Полные права на папку где лежит есть?
mokriak,
27.11.23, 10:05 Відправка пошти на UKR.NET
Цитата(Slon747 @ 25.11.23, 15:18) *
"imap.ukr.net"


Профиль.ПарольIMAP
Профиль.АдресСервераIMAP
Профиль.ИспользоватьSSLIMAP
Профиль.ПользовательIMAP
Профиль.ПортIMAP
Профиль.ТолькоЗащищеннаяАутентификацияIMAP

Не так ли?
pony95, Slon747,

3 страниц V   1 2 3 >
RSS Текстовая версия Сейчас: 20.05.24, 13:38
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!