Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> раскраска строки FormEX          
4andriy Подменю пользователя
сообщение 01.04.24, 8:05
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

для 1с 7.7
для раскраски использую FormEx
надо раскрасить текущую строку
выделеная ячейка сейчас синяя, а надо что-бы ячейка была одним цветом, а строка другим

если пишу такой код тогда красит всю таблицу:
Если ПустоеЗначение(ТекущийЭлемент().Наименование)=0 Тогда Возврат "BRUSH[" + ПолучитьЦвет(200,200,100) + "]"; КонецЕсли;

denis84 Подменю пользователя
сообщение 01.04.24, 9:03
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 438
Из: Украина
Спасибо сказали: 143 раз
Рейтинг: 144.5

4andriy @ Сегодня, 9:05 * ,
Доброго дня, в журналі документів розфарбована ТЧ за ознакою "КонтрольДокументів", якщо контролюємо контрагента:
//==========================================
Функция ПроверитьВид()
    Если ПустоеЗначение(ТекущийДокумент) = 0 Тогда
        //Если ТекущийДокумент.ЗапретРедактирования = 1 Тогда
        //    Возврат "BRUSH["+глПолучитьЦвет(204,204,204)+"]";      //серый фон
        Если ((ТекущийДокумент.Контрагент.КонтрольДокументов = 1) И (ТекущийДокумент.Проверен = 1)) Тогда
            Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(255,255,255)+"]"; //белый  фон
        ИначеЕсли ((ТекущийДокумент.Контрагент.КонтрольДокументов = 1) И (ТекущийДокумент.Проверен = 0)) Тогда
            Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(255, 222, 179)+"]"; //красный  фон
        КонецЕсли;
    КонецЕсли;
    Возврат "";
КонецФункции


Сообщение отредактировал Vofka - 01.04.24, 9:06

Спасибо сказали: 4andriy,

denis84 Подменю пользователя
сообщение 01.04.24, 11:27
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 438
Из: Украина
Спасибо сказали: 143 раз
Рейтинг: 144.5

ось функція з глобал.модулю
Функция глПолучитьЦвет(Красный = 0,Зеленый = 0,Синий = 0) Экспорт
        // функция для формирования значения цвета из составляющих (RGB)
    Возврат Макс(0,Синий)*65536+Макс(0,Зеленый)*256+Макс(0,Красный);
КонецФункции


4andriy Подменю пользователя
сообщение 01.04.24, 13:26
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

тільки там не ТекущийДокумент, а Текущая строка

denis84 Подменю пользователя
сообщение 01.04.24, 14:07
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 438
Из: Украина
Спасибо сказали: 143 раз
Рейтинг: 144.5

4andriy @ Сегодня, 14:26 * ,
в мене це приклад для журнала надходження ТМЦ, а у Вас

4andriy Подменю пользователя
сообщение 01.04.24, 14:44
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

denis84 @ Сегодня, 14:07 * ,
довідник співробітників

piterkzl Подменю пользователя
сообщение 17.04.24, 8:43
Сообщение #7

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

маю реалізацію для любої конфігурації 77 розфарбування любим кольором в стандартних справочниках за допомогою "VCOLORPICKER.VColorPickerCtrl.1"
реалізація складається з обробки , поля "_оформлениестроки" в потрібному справочнику, та 9 строк процедури в глобальному модулі.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.05.24, 15:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!