Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику sava1 ::: Спасибо сказали: 530 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
16.01.20, 11:58 ПолеВвода СписокЗначения
Цитата(bizisoft @ 16.01.20, 8:19) *
Есть иерархический справочник номенклатура, пользователь в ПолеВвода выбирает группу (или несколько групп) номенклатуры, но как узнать, что подгружать в этот список, т.к. заведомо неизвестно пожелания пользователя в выборе.
Может ему нужно сделать отбор из номенклатуры по одной группе, а может и по двум или по пяти группам.


ИСПОЛЬЗУЙТЕ Построитель или СКД - выведите отбор на форму - пусть выбирает что хочет
bizisoft,
28.12.19, 11:51 Как скопировать данные из одного реквизита справочника в другой
IsNULL(ИмяПоля,"") как Поле
lolmatrix,
26.12.19, 13:59 Как скопировать данные из одного реквизита справочника в другой
внешней обработкой
lolmatrix,
26.12.19, 13:38 Как скопировать данные из одного реквизита справочника в другой
не надо - это про Расширение.

по коду -
запрос - выборка из справочникаБезКодов+левое соединение справочника с кодами
прошли по выборке - получили объект - записали.
lolmatrix,
18.12.19, 11:29 Подружить Бухгалтерию с Фискальным регистратором
по-моему АртСофт - гугль в помощь
Володька,
09.12.19, 13:33 метод ВыгрузитьКолонку не досупен
а просто обойти и заполнить список ?
lolmatrix,
26.11.19, 14:10 ПКС-ИсходящиеДанные - ПКО-ВходящиеДанные, не передаются данные
Цитата(edmah @ 26.11.19, 13:34) *
ЕдиницаХраненияОстатков
- это элемент справочника Единицы измерений, а не Номенклатура.
Вы хотите при выгрузке номенклатуры передать элемент справочника ЕИ. Откуда приемник может об этом знать ? В таких случаях используйте ВыгрузитьПоПравилу
edmah,
26.11.19, 11:43 ПКС-ИсходящиеДанные - ПКО-ВходящиеДанные, не передаются данные
Цитата(edmah @ 26.11.19, 11:28) *
В смысле создает таблицу значений с нужными полями и выгружаем по правилу?


любую коллекцию (структура,выборка и т.д) , вызываем выгрузить по правилу.

но -
для Вашего случая проще на стороне приемника просто добавить Базовую ЕИ в справочник с Владельцем - Объект.

ПослеЗагрузки - ищем по коду классификатора и владельцу (Объект) единицу измерения и добавляе в справочник , если не нашли.
edmah,
20.11.19, 12:15 Как сделать так что бы при создании на основании переносились данные табличной части?
прописать заполнение.
darrr,
15.11.19, 17:00 Підкажіть будь-ласка у мене 1с 1.2 Базова для України ,можна якось зняти конфігурацію з підтримки?
лицензия скорее всего действительна только для базовой.
надо будет на другом компе (не сетевом) установить платформу, крякнуть, поменять конфигурацию, потом вернуть базу на место.
платформу желательно до 10й.
почту дайте.
zoltan,
15.11.19, 10:28 При обмене из объекта-источника передать два реквизита в один реквизит объекта-приемника
в ПКС докуменЗаказ

Цитата(sava1 @ 15.11.19, 10:24) *
Это в обработчике "Перед выгрузкой"?


Да. иначе отказаться негде
info230a02,
15.11.19, 10:15 Підкажіть будь-ласка у мене 1с 1.2 Базова для України ,можна якось зняти конфігурацію з підтримки?
Цитата(zoltan @ 15.11.19, 10:08) *
У мене базова і конфігурація не знімається


Может, с этого надо было начать ?
варианты
1. покупаете ключ проф - и снимаете.
2. патчите платформу (унипатч) - и снимаете....
zoltan,
15.11.19, 10:05 Підкажіть будь-ласка у мене 1с 1.2 Базова для України ,можна якось зняти конфігурацію з підтримки?
В ПКО документа ПКС ДокЗаказ

Если ЗначениеЗаполнено(Источник.ДокОснование) Тогда Отказ=Истина; КонецЕсли


это для приоритета ДокОснование
если приоритет докЗаказ - тогда наоборот

Цитата(zoltan @ 15.11.19, 9:52) *
зняти конфігурацію з підтримки


в конфигураторе Конфигурация-Поддержка --- снимаете. Какого там эмулятора надо ?
info230a02,
07.11.19, 15:14 Код Банку "0" в счете на оплату покупателю
в константах есть даты перехода. после перехода код будет 0 - кажись так писали.
yoj,
07.11.19, 9:51 На сервере не работает ADODB.Connection
запускать регл. задание под пользователем с соответствующими правами.- по умолчанию пользователь - 1СЮзер (попробуйте добавить его в группу Повер Юзерс)
vbi,
25.10.19, 16:18 Где описывается код "меню действия", вывести список (обычный клиент)
Цитата(george_smith @ 25.10.19, 16:07) *
Выборка = РЗ.Выбрать(); Пока Выборка.Следующий() Цикл Для Каждого Эл Из Соо Цикл Если Выборка.НоменклатураРегистраШтрихКод = Эл.Ключ Тогда Эл.Значение = Выборка.Штрихкод; КонецЕсли; КонецЦикла; КонецЦикла;


здеся не так.

Выборка делается по оформлению

Для каждого ос из ОформленияСтроки Цикл


для рз надо добавить индекс - иначе будет тормозиииить....

потом ищем для конкретного значения из ос значение штрихкода в Выборке.

если нашли -
ос.Ячейки.Штрихкод.Текст (или значение) = найденнаяСтрокаВыборки.Штрихкод



ну и конецЦикла
george_smith,
08.10.19, 14:02 Программное создание кнопки для всех документов в формах объекта
Если не надо вопроса про запись - тупо отказ и все.

Выше вариант, когда надо спросить человека - "Объект то новый. может Вы хочите его записать ?"

Если человек жмет на кнопу - он на что-то рассчитывает. Хотябы на обратную связь.
Gigi,
08.10.19, 13:27 Программное создание кнопки для всех документов в формах объекта
Копипаст из бухии

Кнопки = Новый СписокЗначений;
        Кнопки.Вставить(0, КодВозвратаДиалога.Да, "Провести");
        Кнопки.Вставить(1, КодВозвратаДиалога.Нет, "Отмена");
        ДополнительныеПараметры = Новый Структура;
        ДополнительныеПараметры.Вставить("ПараметрыВыполненияКоманды", ПараметрыВыполненияКоманды);
        ДополнительныеПараметры.Вставить("ПараметрКоманды", ПараметрКоманды);
        
        Оповещение = Новый ОписаниеОповещения("ВопросПередПросмотромСледуетПровестиЗавершение", ЭтотОбъект, ДополнительныеПараметры);
        ПоказатьВопрос(Оповещение, НСтр("ru='Перед просмотром проводок документ следует провести';uk='Перед переглядом проводок документ слід провести'"), Кнопки,, КодВозвратаДиалога.Да);


и собственно обработка ответа

Если Ответ <> КодВозвратаДиалога.Да Тогда
        Возврат;
    КонецЕсли;
    
    ПараметрКоманды = ДополнительныеПараметры.ПараметрКоманды;
    ПараметрыВыполненияКоманды = ДополнительныеПараметры.ПараметрыВыполненияКоманды;
    
    ДокументПроведен = ПровестиДокумент(ПараметрКоманды);
    Если ДокументПроведен Тогда
        ОповеститьОбИзменении(ПараметрКоманды);
        Оповестить("ВыполненаЗаписьДокумента", Новый Структура("ДокументСсылка", ПараметрКоманды));
    Иначе
        Сообщить(НСтр("ru='Не удалось провести документ';uk='Не вдалося провести документ'"), СтатусСообщения.Важное);
        Возврат;
    КонецЕсли;


а дальше Ваши идеи
Gigi,
08.10.19, 12:41 Программное создание кнопки для всех документов в формах объекта
Цитата(Gigi @ 08.10.19, 13:35) *
что происходит когда на кнопку «Назначить авто-заполнение» нажимаешь не на форме уже сохраненного объекта, а на форме нового.


а сами как думаете ?
если параметром команды идет ссылка на объект, а ссылка пустая ? по-идее Вы должны разрулить эту ситуевину.
Gigi,
08.10.19, 11:58 Программное создание кнопки для всех документов в формах объекта
оффтоп -

Цитата(Gigi @ 08.10.19, 10:48) *
сам в 1С всего два годика.


это типа - знаю, что такое циклы - и для меня достаточно....

по-аналогии - первый раз увидел авто с коробкой-автоматом -- "Как на ней можно ехать - здесь сцепления нет !!!!"
Gigi,
08.10.19, 11:27 Программное создание кнопки для всех документов в формах объекта
чем не нравится Важное ?

Цитата(Gigi @ 08.10.19, 10:48) *
возможно указать только конкретный документ. А указать все документы 1С естественно не позволяет. Это во-первых.


ТипПараметра = составной тип - и ставите "птисы" на чем хочите.

Цитата(Gigi @ 08.10.19, 10:48) *
пределить ссылку на объект, для того что бы вызвать процедуру требующую контекста самой формы?


в модуле команды -

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

//ПараметрКоманды и есть Ссылка на объект



Цитата(Gigi @ 08.10.19, 10:48) *
вызвать процедуру требующую контекста самой формы


интересно, что Вы в формах храните ?
Gigi,
07.10.19, 15:52 Программное создание кнопки для всех документов в формах объекта
Цитата(Gigi @ 07.10.19, 16:35) *
Пользователь ее должен нажать в другом одном месте, а нужно что бы он нажимал на самой форме.


Уважаемый, Вы хреново осведомлены об Общих Командах. Возьмите типовую бухию и посмотрите, как показываются проводки документа.
Gigi,
03.10.19, 10:08 Настройка доступа через RLS!
у пользователя по другим ролям доступ к кассам закрыт ?

это видели ? тыц

аль это тыц
Pashaboston,
24.09.19, 11:23 Форма выбора. Параметр "Дата между". Реально?
а вот так ?

&НаКлиенте
Процедура ОткрытьФормуА(Команда)
    
    фиксНастройки = Новый НастройкиКомпоновкиДанных;
    
    эОтбор = фиксНастройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    эОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Дата");
    эОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно;
    эОтбор.ПравоеЗначение = Объект.Период.ДатаНачала;
    эОтбор.Использование = Истина;
    
    эОтбор = фиксНастройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    эОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Дата");
    эОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.МеньшеИлиРавно;
    эОтбор.ПравоеЗначение = Объект.Период.ДатаОкончания;
    эОтбор.Использование = Истина;

    эОтбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;

    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ФиксированныеНастройки", фиксНастройки);

    ОткрытьФорму("Документ.РеализацияТоваровУслуг.Форма.ФормаСписка", ПараметрыФормы, ЭтаФорма);
КонецПроцедуры
fly, Inkognito,
24.09.19, 10:39 Форма выбора. Параметр "Дата между". Реально?
а по-человечески - так

ФормаВыбора = ПолучитьФорму("Справочник.ТестСправочник.Форма.ФормаВыбора"
fly,

16 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 24.01.20, 16:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!