Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику TipsyKID ::: Спасибо сказали: 160 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
09.07.15, 10:49 Ведомость на выплату з/п
Документ "Зарплата к выплате организаций".
Печатная форма "Ведомость".
Как в бюджетке организаванно не знаю.
vadim007,
08.07.15, 11:26 Иерархия с владельцем справочника
Попробую включить телепата :
ВЫБРАТЬ
    ТАБ_Обороты.Субконто1 КАК Проект,
    ТАБ_Обороты.СуммаОборот
ИЗ
    РегистрБухгалтерии.ЖурналОпераций.Обороты КАК ТАБ_Обороты

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    ТАБ_Обороты2.Субконто2.Владелец,
    ТАБ_Обороты2.СуммаОборот
ИЗ
    РегистрБухгалтерии.ЖурналОпераций.Обороты КАК ТАБ_Обороты2
SV71,
07.07.15, 16:07 Расчет столбца в отчете на СКД
Достаточно ,лишь, доказать, что это решение правильно.
Доказательство — это логическая операция обоснования истинности утверждения с помощью фактов и связанных с ним суждений.
В наиболее общем смысле, научный факт — объективное и проверяемое наблюдение.

Вывод :
Объективно проверьте и понаблюдай за результатами на выборке( чем больше , тем лучше).
candrey,
07.07.15, 12:59 Расчет столбца в отчете на СКД
http://infostart.ru/public/86764/

ВЫЧИСЛИТЬВЫРАЖЕНИЕ()

Следующая (Next). Необходимо получить следующую запись группировки. После слова в скобках можно указывать выражение, результат которого будет использоваться как смещение вперед от текущей записи группировки. Например, Следующая(2) – получение следующей от следующей записи.
candrey, mister-x,
07.07.15, 12:49 Схемы налогообложения star,
01.07.15, 13:00 Выгрузка в Excel всех типов цен номенклатуры
Цитата(Dizeloid @ 01.07.15, 12:53) *
Спасибо, как вариант конечно, но это грабли.

А чем отчет прайс не устраивает ?
С последующей выгрузкой его в Эксель...
Dizeloid,
04.06.15, 9:09 Поиск в пустом подчиненном справочнике
Так красивее будет ( а то 100500+ прерываний функции возвратом - изврат ) :
Функция ПолучитьВладельцаПоКоду(кодПоиска, Контрагент)               
       Результат = ПолучитьПустоеЗначение();
       
    спрКодыКонтрагентов=СоздатьОбъект("Справочник.КодыКонтрагентов");
    спрКодыКонтрагентов.ВыбратьЭлементыПоРеквизиту("КодТовара", кодПоиска, 0,0);

    Пока спрКодыКонтрагентов.ПолучитьЭлемент()=1 Цикл
        КодИзСпр = СокрЛП(спрКодыКонтрагентов.КодТовара);
        КонтрИзСпр = спрКодКонтр.Контрагент;
        Пометка = спрКодКонтр.ПометкаУдаления();
        
        Если (Пометка = 0) И (КонтрИзСпр = Контрагент) И (КодИзСпр = КодПоиска) Тогда
            Результат = спрКодКонтр.Владелец;
            Прервать;
        КонецЕсли;    
    КонецЦикла;
    
    Возврат Результат;
КонецФункции
Sede,
03.06.15, 11:23 Помогите с запросом по регистру бухгалтерии Хозрасчетный
Уберите из виртуальной таблицы условие на подобно и поместите его в обычное условие , только для Субконто1 оставте.
И не волнуйтесь, для этого ВидСубконто и существует, он оставит из остатков только аналитику по Номенклатуре , не зависимо на каком месте ВидСубконто.Номенклатура находился в проводках.

ВЫБРАТЬ
    ХозрасчетныйОстатки.КоличествоОстаток,
    ХозрасчетныйОстатки.Субконто1
ИЗ
    РегистрБухгалтерии.Хозрасчетный.Остатки(&Период, Счет В ИЕРАРХИИ &СпСчетов, &ВидСубконто, ) КАК ХозрасчетныйОстатки
ГДЕ
    ХозрасчетныйОстатки.Субконто1.Наименование ПОДОБНО "%" + "атералы" + "%"
kosalex,
12.05.15, 13:28 Исходная много складов - Конечная один склад
В правиле конвертации объектов ,предположительно "МестаХранения", перед выгрузкой пишем : Значение = "Общий склад";
У этого правила оставляем свойство Наименование ( по нему устанавливаем поиск объекта ). В самом свойстве "Наименования", перед выгрузкой пишем следующее : Значение = Источник;

Объясню логику :
Мы в правило "МестаХранения" подменяем источник, делая его просто строкой, и присваевыем эту строку Наименованию, после чего делаем поиск объекта в базе приемнике, только по наименованию.
DiegoLidabo,
06.03.15, 16:50 связать две формы списков двух разных справочников Vasilii77,
29.11.14, 20:36 проблема с чистой базой
у меня она не заполнена, сам только скачал.
smile.gif На домашнем компе я не работаю, случайно на форум в СУББОТУ зашел !
na1kon,
29.11.14, 20:28 проблема с чистой базой
Изменение структуры справочника валовых доходов/расходов (с 01.01.2003)
Скачайте этот файл. потом откройте его через Файла- Открыть
na1kon,
29.11.14, 20:26 ИзменениеСтруктурыВДВР_20030101
Изменение структуры справочника валовых доходов/расходов (с 01.01.2003)

Скачать: [attachment=782:Изменени...20030101.zip]
Vofka,
29.11.14, 20:09 проблема с чистой базой
Цитата(na1kon @ 29.11.14, 20:04) *
там такой функции нет, захожу в старую базу, там такая есть... О_о

....
Укажите точно релиз конфигурации , т.к. я специально установил 305 релиз Бухгалтерский учет для Украины и проверил ! И там такая обработка есть !
Это не функция , это обработка .
+ укажите Ваш уровень , вы опытный пользователь или программист, или консультант ?
na1kon,
29.11.14, 20:00 проблема с чистой базой
Цитата(na1kon @ 29.11.14, 19:56) *
самое интересное что заполнили все первоначально...

Операции - обработки - "Изменение структуры справочника валовых доходов/расходов (с 01.01.2003)"
na1kon,
29.11.14, 19:53 проблема с чистой базой
Цитата(na1kon @ 29.11.14, 19:48) *
Добрый вечер, столкнулся с такой проблемой, попросили поставить чистую базу, скачал 7.70.305 установку, все хорошо установилось, все работает, но говорят в Справочнике-Валовые доходы/расходы пусто, я вот даже незнаю что делать нужно что бы там появилось все... Может подскажете?wink.gif

или может быть у кого то есть чистая база 1с 7.7, версии 7.70.305 уже с валовыми доходами? поделитесь пожалуйста wink.gif

Первоночальное заполнение не надо закрывать , на то оно и первоначальное заполнение !!!
na1kon,
25.11.14, 14:04 infostart архив 2012
Добрый день!
Прочитав очередное сообщение в теме "Помогите скачать с инфостарта" расстроился.
Такое ощущение, что люди не могут использовать поисковые системы.
Большой процент запросов в этой ветке на разработки до октября 2012 года.
Открою Вам «тайну» haha.gif , все разработки до 01.09.2012 есть в интернете в виде архива :

тыц (ex.ua)
тыц (торрент)

AlexDiablo, pumbaE, sasha007, stark, terrus, Vofka,
29.10.14, 13:53 Загрузка платежек "пакетно" в 1С
В большенстве типовых есть обработка "КлиентБанк". Доработайте её под нужный Вам формат и прикрипите как внешнюю обработку.
Есть еще партнерский Клиент-Банк ( от Абби ) он универсальный под типовые конфигурации, его тоже достаточно легко доработать под необходимый формат.
Tatiana1991,
29.10.14, 12:59 Загрузка платежек "пакетно" в 1С
Проще (лично для меня) работать с dbf. Не нужно мучаться с приведением типов ( в dbf они стандартизированы ).
С другой стороны, бухгалтера не смогут посмотреть что в dbf без спец программки.
но все это очень индивидуально, кто - то любит xml, кому - то привычней txt или dbf
Tatiana1991,
17.10.14, 13:46 Отбор по вычисляемому полю
Поставте для теста на вкладке вычисляемые поля значение 1 и тип Число.
Проверьте заработает ли отчет.
Amfiaray, Vofka,
16.10.14, 14:27 Загрузка из документа
Если типовая то :
ОбщегоНазначения.ЗагрузитьВТаблицуЗначений(ТаблицаИсточник, ТаблицаПриемник);

Если нет :

    // Заполним значения в совпадающих колонках.
    Для каждого СтрокаТаблицыИсточника Из ТаблицаИсточник Цикл

        СтрокаТаблицыПриемника = ТаблицаПриемник.Добавить();
        ЗаполнитьЗначенияСвойств(СтрокаТаблицыПриемника, СтрокаТаблицыИсточника);

    КонецЦикла;


Volodimir19901, Егор Динин,
15.10.14, 10:46 Тормозит база при работе отдельных пользователей
1. Платформа 1с 7.7 точно 027 ?
2. Если это дописанная конфигурация, проверьте в коде имена этих пользователей. Возможно запущены обработчики ожидания или еще что - то подобное ?
1Cv77, f12,
14.10.14, 13:49 Помошь в скд
ВЫБРАТЬ
    КомплектующиеНоменклатуры.Номенклатура КАК Номенклатура,
    КомплектующиеНоменклатуры.Комплектующая КАК Комплектующая,
    СУММА(КомплектующиеНоменклатуры.Количество) КАК Количество,
    СУММА(ЕСТЬNULL(ВложенныйЗапрос.КоличествоОстаток, 0)) КАК КоличествоОстаток,
    ЕСТЬNULL(ВложенныйЗапрос.Склад, ЗНАЧЕНИЕ(Справочник.Склады.ПустаяСсылка)) КАК Склад
ИЗ
    РегистрСведений.КомплектующиеНоменклатуры КАК КомплектующиеНоменклатуры
        ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
            ОстаткиТоваровОпт.Склад КАК Склад,
            ОстаткиТоваровОпт.Номенклатура КАК Номенклатура,
            СУММА(ОстаткиТоваровОпт.КоличествоОстаток) КАК КоличествоОстаток
        ИЗ
            РегистрНакопления.ТоварыНаСкладах.Остатки(&ДатаКон, {(Склад).* КАК Склад, (Номенклатура).* КАК Номенклатура, (ХарактеристикаНоменклатуры).* КАК ХарактеристикаНоменклатуры}) КАК ОстаткиТоваровОпт
        
        СГРУППИРОВАТЬ ПО
            ОстаткиТоваровОпт.Склад,
            ОстаткиТоваровОпт.Номенклатура
        
        ОБЪЕДИНИТЬ ВСЕ
        
        ВЫБРАТЬ
            ОстаткиТоваровРозница.Склад,
            ОстаткиТоваровРозница.Номенклатура,
            СУММА(ОстаткиТоваровРозница.КоличествоОстаток)
        ИЗ
            РегистрНакопления.ТоварыВРознице.Остатки(&ДатаКон, {(Склад).* КАК Склад, (Номенклатура).* КАК Номенклатура, (ХарактеристикаНоменклатуры).* КАК ХарактеристикаНоменклатуры}) КАК ОстаткиТоваровРозница
        
        СГРУППИРОВАТЬ ПО
            ОстаткиТоваровРозница.Номенклатура,
            ОстаткиТоваровРозница.Склад) КАК ВложенныйЗапрос
        ПО КомплектующиеНоменклатуры.Комплектующая = ВложенныйЗапрос.Номенклатура

СГРУППИРОВАТЬ ПО
    КомплектующиеНоменклатуры.Номенклатура,
    КомплектующиеНоменклатуры.Комплектующая,
    ЕСТЬNULL(ВложенныйЗапрос.Склад, ЗНАЧЕНИЕ(Справочник.Склады.ПустаяСсылка))
Volodimir19901,
14.10.14, 11:51 Улыбнуло
Цитата(mister-x @ 13.10.14, 17:34) *


Продолжение ( по версии Хичкока "Barsic's Horror Story ") :
линк
Ardi,
25.09.14, 11:00 Присвоить значение отбору
Вы пытаетесь присвоить реквизиту ссылочного типа (Контрагенты) значение типа Строка ("ДругаяФирма").
Так будет правильнее :
мДругаяФирма = Справочники.Контрагенты.НайтиПоНаименованию("ДругаяФирма");
Если ЗначениеЗаполнено(мДругаяФирма) тогда
  УниверсальныйОтчет.ДобавитьОтбор("Контрагент");
  УниверсальныйОтчет.ПостроительОтчета.Отбор.Контрагент.Значение= мДругаяФирма;
КонецЕсли;


mact,

4 страниц V  < 1 2 3 4 >
RSS Текстовая версия Сейчас: 26.11.20, 15:21
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!