Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Отбор списка справочника по табличной части элемента.
valleha
Отправлено: 14.04.16, 21:45


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


да уж...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #111480 · Ответов: 6 · Просмотров: 2507
 

>  Отбор списка справочника по табличной части элемента.
valleha
Отправлено: 14.04.16, 20:47


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Zaval @ Сегодня, 21:28 *,
Ув. Завал, спасибо за ответ. Но в моём вопросе также звучала просьба о помощи подсказать альтернативное решение данной задачи, если кто знает.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #111477 · Ответов: 6 · Просмотров: 2507
 

>  Отбор списка справочника по табличной части элемента.
valleha
Отправлено: 14.04.16, 19:41


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Дело в том, что мне трудно сформулировать саму задачу....
Хотя, действительно: "у элемента справочника А в ТЧ НЕ могут содержаться как строки, удовлетворяющие отбору, так и не удовлетворяющие".

Результат, который мне нужно (пример):
у элемента справочника
значения в ТЧ1:
-ЗНЧ1
-ЗНЧ2
значения в ТЧ2:
-знч1

и при выборе значений табличных полей на форме:
ТП1(ЗНЧ1, ЗНЧ2) и ТП2(знч1) = элемент справочника показан.
ТП1(ЗНЧ1, ЗНЧ2, ЗНЧ3) и ТП2(знч1) = элемент справочника скрыт.
ТП1(ЗНЧ1, ЗНЧ2) и ТП2() = элемент справочника показан.
ТП1(ЗНЧ2) и ТП2(знч1) = элемент справочника показан.

Пока данный функционал работает через задний проход:

//...........................
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
        
        СписокДляОтбора=Новый СписокЗначений;
        //Сообщить(ВыборкаДетальныеЗаписи.Количество());
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            СписокДляОтбора.Добавить(ВыборкаДетальныеЗаписи.Ссылка);
        КонецЦикла;
        
//////////////////////////////////////////////////////////////////////////////////////////
        Для Каждого СтрокаСферы Из СферыПримененияОтбор Цикл
            Счетчик = СписокДляОтбора.Количество() - 1;
            Пока Счетчик >= 0 Цикл
                ОбъектСпр=СписокДляОтбора[Счетчик].Значение.ПолучитьОбъект();
                Если ОбъектСпр.СферыПрименения.Найти(СтрокаСферы.Значение, "Сфера")=Неопределено Тогда
                    СписокДляОтбора.Удалить(Счетчик);
                КонецЕсли;
                Счетчик = Счетчик - 1;
            КонецЦикла;
        КонецЦикла;
        
        Для Каждого СтрокаХарактеристики Из ТоварХарактеристикаОтбор Цикл
            Счетчик = СписокДляОтбора.Количество() - 1;
            Пока Счетчик >= 0 Цикл
                ОбъектСпр=СписокДляОтбора[Счетчик].Значение.ПолучитьОбъект();
                Если ОбъектСпр.ХарактеристикаТовара.Найти(СтрокаХарактеристики.Значение, "Характеристика")=Неопределено Тогда
                    СписокДляОтбора.Удалить(Счетчик);
                КонецЕсли;
                Счетчик = Счетчик - 1;
            КонецЦикла;    
        КонецЦикла;        
        
////////////////////////////////////////////////////////////////////////////////////////////////
    
    
    
    
    СправочникСписок.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
    СправочникСписок.Отбор.Ссылка.Значение = СписокДляОтбора;
    СправочникСписок.Отбор.Ссылка.Использование = Истина;


вопрос открыт
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #111473 · Ответов: 6 · Просмотров: 2507
 

>  Отбор списка справочника по табличной части элемента.
valleha
Отправлено: 13.04.16, 19:58


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Платформа: 8.3
Приложение: управляемое
Конфигурация: самописная

Добрый день!
Помогите, пожалуйста, решить проблему.
Возникла проблема, при реализации отбора списка справочника по ТЧ элементов, используя несколько табличных полей на обычной форме списка.


Более-менее вышел на результат, используя следующий код:
Процедура ОтборСправочникСписок()

        //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
        // Данный фрагмент построен конструктором.
        // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
        
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    СистемыОкраски.Ссылка КАК Ссылка
        |ИЗ
        |    Справочник.СистемыОкраски КАК СистемыОкраски
        |ГДЕ
        |    СистемыОкраски.СферыПрименения.Сфера В(&Сфера)
        |    И СистемыОкраски.ХарактеристикаТовара.Характеристика В(&Характеристика)";
        
        Запрос.УстановитьПараметр("Сфера", СферыПримененияОтбор);                    //ТП на форме
        Запрос.УстановитьПараметр("Характеристика", ТоварХарактеристикаОтбор);     //ТП на форме
        
        РезультатЗапроса = Запрос.Выполнить();
        
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
        
        СписокДляОтбора=Новый СписокЗначений;
        //Сообщить(ВыборкаДетальныеЗаписи.Количество());
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            СписокДляОтбора.Добавить(ВыборкаДетальныеЗаписи.Ссылка);
        КонецЦикла;
        
        //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА        
    
    
    СправочникСписок.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
    СправочникСписок.Отбор.Ссылка.Значение = СписокДляОтбора;
    СправочникСписок.Отбор.Ссылка.Использование = Истина;

КонецПроцедуры




Но данный алгоритм:
-не удаляет из отбора элементы, в которых нет элемента списка из ТП ("Поры открытые" на скриншоте).
-при СферыПримененияОтбор.Количество()=0 и ТоварХарактеристикаОтбор.Количество()=0, удаляет из отбора все элементы и не отображает их в СправочникСписк.

Возможно есть способ попроще, натолкните на мысль, пожалуйста.

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #111428 · Ответов: 6 · Просмотров: 2507
 

>  Макет ПроверитьВывод(), НетуСилУже()
valleha
Отправлено: 03.02.16, 19:35


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Ув., форумчане!
Прошу помочь разобраться в следующем:
(конфигурация не типовая, приложение обычное)

-из обработки печатаю Каталог товаров: титульный лист с реквизитами компании и тело каталога (шапка - лого компании, подвал - служебная информация, контакты).
-титульный лист должен быть на всю страницу А4 (ТабДок.ВсеПоля=0), шапка и подвал должны присутствовать на каждой странице тела каталога (из-за нулевых полей колонтитулы отпадают, использую ПроверитьВывод() и вставляю подвал до разделителя, шапку - после него).

    ТабДок = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет ("КаталогТоваров1");

    //ТИТУЛЬНЫЙ ЛИСТ
    ОбластьТитул = Макет.ПолучитьОбласть("Титул");
    ОбластьТитул.Параметры.ТЕКСТЗАГ1=ВРег(СтрокаЗаглавия1);
    ОбластьТитул.Параметры.ТЕКСТЗАГ2=ВРег(СтрокаЗаглавия2);
    ОбластьТитул.Параметры.ТЕКСТЗАГ3=ВРег(СтрокаЗаглавия3);
    ОбластьТитул.Параметры.текстдоп1=НРег(СтрокаДоп1);
    ОбластьТитул.Параметры.текстдоп2=НРег(СтрокаДоп2);
    //ТИТУЛЬНЫЙ ЛИСТ

    //РАЗДЕЛИТЕЛИ
    ОбластьРазделительСТ = Макет.ПолучитьОбласть("РазделительСТ");
    ОбластьРазделитель_мини = Макет.ПолучитьОбласть("Разделитель_мини");
    //РАЗДЕЛИТЕЛИ

    ОбластьОснСтрШапка = Макет.ПолучитьОбласть("ОснСтрШапка"); //Шапка
    ОбластьОснСтрШапка.Параметры.АдресКомпании=Константы.АдресОрганизации.Получить()+Символы.ПС+"тел.: "+Константы.ТелефоныОрганизации.Получить();
    
    ОбластьОснСтрПодвал = Макет.ПолучитьОбласть("ОснСтрПодвал");
    ОбластьОснСтрПодвал.Параметры.ТекстКолонтитула="Телефон службы технической поддержки: 380 (хх) ххх-хх-хх."+Символы.ПС;
    
    
    
    ТабДок.Вывести(ОбластьТитул);                                   //ТИТУЛЬНЫЙ ЛИСТ
    ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
    НомерСтраницы=2;    
    
    //ТЕЛО КАТАЛОГА
    
    ТабДок.АвтоМасштаб = Истина;

//.......................................................................
//Код
//.......................................................................
        массивБлокаСтрок=Новый Массив;
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            массивБлокаСтрок.Очистить();
//....................................................................
            ОбластьОднаИзМногихОбластей = Макет.ПолучитьОбласть("ОднаИзМногихОбластей");
            ОбластьОднаИзМногихОбластей .Параметры.Наименование=ВыборкаДетальныеЗаписи.Ссылка.Наименование;            
            массивБлокаСтрок.Добавить(ОбластьОднаИзМногихОбластей );        //массивБлокаСтрок
//......................................................................


            массивБлокаСтрок.Добавить(ОбластьРазделительСТ);
            ОбластьОснСтрПодвал.Параметры.НомерСтраницы="= "+НомерСтраницы+" =";
            массивБлокаСтрок.Добавить(ОбластьОснСтрПодвал);
            
            Если НЕ ТабДок.ПроверитьВывод(массивБлокаСтрок) Тогда
                ТабДок.Вывести(ОбластьРазделительСТ);
                ТабДок.Вывести(ОбластьОснСтрПодвал);
                ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
                ТабДок.Вывести(ОбластьОснСтрШапка);
                НомерСтраницы=НомерСтраницы+1;
            Иначе
                ТабДок.Вывести(ОбластьРазделительСТ);
            КонецЕсли;

        КонецЦикла;


    ТабДок.Защита=Истина;
    Табдок.ПолеСлева=0;
    Табдок.ПолеСправа=0;
    Табдок.ПолеСверху=0;
    Табдок.ПолеСнизу=0;
    Табдок.АвтоМасштаб=Истина;
    Если ВПДФ=Ложь Тогда    
        ТабДок.ОтображатьСетку = Ложь;      
        ТабДок.ОтображатьЗаголовки = Ложь;
        
        ТабДок.Показать("Каталог Товаров для"+Контрагент);
        
    Иначе
        ВремФайл=ПолучитьИмяВременногоФайла("Каталог Товаров для"+Контрагент+" ("+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd")+").pdf");
        ТабДок.Записать(ВремФайл,ТипФайлаТабличногоДокумента.PDF);
        ЗапуститьПриложение(ВремФайл);
    КонецЕсли;




Вопрос 1.
ПроверитьВывод() всё отлично проверяет, НО: в случае, когда страница забивается под завязку и срабатывает автоматический разрыв страницы - ни подвал на предыдущей, ни шапка на следующей не появляются. Каким образом можно словить этот момент?

Вопрос 2.
Подвал: одна область, 2 строки. как его разместить в самом низу листа? перепробовал много чего, а в результате: то обе строки после данных о товаре, то первая в конце листа, вторая в начале следующего, плюс шапка пропадает.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #108011 · Ответов: 0 · Просмотров: 1361
 

>  Алгоритм вычисления возможных комбинаций цен из дерева значений
valleha
Отправлено: 22.11.15, 21:58


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Процедура Печать()
//...............
            ТЗ_Цен=Новый ТаблицаЗначений;
            ТЗ_Цен.Колонки.Добавить("СуммаКГВСмеси");
            ТЗ_Цен.Колонки.Добавить("Цена");
            РекурсияДереваКомпонентов(ДЗ_Компонентов, 0, ТЗ_Цен);
//...............
КонецПроцедуры
Процедура РекурсияДереваКомпонентов(ДЗ_Компонентов, ИндексВетки, ТЗ, СуммаЦен=0, СуммаКГ=0)
    КоличествоВеток=ДЗ_Компонентов.Строки.Количество();                             //Количество элементов верхнего уровня
    Для Каждого СтрокаВВетке Из ДЗ_Компонентов.Строки[ИндексВетки].Строки Цикл      //Перебор нижнего уровня в рамках одной ветки
        Сумма=СуммаЦен+СтрокаВВетке.Цена*СтрокаВВетке.Вес;                          //Суммируем значение цены
        КГ=СуммаКГ+СтрокаВВетке.Вес;
        Если КоличествоВеток-1=ИндексВетки Тогда                                    //Если добрались до последней ветки, тогда...
            Нов=ТЗ.Добавить();                                                      //...добавляем новую запись в таблицу значений
            Нов.Цена=Сумма;
            Нов.СуммаКГВСмеси=КГ;
        Иначе
            РекурсияДереваКомпонентов(ДЗ_Компонентов, ИндексВетки+1, ТЗ, Сумма, КГ);    //...иначе ныряем в следующую ветку с новой Суммой
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры



Всем спасибо за участие...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #105377 · Ответов: 2 · Просмотров: 1134
 

>  Алгоритм вычисления возможных комбинаций цен из дерева значений
valleha
Отправлено: 22.11.15, 0:13


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Добрый день. Прошу помощи, т.к. идеи уже иссякли.
Буду ёмким и кратким.

Платформа 8.3 (обычное приложение), конф-я самописная.

Есть заполненное дерево значений ДЗ_Компонентов.
1-й уровань:
  • колонка Наименование, содержит наименование товара из Каталога Номенклатуры.

2-й уровень (последний):
  • колонки:
    • 1 Наименование, содержит наименование товара из Номенклатуры (в отличии от Каталога Номенклатуры, содержит ещё и ведомости об упаковке).
    • 2 Вес в смеси, число.
    • 3 Объём в смеси, число.
    • 4 Цена в номенклатуры за 1 кг., число.
  • количество уровней: 2
  • количество строк в 1-м или 2-м уровнях неограничено


Пример дерева:
-ТОВАР1изКаталога
--[ТОВАР1 25 кг.] [Вес:100] [Объём:72] [Цена:200]
-ТОВАР2изКаталога
--[ТОВАР2 6 л.] [Вес:25] [Объём:30] [Цена:140]
--[ТОВАР2 12,5 л.] [Вес:25] [Объём:30] [Цена:130]
--[ТОВАР2 25 л.] [Вес:25] [Объём:30] [Цена:120]
-ТОВАР3изКаталога
--[ТОВАР2 12,5 л.] [Вес:40] [Объём:45] [Цена:230]

Вес в кг, объём в литрах. Для товара1 100кг=72л по цене 200 за кг.

Задача-минимум: перебрать дерево таким образом, чтобы на выходе получить Массив или таблицу значений со всеми возможными комбинациями цен за 1кг из которой можно будет вытянуть максимальное и минимальное значение цены.

Количество кг в смеси: 100+25+40=165

Пример варианотов цен из дерева:
200*100+140*25+230*40=32700 грн/за 165 кг
200*100+130*25+230*40=32450 грн/за 165 кг
200*100+120*25+230*40=32200 грн/за 165 кг


Возможные цены:
32700 /165=198,18 грн за 1 кг смеси
32450 /165=196,67 грн за 1 кг смеси
32200 /165=195,15 грн за 1 кг смеси

Мин: 195,15
Макс: 198,18
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #105350 · Ответов: 2 · Просмотров: 1134
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 14.08.15, 8:36


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Цитата(TipsyKID @ 14.08.15, 8:32) *
Реквизит у обработки должен быть ДокументОбъект.ЗаказПокупателя.


Как всё просто оказалось. У меня был выбран тип ДокументСсылка.
Спасибо огромное!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101984 · Ответов: 18 · Просмотров: 7081
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 13.08.15, 22:02


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


При вызове формы обработки:
Процедура КоманднаяПанель6СоздатьСмесь(Кнопка)
        ОбработкаКомплектацияСмеси = Обработки.КомплектацияСмеси.ПолучитьФорму("Форма", ЭтаФорма);
    ОбработкаКомплектацияСмеси.ЗакрыватьПриЗакрытииВладельца=Истина;
    ОбработкаКомплектацияСмеси.Наименование="Новая смесь";
    ОбработкаКомплектацияСмеси.Документ=ЭтотОбъект.Ссылка;
    ОбработкаКомплектацияСмеси.ПолучитьФорму().ОткрытьМодально();
КонецПроцедуры


Выполнение обработки:
Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если ПроверитьЗаполнение()=Ложь ИЛИ СмесьКТ.Количество()=0 Тогда
        Сообщить("Ошибка заполнения!");
        Возврат;
    ИначеЕсли Окр(СмесьНМНК.Итог("ПроцентВоВладельце")/СмесьКТ.Количество(), 2)=100 Тогда
        
               //Получение непонятно чего   ////////////////////////////////////////////////
                Объект = Документ.ПолучитьОбъект();
        Строка=Объект.ТЧ_СмесиКТ.Добавить();
        Строка.СмесьНМНК = Наименование;    
        
        Для Каждого СтрокаТаб из СмесьНМНК Цикл
            
            //заполнить ТЧ_Ёмкости
            
        КонецЦикла;
        /////////////////////////////////////////////////////////////////////////////////
    КонецЕсли;
    ЭтаФорма.Закрыть();    
КонецПроцедуры


В результате ничего!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101961 · Ответов: 18 · Просмотров: 7081
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 13.08.15, 19:39


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Цитата(TipsyKID @ 13.08.15, 9:45) *
3. В обработке "передзакрытием" ( или по любому другому обработчику) записываем в реквизит документ все что душа желает.

дело в том, что с этим пунктом у меня проблемы. мне стыдно, но туплю, простите.
Как обратиться к реквизитам объекта документа?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101959 · Ответов: 18 · Просмотров: 7081
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 13.08.15, 19:39


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101960 · Ответов: 18 · Просмотров: 7081
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 13.08.15, 8:21


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Цитата(TipsyKID @ 13.08.15, 7:56) *
Строчка которую закомментировали все решает :
//ОбработкаКомплектацияСмеси.Документ=ЭтотОбъект;



Выдаёт ошибку:
{Документ.ЗаказыПокупателей.Форма.ФормаДокумента.Форма(1017)}: Поле объекта не обнаружено (Документ)
    ОбработкаКомплектацияСмеси.Документ=ЭтотОбъект;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101931 · Ответов: 18 · Просмотров: 7081
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 12.08.15, 21:49


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Цитата(logist @ 12.08.15, 22:07) *
Имею ввиду, у документа создать произвольную форму, и разместить там необходимые данные Объекта для работы, тогда передавать данные между формами не нужно.

От этого варианта я отказался ещё на этапе планирования. Дело в том, что мне нужно вызвать одно окно для редактирования одной строки ТЧ_НаборыНоменклатуры и одной или более строк подчинённой ей ТЧ_СоставНаборовНоменклатуры. после этого обновить родительскую форму документа, добавив нужные строки.
Мне казалось, дело будет за парой строк кода инициализации формы документа и циклом вставки строк в ТЧ. А нет, судя по всему.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101907 · Ответов: 18 · Просмотров: 7081
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 12.08.15, 20:53


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Цитата(logist @ 12.08.15, 21:43) *
Тогда другой вопрос - почему это нельзя сделать при помощи дополнительных форм документа?

Вы имеете ввиду вместо обработки вызвать дополнительную форму документа или использовать дополнительную изначально?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101903 · Ответов: 18 · Просмотров: 7081
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 12.08.15, 19:36


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Цитата(Vofka @ 12.08.15, 19:04) *
Опишите подробнее как именно делаете.


Документ ЗаказПокупателя:
-ТЧ_НаборыНоменклатуры, (содержит ссылки на стандартные наборы из справочника и наборные в ручную)
-ТЧ_СоставНаборовНоменклатуры (содержит список входящих в набор материалов)

Связь между набором и его составом осуществляется через УникальныйИдентификатор, реквизит ТЧ "ИД".
Для того чтобы пользователь составил нестандартный набор, он вызывает обработку по кнопке СоздатьНабор;
    ОбработкаКомплектацияСмеси = Обработки.КомплектацияСмеси.ПолучитьФорму("Форма", ЭтаФорма);
    ОбработкаКомплектацияСмеси.ЗакрыватьПриЗакрытииВладельца=Истина;
    ОбработкаКомплектацияСмеси.Наименование="Новая смесь";
    //ОбработкаКомплектацияСмеси.Документ=ЭтотОбъект;
    ОбработкаКомплектацияСмеси.ПолучитьФорму().Открыть();

Далее в обработке в двух похожих табличных частях (как в документе) создаётся или редактируется набор и по кнопке выполнить необходимо заполнить данными этих ТЧ табличные части документа владельца. Совет и помощь мне нужны на этом этапе. Как в обработке поймать форму открытого документа и начинить его данными из обработки?

На вопрос "почему это нельзя сделать в документе сразу?";
-в обработке пользователь может настраивать смесь, пользуясь большим количеством данных: пропорции, плотности, единицы, цены, остатки и т.д.
-вторая табличная часть ТЧ_СоставНаборовНоменклатуры может содержать большое количество строк, а это затрудняет восприятие информации пользователем. Вероятность того, что пользователь ошибётся, нужно свести к нулю.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101898 · Ответов: 18 · Просмотров: 7081
 

>  Получить доступ к ТЧ документа из формы обработки.
valleha
Отправлено: 12.08.15, 16:54


Общительный
**

Группа: Пользователи
Сообщений: 16
Регистрация: 16.09.13
Пользователь №: 29856


Добрый день. Устал бороться с поисковиками. Прошу помощи специалистов!
Платформа 8.3 (обычное), конф-я самописная.

Суть вопроса.
Из документа вызывается форма обработки, в которой настраиваются данные для заполнения ТЧ документа. В обработку могу передать значения реквизитов, а назад, по кнопке выполнить, вернуть обработанные данные в табличную часть не получается. Идей ноль. Направьте хотя бы на верную сторону.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #101890 · Ответов: 18 · Просмотров: 7081
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 26.01.21, 17:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!