Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



17 страниц V   1 2 3 > » 

>  Не могу получить макет
denis84
Отправлено: 23.02.24, 9:23


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


alex_shkut @ Сегодня, 9:21 * ,
ТабДокумент = Новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178465 · Ответов: 9 · Просмотров: 225
 

>  Нумерация документов в зависимости от вида операции
denis84
Отправлено: 12.02.24, 20:01


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 18:21 * ,
Описать свой алгоритм. У меня например в 1с 7 была организована нумерация от номера склада.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #178394 · Ответов: 3 · Просмотров: 290
 

>  При нажатии на кнопку программно заполнить реквизит Формы
denis84
Отправлено: 12.02.24, 14:35


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


url_2l @ Сегодня, 14:31 * ,
Для "дякую" там є спеціальна кнопочка.
  Форум: Прочее 1С 7.7 · Просмотр сообщения: #178390 · Ответов: 3 · Просмотров: 230
 

>  При нажатии на кнопку программно заполнить реквизит Формы
denis84
Отправлено: 12.02.24, 13:42


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


url_2l @ Сегодня, 13:14 * ,
Доброго дня! Є такий приклад в моїй конфігурації. В документі списання на виробництво - при зміні реквизиту "підрозділ у шапці документу, заповнюємо підрозділ в рядках документу
    текОтвет = Вопрос("У документі змінено реквізит підрозділу. Заповнити підрозділ по рядкам документу?","Да+Нет");
    Если текОтвет = "Да" Тогда
        ВыбратьСтроки();
        Пока ПолучитьСтроку()=1 Цикл
            СтрУчасток = Подразделение;
        КонецЦикла;
    КонецЕсли;


//або ось так: якщо заповнено реквізит "разрешил" в документі "заказ", то ставимо "да" для "готов к получению"
    Если ПустоеЗначение(Разрешил)=0 Тогда
        ГотовКПолучению = Перечисление.ДаНет.Да;
    Иначе
        ГотовКПолучению = Перечисление.ДаНет.Нет;        
    КонецЕсли;
  Форум: Прочее 1С 7.7 · Просмотр сообщения: #178387 · Ответов: 3 · Просмотров: 230
 

>  Аптечний облік
denis84
Отправлено: 09.02.24, 15:02


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700



barokko23 @ Сегодня, 14:41 * ,

скачайте ще раз в мене з цим проблем не було - архів нормальний, а пароль в пункти 14 ПРАВИЛ
  Форум: Конфигурации · Просмотр сообщения: #178368 · Ответов: 7 · Просмотров: 3513
 

>  Как в форму выбора справочника передать параметр?
denis84
Отправлено: 09.02.24, 13:48


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 12:08 * ,
https://pro1c.org.ua/index.php?showtopic=4042
  Форум: Программирование в 1С Предприятие 8.1 (8.0) · Просмотр сообщения: #178366 · Ответов: 1 · Просмотров: 263
 

>  Аптечний облік
denis84
Отправлено: 09.02.24, 13:20


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


barokko23 @ Сегодня, 10:52 * ,
Це не до мене! Відкрию Вам секрет,це не я викладав файл!!! Я Вам тільки сказав де взяти пароль

І мене все чудово вдалося розархівувати. Перевірти розкладку клавіатури. пароль вводимо на англ.розкладці клавіатури
  Форум: Конфигурации · Просмотр сообщения: #178365 · Ответов: 7 · Просмотров: 3513
 

>  1Cv7.MD Неисправимая ошибка. Неправильный формат файла
denis84
Отправлено: 08.02.24, 16:49


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 16:08 * ,
а счета забалансового учета. Они есть даже в нашем плане счетов

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178354 · Ответов: 30 · Просмотров: 708
 

>  1Cv7.MD Неисправимая ошибка. Неправильный формат файла
denis84
Отправлено: 08.02.24, 15:08


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 13:13 * ,
Это белоруская конфигурация! Может у них есть такой план счетов?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178352 · Ответов: 30 · Просмотров: 708
 

>  Аптечний облік
denis84
Отправлено: 07.02.24, 13:24


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


barokko23 @ Сегодня, 11:38 * ,
пароль до архівів описаний в правилах форуму. Він однаковий для всіх архівів
  Форум: Конфигурации · Просмотр сообщения: #178341 · Ответов: 7 · Просмотров: 3513
 

>  1Cv7.MD Неисправимая ошибка. Неправильный формат файла
denis84
Отправлено: 06.02.24, 10:33


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Платформа 1с 7.70.027 должна у Вас быть. И попробуй из этого мд-файла в конфигураторе сделать: "загрузить измененную конфигурацию" в меню конфигурация - загрузить измененную конфигурацию. У Вас проблема для некоторых субконто (материалы и что-то еще) изменено "предсталение".

https://pro1c.org.ua/topic/1c-7-7-02770-70-...mp;p=29304&

https://pro1c.org.ua/index.php?showtopic=3953
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178334 · Ответов: 30 · Просмотров: 708
 

>  1Cv7.MD Неисправимая ошибка. Неправильный формат файла
denis84
Отправлено: 05.02.24, 20:03


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Dmitrij19631025 @ Вчера, 19:50 * ,
Цікаво, завтра гляну Вашу проблему
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178328 · Ответов: 30 · Просмотров: 708
 

>  Загрузка курсов валют НБУ для 1с 7.7
denis84
Отправлено: 04.02.24, 15:01


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


ArinaBuhgalter @ Сегодня, 13:40 * ,
В правилах форуму є. Цей пароль, для всіх архівів один.
  Форум: Отчеты / Обработки · Просмотр сообщения: #178316 · Ответов: 16 · Просмотров: 5197
 

>  УПП 1.3.82.1 какой релиз режима совместимости?
denis84
Отправлено: 02.02.24, 10:49


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kserg2012 @ Вчера, 14:47 * ,
Доброго дня! Користувався платформою 1С:Предприятие 8.3.13.1513, потім ставив 8.3.16.1148. Все наче було стабільно на різних конфігураціях. Але ніколи "не ганявся" за плаформами, поставив - працює все, що мені треба і ОК,
  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #178308 · Ответов: 7 · Просмотров: 288
 

>  Переименование номенклатуры для 1С 8.3 (внешняя обработка)
denis84
Отправлено: 30.01.24, 11:57


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Nevermore @ Вчера, 14:31 * ,
Тоже когда-то делал перевод. Добавлял реквизит "НаименованиеУкр" и в форме списка справочника (и с помощью обработки") записывал перевод "Наименование" в этот реквизит "НаименованиеУкр". Все делал в обычных формах.
  Форум: Прочее 1С 8 · Просмотр сообщения: #178283 · Ответов: 18 · Просмотров: 334
 

>  Как при проведении документа установить всремя документа в начало дня?
denis84
Отправлено: 30.01.24, 10:41


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 9:16 * ,
Добрый день, есть такая штука в 1с:
//это все делается при записи документа в модуле формы
АвтоВремяНачалоДня();

// а можно и так:

Процедура ПриЗаписи()
    Если Выбран() = 0 Тогда
        АвтоВремяОтключить();
        УстановитьВремя(08,0,0);
    КонецЕсли;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178274 · Ответов: 1 · Просмотров: 248
 

>  Чи можна в мою версію 1С додати ще одну компанію (ФОПа)
denis84
Отправлено: 09.01.24, 15:58


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


zanizdra_olga @ Сегодня, 15:42 * ,
В організаціях повинно бути. Меню "компиния" - "организации"


Заходимо в "Организации" і там створюємо нову, а в документах вибераємо ту яка Вам потрібна. Одна організація використовується, як основна

  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #178153 · Ответов: 5 · Просмотров: 357
 

>  Организовать запуск обработки по времени и после заверешения работы обработки отправить результат работы пользователю
denis84
Отправлено: 26.12.23, 8:43


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 7:27 * ,
Добрый день! Когда-то тоже хотел такое сделать: но наверное политики безопасности нашей корп.сети(или что то не так в самой обработке) не позволили мне это организовать. Для этого на форме обрабтки был список пользователь кому отправить текст сообщения. сам текст сообщения и кнопка отправить с такой процедурой:
//*******************************************
Процедура Отправить()
    Если ПустаяСтрока(ТекстСообщ)=1 Тогда
        Предупреждение("Введите текст сообщения !");
        Возврат;
    КонецЕсли;

    КвоМеток=0;
    Для ии=1 По спКомуОтправить.РазмерСписка() Цикл
        
        Если спКомуОтправить.Пометка(ии)=0 Тогда
            Продолжить;
        КонецЕсли;
        
        стрДобавить="";
        ИмяКомпКому=спКомуОтправить.ПолучитьЗначение(ии,стрДобавить);
        Если ПустаяСтрока(ИмяКомпКому)=1 Тогда
            Сообщить("В строке <"+стрДобавить+"> не заполнено имя компьютера !");
            Продолжить;
        КонецЕсли;
        
        КвоМеток=КвоМеток+1;
        
        КомандаСистемы("NET SEND "+СокрЛП(ИмяКомпКому)+ТекстСообщения);
    КонецЦикла;
    
    Если КвоМеток=0 Тогда
        Предупреждение("Не выбраны пользователи кому отправлять сообщение !");
    КонецЕсли;    
    
КонецПроцедуры


попробуйте отпишитесь по результату
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178044 · Ответов: 7 · Просмотров: 478
 

>  Обычные формы: повторно открыть форму отчета
denis84
Отправлено: 15.12.23, 11:32


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kserg2012 @ Сегодня, 11:01 * ,

а можливо "Предопределенная процедура в модуле формы "ПриПовторномОткрытии()""

//В модуле формы отчта процедура ПриПовторномОткрытии

Процедура ПриПовторномОткрытии()
   Активизировать();
КонецПроцедуры
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #178000 · Ответов: 4 · Просмотров: 275
 

>  Установка новой версии платформы 1С. Работоспособность базы.
denis84
Отправлено: 15.12.23, 10:51


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Talkman @ Сегодня, 10:41 * ,
ну я наче не зустрічав проблем. Що можу сказати треба діяти! Тільки так зможете щось виявити.
  Форум: Вся 1С · Просмотр сообщения: #177997 · Ответов: 3 · Просмотров: 215
 

>  Установка новой версии платформы 1С. Работоспособность базы.
denis84
Отправлено: 15.12.23, 10:32


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Talkman @ Сегодня, 10:08 * ,
Користуюся УТП, УПП на різних нових платформах. Нічого такого (помилок) не зустрічав. Головне, щоб підключені у всихкористувачів були однакові версії платформи.
  Форум: Вся 1С · Просмотр сообщения: #177995 · Ответов: 3 · Просмотров: 215
 

>  Создание нового элемента справочника
denis84
Отправлено: 06.12.23, 8:08


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 7:44 * ,
Доброго ранку! Через vpn відкрити посилання https://forum.infostart.ru/forum9/topic232203/

або тут https://forum.mista.ru/topic.php?id=749413, https://forum.mista.ru/topic.php?id=856738
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #177965 · Ответов: 1 · Просмотров: 184
 

>  Как скачать картинку по ссылке из Интернета?
denis84
Отправлено: 20.11.23, 11:52


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 11:20 * ,
Можна через VPN відкрити. Ось таке є тут:
https://pro1c.org.ua/topic/kak-zagruzit-kar...nklatura-67289/
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #177932 · Ответов: 4 · Просмотров: 350
 

>  Как скачать картинку по ссылке из Интернета?
denis84
Отправлено: 20.11.23, 11:18


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 10:23 * ,
https://forum.mista.ru/topic.php?id=868238
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #177930 · Ответов: 4 · Просмотров: 350
 

>  Как при загрузке из Книги Excel получить досту к нужному листу
denis84
Отправлено: 14.11.23, 16:33


Оратор
Иконка группы

Группа: Местный
Сообщений: 416
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 16:14 * ,
    Попытка
        Эксель = СоздатьОбъект("Excel.Application");
    Исключение
        Сообщить("Похоже, Excel на компьютере не установлен. Необходимо выполнить установку/переустановку Excel.","!");
        Возврат;
    КонецПопытки;
    
    Попытка
        Книга = Эксель.WorkBooks.Open(СокрЛП(ИмяФайла));
        Лист  = Книга.Worksheets(1);    
    Исключение
        Сообщить(описаниеОшибки());
        Возврат;
    КонецПопытки;    
    Строк = Лист.Cells.Rows.Count;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #177919 · Ответов: 2 · Просмотров: 431
 

17 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 01.03.24, 10:59
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!