Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



3 страниц V   1 2 3 >

>  Внешняя обработка и батник
Anderson
Отправлено: 26.11.20, 11:06


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


А зачем через батник? 1С сама может с фтп работать.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #168611 · Ответов: 7 · Просмотров: 236
 

>  Как прочитать и перебрать JSON
Anderson
Отправлено: 20.11.20, 23:31


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Vofka, Да и такое встречается.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168465 · Ответов: 25 · Просмотров: 718
 

>  Как прочитать и перебрать JSON
Anderson
Отправлено: 20.11.20, 9:34


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Petre, Судя по всему у автора проблемы с пониманием принципа работы с данными такого типа. Предоставил готовый вариант, который в одну строку распарсит его данные в удобный формат.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168452 · Ответов: 25 · Просмотров: 718
 

>  Связка Вин 2008 + SQL + 1C 7.7
Anderson
Отправлено: 20.11.20, 9:29


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Стояла у меня база на WIN2008, вот скуль не помню 2000 или 2008. Все отлично работало без танцев с длл.
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #168451 · Ответов: 4 · Просмотров: 288
 

>  Как прочитать и перебрать JSON
Anderson
Отправлено: 19.11.20, 14:29


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


А зачем изобретать велосипед. Спасибо человеку, все делается в одну строку. https://github.com/vbondarevsky/Connector
Результат = КоннекторHTTP.GetJson("http://httpbin.org/get");
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168424 · Ответов: 25 · Просмотров: 718
 

>  Слетает пароль и роли пользователя
Anderson
Отправлено: 30.07.20, 11:29


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Макс1С @ 01.07.20, 0:32 * ,
Так и делал. Удалял и создавал нового пользователя. Уже дошел до того, что после обмена приписываю роли, но они все равно слетают.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #165180 · Ответов: 12 · Просмотров: 4273
 

>  Поиск книги по конфигурации "Розница для Украины, редакция 2.0"
Anderson
Отправлено: 01.07.20, 9:25


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


sava1 @ 23.09.15, 11:29 * ,
Можо и мне скинуть?
  Форум: Литература, ссылки на полезные ресурсы · Просмотр сообщения: #164331 · Ответов: 5 · Просмотров: 2284
 

>  Слетает пароль и роли пользователя
Anderson
Отправлено: 26.06.20, 21:53


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


bestnamebest @ 07.10.16, 16:11 * ,
Добрый день. Подскажите проблему как-то решили.
Розница 2.0, РИБ, на некоторых магазинах слетают права, а на некоторых нет.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #164243 · Ответов: 12 · Просмотров: 4273
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 27.05.20, 18:11


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Цитата(Petre @ 27.05.20, 12:52) *
Кодировка закладывается в обработке формата.

Да, но иногда то ли банк, то ли на разных машинах кодировки разные и одну и ту же выгрузку получают в разных кодировках и приходится править обработку формата.
Было бы удобно выбирать кодировку в главной обработке и получать ее в параметрах обработки формата.
  Форум: Отчеты / Обработки · Просмотр сообщения: #163384 · Ответов: 355 · Просмотров: 63864
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 27.05.20, 11:30


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Добрый день. Можно добавить в новом релизе возможность выбора кодировки файла?
  Форум: Отчеты / Обработки · Просмотр сообщения: #163372 · Ответов: 355 · Просмотров: 63864
 

>  Ocvita Barcode запуск на сервере
Anderson
Отправлено: 15.04.20, 14:55


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Цитата(Vofka @ 09.04.20, 13:05) *
Почему вы так решили? тыц

Тут пишется. Они его в прошлом году даже отключили. Но топом судя по всему опять включили, раз еще работает.
А приходилось в авральном режиме переписывать формирование кодов.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #162245 · Ответов: 32 · Просмотров: 1415
 

>  Ocvita Barcode запуск на сервере
Anderson
Отправлено: 09.04.20, 12:28


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Цитата(Vofka @ 05.04.20, 10:45) *
Вот, например от Гугла

Гугл уже прекратил доступ к этой функции.


Цитата(cao0603 @ 06.04.20, 13:40) *
помогите пожалуйста кодом

Вот ленивый народ. Говорят же в БСП есть, нет разжуйте положите.
компонента
Код
//--печать qr через компоненету 1С
// Возвращает двоичные данные для формирования QR кода.
//
// Параметры:
//  QRСтрока         - Строка - данные, которые необходимо разместить в QR-коде.
//
//  УровеньКоррекции - Число - уровень погрешности изображения при котором данный QR-код все еще возможно 100%
//                             распознать.
//                     Параметр должен иметь тип целого и принимать одно из 4 допустимых значений:
//                     0(7% погрешности), 1(15% погрешности), 2(25% погрешности), 3(35% погрешности).
//
//  Размер           - Число - определяет длину стороны выходного изображения в пикселях.
//                     Если минимально возможный размер изображения больше этого параметра - код сформирован не будет.
//
// Возвращаемое значение:
//  ДвоичныеДанные  - буфер, содержащий байты PNG-изображения QR-кода.
//
// Пример:
//  
//  // Выводим на печать QR-код, содержащий в себе информацию зашифрованную по УФЭБС.
//
//  QRСтрока = УправлениеПечатью.ФорматнаяСтрокаУФЭБС(РеквизитыПлатежа);
//  ТекстОшибки = "";
//  ДанныеQRКода = УправлениеПечатью.ДанныеQRКода(QRСтрока, 0, 190, ТекстОшибки);
//  Если Не ПустаяСтрока(ТекстОшибки)
//      ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки);
//  КонецЕсли;
//
//  КартинкаQRКода = Новый Картинка(ДанныеQRКода);
//  ОбластьМакета.Рисунки.QRКод.Картинка = КартинкаQRКода;
//
Функция ДанныеQRКода(QRСтрока, УровеньКоррекции, Размер) Экспорт
    
    Отказ = Ложь;
    ИмяВременногоФайла = ПолучитьИмяВременногоФайла("png");
    ГенераторQRКода = КомпонентаФормированияQRКода(Отказ);
    Если Отказ Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    Попытка
        ДвоичныеДанныеКартинки = ГенераторQRКода.GenerateQRCode(QRСтрока, УровеньКоррекции, Размер);
    Исключение
        ЗаписьЖурналаРегистрации(НСтр("ru='Формирование QR-кода';uk='Формування QR-коду'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка, , , ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
    КонецПопытки;

    
    Возврат ДвоичныеДанныеКартинки;
КонецФункции

Функция КомпонентаФормированияQRКода(Отказ)
    
    ТекстОшибки = НСтр("ru='Не удалось подключить внешнюю компоненту для генерации QR-кода. Подробности в журнале регистрации.';uk='Не вдалося підключити зовнішню компоненту для генерації QR -кода. Подробиці в журналі реєстрації.'");
    
    QRCodeGenerator = ОбщегоНазначения.ПодключитьКомпонентуИзМакета("QRCodeExtension", "ОбщийМакет.КомпонентаПечатиQRКода");
        
    Если QRCodeGenerator = Неопределено Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки,,,, Отказ);
    КонецЕсли;
    
    Возврат QRCodeGenerator;
    
КонецФункции

Процедура СформироватьQRАртикула(ТабДок,СтрокаШК,Параметры)
    Макет = ПолучитьОбщийМакет("ЭтикеткаQR");
    Область = Макет.ПолучитьОбласть("ШКАртикула|Первый");
    Рисунок = Область.Область("КартинкаQRАртикула");
    Рисунок.Картинка = Новый Картинка(ПечатьШК.ДанныеQRКода(СтрокаШК,1,82));
    ТабДок.Вывести(Область);
КонецПроцедуры // СформироватьQR()
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #162083 · Ответов: 32 · Просмотров: 1415
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 23.03.20, 19:47


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Petre @ Сегодня, 18:11 * ,
а как его можно получить. укргаз в выписки до сих пор пишет старые счета

Anderson @ Сегодня, 18:58 * ,
Решил. отбой
  Форум: Отчеты / Обработки · Просмотр сообщения: #161561 · Ответов: 355 · Просмотров: 63864
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 23.03.20, 18:08


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Petre, Добрый день. Подскажите есть ли в параметрах передаваемых в шаблон обработки старый счет?
  Форум: Отчеты / Обработки · Просмотр сообщения: #161559 · Ответов: 355 · Просмотров: 63864
 

>  Как скопировать данные из одного реквизита справочника в другой
Anderson
Отправлено: 26.12.19, 16:33


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


lolmatrix @ Сегодня, 12:20 * ,
Цитата(lolmatrix @ 26.12.19, 12:20) *
сделал так:
    выборка =Справочники.Должности.Выбрать();
    Пока выборка.Следующий() Цикл
    ЗаполняемыйОбъект =выборка.ПолучитьОбъект();        
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ОКПДТР.Наименование КАК Наименование,
        |    ОКПДТР.КОДОКПДТР КАК КОДОКПДТР
        |ИЗ
        |    Справочник.ОКПДТР КАК ОКПДТР
        |ГДЕ
        |    ОКПДТР.Наименование = &Наименование";
    
    Запрос.УстановитьПараметр("Наименование", выборка.Наименование);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
     ЗаполняемыйОбъект.ОКПДТРКод = ВыборкаДетальныеЗаписи.КОДОКПДТР;
     ЗаполняемыйОбъект.Записать();
     Сообщить("Заполнен:"+" "+ЗаполняемыйОбъект.Ссылка+"Код:"+ВыборкаДетальныеЗаписи.КОДОКПДТР);
    КонецЦикла;
КонецЦикла;

Больше так не делай. Цикл в цикле очень плохой подход. Если запросом, то учи соединения. А если просто, то выведи нужный справочник в таблицу и воспользуйся универсальной обработкой загрузки табличных документов.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158912 · Ответов: 14 · Просмотров: 916
 

>  Чековый принтер для 1с 8.3 ут 3.0
Anderson
Отправлено: 19.12.19, 16:31


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Ruslanzpua @ Сегодня, 0:19 * ,
Вам в раздел заказов.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #158705 · Ответов: 1 · Просмотров: 491
 

>  Создание ОперацияБух
Anderson
Отправлено: 30.04.19, 11:50


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Irzik @ Вчера, 14:17 * ,
А точнее можно вопрос описать. С какой конфигурации, с помощью какой конвертации переносите?
  Форум: Конфигурация "1С:Конвертация данных" · Просмотр сообщения: #151871 · Ответов: 6 · Просмотров: 1283
 

>  Обробка "Завантаження курсів валют НБУ" для БУ 2.0
Anderson
Отправлено: 03.04.19, 16:30


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


В Бух 2.0 и УНФ работает. Спасибо.
  Форум: Отчеты / Обработки · Просмотр сообщения: #151196 · Ответов: 12 · Просмотров: 3357
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 04.03.19, 14:40


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


С ДБФ все работает нормально, кроме вышеописанного бага.
Почему-то он упорно не хочет открываться через временные файлы, а когда напрямую обращаться к файлу все нормально.
     
                 //ТмчНазваФайлу = ПолучитьИмяВременногоФайла("dbf");
        //ДаніВиписки = ПолучитьИзВременногоХранилища(ПотЕлемент.АдресаСховищаВиписки);
        //ДаніВиписки.Записать(ТмчНазваФайлу);
        //Файли.Добавить(ТмчНазваФайлу);
        
        
        ФайлВиписки    = Новый XBase;
        Попытка
            //ФайлВиписки.ОткрытьФайл(ТмчНазваФайлу,,Истина);
            ФайлВиписки.ОткрытьФайл(ПотЕлемент.НазваФайлуВиписки,,Истина);
        Исключение
            Результат.Попередження.Добавить(НСтр("ru = 'Помилка читання файлу виписки'; uk = 'Помилка читання файлу виписки'") + " """ + ПотЕлемент.НазваФайлуВиписки + """");
            Продолжить;
        КонецПопытки;


ДБФ Укргаз, Пивденный, ОТР
Прикрепленный файл  ____________________________DBF.zip ( 3.95 килобайт ) Кол-во скачиваний: 251
  Форум: Отчеты / Обработки · Просмотр сообщения: #150372 · Ответов: 355 · Просмотров: 63864
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 02.03.19, 0:20


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Нашел небольшой баг. При обработке формата дбф. Если параметр обработки "Дата платежа" установить в диапазон дат не входящих в выписку, то зависает вся база напрочь. Например дата платежа установить на март, а в выписке данные только за февраль.
  Форум: Отчеты / Обработки · Просмотр сообщения: #150303 · Ответов: 355 · Просмотров: 63864
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 06.07.18, 9:21


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Petre @ Вчера, 17:28 * ,
CSV нашел ошибку и все работат. Спасибо!
DBF на хочет открывать файл - Помилка читання файлу виписки "D:\extract.dbf"
  Форум: Отчеты / Обработки · Просмотр сообщения: #143177 · Ответов: 355 · Просмотров: 63864
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 05.07.18, 15:47


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Petre @ Сегодня, 16:32 * ,
Сначала изменил Шаблонную под dbf, теперь взял за основу ОбмінЗБанком_ОбробкаФормату_iBank2 3.1.epf и подправил порядок строк. Результат одинаковый. Банк УкрГаз.
До этого делал под ОТР и все работало.
  Форум: Отчеты / Обработки · Просмотр сообщения: #143172 · Ответов: 355 · Просмотров: 63864
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 05.07.18, 15:28


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Irzik @ Сегодня, 15:53 * ,
D:\123.dbf - Помилка файлу обробки формату
  Форум: Отчеты / Обработки · Просмотр сообщения: #143170 · Ответов: 355 · Просмотров: 63864
 

>  Обробка "Обмін з банком" для БУ 2.0
Anderson
Отправлено: 05.07.18, 14:28


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Почему-то не хочет читать файлы. Ни dbf, ни csv.
Помилка читання файлу виписки "D:\extract_25.06.2018_03.07.2018.dbf" или Помилка файлу обробки формату
Версия обработки 3.6, конфигурация Бухгалтерия 2.0.9.2, 1С 8.3.11.2867
  Форум: Отчеты / Обработки · Просмотр сообщения: #143167 · Ответов: 355 · Просмотров: 63864
 

>  Загрузка курсов валют в конфигуации 7.7, 8.1
Anderson
Отправлено: 05.05.17, 22:14


Говорящий
***

Группа: Пользователи
Сообщений: 65
Регистрация: 07.11.09
Из: Одесса
Пользователь №: 2017


Бух 1.2.41.1 Работает. Спасибо.
  Форум: Наши сервисы · Просмотр сообщения: #126449 · Ответов: 264 · Просмотров: 196021
 

3 страниц V   1 2 3 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 11.04.21, 17:00
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!