Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Запрос с флагом выбора          
Oksana35 Подменю пользователя
сообщение 22.05.24, 10:37
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день. Первый раз столкнулась с запросами в 1С 7.7. Помогите пожалуйста с кодом. На форме есть 3 флага выбора: ДокументыРБ, ДокументыЗагран и ДокументыТрансп.
Как при нажатии на определенный флаг выводить документ?
У меня есть запрос только для вывода всех документов сразу.


Процедура Сформировать()

Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)    
|Период с ДатаС по ДатаПо;
|ОбрабатыватьДокументы все;

|Док = Документ.КомандировкиРБ.ТекущийДокумент,
|      Документ.КомандировкиЗагран.ТекущийДокумент,
|      Документ.КомандировкиТрансп.ТекущийДокумент;
|
|ДатаРег = Документ.КомандировкиРБ.ДатаРегКомандир,  
|          Документ.КомандировкиЗагран.ДатаРегКомандир,  
|          Документ.КомандировкиТрансп.ДатаРегКомандир;
|
|ФИО = Документ.КомандировкиРБ.ФИО,
|      Документ.КомандировкиЗагран.ФИО,
|      Документ.КомандировкиТрансп.ФИО;
|
|Табельный = Документ.КомандировкиРБ.Табельный,
|            Документ.КомандировкиЗагран.Табельный,
|            Документ.КомандировкиТрансп.Табельный;
|
|Должность = Документ.КомандировкиРБ.Профессия,
|            Документ.КомандировкиЗагран.Профессия,
|            Документ.КомандировкиТрансп.Профессия;
|
|Страны = Документ.КомандировкиРБ.КодСтраны,
|         Документ.КомандировкиЗагран.КодСтраны,
|         Документ.КомандировкиТрансп.КодСтраны;
|
|Город = Документ.КомандировкиРБ.КодГорода,
|        Документ.КомандировкиЗагран.КодГорода,
|        Документ.КомандировкиТрансп.КодГорода;
|
|ГруппаЦелей = Документ.КомандировкиРБ.ГруппаЦелей,
|              Документ.КомандировкиЗагран.ГруппаЦелей,
|              Документ.КомандировкиТрансп.ГруппаЦелей;
|
|Цель = Документ.КомандировкиРБ.Цели,
|       Документ.КомандировкиЗагран.Цели,
|       Документ.КомандировкиТрансп.Цели;
|
|Начало = Документ.КомандировкиРБ.ДатаНачКомандир,
|         Документ.КомандировкиЗагран.ДатаНачКомандир,
|         Документ.КомандировкиТрансп.ДатаНачКомандир;
|
|Конец = Документ.КомандировкиРБ.ДатаКонКомандир,
|        Документ.КомандировкиЗагран.ДатаКонКомандир,
|        Документ.КомандировкиТрансп.ДатаКонКомандир;
|
|ДатаДок = Документ.КомандировкиРБ.ДатаДок,
|          Документ.КомандировкиЗагран.ДатаДок,
|          Документ.КомандировкиТрансп.ДатаДок;
|
|Группировка Док все;
|"//}}ЗАПРОС
;    

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ПовторятьПриПечатиСтроки(3,3);
    Таб.ВывестиСекцию("Заголовок");
    Таб.ВывестиСекцию("Шапка");
    
    
    Пока Запрос.Группировка() = 1 Цикл
        Таб.ВывестиСекцию("Строчка");
    КонецЦикла;


Таб.Показать();
КонецПроцедуры

volodya1122 Подменю пользователя
сообщение 22.05.24, 11:48
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 343
Из: Тернопіль
Спасибо сказали: 138 раз
Рейтинг: 140.7

Oksana35 @ Сегодня, 11:37 * ,

Не перевіряв. З типової варіант

Сам список документів сформуйте по условию флажков

    Докум = "
    |""КомандировкиРБ"",
    |""КомандировкиЗагран"",
    |""КомандировкиТрансп"",
    |";
  
    спДокум = СоздатьОбъект("СписокЗначений");
    спДокум.ИзСтрокиСРазделителями(Докум);


// сам запрос


|Группировка Док все;
|Условие(Документ.Вид() в спДокум);


Сообщение отредактировал volodya1122 - 22.05.24, 11:50

Спасибо сказали: Oksana35,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.06.24, 8:54
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!