Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Встановлення картинки в ТЧ програмно          
Inkognito Подменю пользователя
сообщение 22.02.24, 14:58
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 939
Из: Україна
Спасибо сказали: 446 раз
Рейтинг: 13.5

Бухгалтерія 2.1 на "Керованих формах". Таблична частина, зовнішня обробка.
Необхідно проаналізувати статус документу по коду, і в табличній частині вивести картинку.
Додано реквізит "Картинка", числовий, 1.
На формі "Вид" = "Поле картинки". Пусте, з прив*язкою до реквізиту.
Код відпрацьовує, але картинки для різних статусів не відображуються.

Для Каждого Стр из Объект.ТЧДокументи Цикл
Код = Стр.КодСтатуса;
    Если Код = "1" Тогда
        Стр.Картинка = БиблиотекаКартинок.ОформлениеФлагКрасный;
    ИначеЕсли Код ="2" Тогда
        Стр.Картинка = БиблиотекаКартинок.ОформлениеФлагЗеленый;
    Иначе
        Стр.Картинка = БиблиотекаКартинок.ОформлениеФлагЖелтый;
    КонецЕсли;
КонецЦикла;

AnryMc Подменю пользователя
сообщение 22.02.24, 15:08
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 328
Спасибо сказали: 96 раз
Рейтинг: 97.6

Цитата(Inkognito @ 22.02.24, 15:58) *
Додано реквізит "Картинка", числовий, 1.


Стр.Картинка Колонка (реквизит) табличной части "Картинка" должен быть с Тип'ом "Картинка"

Сообщение отредактировал AnryMc - 22.02.24, 15:11

Inkognito Подменю пользователя
сообщение 22.02.24, 15:24
Сообщение #3

Ветеран
*******
Группа: Пользователи
Сообщений: 939
Из: Україна
Спасибо сказали: 446 раз
Рейтинг: 13.5

Так і є. Вид "Поле картинки". Картинка значений - пусто.
Реквізит табличної частини - число, 1. Типу "Картинка" немає в переліку типів.

mvo2008 Подменю пользователя
сообщение 22.02.24, 15:35
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 39
Из: г. Черкасcы
Спасибо сказали: 11 раз
Рейтинг: 6.3

Я робив так
https://ibb.co/CPMjv6h

Inkognito Подменю пользователя
сообщение 22.02.24, 15:40
Сообщение #5

Ветеран
*******
Группа: Пользователи
Сообщений: 939
Из: Україна
Спасибо сказали: 446 раз
Рейтинг: 13.5

Так, якщо колекція картинок, працює. А якщо це різні картинки?

AnryMc Подменю пользователя
сообщение 22.02.24, 17:20
Сообщение #6

Оратор
Иконка группы
Группа: Местный
Сообщений: 328
Спасибо сказали: 96 раз
Рейтинг: 97.6

Мой рабочий код (внешняя обработка)
ТипыМетаданных - реквизит формы - таблица значений
Картинка - Реквизит ТЗ ТипыМетаданных - тип картинка
На форма для реквизита Картинка (колонка) -Вид: Поле картинки

&НаСервере
Процедура ЗаполнитьТипыМетаданных()

       //****

    ДобавитьТипМД(НСтр("ru = 'Метаданные'; uk = 'Метадані'"), "Метаданные", "Метаданные", БиблиотекаКартинок.ВнешнийИсточникДанных);
    ДобавитьТипМД(НСтр("ru = 'Константы'; uk = 'Константи'"), "Константы", "Константа", БиблиотекаКартинок.Константа);
    ДобавитьТипМД(НСтр("ru = 'Справочники'; uk = 'Довідники'"), "Справочники", "Справочник", БиблиотекаКартинок.Справочник);
    ДобавитьТипМД(НСтр("ru = 'Документы'; uk = 'Документи'"), "Документы", "Документ", БиблиотекаКартинок.Документ);    
    ДобавитьТипМД(НСтр("ru = 'Журналы документов'; uk = 'Журнали документів'"), "ЖурналыДокументов", "ЖурналДокументов", БиблиотекаКартинок.ЖурналДокументов);    
    ДобавитьТипМД(НСтр("ru = 'Отчеты'; uk = 'Звіти'"), "Отчеты", "Отчет", БиблиотекаКартинок.Отчет);
    ДобавитьТипМД(НСтр("ru = 'Обработки'; uk = 'Обробки'"), "Обработки", "Обработка", БиблиотекаКартинок.Обработка);
    ДобавитьТипМД(НСтр("ru = 'Планы видов характеристик'; uk = 'Плани видів характеристик'"), "ПланыВидовХарактеристик", "ПланВидовХарактеристик", БиблиотекаКартинок.ПланВидовХарактеристик);
    ДобавитьТипМД(НСтр("ru = 'Планы счетов'; uk = 'Плани рахунків'"), "ПланыСчетов", "ПланСчетов", БиблиотекаКартинок.ПланСчетов);
    ДобавитьТипМД(НСтр("ru = 'Планы видов расчета'; uk = 'Плани видів розрахунку'"), "ПланыВидовРасчета", "ПланВидовРасчета", БиблиотекаКартинок.ПланВидовРасчета);    
    ДобавитьТипМД(НСтр("ru = 'Регистры сведений'; uk = 'Регістри відомостей'"), "РегистрыСведений", "РегистрСведений", БиблиотекаКартинок.РегистрСведений);
    ДобавитьТипМД(НСтр("ru = 'Регистры накопления'; uk = 'Регістри накопичення'"), "РегистрыНакопления", "РегистрНакопления", БиблиотекаКартинок.РегистрНакопления);
    ДобавитьТипМД(НСтр("ru = 'Регистры бухгалтерии'; uk = 'Регістри бухгалтерії'"), "РегистрыБухгалтерии", "РегистрБухгалтерии", БиблиотекаКартинок.РегистрБухгалтерии);
    ДобавитьТипМД(НСтр("ru = 'Регистры расчета'; uk = 'Регістри розрахунку'"), "РегистрыРасчета", "РегистрРасчета", БиблиотекаКартинок.РегистрРасчета);
    ДобавитьТипМД(НСтр("ru = 'Бизнес процессы'; uk = 'Бізнес процеси'"), "БизнесПроцессы", "БизнесПроцесс", БиблиотекаКартинок.БизнесПроцесс);    
    ДобавитьТипМД(НСтр("ru = 'Задачи'; uk = 'Завдання'"), "Задачи", "Задача", БиблиотекаКартинок.Задача);
    ДобавитьТипМД(НСтр("ru = 'Планы обмена'; uk = 'Плани обміну'"), "ПланыОбмена", "ПланОбмена", БиблиотекаКартинок.ПланОбмена);

       //*****

&НаСервере
Процедура ДобавитьТипМД(текИмя, СистИмя, Имя1, текКартинка)
    
    //***
    
    нс = ТипыМетаданных.Добавить();
    
    нс.Картинка = текКартинка;
    нс.ИмяТипа = СистИмя;
    нс.ИмяТипа1 = Имя1;
    нс.ОтображаемоеИмя = текИмя;
    
        //*******
    
КонецПроцедуры


Сообщение отредактировал AnryMc - 22.02.24, 17:22

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 13.04.24, 9:19
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!