Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> управление текстом програмно          
4andriy Подменю пользователя
сообщение 16.09.23, 13:26
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

в конфигураторе можно изменять размер и цвет шрифта
нужно менять без конфигуратора сразу на форме, например кнопкой

AnryMc Подменю пользователя
сообщение 18.09.23, 10:00
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 373
Спасибо сказали: 102 раз
Рейтинг: 103.6

4andriy @ 16.09.23, 14:26 * ,

https://pro1c.org.ua/index.php?showtopic=5960


FormEx версия 2.0.5.91

...
Средства доступа и изменения свойств для любых реквизитов формы
...

4andriy Подменю пользователя
сообщение 18.09.23, 10:24
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

AnryMc @ Сегодня, 11:00 * ,
форму умею, я хочу что-бы текст типа "Акт" или "Счет" вверху формы документа можно было раскрашивать вручную без перехода в конфигуратор

4andriy @ Сегодня, 11:11 * ,
на форме элемента

volodya1122 Подменю пользователя
сообщение 18.09.23, 13:43
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 344
Из: Тернопіль
Спасибо сказали: 138 раз
Рейтинг: 140.7

Цитата(4andriy @ 18.09.23, 10:24) *
на форме элемента

1. Поясните что имеется в виду. Форма документа в 1С, где заполняются данные. Или печатная форма - которая выводится на печать?
2. И каков сакральный смысл в этом?

4andriy Подменю пользователя
сообщение 18.09.23, 14:56
Сообщение #5

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

volodya1122 @ Сегодня, 14:43 * ,
журнал документов - новая строка - выбор документа - например СЧЕТ - дальше открывается сам счет. нужно что-бы если в документе есть ошибка слово "СЧЕТ" был написан красным до распечатывания. в идеале хочу запрограмировать что-бы он светился) хочу добавить в 1с немного визуального оформления. ничего по функционалу - только красота.

volodya1122 Подменю пользователя
сообщение 19.09.23, 15:54
Сообщение #6

Оратор
Иконка группы
Группа: Местный
Сообщений: 344
Из: Тернопіль
Спасибо сказали: 138 раз
Рейтинг: 140.7

4andriy @ Вчера, 14:56 * ,
Можно раскрасить табличную часть журнала документов. Например так. Формексом

Функция КолонкаТекстВТабличнойЧастиЖурнала()       
    ЦветПроба=Число(НомерДок);
    Возврат "BRUSH["+(ЦветПроба*1450)+"] "+"COUNT["+2+"]";;

    // FONT[<Цвет>] - задает цвет шрифта строки;
    // BRUSH[<Цвет>] - задает цвет фона строки;
    // FONT_S[<Цвет>] - задает цвет шрифта строки, если она является текущей (не влияет на текущую ячейку);
    // BRUSH_S[<Цвет>] - задает цвет фона строки, если она является текущей (не влияет на текущую ячейку);
    // COUNT[<КоличествоКолонок>] - задает количество колонок, на которые распространяется раскраска;
    // INDENT[<Отступ>] - задает количество колонок, которое необходимо пропустить перед началом раскраски;
    // FONTSET[<КодШрифта>] - задает шрифт строки;
    // FONTSET_S[<КодШрифта>] - задает шрифт строки, если она является текущей;

КонецФункции


Процедура ПослеОткрытия()  
    ФормаРасш = СоздатьОбъект("РасширениеФормы");
    ФормаРасш.УстановитьФорму(Форма);  
    ФормаРасш.Максимизирована = 1;    
    Сервис = СоздатьОбъект("Сервис");
    Сервис.ВключитьРаскраскуТаблиц();
КонецПроцедуры


Насчет слова "Счет" на самой форме документа. Можно сделать несколько вариантов надписи в разных цветах, и по условию показывать нужное.

4andriy Подменю пользователя
сообщение 22.09.23, 17:36
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

volodya1122 @ 19.09.23, 16:54 * ,
Насчет слова "Счет" на самой форме документа. Можно сделать несколько вариантов надписи в разных цветах, и по условию показывать нужное.

а как показывать на форме и скрывать по условию?

volodya1122 Подменю пользователя
сообщение 24.09.23, 14:24
Сообщение #8

Оратор
Иконка группы
Группа: Местный
Сообщений: 344
Из: Тернопіль
Спасибо сказали: 138 раз
Рейтинг: 140.7

4andriy @ 22.09.23, 17:36 * ,

Очень просто:

Если Условие1 тогда
Форма.Дата1.видимость(0);
Форма.ТекстНаФорме.видимость(0);
Форма.ТекстНаФорме1.видимость(1);
ИначеЕсли Условие2 тогда
Форма.Дата1.видимость(1);
Форма.ТекстНаФорме.видимость(0);
Форма.ТекстНаФорме1.видимость(1);
ИначеЕсли Условие3 тогда
Форма.Дата1.видимость(1);
Форма.ТекстНаФорме.видимость(1);
Форма.ТекстНаФорме1.видимость(0);
Иначе
Форма.Дата1.видимость(0);
Форма.ТекстНаФорме.видимость(1);
Форма.ТекстНаФорме1.видимость(0);
КонецЕсли


Сообщение отредактировал volodya1122 - 24.09.23, 14:26

Спасибо сказали: 4andriy,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 13.07.24, 17:20
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!