Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Текст на картинке в макете отчета          
bereznoy Подменю пользователя
сообщение 06.01.13, 2:18
Сообщение #1

Оратор
*****
Группа: Пользователи
Сообщений: 329
Из: Simferopol
Спасибо сказали: 9 раз
Рейтинг: 0

сделал прайс-лист с фотографиями, было б неплохо наложить на фото номер кода или артикула, есть ли в 1с 8.2 такая возможность?
Код в котором я получаю изображение
            ОбластьНоменклатура = Макет.ПолучитьОбласть("Номенклатура");
            Изображение = Выборка.Номенклатура.ОсновноеИзображение.Хранилище.Получить();
        Если НЕ Изображение = Неопределено Тогда
         Рисунок = ОбластьНоменклатура.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
Рисунок.Верх = 3;
Рисунок.Высота =70;
Рисунок.Ширина = 90;
Рисунок.Лево = 3.5;

Рисунок.РазмерКартинки = РазмерКартинки.Растянуть;//.Пропорционально;

Рисунок.Картинка = Изображение;
КонецЕсли;


Signature
Ковыряю 1С 8.2.14.528 конфигурация УТП ред. 1.2.1.3
1С 8.3 (8.3.1.531) конфиг УТ 2.3.16.1
1С 7.7 Торговля+Склад

Ardi Подменю пользователя
сообщение 06.01.13, 4:20
Сообщение #2

Живет на форуме
***********
Гений телепатии и социального моделирования
Группа: Пользователи
Сообщений: 4121
Из: Киев
Спасибо сказали: 956 раз
Рейтинг: 0

Вставить объект "Текст". Поместить его над картинкой. Убрать рамки.


Signature
Услуги 1С программиста 8.2, 7.7 (Плохо, дорого, очередь). Киев.

bereznoy Подменю пользователя
сообщение 06.01.13, 11:34
Сообщение #3

Оратор
*****
Группа: Пользователи
Сообщений: 329
Из: Simferopol
Спасибо сказали: 9 раз
Рейтинг: 0

Цитата(Ardi @ 06.01.13, 4:20) *
Вставить объект "Текст". Поместить его над картинкой. Убрать рамки.

А где можно почитать или подскажите как "Вставить объект "Текст" ?
Рисунок.Текст .... ?
Рисунок.РазмещениеТекста ..... ?
Это есть но у меня не получается, пытался Рисунок.Текст = "какой то текст"


Получилось, но вот как бы сделать что б прямоугольник текста не перекрывал рисунок, т.е. был просто прозрачный и виден только текст и рамки у самой картики не получается обрезать


ОбластьНоменклатура = Макет.ПолучитьОбласть("Номенклатура");
            Изображение = Выборка.Номенклатура.ОсновноеИзображение.Хранилище.Получить();
        Если НЕ Изображение = Неопределено Тогда
         Рисунок = ОбластьНоменклатура.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
Рисунок.Верх = 3;
Рисунок.Высота =70;
Рисунок.Ширина = 90;
Рисунок.Лево = 3.5;

Рисунок.РазмерКартинки = РазмерКартинки.Растянуть;//.Пропорционально;

Рисунок.Картинка = Изображение;
///////////////////////////////////////
Рисунок = ОбластьНоменклатура.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Текст);
Рисунок.Верх = 10;
Рисунок.Лево = 10;
Рисунок.Ширина = 30;
Рисунок.Высота = 10;
Рисунок.ОриентацияТекста = -15; //наклон 15 градусов по часовой стрелке
Рисунок.ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
Рисунок.ВертикальноеПоложение = ВертикальноеПоложение.Центр;
Рисунок.Шрифт = Новый Шрифт (,,Истина); //жирный
Рисунок.ЦветТекста = Новый Цвет(0,0,255); //синий
Рисунок.Текст = Выборка.Номенклатура.Артикул;

/////////////////////////////////////////////////////
Если ЛевыйСтолбец Тогда
                    ТабДок1.Вывести(ОбластьНоменклатура);
                Иначе
                    ТабДок2.Вывести(ОбластьНоменклатура);
                КонецЕсли;


КонецЕсли;


Signature
Ковыряю 1С 8.2.14.528 конфигурация УТП ред. 1.2.1.3
1С 8.3 (8.3.1.531) конфиг УТ 2.3.16.1
1С 7.7 Торговля+Склад

Спасибо сказали: IrinaKostroma,

Ardi Подменю пользователя
сообщение 06.01.13, 14:43
Сообщение #4

Живет на форуме
***********
Гений телепатии и социального моделирования
Группа: Пользователи
Сообщений: 4121
Из: Киев
Спасибо сказали: 956 раз
Рейтинг: 0

цветфона
границаСлева, ГраницаСправа, ...


Signature
Услуги 1С программиста 8.2, 7.7 (Плохо, дорого, очередь). Киев.

Спасибо сказали: IrinaKostroma,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 18.01.20, 0:42
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!