Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Сравнение 2-х ТЗ          
lensky Подменю пользователя
сообщение 22.09.17, 10:33
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

Доброго времени суток!
Сравниваю 2 ТЗ по двум колонкам. Вот запрос
Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ
                       |    ТоварыВРезервеНаСкладах.Номенклатура,
                       |    ТоварыВРезервеНаСкладах.Количество
                       |ИЗ
                       |    РегистрНакопления.ТоварыВРезервеНаСкладах КАК ТоварыВРезервеНаСкладах
                       |ГДЕ
                       |    ТоварыВРезервеНаСкладах.Регистратор ССЫЛКА Документ.КомплектацияНоменклатуры
                       |    И ТоварыВРезервеНаСкладах.ДокументРезерва = &ДокументРезерва
                       |    И ТоварыВРезервеНаСкладах.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Приход)
                       |
                       |СГРУППИРОВАТЬ ПО
                       |    ТоварыВРезервеНаСкладах.Номенклатура,
                       |    ТоварыВРезервеНаСкладах.Количество";
        Запрос.УстановитьПараметр("ДокументРезерва", Сделка);    
        ТЗК = Запрос.Выполнить().Выгрузить();
        
        ТЗР = Товары.Выгрузить();
        ТЗК.Свернуть("Номенклатура", "Количество");
        ТЗР.Свернуть("Номенклатура", "Количество");
        
        Для каждого Стр1 Из ТЗР Цикл
            НР = ТЗР.Колонки.Номенклатура;
            КР = ТЗР.Колонки.Количество;
            Для каждого Стр2 Из ТЗК Цикл
                 НК = ТЗК.Колонки.Номенклатура;
                КК = ТЗК.Колонки.Количество;
                Если НК = НР и КК > КР Тогда
                    Сообщить("Сработало");
                Иначе
                    Сообщить("Не сработало");
                КонецЕсли;
            КонецЦикла;
        КонецЦикла;


В условии всегда выскакивает в "иначе". условие НК = НР почему то ЛОЖЬ, хотя должна быть ИСТИНА, а условие КК > КР выдаёт: {(1)}: Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата).

Где я накосячил? Подскажите

Petre Подменю пользователя
сообщение 22.09.17, 10:50
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2631
Из: Київ, Україна
Спасибо сказали: 721 раз
Рейтинг: 697.8

lensky @ Сегодня, 11:33 * ,
1. Колонка одной тз не может быть равной колонке другой тз, т. к. тз разные.
2. Колонки нельзя сравнивать на больше/меньше.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: lensky,

lensky Подменю пользователя
сообщение 22.09.17, 10:53
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

Petre @ Сегодня, 11:50 * ,
А как сравнить тогда их содержимое?

Petre Подменю пользователя
сообщение 22.09.17, 10:58
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2631
Из: Київ, Україна
Спасибо сказали: 721 раз
Рейтинг: 697.8

lensky @ Сегодня, 11:53 * ,
Если вы хотите сравнить содержимое, то оно берется из текущей строки, например:
Для Каждого Стр1 Из ТЗР Цикл
    НР = Стр1.Номенклатура;
    КР = Стр1.Количество;


Signature
Допрацьовую:
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

lensky Подменю пользователя
сообщение 22.09.17, 10:59
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

Petre @ Сегодня, 11:58 * ,
Точно, вот я балбес
Спасибо

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 12.11.19, 2:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!