Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Программное создание кнопки для всех документов в формах объекта 2 страниц V  < 1 2          
Gigi Подменю пользователя
сообщение 09.10.19, 9:56
Сообщение #21

Оратор
*****
Группа: Пользователи
Сообщений: 428
Спасибо сказали: 5 раз
Рейтинг: 2

sava1 @ Вчера, 15:39 * ,
Опять привет ...
Вы знаете ...
Проблема диалогового окна Да/Нет в общей команды не решаема.
Да ... именно так... С этим ничего не сделаешь..
Короче НИКАК!
И дело в том, что в общей команде со свойствами по группе: "Командная панель формы.Важное" или "Командная панель формы.Создать на основании", диалог вопроса появляется на уровне самой платформы. Т.е. и вовсе до того как сработает эта строка.
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды,Отказ)
Если ПараметрКоманды.Пустая() Тогда Возврат; КонецЕсли; // Точка остановки
КонецПроцедуры

Ибо это вообще команда глобального типа. И такие глобальные команды обязательно требуют ссылку на объект в качестве параметра команды (ну, или массив ссылок).
В любом случае, перед использованием такой команды объект должен быть записан.
Гууу... а еще меня тут уверяли, что та цель которую ставил достижима. А на деле получается иначе .... приходиться использовать возможности платформы не по назначению.
Видимо эта хваленная команда не предназначена для той поставленной цели. Поэтому это наверно опять недоработки производителя 1С.
Ведь проблему было бы легко решить если в 1С событие: "ПриСозданииНаСервере" существовала бы в глобальном контексте. Тогда никаких проблем не возникало бы. И на самом деле, вот где собака зарыта.
И именно потому, что нет такого события именно поэтому и приходиться извиваться и заниматься разным извратом. Используя возможности платформы не по назначению. И это в хваленной системе 1С.
Ай разработчики, разработчики ... вы и ваши грехи... от которых уже устал.
Короче ничего с этим не сделаешь... И опять и тут миссия НЕ ВЫПОЛНИМА!
Уже устал клянусь... итак тяжело на духу... аж застрелиться охота..
Так что, можете сами подумать как, при создании нового объекта устранить эту проблему по общей команде, ... и как убрать этот диалог вопроса сохранять-Да/Нет, или вовсе спрятать эти кнопки.
А я уже устал.

daveal Подменю пользователя
сообщение 09.10.19, 13:22
Сообщение #22

Говорящий
***
Группа: Пользователи
Сообщений: 52
Из: Киев
Спасибо сказали: 18 раз
Рейтинг: 18

Насколько я помню, при вызове из формы объекта в ПараметрыВыполненияКоманды есть источник - это и будет форма объекта. А там уже можно обратится к Объект

Спасибо сказали: Gigi,

Gigi Подменю пользователя
сообщение 09.10.19, 13:54
Сообщение #23

Оратор
*****
Группа: Пользователи
Сообщений: 428
Спасибо сказали: 5 раз
Рейтинг: 2

Цитата(daveal @ 09.10.19, 14:22) *
Насколько я помню, при вызове из формы объекта в ПараметрыВыполненияКоманды есть источник - это и будет форма объекта. А там уже можно обратится к Объект

Да нет ... это не поможет smile.gif
Какая разница в таком виде:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды,Отказ)
        //Сообщить(ПараметрКоманды);Отказ=Истина; //Если ПараметрКоманды.Пустая() Тогда Отказ=Истина; Возврат; КонецЕсли;    
МетаданныеПолноеИмя=Config_МетаДанные.ОбъектМетаданных(ПараметрКоманды,"ПолноеИмяЕд"); // Функция определения метаданных по ссылке
Форма=ПолучитьФорму(МетаданныеПолноеИмя+".ФормаОбъекта", Новый Структура("Ключ",ПараметрКоманды));
Config_PrideSettingsFill_кл.НазначитьАвтозаполнение(Форма.Объект);
КонецПроцедуры

Или в еще более просто и коротком, в том что Вы имеете ввиду. Т.е. в таком:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды,Отказ)
Config_PrideSettingsFill_кл.НазначитьАвтозаполнение(ПараметрыВыполненияКоманды.Источник.Объект);
КонецПроцедуры

Это не решает проблему ... ибо диалоговое окно Да/Нет всплывает на уровне платформы и до вызова этой процедуры.
Если в глобальном смысле было бы событие "ПриСозданииНаСервере", то кнопки при новом объекте можно было бы просто скрыть.
Гуу .... нет настроения уже просто ... не на что ..

Gigi Подменю пользователя
сообщение 10.10.19, 10:34
Сообщение #24

Оратор
*****
Группа: Пользователи
Сообщений: 428
Спасибо сказали: 5 раз
Рейтинг: 2

Gigi @ Вчера, 14:54 * ,
И все таки решил не сдаваться ... без боя smile.gif
Поэтому решил продолжить другой новой темой
Вот этой


Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


2 страниц V  < 1 2
Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.10.19, 11:10
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!