Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> При создании новой базы из CF файла - ошибка: Запись с такими ключевыми полями существует! , МРОТ          
f12 Подменю пользователя
сообщение 28.10.22, 22:02
Сообщение #1

Оратор
Иконка группы
Группа: Местный
Сообщений: 290
Из: Ивано-Франковск
Спасибо сказали: 381 раз
Рейтинг: 197

Прошу допомоги.
Конфігурація УНФ 1.6.1 Створив cf-файл з робочої бази. При створенні нової чистої бази при загрузці цього cf-файлу видає таку помилку. Як виправити?

Запись с такими ключевыми полями существует! МРОТ: 01.12.2015 (Регистр сведений. Мінімальна оплата праці; Номер строки 17

Ось що пише в цій в конфігураторі
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

#Область ПрограммныйИнтерфейс

// Возвращает значение МРОт на переданную дату
//
Функция МРОТНаДату(Дата = Неопределено) Экспорт
    
     //МРОТ
    Запрос = Новый Запрос(
    "ВЫБРАТЬ
      |    МРОТСрезПоследних.Значение
      |ИЗ
      |    РегистрСведений.МРОТ.СрезПоследних(&ДатаСреза, ) КАК МРОТСрезПоследних");
      Запрос.УстановитьПараметр("ДатаСреза", НачалоГода(Дата));
    
      Выборка = Запрос.Выполнить().Выбрать();
    
      Если Выборка.Следующий() Тогда
        Возврат Выборка.Значение;
      Иначе
        ВызватьИсключение НСтр("ru='Регистр сведений МРОТ не заполнен';uk='Регістр відомостей МРОП не заповнений'");
    КонецЕсли;
    
КонецФункции

#КонецОбласти

#КонецЕсли


Сообщение отредактировал Vofka - 31.10.22, 9:13

Moloko Подменю пользователя
сообщение 29.10.22, 23:09
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 74
Спасибо сказали: 14 раз
Рейтинг: 12

f12 @ Вчера, 22:02 * ,
Перевірив - при створенні бази зі стандартного цфника таких проблем не виникає. Якщо в вас вже вскрита конфігурація,
подивіться на макет НачальноеЗаполнение в цьому регістрі, можливо, там і є ця фігня з 01.12.2015

Спасибо сказали: f12,

f12 Подменю пользователя
сообщение 31.10.22, 11:13
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 290
Из: Ивано-Франковск
Спасибо сказали: 381 раз
Рейтинг: 197

Питання закрите, проблема вирішилась іншим шляхом.

Vofka Подменю пользователя
сообщение 31.10.22, 15:03
Сообщение #4

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13836
Из: Киев
Спасибо сказали: 4418 раз
Рейтинг: 3538

f12, то може розкажете яким?

f12 Подменю пользователя
сообщение 01.11.22, 8:34
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 290
Из: Ивано-Франковск
Спасибо сказали: 381 раз
Рейтинг: 197

Vofka @ Вчера, 16:03 * ,

Знайшов в архіві за 2021 рік файл вигрузки чистої бази (з якою працював наш попередній програміст) без документів і залишків номенклатури, загрузив її, а потім поновив її більш новим cf-файлом з актуальної на даний момент бази. Ось так і вийшов з ситуації..

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 07.12.22, 6:14
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!