Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> При нажатии на кнопку программно заполнить реквизит Формы          
url_2l Подменю пользователя
сообщение 12.02.24, 13:14
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Доброго дня!!! Потрібна допомога 1С 7.7 в Розхідній Накладній в формі є реквізит Чек (поле вибору з Списку Перечислення Да Ні) при натасканні на кнопку друк перевіряє щоб поле було не пусте. Чи можна зробити щоб при натискані на кнопку це поле заповнювалось автоматично із списку на "Да"?
Приклад перевірки


Если ПустоеЗначение(Чек) = 1 Тогда
            Предупреждение("Виберіть тип Чеку (Да)");        
        Возврат;
        КонецЕсли;


Сообщение отредактировал Vofka - 12.02.24, 13:44

denis84 Подменю пользователя
сообщение 12.02.24, 13:42
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 416
Из: Украина
Спасибо сказали: 131 раз
Рейтинг: 132.5

url_2l @ Сегодня, 13:14 * ,
Доброго дня! Є такий приклад в моїй конфігурації. В документі списання на виробництво - при зміні реквизиту "підрозділ у шапці документу, заповнюємо підрозділ в рядках документу
    текОтвет = Вопрос("У документі змінено реквізит підрозділу. Заповнити підрозділ по рядкам документу?","Да+Нет");
    Если текОтвет = "Да" Тогда
        ВыбратьСтроки();
        Пока ПолучитьСтроку()=1 Цикл
            СтрУчасток = Подразделение;
        КонецЦикла;
    КонецЕсли;


//або ось так: якщо заповнено реквізит "разрешил" в документі "заказ", то ставимо "да" для "готов к получению"
    Если ПустоеЗначение(Разрешил)=0 Тогда
        ГотовКПолучению = Перечисление.ДаНет.Да;
    Иначе
        ГотовКПолучению = Перечисление.ДаНет.Нет;        
    КонецЕсли;


Сообщение отредактировал denis84 - 12.02.24, 13:52

Спасибо сказали: url_2l,

url_2l Подменю пользователя
сообщение 12.02.24, 14:31
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 13:42 * ,
Дякую величезне запрацювало

Если ПустоеЗначение(Чек) = 1 Тогда
            Чек = Перечисление.ДаНет.Да;
    КонецЕсли;


Сообщение отредактировал Vofka - 12.02.24, 14:52

denis84 Подменю пользователя
сообщение 12.02.24, 14:35
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 416
Из: Украина
Спасибо сказали: 131 раз
Рейтинг: 132.5

url_2l @ Сегодня, 14:31 * ,
Для "дякую" там є спеціальна кнопочка.

Спасибо сказали: url_2l,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 02.03.24, 4:40
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!