Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Печать документов на два разных принтера          
kostya77 Подменю пользователя
сообщение 27.05.24, 9:50
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 139
Спасибо сказали: 5 раз
Рейтинг: 4

Добрый день. В документа есть две печатные формы. Подскажите, как организовать печать одной фомы на принтер №1, а второй на принтер №2. Оба принтера подключены к одному компу

Сообщение отредактировал Vofka - 27.05.24, 11:40

AnryMc Подменю пользователя
сообщение 27.05.24, 10:28
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 362
Спасибо сказали: 99 раз
Рейтинг: 100.6

Цитата
ТабличныйДокумент (SpreadsheetDocument)
ИмяПринтера (PrinterName)
Использование:
Чтение и запись.
Описание:
Тип: Строка.
Содержит имя принтера, известного в системе, на который будет выводиться табличный документ при печати.
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение (клиент), мобильное приложение (сервер).
Использование в версии:
Доступен, начиная с версии 8.0.


Сообщение отредактировал AnryMc - 27.05.24, 10:28

Спасибо сказали: kostya77,

denis84 Подменю пользователя
сообщение 27.05.24, 10:51
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 440
Из: Украина
Спасибо сказали: 144 раз
Рейтинг: 145.5

kostya77 @ Сегодня, 10:31 * ,
Добрый день! Через два разных табличных документа (печатные формы) в свойствах табличного документа можно указать принтер

kostya77 Подменю пользователя
сообщение 27.05.24, 10:55
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 139
Спасибо сказали: 5 раз
Рейтинг: 4

AnryMc @ Сегодня, 11:28 * ,
Подскажите. как можно организовать, для пользователя, настройки выбора принтера для каждой печатной формы?

AnryMc Подменю пользователя
сообщение 27.05.24, 11:05
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 362
Спасибо сказали: 99 раз
Рейтинг: 100.6

kostya77 @ Сегодня, 11:55 * ,

Папример добавить 2 реквизита (для 2 печатных форм соответственно) и сделать подбор значения из списка установленных в системе.
Правда этот список нужно будет получить скриптом, напимер...
wmic printer list brief > "%userprofile%\Desktop\Printers.txt"

Потом парсить файл %userprofile%\Desktop\Printers.txt - создавая список имён для выбора

Или если список практически не меняется - задать имена вручную

volodya1122 Подменю пользователя
сообщение 27.05.24, 11:31
Сообщение #6

Оратор
Иконка группы
Группа: Местный
Сообщений: 342
Из: Тернопіль
Спасибо сказали: 137 раз
Рейтинг: 139.7

kostya77 @ Сегодня, 11:55 * ,


Ось мій варіант вибора принтера. в довіднику "Користувачів" в мене прописані назви принтерів які потрібно використовувати для різних варіантів друку (назву принтера необовязково вказувати повністю - головне щоб всі назви принтерів в компютері були різні)


Функция ПолучитьИмяПринтераДляПечати(Вид)
    ИмяПринтера="";    
    принтеры =  Новый COMОбъект ("WScript.Network");    
    prn =  принтеры.EnumPrinterConnections();    
    i = 0;    
    Если Вид="Чек" тогда
        ПроверочнПринтер=ПараметрыСеанса.Користувач.ПринтерЧеков;
    Иначе
        ПроверочнПринтер=ПараметрыСеанса.Користувач.ПринтерОсновной;
    КонецЕсли;
    
    Пока i < prn.Count()-1 Цикл    
        //  НовыйПринтер=ТЗПринтеры.Добавить();    
        ВремИмяПринтера=prn.Item(i+1);    
        i = i + 2;    
        Если Найти(ВремИмяПринтера,ПроверочнПринтер)>0 тогда
            ИмяПринтера=ВремИмяПринтера;
            Прервать;
        КонецЕсли;    
    КонецЦикла;        
    Возврат ИмяПринтера;    
    
КонецФункции


Сообщение отредактировал volodya1122 - 27.05.24, 11:31

Спасибо сказали: AnryMc, kostya77,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 14.06.24, 8:21
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!