Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Ошибка при установке обработки загрузки/выгрузки документов в XML          
berjozov Подменю пользователя
сообщение 12.11.21, 12:48
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Здравствуйте, хочу подключить обработку для загрузки/выгрузки документов в XML для 1С:Підприємство 8.3 (8.3.18.1289) BAS 2.1 (2.1.16.1), при добавлении выдает ошибку "Невозможно подключить дополнительную обработку из файла. Возможно она не подходит для этой версии программы. Техническая информация.Метод объекта не обнаружен (СведенияОВнешнейОбработке)"
Обработки - "Выгрузка загрузка данных XML" (ВыгрузкаЗагрузкаДанныхXML83.epf)" и аналогичные, которые входили в поставку 1С:Предприятие 8 Типовая конфигурация Конвертация данных, редакция 2.1. Также реагирует на обработки универсального обмена данных в XML, утянутые с просторов интернета.
Возможно для данной конфигурации существуют другие обработки или способы выгрузить информацию про авансовые отчеты/определенные хоз.операции и загрузить их потом в базу снова?
Заранее благодарен за ответ

mvo2008 Подменю пользователя
сообщение 12.11.21, 13:06
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 21
Из: г. Черкасcы
Спасибо сказали: 4 раз
Рейтинг: 4.3

В модулі немає процедур типу: тільки для обробки а не звіту (пошукайте в інеті)

Функция СведенияОВнешнейОбработке() Экспорт

    ИмяОтчета = ЭтотОбъект.Метаданные().Имя;
    Синоним = ЭтотОбъект.Метаданные().Синоним;
    Синоним = ?(ЗначениеЗаполнено(Синоним), Синоним, ИмяОтчета);

    РегистрационныеДанные = Новый Структура;
    РегистрационныеДанные.Вставить("Вид", "ДополнительныйОтчет");
    РегистрационныеДанные.Вставить("Наименование", Синоним);
    РегистрационныеДанные.Вставить("Версия", "2.1");
    РегистрационныеДанные.Вставить("БезопасныйРежим", Истина);
    РегистрационныеДанные.Вставить("Информация", "Отчет " + Синоним);

    ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(ТаблицаКоманд, Синоним, "СформироватьОтчет", "ОткрытиеФормы", Истина);

    РегистрационныеДанные.Вставить("Команды", ТаблицаКоманд);

    Возврат РегистрационныеДанные;

КонецФункции

Функция ПолучитьТаблицуКоманд()

    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

    Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование = "ОткрытиеФормы", ПоказыватьОповещение = Ложь, Модификатор = "ПечатьMXL")

    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры


Сообщение отредактировал Vofka - 12.11.21, 15:19

Спасибо сказали: berjozov,

Gazulo Подменю пользователя
сообщение 12.11.21, 13:52
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 235
Спасибо сказали: 37 раз
Рейтинг: 37

berjozov @ Сегодня, 13:48 * ,
Открывайте через Файл - Открыть.

Спасибо сказали: berjozov,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 06.12.21, 6:39
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!