Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Ошибка COM при обмене          
burza Подменю пользователя
сообщение 05.03.24, 17:37
Сообщение #1

Оратор
*****
Группа: Пользователи
Сообщений: 312
Спасибо сказали: 1 раз
Рейтинг: 1

Делаю обмен через COM между базами, когда делаю через файловую версию всё ок через сервер вот такое вылазит.Помогите уже не знаю куда смотреть.

Лазил в обсужение ОбсужденияПередЗаписьюДокумента удалил оттуда документ, всеровно ошибка.

Произошла исключительная ситуация (1C:Enterprise 8.3.19.1522): При подписке ОбсужденияПередЗаписьюДокумента на событие ПередЗаписью произошла ошибка. Обработчик события не найден.
{Обработка.ОбменСДана.Форма.Форма1.Форма(800)}: ДокументБух = ПоступленияТУБух.СоздатьДокумент();
{Обработка.ОбменСДана.Форма.Форма1.Форма(861)}: ОбменЗаказНаСервере();

по причине:
Произошла исключительная ситуация (1C:Enterprise 8.3.19.1522): При подписке ОбсужденияПередЗаписьюДокумента на событие ПередЗаписью произошла ошибка. Обработчик события не найден.

alex-l1904 Подменю пользователя
сообщение 06.03.24, 8:54
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 67
Спасибо сказали: 11 раз
Рейтинг: 11

burza @ Вчера, 18:37 * ,

можливо на модулі не стоїть Зовнішнє з'єднання

sava1 Подменю пользователя
сообщение 06.03.24, 9:14
Сообщение #3

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2688
Из: Проскуров
Спасибо сказали: 681 раз
Рейтинг: 659.7

для начала - почистить кеш серверный

burza Подменю пользователя
сообщение 06.03.24, 10:30
Сообщение #4

Оратор
*****
Группа: Пользователи
Сообщений: 312
Спасибо сказали: 1 раз
Рейтинг: 1

alex-l1904 @ Сегодня, 8:54 * ,
это не модуль я обработка там все на форме. точно такая же в Бух БАС выгружает все ок.

sava1 @ Сегодня, 9:14 * ,
ничего


ЗАказ покупателя снял. а ошибка осталась.
burza @ Вчера, 17:37 * ,

alex-l1904 Подменю пользователя
сообщение 06.03.24, 11:10
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 67
Спасибо сказали: 11 раз
Рейтинг: 11

burza @ Сегодня, 11:30 * ,

обробник підписки на подію це експортна процедура загального модуля

перевірте модуль обробника ОбсужденияПередЗаписьюДокумента

burza Подменю пользователя
сообщение 06.03.24, 11:34
Сообщение #6

Оратор
*****
Группа: Пользователи
Сообщений: 312
Спасибо сказали: 1 раз
Рейтинг: 1

alex-l1904 @ Сегодня, 11:10 * ,
Коментував цю строку і нічого. Дивно що в файловій версії все ок, нічого не треба роботи.
Процедура ОбсужденияПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
    
    Если Источник.ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;
    
    Если Отказ Тогда
        Возврат;
    КонецЕсли;
    
    Если Источник.ЭтоНовый() Тогда
        Источник.ДополнительныеСвойства.Вставить("ЭтоНовый", Истина);
        Возврат;
    КонецЕсли;
    
    Если ОбщегоНазначения.ЭтоДокумент(Источник.Метаданные()) Тогда
        Сообщение = ОбсужденияСравнитьОбъектыДокумент(Источник, РежимЗаписи, РежимПроведения);
    ИначеЕсли ОбщегоНазначения.ЭтоСправочник(Источник.Метаданные()) Тогда
        Сообщение = ОбсужденияСравнитьОбъектыСправочник(Источник);
    КонецЕсли;
    
    Если НЕ ПустаяСтрока(Сообщение) Тогда
        ДобавитьСообщение(
        Сообщение,
        Источник.Ссылка,
        ,
        Истина);
    КонецЕсли;
    
КонецПроцедуры

burza Подменю пользователя
сообщение 06.03.24, 17:21
Сообщение #7

Оратор
*****
Группа: Пользователи
Сообщений: 312
Спасибо сказали: 1 раз
Рейтинг: 1

alex-l1904 @ Сегодня, 8:54 * ,
да вы были правы, не стояло. тупанул не про тот модуль сразу полумал. Не теперь в мутабельность сваливаеться(

по причине:
Произошла исключительная ситуация (1C:Enterprise 8.3.19.1522): Ошибка при выполнении обработчика - 'ПередЗаписью'
Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода ПередЗаписьюДокумента ().

AnryMc Подменю пользователя
сообщение 07.03.24, 12:46
Сообщение #8

Оратор
Иконка группы
Группа: Местный
Сообщений: 328
Спасибо сказали: 96 раз
Рейтинг: 97.6

alex-l1904 @ Вчера, 12:10 * ,
+
Цитата
В версии 8.2 добавился флаг «вызов сервера», который помогает разрулить условия перехода на другую машину. Если модулю назначить этот флаг, то модуль будет виден с клиента, если нет – то попытка вызова с клиента приведет к ошибке. Код модуля виден не будет, как будто его нет совсем.

Таким образом, в обычном толстом клиенте перенести код на сервер можно, только если с клиента вызвать общий модуль, для которого:

Установлен флажок «Сервер»
Установлен флажок «Вызов сервера»
Сняты все «клиентские» флажки

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 13.04.24, 8:19
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!