Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Обробка "Обмін з банком" для БУ 2.0 , завантаження банківської виписки 22 страниц V  « < 7 8 9 10 11 > »           
olegbilas Подменю пользователя
сообщение 12.11.19, 7:34
Сообщение #161

Общительный
**
Группа: Пользователи
Сообщений: 12
Из: Днепр
Спасибо сказали: 11 раз
Рейтинг: 7.2

Обновленная обработка формата для Ощадбанка
[необходимо зарегистрироваться для просмотра ссылки]

olegbilas Подменю пользователя
сообщение 14.11.19, 11:28
Сообщение #162

Общительный
**
Группа: Пользователи
Сообщений: 12
Из: Днепр
Спасибо сказали: 11 раз
Рейтинг: 7.2

Цитата(Kseniapn @ 23.05.19, 16:52) *
Я в обработке dbf немного изменила условия проверки даты выписки

Если (ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаНачала) и ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаОкончания)) И (ДатаВиписки >= Параметри.ПеріодВиписки.ДатаНачала и ДатаВиписки <= Параметри.ПеріодВиписки.ДатаОкончания) Тогда


У меня условие проверки даты выписки сделано так:
                Если (ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаНачала) и ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаОкончания)) И (ДатаВиписки >= Параметри.ПеріодВиписки.ДатаНачала и ДатаВиписки <= Параметри.ПеріодВиписки.ДатаОкончания) Тогда
                    ЗаповненняДанихВиписки(Дані, ДаніРядка, ДатаВиписки);
                ИначеЕсли (ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаНачала) и не ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаОкончания)) И ДатаВиписки >= Параметри.ПеріодВиписки.ДатаНачала Тогда
                     ЗаповненняДанихВиписки(Дані, ДаніРядка, ДатаВиписки);
                ИначеЕсли (не ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаНачала) и ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаОкончания)) И ДатаВиписки <= Параметри.ПеріодВиписки.ДатаОкончания Тогда
                     ЗаповненняДанихВиписки(Дані, ДаніРядка, ДатаВиписки);
                 ИначеЕсли Не ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаНачала) И Не ЗначениеЗаполнено(Параметри.ПеріодВиписки.ДатаОкончания)  Тогда
                     ЗаповненняДанихВиписки(Дані, ДаніРядка, ДатаВиписки);
                КонецЕсли;


В результате пользователь может не вводить даты в шапку обработки (втягиваются все данные выписки), или ограничить отбор: либо начальной, либо конечной датой, либо обеими датами

Очень распространенная ситуация, когда оплата на расчетный счет организации идет от физических лиц (не предпринимателей) наличкой. В таком случае по выписке банка мы видим приход на счет с какого-либо транзитного счета банка плательщика, а самого плательщика можно определить только по назначению платежа. Привожу свой код вытягивания плательщика из назначения платежа и его поиск в справочнике "Контрагенты". Может, кому-то пригодится в написании обработки формата:
        РезультатПоиска = Справочники.Контрагенты.НайтиПоРеквизиту("КодПоЕДРПОУ", ДаніРядка[9]);
        // Пошук платника по прізвищу в призначенні платежу, якщо не знайдено у довіднику "Контрагенти" по коду ЄДРПОУ,
        //а також ігнорування платежів з транзитного рахунка Ощадбанку
        Если РезультатПоиска.Пустая() Или Найти(НРег(РезультатПоиска.Наименование), "ощад")<>0 Тогда
            ДаніРядкаПризначення = ОтриматиМасивДанихРядка(ПотПлатіж.Призначення, " ");;
            Для ЭлементРядкаПризначення=0 По ДаніРядкаПризначення.Количество()-1 Цикл
                Если СтрДлина(ДаніРядкаПризначення[ЭлементРядкаПризначення])>2 Тогда
                    ЗначениеДляПоиска=СтрЗаменить(ДаніРядкаПризначення[ЭлементРядкаПризначення],Символ(73), "і"); // Заміна англійської букви  І на українську і
                    ЗначениеДляПоиска=СтрЗаменить(ЗначениеДляПоиска,Символ(1168), "є"); // Заміна букви Ґ на букву є
                    РезультатПоиска1 = Справочники.Контрагенты.НайтиПоНаименованию(ЗначениеДляПоиска, Ложь);
                    Если Не РезультатПоиска1.Пустая() Тогда
                        ПотПлатіж.НазваКонтрагента = РезультатПоиска1.Наименование;
                        ПотПлатіж.КодКонтрагента = РезультатПоиска1.КодПоЕДРПОУ;
                        Прервать;
                    КонецЕсли;
                КонецЕсли;
            КонецЦикла;
        Иначе
            ПотПлатіж.НазваКонтрагента = ДаніРядка[8];
            ПотПлатіж.КодКонтрагента = ДаніРядка[9];
        КонецЕсли;

Функция ОтриматиМасивДанихРядка() взята из обработки для банка "Аваль", она в данном случае разбирает назначение платежа на отдельные слова, по которым в дальнейшем производится поиск на соответствие в справочнике "Контрагенты".

Petre Подменю пользователя
сообщение 14.11.19, 11:52
Сообщение #163

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2821
Из: Київ, Україна
Спасибо сказали: 944 раз
Рейтинг: 973.4

QUOTE (olegbilas @ 14.11.19, 11:28) *
Привожу свой код вытягивания плательщика из назначения платежа и его поиск в справочнике "Контрагенты".

Специально для этих целей начиная с версии 3.7 добавлено поле "Контрагент" таблицы "Дані". Т. е. можно сделать так:
                    Если Не РезультатПоиска1.Пустая() Тогда
                        ПотПлатіж.Контрагент = РезультатПоиска1;
                        Прервать;
                    КонецЕсли;


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

mkc123 Подменю пользователя
сообщение 18.11.19, 16:38
Сообщение #164

Молчаливый
*
Группа: Пользователи
Сообщений: 8
Спасибо сказали: 0 раз
Рейтинг: 0

Ув. форумчане, дайте пожалуйста обработку для Укргазбанка! Для РадаБанка переделал сам, а для Газа не получается.

Mist1K Подменю пользователя
сообщение 22.11.19, 9:48
Сообщение #165

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день, я ищу обработку для импорта выписок с Аваля, читаю в отзывах что у кого-то получалось данной обработкой, но мне пишет что
Цитата
У файлі не виявлено потрібних даних. Перевірте дату виписки, рахунок, формат файлу "D:\InOut\1.csv"

Счет и дату естественно проверил.
Структура файла
Цитата
ЄДРПОУ;МФО;Рахунок;Валюта;Дата операцiї;Код операцiї;МФО банка;Назва банка;Рахунок кореспондента;ЄДРПОУ кореспондента;Кореспондент;Номер документа;Дата документа;Дебет;Кредит;Призначення платежу;Гривневе покриття

При выборе формата указывал "Файл рядок з розділювачами CSV"
Подскажите что я, возможно, делаю не так? Или какую структуру ожидает обработка?
Заглянул в код, а там зашифровано все... 64000000.gif

Petre Подменю пользователя
сообщение 22.11.19, 10:50
Сообщение #166

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2821
Из: Київ, Україна
Спасибо сказали: 944 раз
Рейтинг: 973.4

QUOTE (Mist1K @ 22.11.19, 9:48) *
Структура файла

У меня заголовки авалевской выписки немного отличаются.
Дайте одну строку данных (подмените конфиденциальную информацию).


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Mist1K Подменю пользователя
сообщение 22.11.19, 12:05
Сообщение #167

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(Petre @ 22.11.19, 10:50) *
Дайте одну строку данных

33333333;380805;UA333808050000000026333333333;UAH;01.11.2019 10:06;;322539;"АТ ""ЮНЕКС БАНК"" м. Київ";UA823225390000000029444444444;44444444;"АТ ""ЮНЕКС БАНК""";495;01.11.2019;;3195.00;оренда приміщення за 10/2019 зг Дог суборенди N01/11/11-1 від 01/01/2018 в т.ч.ПДВ Платник - Василь Васильйович Директорович;3195.00;

Petre Подменю пользователя
сообщение 22.11.19, 12:44
Сообщение #168

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2821
Из: Київ, Україна
Спасибо сказали: 944 раз
Рейтинг: 973.4

Попробуйте эту.
Прикрепленные файлы
Прикрепленный файл  aval.zip ( 3.37 килобайт ) Кол-во скачиваний: 296
 


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: alienextrime, allegro, dychenkot, VSB,

Mist1K Подменю пользователя
сообщение 22.11.19, 15:12
Сообщение #169

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(Petre @ 22.11.19, 12:44) *
Попробуйте эту.

Благодарю, информация из файла выгрузки отобразилась в таблице, буду проверять дальше

penadine Подменю пользователя
сообщение 24.11.19, 1:01
Сообщение #170

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 1 раз
Рейтинг: 0

Petre @ 22.11.19, 12:44 * ,
А для УТП есть ?

Спасибо сказали: anagk,

Petre Подменю пользователя
сообщение 25.11.19, 9:39
Сообщение #171

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2821
Из: Київ, Україна
Спасибо сказали: 944 раз
Рейтинг: 973.4

penadine @ Yesterday, 1:01 * ,
Нет.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

AlexUA Подменю пользователя
сообщение 26.11.19, 19:39
Сообщение #172

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 1 раз
Рейтинг: 0

olegbilas @ 12.11.19, 8:34 * ,
Други, а что нужно сделать, чтобы скачать с данного файлообменника? При попытке скачать выдает ошибку smile.gif и посылает в лес к админам.
Пож, залейте на другой файлообменник, если это возможно.
Спасибо

olegbilas Подменю пользователя
сообщение 27.11.19, 14:40
Сообщение #173

Общительный
**
Группа: Пользователи
Сообщений: 12
Из: Днепр
Спасибо сказали: 11 раз
Рейтинг: 7.2

AlexUA, Обработка формата для Ощадбанк [необходимо зарегистрироваться для просмотра ссылки]

Спасибо сказали: AlexUA,

alla35 Подменю пользователя
сообщение 03.12.19, 8:21
Сообщение #174

Общительный
**
Группа: Пользователи
Сообщений: 40
Спасибо сказали: 4 раз
Рейтинг: 2.6

novomax @ 17.10.18, 12:12 * ,
Доброго дня! Спасибо за обработку, работала прекрасно, до последнего времени. Не поделитесь с измененной версией? Спасибо!

dychenkot Подменю пользователя
сообщение 09.12.19, 12:18
Сообщение #175

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Из: Черкассы
Спасибо сказали: 1 раз
Рейтинг: 0

Petre, Добрый день! Помогите пожалуйста с обработкой формата Укргазбанк .

Спасибо сказали: mkc123,

JENDA81 Подменю пользователя
сообщение 16.12.19, 13:50
Сообщение #176

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Petre, Добрый день! Помогите пожалуйста с обработкой для Приват банка. Заранее благодарен.

Petre Подменю пользователя
сообщение 16.12.19, 14:04
Сообщение #177

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2821
Из: Київ, Україна
Спасибо сказали: 944 раз
Рейтинг: 973.4

Если на форуме нет нужной обработки формата конкретного банка, для создания такой обработки вы можете обратиться либо ко мне через личные сообщения, либо в сервис доработки 1с.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

dubrova19 Подменю пользователя
сообщение 19.12.19, 14:31
Сообщение #178

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Petre @ 16.04.18, 10:16 * ,
не нашла пароль (((

mut Подменю пользователя
сообщение 28.12.19, 18:47
Сообщение #179

Завсегдатай
****
Группа: Пользователи
Сообщений: 162
Из: Новая Каховка
Спасибо сказали: 133 раз
Рейтинг: 150.7


Petre,
У некоторых клиентов в договоре указан учет взаиморасчетов "по расчетным документам", но при заполнении выписки они не всегда указывают ссылку на расчетный документ. Предлагаю добавить возможность отключить проверку заполнения реквизита "Угода".

Спасибо сказали: mvo2008, Petre,

bektek Подменю пользователя
сообщение 05.01.20, 11:32
Сообщение #180

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 1 раз
Рейтинг: 0

Хотим перейти на BAS КУП. Подскажите там свая система выгрузки платежек или есть обработка клиент банка для BAS КУП

Спасибо сказали: vmmiron,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


22 страниц V  « < 7 8 9 10 11 > » 
Ответить Новая тема
4 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 2 mvo2008, sok

 

RSS Текстовая версия Сейчас: 28.09.21, 10:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!