Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> метод ВыгрузитьКолонку не досупен          
lolmatrix Подменю пользователя
сообщение 09.12.19, 9:55
Сообщение #1

Говорящий
***
Группа: Пользователи
Сообщений: 54
Спасибо сказали: 1 раз
Рейтинг: 0

Здравствуйте,уважаемые Форумчане, подскажите пожалуйста, почему не доступен метод ВыгрузитьКолонку в ДанныеФормыКоллекция, что-то не так пишу? Заранее благодарен за ответы, пишу собственную конфигурацию 1с 8.3
 
&НаСервере
Функция ПолучаемКолонку(ТипыЦен)
Колонка = ТипыЦен.ВыгрузитьКолонку("ТипЦен");//ДанныеформыКоллекция
Возврат Колонка;    
КонецФункции
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ТипыЦен = Объект.ТипыЦен;
Колонка =  ПолучаемКолонку(ТипыЦен);

    СписокТиповЦен.ЗагрузитьЗначения(Колонка);
КонецПроцедуры

sava1 Подменю пользователя
сообщение 09.12.19, 10:11
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2385
Из: Проскуров
Спасибо сказали: 575 раз
Рейтинг: 559

тут , скорее, ТипыЦен недоступна. Через Объект.ТипыЦен - не пробовали ?

lolmatrix Подменю пользователя
сообщение 09.12.19, 10:25
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 54
Спасибо сказали: 1 раз
Рейтинг: 0

sava1 @ Сегодня, 11:11 * ,
пробовал та же ошибка

Макс1С Подменю пользователя
сообщение 09.12.19, 11:14
Сообщение #4

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 166
Из: Днепр
Спасибо сказали: 56 раз
Рейтинг: 50.6

lolmatrix @ Сегодня, 10:25 * ,
ВыгрузитьКолонку применяется к табличной части или к таблице значений, для ДанныеФормыКоллекция такого метода действительно нет.
Вам пригодится ДанныеФормыВЗначение()
Например так:
ВремТабл = ДанныеФормыВЗначение(ТипыЦен,Тип("ТаблицаЗначений"));
Колонка = ВремТабл.ВыгрузитьКолонку("ТипЦен")

В этом примере "ТипыЦен" - реквизит формы с типом ТЗ

Спасибо сказали: lolmatrix,

lolmatrix Подменю пользователя
сообщение 09.12.19, 12:05
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 54
Спасибо сказали: 1 раз
Рейтинг: 0

Макс1С @ Сегодня, 12:14 * ,
спасибо, теперь ошибка такая
ВремТабл = ДанныеФормыВЗначение(ТипыЦен,Тип("ТаблицаЗначений"));
по причине:
Недопустимое значение параметра (параметр номер '1'), скажите ,
а есть у ДанныеФормыКоллекция метод выгрузить, как его правильно написать, пробовал по разному тоже пишет нет метода им же тоже можно колонку выгузить?

Сообщение отредактировал lolmatrix - 09.12.19, 12:10

sava1 Подменю пользователя
сообщение 09.12.19, 13:18
Сообщение #6

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2385
Из: Проскуров
Спасибо сказали: 575 раз
Рейтинг: 559

Цитата(lolmatrix @ 09.12.19, 9:55) *
&НаСервере Функция ПолучаемКолонку(ТипыЦен) Колонка = ТипыЦен.ВыгрузитьКолонку("ТипЦен");//ДанныеформыКоллекция Возврат Колонка; КонецФункции &НаКлиенте Процедура ПриОткрытии(Отказ) ТипыЦен = Объект.ТипыЦен; Колонка = ПолучаемКолонку(ТипыЦен); СписокТиповЦен.ЗагрузитьЗначения(Колонка); КонецПроцедуры


зачем этот бред с Сервером.
Выгрузите колонку на клиенте

lolmatrix Подменю пользователя
сообщение 09.12.19, 13:30
Сообщение #7

Говорящий
***
Группа: Пользователи
Сообщений: 54
Спасибо сказали: 1 раз
Рейтинг: 0

написано в справке, что доступность на Сервере
ДанныеФормыКоллекция.Выгрузить (FormDataCollection.Unload)
Доступность:
Сервер, мобильное приложение(сервер).

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ТипыЦен = Объект.ТипыЦен;
    СписокТиповЦен.ЗагрузитьЗначения(ТипыЦен.ВыгрузитьКолонку("ТипЦен"));
КонецПроцедуры


Так тоже не работает

sava1 Подменю пользователя
сообщение 09.12.19, 13:33
Сообщение #8

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2385
Из: Проскуров
Спасибо сказали: 575 раз
Рейтинг: 559

а просто обойти и заполнить список ?

Спасибо сказали: lolmatrix,

lolmatrix Подменю пользователя
сообщение 09.12.19, 13:35
Сообщение #9

Говорящий
***
Группа: Пользователи
Сообщений: 54
Спасибо сказали: 1 раз
Рейтинг: 0

sava1 @ Сегодня, 14:33 * ,
можно конечно и обойти, спасибо, попробую обойти, но есть же метод выгрузить, хочу понят как ? примера в Синтаксис помощнике нет

sava1 Подменю пользователя
сообщение 09.12.19, 14:01
Сообщение #10

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2385
Из: Проскуров
Спасибо сказали: 575 раз
Рейтинг: 559

Цитата(lolmatrix @ 09.12.19, 12:05) *
теперь ошибка такая
ВремТабл = ДанныеФормыВЗначение(ТипыЦен,Тип("ТаблицаЗначений"));
по причине:


ВремТабл = ДанныеФормыВЗначение("ТипыЦен",Тип("ТаблицаЗначений"));

lolmatrix Подменю пользователя
сообщение 09.12.19, 14:12
Сообщение #11

Говорящий
***
Группа: Пользователи
Сообщений: 54
Спасибо сказали: 1 раз
Рейтинг: 0

sava1 @ Сегодня, 15:01 * ,
спасибо, Всем за ответы, если можно напишите пожалуйста с пример выгрузить из ДанныеФормыКоллекция
решил так
&НаКлиенте
Процедура ПриОткрытии(Отказ)
        ТипыЦен = Объект.ТипыЦен;
Для каждого Элемент из ТипыЦен Цикл
    
    СписокТиповЦен.Добавить(Элемент.Типцен);
    КонецЦикла;

КонецПроцедуры

Макс1С Подменю пользователя
сообщение 09.12.19, 17:54
Сообщение #12

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 166
Из: Днепр
Спасибо сказали: 56 раз
Рейтинг: 50.6

lolmatrix @ Сегодня, 13:30 * ,
У вас Табличная часть объекта "ТипыЦен" поэтому можно так:
ВремТабл = ДанныеФормыВЗначение(Объект.ТипыЦен,Тип("ТаблицаЗначений"));

или
ВремТабл = Объект.ТипыЦен.Выгрузить()

или обойти циклом

TipsyKID Подменю пользователя
сообщение 09.12.19, 19:41
Сообщение #13

Оратор
Иконка группы
Группа: Местный
Сообщений: 408
Из: Киев
Спасибо сказали: 160 раз
Рейтинг: 0

&НаСервере
Процедура ЗагрузитьКолонку()
    
    
    ТаблицаЗначенийТипыЦен = ТипыЦен.Выгрузить( ,"ТипЦен");//ДанныеформыКоллекция в ТЗ
    МассивЗначений = ТаблицаЗначенийТипыЦен.ВыгрузитьКолонку("ТипЦен"); // Из ТЗ в Массив
    СписокТиповЦен.ЗагрузитьЗначения(МассивЗначений); // Из Массива в СЗ
    
КонецПроцедуры


Сообщение отредактировал TipsyKID - 09.12.19, 19:43


Signature
Специалист : Технологическая платформа 8.х, Бухгалтерия для Украины, Управление торговлей для Украины, Зарплата и Управление Персоналом для Украины

lolmatrix Подменю пользователя
сообщение 10.12.19, 6:43
Сообщение #14

Говорящий
***
Группа: Пользователи
Сообщений: 54
Спасибо сказали: 1 раз
Рейтинг: 0

TipsyKID @ Вчера, 20:41 * ,
Спасибо, так я тоже пробовал метод выгрузить не доступен

fly Подменю пользователя
сообщение 10.12.19, 13:05
Сообщение #15

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 215
Спасибо сказали: 46 раз
Рейтинг: 0

Цитата(lolmatrix @ 10.12.19, 6:43) *
СписокТиповЦен.ЗагрузитьЗначения(Колонка);

Объект.ТипыЦен

я так понимаю, есть табличная часть "ТипыЦен"

Колонка =  ПолучаемКолонку(ТипыЦен);

получаем: Тип = ДанныеФормыКоллекция

а у этого типа (ДанныеФормыКоллекция) нет метода
ВыгрузитьКолонку("");

есть только - Выгрузить (Unload)

Цитата(lolmatrix @ 10.12.19, 6:43) *
TipsyKID @ Вчера, 20:41 ,
Спасибо, так я тоже пробовал метод выгрузить не доступен


что вы не то пробовали, работает если сначала ДанныеФормы - выгрузить в ТаблицуЗначений, потом из Таблицы значений выгрузить колонку

&НаКлиенте
Процедура ПриОткрытии(Отказ)
         ТипыЦен = Объект.ТипыЦен;
         // ----- выгружаем ДанныеФормыКолекция в Таблицу значений
         ТЗ = ТипыЦен.Выгрузить();
         // -----
         Колонка = ПолучаемКолонку(ТЗ);
        
         СписокТиповЦен.ЗагрузитьЗначения(Колонка);
КонецПроцедуры


&НаСервере
Функция ПолучаемКолонку(ТипыЦен)
    
    Колонка =  ТипыЦен.ВыгрузитьКолонку("ТипЦен");
    Возврат Колонка;
КонецФункции


Сообщение отредактировал fly - 10.12.19, 13:07

Макс1С Подменю пользователя
сообщение 11.12.19, 9:32
Сообщение #16

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 166
Из: Днепр
Спасибо сказали: 56 раз
Рейтинг: 50.6

fly @ Вчера, 13:05 * ,
Коллега, вы немного напутали, метод Выгрузить() для ДанныеФормыКоллекция недоступен на клиенте.
lolmatrix @ Вчера, 6:43 * ,
Если у вас табличная часть, в вашей серверной процедуре пишите:
Колонка = Объект.ТипыЦен.ВыгрузитьКолонку("ТипЦен")

Если "Типы цен" - просто реквизит формы:
ВремТабл = ДанныеФормыВЗначение(ТипыЦен,Тип("ТаблицаЗначений"));
Колонка = ВремТабл.ВыгрузитьКолонку("ТипЦен")

ИЛИ:
ВремТабл = ТипыЦен.Выгрузить(,"ТипЦен"); //можно как со вторым параметром  так и без него, возвращаемый результат - ТЗ
Колонка = ВремТабл.ВыгрузитьКолонку("ТипЦен")


Сообщение отредактировал Макс1С - 11.12.19, 9:33

Спасибо сказали: fly,

fly Подменю пользователя
сообщение 11.12.19, 10:10
Сообщение #17

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 215
Спасибо сказали: 46 раз
Рейтинг: 0

Цитата(Макс1С @ 11.12.19, 9:32) *
Коллега, вы немного напутали, метод Выгрузить() для ДанныеФормыКоллекция недоступен на клиенте.

Реально спасибо, так как не обратил внимание - и перенес на Клиент
Изначально
ТЗ = ТипыЦен.Выгрузить();

делал на сервере - отвлекся на другую задачу,и вернувшись - потом для более похожести на изначальный код. перенес на клиент.

Цитата(Макс1С @ 11.12.19, 9:32) *
Если у вас табличная часть, в вашей серверной процедуре пишите:
Колонка = Объект.ТипыЦен.ВыгрузитьКолонку("ТипЦен")


а вот с этим соглашусь, но с оговорками:
если берем модуль Формы:
что на сервере, что на клиенте на управляемых формах табличная часть через точку возвращается тип = ДанныеФормыКоллекция, и тогда нет метода ВыгрузитьКолонку()...


если же берем модуль объекта
то обращение не через точку (т.е. изначально было на форме написано), а просто к табличной части и тогда работает метод ВыгрузитьКолонку:
Цитата
Колонка = ТипЦен.ВыгрузитьКолонку()





fly @ Сегодня, 10:05 * ,

Спасибо сказали: Макс1С,

Макс1С Подменю пользователя
сообщение 11.12.19, 11:14
Сообщение #18

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 166
Из: Днепр
Спасибо сказали: 56 раз
Рейтинг: 50.6

Цитата(fly @ 11.12.19, 10:10) *
что на сервере, что на клиенте на управляемых формах табличная часть через точку возвращается тип = ДанныеФормыКоллекция, и тогда нет метода ВыгрузитьКолонку()...

Спасибо, действительно. Это затмение нашло какое-то, изначально написал Выгрузить() в ТЗ и ВыгрузитьКолонку(), а потом с какого-то перепугу поправил свой пост

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 05.12.20, 3:59
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!