Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Метаданные          
vadim007 Подменю пользователя
сообщение 14.08.15, 10:38
Сообщение #1

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1298
Из: Донецк
Спасибо сказали: 207 раз
Рейтинг: 0

Всем привет!
Можно-ли получить список всех типов объектов метаданных (т.е. Справочники, Документы, Константы, Журналы и т.д., без детализации) конфигурации программным путем?
Если ДА, то как?

Petre Подменю пользователя
сообщение 14.08.15, 10:56
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2750
Из: Київ, Україна
Спасибо сказали: 830 раз
Рейтинг: 828.9

СписокВсехТипов = Новый СписокЗначений;
Для Каждого ТекОбъект Из Метаданные.Справочники Цикл
    СписокВсехТипов.Добавить(ТекОбъект.Имя);
КонецЦикла;
Для Каждого ТекОбъект Из Метаданные.Документы Цикл
    СписокВсехТипов.Добавить(ТекОбъект.Имя);
КонецЦикла;
//* . . .


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

TipsyKID Подменю пользователя
сообщение 14.08.15, 11:14
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 408
Из: Киев
Спасибо сказали: 160 раз
Рейтинг: 0

Единственное решение ( уже давно гуляет по интернету )
 
    МассивКлассовМетаданных = Новый Массив;
    МассивКлассовМетаданных.Добавить("Справочники");
    МассивКлассовМетаданных.Добавить("Документы");
    МассивКлассовМетаданных.Добавить("Отчеты");
    МассивКлассовМетаданных.Добавить("Обработки");
    
    Для каждого КлассМетаданных Из МассивКлассовМетаданных Цикл
        
        Для Каждого ОбъектМетаданных Из Метаданные[КлассМетаданных] Цикл
            
            Сообщить(ОбъектМетаданных.Имя);
        КонецЦикла;
    КонецЦикла;


Signature
Специалист : Технологическая платформа 8.х, Бухгалтерия для Украины, Управление торговлей для Украины, Зарплата и Управление Персоналом для Украины

Спасибо сказали: logist,

vadim007 Подменю пользователя
сообщение 14.08.15, 11:32
Сообщение #4

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1298
Из: Донецк
Спасибо сказали: 207 раз
Рейтинг: 0

Только так?
А наподобие следующего нельзя?
Мета = Новый Структура();
Для Каждого ТекТипМД Из Метаданные Цикл
   Если Не ПустоеЗначение(ТекТипМД) Тогда // Есть метаданные текущего типа
      спТекМета = Новый СписокЗначений();
      Для Каждого ТекМД из Метаданные(ТекТипМД) Цикл
          спТекМета.Добавить(ТекМД);
      КонецЦикла;
      Мета.Вставить(ТекТипМД, спТекМета);
   КонецЕсли;
КонецЦикла;

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 26.11.20, 11:18
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!