Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Массив и таблица значений          
vet07 Подменю пользователя
сообщение 10.01.24, 16:15
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 37
Из: Харьков
Спасибо сказали: 0 раз
Рейтинг: 0

Усім привіт.
Уже туплю часа три. Запитання таке: маємо масив масивів. Кожен масив в масиві повинен бути строкою ТЗ. Як тудИ його засунуть циклами уже не розумію? Дякую.

AnryMc Подменю пользователя
сообщение 10.01.24, 16:46
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 275
Спасибо сказали: 83 раз
Рейтинг: 84.6

vet07 @ Сегодня, 17:15 * ,

ТаблицаЗначений (ValueTable)
ЗагрузитьКолонку (LoadColumn)
Синтаксис:
ЗагрузитьКолонку(<Массив>, <Колонка>)

alex-l1904 Подменю пользователя
сообщение 10.01.24, 16:50
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 62
Спасибо сказали: 10 раз
Рейтинг: 10

vet07 @ Сегодня, 17:15 * ,
напишіть для чого масив масивів зі строками ТЗ ?

alex1c Подменю пользователя
сообщение 10.01.24, 20:03
Сообщение #4

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 233
Спасибо сказали: 45 раз
Рейтинг: 40

Я так робив
Функция МасивВТаблицю(МасивДаних) Экспорт
    
    ТЗ = Новый ТаблицаЗначений;
    Если МасивДаних.Количество() Тогда
        // Малюємо колонки для таблиці
        Для Каждого ЭлементМассива Из МасивДаних[0] Цикл
            ТЗ.Колонки.Добавить(ЭлементМассива.Ключ);
        КонецЦикла;
        
        Для Каждого ЭлементМассива Из МасивДаних Цикл
            // Додаємо дані до таблиці
            РядокТЗ = ТЗ.Добавить();
            Для Каждого ЗначениеСтруктуры Из ЭлементМассива Цикл
                РядокТЗ[ЗначениеСтруктуры.Ключ] = ЗначениеСтруктуры.Значение;
            КонецЦикла;
        КонецЦикла;
    КонецЕсли;
    Возврат ТЗ;
    
КонецФункции

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 24.02.24, 21:10
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!