Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Картинка ОсновноеИзображение при выборе меняет допкартинку          
MOTOPARTNER Подменю пользователя
сообщение 28.10.20, 12:15
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 37
Из: Харьков
Спасибо сказали: 1 раз
Рейтинг: 1

1С 8.3 Управление торговлей для Украины 2.3

Создал еще 3 картинки в номенклатуре как ИзображениеДоп.
Все работает но когда нажимаешь на любую картинку что-бы добавить оно эту картинку ставит во все 3 картинке я так понял проблема в коде
когда выбираю значение оно ставит во все доп фото как сделать что нужно сделать с кодом что бы на определённую картинку допустим ИзображениеДоп2 ставилась картинка только в эту картинку а остальные не трогало не меняло.

я так понимаю для каждой доп картинке нужно ЗначениеВыбора , ЗначениеВыбора2, ЗначениеВыбора3. или как по другому это реализовать

Если ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.ТипыЦенНоменклатуры") Тогда 
  мТипЦенДляПечати = ЗначениеВыбора;
ИначеЕсли ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.ХранилищеДополнительнойИнформации") Тогда
  Если ОсновноеИзображение <> ЗначениеВыбора Тогда
   ОсновноеИзображение = ЗначениеВыбора;
  КонецЕсли;
  Если ИзображениеДоп <> ЗначениеВыбора Тогда
   ИзображениеДоп = ЗначениеВыбора;
  КонецЕсли;
  Если ИзображениеДоп2 <> ЗначениеВыбора Тогда
   ИзображениеДоп2 = ЗначениеВыбора;
  КонецЕсли;
  Если ИзображениеДоп3 <> ЗначениеВыбора Тогда
   ИзображениеДоп3 = ЗначениеВыбора;
  КонецЕсли;




Заранее спасибо за помощь!

MOTOPARTNER Подменю пользователя
сообщение 28.10.20, 17:40
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 37
Из: Харьков
Спасибо сказали: 1 раз
Рейтинг: 1

Как правильно написать что бы выбранный файл сохранялся только в определенную доп картинку ?
Этот код добавляет сразу во все доп картинки.

Vofka Подменю пользователя
сообщение 29.10.20, 11:03
Сообщение #3

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13403
Из: Киев
Спасибо сказали: 4143 раз
Рейтинг: 3290.4

MOTOPARTNER, да проблема в коде. Вам надо сравнивать не каждую картинку с выбранной, а только ту по которой произошло нажатие.

MOTOPARTNER Подменю пользователя
сообщение 29.10.20, 11:35
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 37
Из: Харьков
Спасибо сказали: 1 раз
Рейтинг: 1

Vofka @ Сегодня, 12:03 * ,
Это я понимаю вот как правильно написать не могу понять

Vofka Подменю пользователя
сообщение 29.10.20, 12:34
Сообщение #5

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13403
Из: Киев
Спасибо сказали: 4143 раз
Рейтинг: 3290.4

MOTOPARTNER @ Сегодня, 11:35 * ,
покажите где обработка нажатия происходит

MOTOPARTNER Подменю пользователя
сообщение 30.10.20, 1:18
Сообщение #6

Общительный
**
Группа: Пользователи
Сообщений: 37
Из: Харьков
Спасибо сказали: 1 раз
Рейтинг: 1

Vofka @ Вчера, 13:34 * ,
Процедура ИзображениеДопНажатие(Элемент)

    Если Не РаботаСДиалогами.ЗаписатьНовыйОбъектВФорме(ЭтаФорма) Тогда
        Возврат;
    КонецЕсли;

    РаботаСФайлами.ОткрытьФормуИзображения2(ЭтаФорма, ИзображениеДоп, Ссылка);    
    
КонецПроцедуры


Vofka Подменю пользователя
сообщение 30.10.20, 9:47
Сообщение #7

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13403
Из: Киев
Спасибо сказали: 4143 раз
Рейтинг: 3290.4

Надо смотреть ещё что в
РаботаСФайлами.ОткрытьФормуИзображения2(ЭтаФорма, ИзображениеДоп, Ссылка);


Похоже, что в ОткрытьФормуИзображения2 открывается форма для выбора, а то что в 1 сообщении - это ОбработкаВыбора. Если так, то вам надо в ОткрытьФормуИзображения2() передать ещё имя элемента по которому происходит нажатие, а в открываемой форме написать свой обработчик выбора и передавать туда не только ссылку на выбранный элемент, а и имя элемента по которому был щелчок, упаковав это в структуру, например.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 02.12.20, 11:32
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!