Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Как вывести на печатную форму номер телефона основного менеджера контрагента в расходной накладной?          
victor_as Подменю пользователя
сообщение 11.12.20, 21:39
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

Подскажите как вывести на печатную форму номер телефона основногоменеджера контрагента. На печать вывожу основногоменеджера текущего контрагента. А вот телефон не получается выести

ОбластьМакета = Макет.ПолучитьОбласть("Менеджер");
ОбластьМакета.Параметры.ПредставлениеМенеджер =Контрагент.ОсновнойМенеджерПокупателя;
ОбластьМакета.Параметры.Заполнить(Шапка);

ТабДокумент.Вывести(ОбластьМакета);


Сообщение отредактировал Vofka - 16.12.20, 10:27

DartRomanius Подменю пользователя
сообщение 11.12.20, 23:04
Сообщение #2

Ветеран
Иконка группы
Группа: Местный
Сообщений: 787
Из: Запорожье
Спасибо сказали: 139 раз
Рейтинг: 66

Обратится к контактным данным контрагента?


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

denis84 Подменю пользователя
сообщение 12.12.20, 9:07
Сообщение #3

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 193
Из: Украина
Спасибо сказали: 51 раз
Рейтинг: 51

victor_as @ Вчера, 21:39 * ,
Добрый день! Вот здесь почитайте. Сейчас не возле компа,не как глянуть свои печатные формы.
[необходимо зарегистрироваться для просмотра ссылки]

Сообщение отредактировал denis84 - 12.12.20, 9:15

victor_as Подменю пользователя
сообщение 13.12.20, 21:11
Сообщение #4

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

DartRomanius @ 11.12.20, 23:04 * ,
к контактным данным физ.лица -контактная информация - телефон

Цитата(denis84 @ 12.12.20, 9:07) *
Добрый день! Вот здесь почитайте. Сейчас не возле компа,не как глянуть свои печатные формы.

спасибо за инфу, но вытащить именно телефон текущего физ.лица не получилось

denis84 Подменю пользователя
сообщение 13.12.20, 21:32
Сообщение #5

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 193
Из: Украина
Спасибо сказали: 51 раз
Рейтинг: 51

victor_as @ Сегодня, 21:11 * ,
Укажите,какая конфигурации?

denis84 Подменю пользователя
сообщение 14.12.20, 8:39
Сообщение #6

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 193
Из: Украина
Спасибо сказали: 51 раз
Рейтинг: 51

victor_as @ Вчера, 21:11 * ,
Добрый день! У меня есть такой вариант:

ОбластьПокупатель  = Макет.ПолучитьОбласть("Покупатель");
СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Контрагент, СсылкаНаОбъект.Дата,,,"uk");
ОбластьПокупатель.Параметры.РеквизитыПокупателя        = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе,"Телефоны,",,"uk");
ОбластьПокупатель.Параметры.ПредставлениеПокупателя   = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ПолноеНаименование,",,"uk");
ТабДок.Вывести(ОбластьПокупатель);


Сообщение отредактировал denis84 - 14.12.20, 8:40

victor_as Подменю пользователя
сообщение 14.12.20, 21:22
Сообщение #7

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(denis84 @ 14.12.20, 8:39) *
ОбластьПокупатель  = Макет.ПолучитьОбласть("Покупатель");
СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Контрагент, СсылкаНаОбъект.Дата,,,"uk");
ОбластьПокупатель.Параметры.РеквизитыПокупателя        = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе,"Телефоны,",,"uk");
ОбластьПокупатель.Параметры.ПредставлениеПокупателя   = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ПолноеНаименование,",,"uk");
ТабДок.Вывести(ОбластьПокупатель);


не то, нужно вывести номер телефона сотрудника (менеджера) который закреплен за контрагентом

denis84 Подменю пользователя
сообщение 15.12.20, 10:15
Сообщение #8

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 193
Из: Украина
Спасибо сказали: 51 раз
Рейтинг: 51

victor_as @ Вчера, 21:22 * ,
добрый день! Вот такой вариант:
Запрос = Новый Запрос;
Запрос.Текст =
    "ВЫБРАТЬ
    |    КонтактнаяИнформация.Объект Как Контакт,
    |    ПРЕДСТАВЛЕНИЕ(КонтактнаяИнформация.Объект),
    |    КонтактнаяИнформация.Тип,
    |    КонтактнаяИнформация.Вид,
    |    ПРЕДСТАВЛЕНИЕ(КонтактнаяИнформация.Вид),
    |    КонтактнаяИнформация.Представление
    |ИЗ
    |    РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
   |ГДЕ
   |    КонтактнаяИнформация.Объект = &Объект
   |    И КонтактнаяИнформация.Тип = &Тип
   |    И КонтактнаяИнформация.Вид = &Вид";
    
Запрос.УстановитьПараметр("Объект",СсылкаНаОбъект.Контрагент.ОсновноеКонтактноеЛицо);
Запрос.УстановитьПараметр("Тип",Перечисления.ТипыКонтактнойИнформации.Телефон);
Запрос.УстановитьПараметр("Вид",Справочники.ВидыКонтактнойИнформации.МобильныйТелефонКонтактногоЛицаКонтрагента);
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    ОбластьПокупатель.Параметры.Телефон        = Строка(ВыборкаДетальныеЗаписи.Контакт)+",  "+"тел. " + ВыборкаДетальныеЗаписи.Представление;
КонецЦикла;


Если помогло нажмите "спасибо"

Спасибо сказали: victor_as,

victor_as Подменю пользователя
сообщение 15.12.20, 20:53
Сообщение #9

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 10:15 * ,
Спасибо за помощь, получилось вот так, может замудренно но получилось
//функция получения номера телефона ФИЗЛИЦА
Функция ПолучитьТелефонИзКонтактнойИнформации(Объект, ВидТелефона = Неопределено) Экспорт  

   Если ВидТелефона = Неопределено Тогда
      ВидТелефона = Справочники.ВидыКонтактнойИнформации.ТелефонОрганизации;
   КонецЕсли;

   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);

   Запрос.УстановитьПараметр("Объект", Объект);
   Запрос.УстановитьПараметр("Тип"   , Перечисления.ТипыКонтактнойИнформации.Телефон);
   Запрос.УстановитьПараметр("Вид"   , ВидТелефона);
  
   Запрос.Текст =
   "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
   |   КонтактнаяИнформация.Представление
   |ИЗ
   |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
   |ГДЕ
   |   КонтактнаяИнформация.Объект = &Объект
   |   И КонтактнаяИнформация.Тип = &Тип
   |   И КонтактнаяИнформация.Вид = &Вид";
  
   РезультатЗапроса = Запрос.Выполнить();
  
   Если РезультатЗапроса.Пустой() Тогда
      Возврат "";
   Иначе
      Возврат РезультатЗапроса.Выгрузить()[0].Представление;
   КонецЕсли;

КонецФункции // ПолучитьТелефонИзКонтактнойИнформации()


    // Выводим информацию о основном менеджере покупателя и номер телефона
    ОсновнойМенеджер = Контрагент.ОсновнойМенеджерПокупателя;
    ФизТелефон=""+", "+"тел. (" +ПолучитьТелефонИзКонтактнойИнформации(Справочники.ФизическиеЛица.НайтиПоНаименованию(ОсновнойМенеджер, Истина), Справочники.ВидыКонтактнойИнформации.ТелефонФизЛицаСлужебный)+")";
    ОбластьМакета = Макет.ПолучитьОбласть("Менеджер");
    ОбластьМакета.Параметры.ПредставлениеМенеджер =""+ОсновнойМенеджер+ФизТелефон;


Показывает текущего менеджера(агента) клиента/покупателя, и номер телефона менеджера(Василий Ветров, тел. (91111111)

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.01.21, 1:23
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!