Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Как определить в двух строковых типах большее число , В двух строковых полях разные числа типа IP адреса: какое число больше          
webaristan Подменю пользователя
сообщение 29.06.20, 14:32
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Как определить в двух строковых типах большее число
Подскажите пожалуйста, заранее благодарен.
В двух строковых полях разные числа типа IP адреса: 245.120.243.567 и к примеру 299.125.40.69. Как определить в другом текстовом поле большее число.

Данное решение нужно для управляемых форм.

Подскажите где посмотреть пример или код, ну или описание этого метода обработки кода.
Благословений всем.

mut Подменю пользователя
сообщение 29.06.20, 14:55
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 123
Из: Новая Каховка
Спасибо сказали: 48 раз
Рейтинг: 47.2

Разделить на триады, каждую триаду привести к трехзначному виду (40 -> 040)
Сложить тройки цифр в одну строку, преобразовать в число.
Повторить для второй строки. Числа сравнить.

webaristan Подменю пользователя
сообщение 29.06.20, 16:22
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

mut @ Сегодня, 15:55 * ,
Благодарю за ответ.

А можно как то наглядно посмотреть код. Если не трудно и не жалко.
Рахмет заранее.

volodya1122 Подменю пользователя
сообщение 30.06.20, 9:07
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 276
Из: Тернопіль
Спасибо сказали: 108 раз
Рейтинг: 110.1

Наприклад так можна

Функция СравнитьЧисла(МояСтрока1,МояСтрока2)
МассивЧисел1=СтрРазделить(МояСтрока1,".");
МассивЧисел2=СтрРазделить(МояСтрока2,".");
Для Индекс = 0 По МассивЧисел1.Количество() - 1 Цикл
    Если число(МассивЧисел1[Индекс])> число(МассивЧисел2[Индекс]) тогда
        Возврат "Перше число більше";
        //Прервать;
    ИначеЕсли число(МассивЧисел1[Индекс])< число(МассивЧисел2[Индекс]) тогда
        Возврат "Друге число більше";
        //Прервать;
    КонецЕсли;    
КонецЦикла;
Возврат "Числа однакові";
КонецФункции


Сообщение отредактировал volodya1122 - 30.06.20, 9:15

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 06.07.20, 22:01
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!