Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Как изменить список печатных форм в документах , не знаю как это сделать правильно          
Laky2006 Подменю пользователя
сообщение 17.10.19, 17:03
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

Здравствуйте возможно ли в документе скрыть или поместить в низ печатные формы которыми не планируется пользоваться?

fly Подменю пользователя
сообщение 18.10.19, 8:18
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 84
Спасибо сказали: 22 раз
Рейтинг: 21

Laky2006 @ Вчера, 18:03 * ,
Добрый день.
Возможно.

Vofka Подменю пользователя
сообщение 18.10.19, 8:35
Сообщение #3

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13137
Из: Киев
Спасибо сказали: 3987 раз
Рейтинг: 3119.8

fly, наверняка вы знаете какой будет следующий вопрос wink.gif . Можно на него ответить авансом.

Сообщение отредактировал Vofka - 18.10.19, 8:35


Signature
Пишу программы за деньги

fly Подменю пользователя
сообщение 18.10.19, 9:57
Сообщение #4

Говорящий
***
Группа: Пользователи
Сообщений: 84
Спасибо сказали: 22 раз
Рейтинг: 21

Vofka @ Сегодня, 9:35 * ,
Да как бы и без проблем,
только в разных конфигурациях могут отличаться - обычно в модуле объекта соответствующего документа прописан список форм.

типо такого:

МодульОбъекта.ЗаказазПокупателя - УТП
Управление производственным предприятием для Украины, редакция 1.3

Функция ПолучитьСтруктуруПечатныхФорм() Экспорт

    СтруктураПечатныхФорм = Новый Структура("Заказ,ЗаказКорректировка,Счет,Бланк",
                                            "Заказ покупателя",
                                            "Заказ покупателя (с учетом корректировок)",
                                            "Счет на оплату (с учетом корректировок)",
                                            "Бланк товарного наполнения");

    Если ВидОперации = Перечисления.ВидыОперацийЗаказПокупателя.Переработка Тогда
        СтруктураПечатныхФорм.Вставить("ПереченьМатериалов", "Перечень материалов для переработки");
    КонецЕсли;

    Возврат СтруктураПечатныхФорм;

КонецФункции // ПолучитьСтруктуруПечатныхФорм()


достаточно удалить из списка форм соотвествующую, или переместить ее в конец.
но факт остается фактом, что конфигурация какая используется не прописано, Документ не указан и т.п.

Vofka Подменю пользователя
сообщение 18.10.19, 10:21
Сообщение #5

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13137
Из: Киев
Спасибо сказали: 3987 раз
Рейтинг: 3119.8

fly, как же не прописано: Пользователю 1С 8.3, 8.2, 8.1, 8.0 » 1С Управление небольшой фирмой для Украины smile.gif
И тут вопрос, исходя из раздела, полагаю звучит так: можно ли это сделать на уровне пользователя?

Сообщение отредактировал Vofka - 18.10.19, 10:21


Signature
Пишу программы за деньги

Спасибо сказали: fly,

Petre Подменю пользователя
сообщение 18.10.19, 10:27
Сообщение #6

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2638
Из: Київ, Україна
Спасибо сказали: 726 раз
Рейтинг: 701.8

Начнем с того, что это функционал БСП. Конфигурация - УНФ. Какой документ в контексте БСП - не принципиально вообще.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: fly,

fly Подменю пользователя
сообщение 18.10.19, 16:13
Сообщение #7

Говорящий
***
Группа: Пользователи
Сообщений: 84
Спасибо сказали: 22 раз
Рейтинг: 21

Цитата(Petre @ 18.10.19, 11:27) *
Начнем с того, что это функционал БСП. Конфигурация - УНФ. Какой документ в контексте БСП - не принципиально вообще.


на счет УНФ может и одна конфигурация без релизов 1-2-3 и т.п., тут особо не все конфигурации и знаю - хотя возможно уже теперь знаю.


на счет не важности документа
Обработки печати для УНФ для каждого разные
ЗаказПокупателя - определеяет список
Если ПечатнаяФорма <> Неопределено Тогда
        
        ПечатнаяФорма.ТабличныйДокумент = Новый ТабличныйДокумент;
        ПечатнаяФорма.ТабличныйДокумент.КлючПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЗаказПокупателя_ЗаказПокупателя";
        ПечатнаяФорма.ПолныйПутьКМакету = "Документ.ЗаказПокупателя.ПФ_MXL_ЗаказПокупателя";
        ПечатнаяФорма.СинонимМакета = НСтр("ru='Заказ покупателя';uk='Замовлення покупця'");
        
        СформироватьЗаказПокупателя(ПечатнаяФорма, МассивОбъектов, ОбъектыПечати, Ошибки, КодЯзыкаПечать);
        
    КонецЕсли;


РасходнаяНакладная
Если ПечатнаяФорма <> Неопределено Тогда
        
        ПечатнаяФорма.ТабличныйДокумент = Новый ТабличныйДокумент;
        ПечатнаяФорма.ТабличныйДокумент.КлючПараметровПечати = Обработки.ПечатьАктаОбОказанииУслуг.КлючПараметровПечати();
        ПечатнаяФорма.ПолныйПутьКМакету = Обработки.ПечатьАктаОбОказанииУслуг.ПолныйПутьКМакету();
        ПечатнаяФорма.СинонимМакета = Обработки.ПечатьАктаОбОказанииУслуг.ПредставлениеПФ(Ложь);
        
        ДанныеОбъектовПечати = ДанныеДокументовАктОбОказанииУслуг(МассивОбъектов, Ложь);
        Обработки.ПечатьАктаОбОказанииУслуг.СформироватьПФ(ПечатнаяФорма, ДанныеОбъектовПечати, ОбъектыПечати);
        
    КонецЕсли;


и суть не особо изменилась
Изменилось расположение непосредственно где определяется,
ранее УТП-УПП-> МодульОбъекта, в УНФ - МодульМенеджера

Пример из УТП - была под рукой открыта.
В любом случае, спасибо - не было желание лазить smile.gif , для себя на будущее полезно новое найти. smile.gif

Цитата(Vofka @ 18.10.19, 11:21) *
И тут вопрос, исходя из раздела, полагаю звучит так: можно ли это сделать на уровне пользователя?


только внешние печатные формы.

Toka Подменю пользователя
сообщение 21.10.19, 7:28
Сообщение #8

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Laky2006 @ 17.10.19, 18:03 * ,
Администрирование>Печатные формы и обработки>Подменю печать

alla35 Подменю пользователя
сообщение 08.11.19, 15:45
Сообщение #9

Общительный
**
Группа: Пользователи
Сообщений: 18
Спасибо сказали: 3 раз
Рейтинг: 2.6

Laky2006 @ 17.10.19, 17:03 * ,
Ух... Куда всех понесло, а вопрос то в другом, В документе есть значок "Печать с предварительным просмотром" и там куча печатных форм которыми не всегда пользуешься. Вопрос как убрать лишние. Ответ: кнопка "ЕЩЕ" или "ЩЕ" в правом верхнем угле, находим "Змінити форму..." "Командна понель" "Важные команды" "Печать" Печать(Важное)"
И там найдете весь перечень, убираете галочку на против не нужной формы. Нужную форму, перемещаете синими стрелками, на верхней или вниз.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 18.11.19, 2:57
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!