Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Добавить кнопку Печать в самописный документ.          
SpecAgent Подменю пользователя
сообщение 14.06.18, 15:39
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 24
Спасибо сказали: 0 раз
Рейтинг: 0

1С Бухгалтерия 2.0.8.3 . Платформа 8.3.9.2033 Только начал разбираться с этой бедой.

Есть самописный документ ТТН. Нужно добавить кнопку ПЕЧАТЬ.
Что сделал:
1) В Общих командах ДополнительныеПечатныеФормыОбъекта во вкладке 'Тип параметра команды' добавил свой документ
далее в модуле формы добавил
&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        
    УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма)    
    
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
    
    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект)
    
КонецПроцедуры


в модуле менеджера
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт 

    КомандаПечати = КомандыПечати.Добавить();
    КомандаПечати.Идентификатор = "ТТН2014";
    КомандаПечати.Представление = "ТТН 2014";
    КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
    КомандаПечати.СписокФорм    = "ФормаСписка,ФормаДокумента";
    
КонецПроцедуры

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт     
    
    ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТТН2014") Тогда
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ТТН2014", "ТТН2014",
            СформироватьНесколькоТТН(МассивОбъектов),"Документ.ТТН.ТТН2014");
    КонецЕсли;
    
    
КонецПроцедуры

Функция   СформироватьНесколькоТТН(МассивОбъектов)
    
    ТабДокумент = Новый ТабличныйДокумент;
    Для каждого Ссылка из МассивОбъектов Цикл
        ТабДокументОбъекта = СформироватьТТН(Ссылка);
        Если ТабДокумент.ВысотаТаблицы > 0 И ТабДокументОбъекта.ВысотаТаблицы > 0 Тогда
            ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц()
        КонецЕсли;
        ТабДокумент.Вывести(ТабДокументОбъекта)
    КонецЦикла;

    Возврат ТабДокумент

КонецФункции

Функция  СформироватьТТН(Ссылка)

    ТабДокумент = Новый ТабличныйДокумент;
    // подготовка ТабДокумента
    Возврат ТабДокумент

КонецФункции


2) Кнопка "печать" на форме в конфигураторе появилась, в режиме работы нет.

Что пропустил?

Собственно почему кнопка ПЕЧАТЬ не видится в режиме работы? Где-то еще нужно прописывать это документ?


 ! 

Правила: 9
 


Сообщение отредактировал Vofka - 14.06.18, 16:23

SpecAgent Подменю пользователя
сообщение 14.06.18, 21:21
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 24
Спасибо сказали: 0 раз
Рейтинг: 0

SpecAgent @ Сегодня, 16:39 * ,

вопрос снят

most_fucking Подменю пользователя
сообщение 01.07.19, 14:27
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Из: Киев
Спасибо сказали: 1 раз
Рейтинг: 1

SpecAgent @ 14.06.18, 16:39 * ,

Обычно пишут в чем была ошибка, друг у кого-то похожая ситуация

Vladal Подменю пользователя
сообщение 18.11.19, 14:57
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 347
Из: Украина
Спасибо сказали: 60 раз
Рейтинг: 46.2

most_fucking @ 01.07.19, 14:27 * ,

Как вариант - в модуле формы отсутствует обработчик

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
    
    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);
    
КонецПроцедуры

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 10.12.19, 5:25
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!