Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



2 страниц V   1 2 >

>  Средства мультимедиа в мобильном клиенте
alex_shkut
Отправлено: 23.04.24, 17:51


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


DrLivsi @ 08.02.21, 4:32 * ,
А у меня везде написано #Если МобильныйКлиент - и все работает
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178774 · Ответов: 2 · Просмотров: 1234
 

>  Як створити форму налаштування відборів для ТЗ на основі ПостроителяЗапроса или ПостроителяОтчета
alex_shkut
Отправлено: 21.03.24, 18:49


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


alex_shkut @ 19.03.24, 18:13 * ,

//Структура отбора
ПостроительЗапроса.ИсточникДанных = Новый ОписаниеИсточникаДанных(СписокВРаботе);
мОтбор = ПостроительЗапроса.Отбор;
Для каждого Колонка из ЭлементыФормы.ДокументСписокВРаботе.Колонки Цикл
          Если Колонка.Видимость Тогда
               мОтбор.Добавить(Колонка.Имя);
           КонецЕсли;
КонецЦикла;


Процедура КоманднаяПанельВРаботеНастроитьОтбор(Кнопка)

    ФормаО = Документы.ЗаказНаРемонт.ПолучитьФорму("ФормаОтбора",ЭтаФорма);
    ФормаО.ТаблицаОтбор = мОтбор;
    ФормаО.ОткрытьМодально();
    СписокВРаботе = ПолучитьТаблицуПоСостоянию(Перечисления.СтатусыРабот.ВРаботе,мОтбор);

КонецПроцедуры


Где ФормаО.ТаблицаОтбор = Тип Отбор;
Дальше разберетесь, думаю.
Прикольно, что можно использовать методы ПостроителяЗапроса, немного добавляя (убавляя) параметры - еще не пробовал, но наверное легче чем вручную формировать условия для своего запроса.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178630 · Ответов: 7 · Просмотров: 904
 

>  Як створити форму налаштування відборів для ТЗ на основі ПостроителяЗапроса или ПостроителяОтчета
alex_shkut
Отправлено: 19.03.24, 18:13


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


nik389 @ Сегодня, 18:01 * ,
Я намагаюся створити функціонал отбору для ТЗ, такий як типовий для звичайних форм списків документів, тощо.
Без зайвого навантаження типу СКД и т.і.
Просто і лаконічно.

Ну ось є перші результати.
//Структура отбора
        ПостроительЗапроса.ИсточникДанных = Новый ОписаниеИсточникаДанных(СписокВРаботе);
        Для каждого Колонка из ЭлементыФормы.ДокументСписокВРаботе.Колонки Цикл
            Если Колонка.Видимость Тогда
                Элем = мОтбор.Добавить(Колонка.Имя);
            КонецЕсли;
        КонецЦикла;


Отримав повноцінну структуру усіх можливих отборів по ТЗ.
По видимих колонках, бо буду обробляти також накопичуваний відбір "по значенню у поточній колонці".
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178617 · Ответов: 7 · Просмотров: 904
 

>  Як створити форму налаштування відборів для ТЗ на основі ПостроителяЗапроса или ПостроителяОтчета
alex_shkut
Отправлено: 19.03.24, 17:05


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


nik389 @ Сегодня, 16:39 * ,
Щось подібне до стандартної форми настройки відборів для звичайних форм.
ПостроительЗапроса - 10%
ПостроительОтчета - 50%
СКД - 120%
Навіщо зайвий функціонал, тормоза і оперативна пам'ять для простої задачі?
Тим більше, що наступне використовує попереднє.
А досить лише ПостроительЗапроса.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178615 · Ответов: 7 · Просмотров: 904
 

>  Як створити форму налаштування відборів для ТЗ на основі ПостроителяЗапроса или ПостроителяОтчета
alex_shkut
Отправлено: 19.03.24, 16:01


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


AnryMc @ Сегодня, 15:31 * ,
Як виконати - я знаю. Як показати користувачу налаштування цих отборів?
Щоб у формі не було таблиці ПостроительОтчета.Отбор на все хлебало, а відкривалася окрема форма тиму стандартного налаштування отборів.
Для Каждого СтрокаКоллекции Из ТаблицаОтборов Цикл


Як налаштувати цю саму ТаблицаОтборов?
Ага, і якщо це не ПостроительОтчета, а ПостроительЗапроса?
У ПостроителяЗапроса також є Відбір.
Навіщо мені "паровозом куча непотрібного функціоналу?

alex_shkut @ Сегодня, 15:59 * ,
Якраз завдання в тому, щоб дати можливість користувачу вібрати ці самі отбори. Множинні.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178612 · Ответов: 7 · Просмотров: 904
 

>  Як створити форму налаштування відборів для ТЗ на основі ПостроителяЗапроса или ПостроителяОтчета
alex_shkut
Отправлено: 19.03.24, 15:28


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


Власне завдання: Створити множинний відбір для ТЗ як у списках документів і т.і.
Є форма з ТЗ.
Форма додана до Документу.
Сам відбір доступний у ПострительЗапроса - все гарно.
Як створити та відобразити форму налаштування цих відборів як у стандартних списках типу: Використання, Поле, Тип порівняння, значення?
В мене проблема сформувати та показати цю форму.
Які є ідеї?

alex_shkut @ Сегодня, 15:24 * ,
У мене є ідея винести цю форму у Обробку і там це трохи простіше.
Користувач взагалі нічого не помітить, бо явного зв'язку з Документом немає ніякого.

alex_shkut @ Сегодня, 15:27 * ,
І прошу мене не хаяти - "це папереднікі", розгрібаю г...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178609 · Ответов: 7 · Просмотров: 904
 

>  Фото в отчете номенклатуры
alex_shkut
Отправлено: 19.03.24, 15:13


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


burza @ 08.03.24, 12:17 * ,
Знает:
Для ячейки справа от Номенклатура определите имя: ОбластьКартинка, всуньте туда свою картинку.
За размеры пока не парьтесь - потом подгоните.

ЭтикеткаОбласть         = Макет.ПолучитьОбласть("Шапка|Столбец");
ОбластьКартинка            = ЭтикеткаОбласть.Области.ОбластьКартинка;
РисунокКартинка            = ЭтикеткаОбласть.Рисунки.Изображение;

РисунокКартинка.Расположить(ОбластьКартинка);

Если НЕ СтрокаИзСписка.Номенклатура.ОсновноеИзображение.Пустая() Тогда
        ЭтикеткаОбласть.Рисунки.Изображение.Картинка = СтрокаИзСписка.Номенклатура.ОсновноеИзображение.Хранилище.Получить();
Иначе
    ЭтикеткаОбласть.Рисунки.Изображение.Картинка = мПустаяКартинка;
КонецЕсли;


Думаю, разберетесь... В свойствах Картинки на макете ставь Пропорционально.

burza @ 08.03.24, 12:17 * ,
Я бы не парился с СКД ради такого отчета, но все же:
ТекОбласть = ДокументРезультат.Область(стПерв, Кл, Ст-1,Кл);


попробуйте заменить на:
ТекОбласть = ДокументРезультат.Область(ОбластьКартинки);


Вы растягиваете область изображения на всю высоту отчета, а надо создавать отдельную область для каждой строки.
Там еще будут приколы, но мы разберемся...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178608 · Ответов: 2 · Просмотров: 424
 

>  Загрузка документа в Excel. Формат файла не поддерживается
alex_shkut
Отправлено: 19.03.24, 14:42


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


Slon747 @ 15.03.24, 16:49 * ,
В напрямку LibreOffice не дивилися? Я усе через нього роблю.
Процедура ЗагрузитьИзФайла()
    ТипФайла = 0; //0-файл не прочитан,1- для МС Экселя,2- для ОпенОфиса
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Фильтр = "Табличный документ(*.xls)|*.xls|Табличный документ(*.xlsx)|*.xlsx";
    Если не Диалог.Выбрать() Тогда
        Возврат;
    КонецЕсли;
    Если ДанныеФайла.Количество()>0 Тогда
        Режим = РежимДиалогаВопрос.ДаНет;
        Текст = "ru = ""Табличная часть будет очищена, продолжить?"";"
         + " uk = ""Таблична частина буде очищена, продовжити?""";
        Ответ = Вопрос(НСтр(Текст), Режим, 0);
    КонецЕсли;
    Если Ответ = КодВозвратаДиалога.Нет Тогда
        Возврат;
    КонецЕсли;
    ТабЗн = Новый ТаблицаЗначений;
    Попытка
        ТабЗн.Прочитать(Диалог.ПолноеИмяФайла);
        ТипФайла = 1;
    Исключение
    КонецПопытки;
    Если ТипФайла=0 Тогда
        Попытка
            ТабЗн=ОО.ЗагрузитьТЗизФайла(Диалог.ПолноеИмяФайла,1);
            ТипФайла = 2;
        Исключение
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Не найдено подходящего приложения для загрузки файла"+Символы.ПС+ОписаниеОшибки();
            Сообщение.Сообщить();
            Возврат;
        КонецПопытки;
    КонецЕсли;
    ДанныеФайла.Очистить();
    Шкут_Общий.ДополнитьКолонкиТаблицыЗначений(ДанныеФайла,ТабЗн);
    ОбщегоНазначения.ЗагрузитьВТаблицуЗначений(ТабЗн,ДанныеФайла);
    ДанныеФайла.Колонки.Добавить("Проект",Новый ОписаниеТипов("СправочникСсылка.Проекты"));
    ДанныеФайла.Колонки.Добавить("Счет",Новый ОписаниеТипов("ДокументСсылка.СчетНаОплатуПокупателю"));
    ДанныеФайла.Колонки.Добавить("Корр",Новый ОписаниеТипов("ДокументСсылка.КорректировкаДолга"));
    
    ЭлементыФормы.ДанныеФайла.СоздатьКолонки();
    Для Каждого Колонка из ЭлементыФормы.ДанныеФайла.Колонки Цикл
        Колонка.Ширина = 4;
    КонецЦикла;
    
        
КонецПроцедуры

Процедура КоманднаяПанель2ВосстановитьДаты(Кнопка)
    Колонка = ЭлементыФормы.ДанныеФайла.ТекущаяКолонка;
    Для Каждого Строка из ДанныеФайла Цикл
        Если ЗначениеЗаполнено(Строка[Колонка.Имя]) Тогда
            Попытка
                Строка[Колонка.Имя] = Дата("19000101")+((Строка[Колонка.Имя]-2)*24*60*60);
            Исключение
            КонецПопытки;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры


Код загального модуля ОО:
функция ПривестиФайлКУРЛ(ПутьКФайлу)

    ПутьКФайлу = СтрЗаменить(ПутьКФайлу," ","%20");
    ПутьКФайлу = СтрЗаменить(ПутьКФайлу,"\","/");
    Возврат "file:/" + "/localhost/" + ПутьКФайлу;

Конецфункции

Функция ЗагрузитьТЗизФайла(ПутьКФайлу,текЛист=1,Знач endCol=0) Экспорт

    //OpenOffice Calc//
    Попытка
            ServiceManager = Новый COMОбъект("com.sun.star.ServiceManager");
    Исключение
            Предупреждение(ОписаниеОшибки() + Символы.ПС + "программа OpenOffice\LibreOffice не установлена на данном компьютере!");
    Возврат Неопределено;
    КонецПопытки;
    
    Desktop = ServiceManager.createInstance("com.sun.star.frame.Desktop");
    Свойства = ServiceManager.Bridge_GetStruct("com.sun.star.beans.PropertyValue");
    Свойства.Name = "AsTemplate";
    Свойства.Value = Истина;
    Args = Новый COMSafeArray("VT_VARIANT", 2);
    Args.SetValue(0, Свойства);
    Свойства1 = ServiceManager.Bridge_GetStruct("com.sun.star.beans.PropertyValue");
    Свойства1.Name = "Hidden";
    Свойства1.Value = Истина;
    Args.SetValue(1,Свойства1);
    Попытка
        FileProvider=ServiceManager.createInstance("com.sun.star.ucb.FileContentProvider");
        URL=FileProvider.getFileURLFromSystemPath("",ПутьКФайлу);
        Document = Desktop.LoadComponentFromURL(URL, "_blank", 0, Args);
    Исключение
        ServiceManager = Неопределено;
    КонецПопытки;
    Sheets = Document.getSheets();
    Если Sheets.Count<текЛист Тогда
        Сообщить("Количество страниц в файле меньше, чем запрошено");
        ServiceManager = Неопределено;
        Возврат Неопределено;
    КонецЕсли;
    Sheet = Sheets.getByIndex(текЛист-1);
    Курсор   = Sheet.createCursor();
    Курсор.gotoEndOfUsedArea(Истина);
    endCol   = Курсор.Columns.Count - 1;
    endRow  = Курсор.Rows.Count - 1;
    begCol = 0;
    begRow = 0;
    нКол = 0;
    локТабЗнач = Новый ТаблицаЗначений;
    локТабЗнач.Колонки.Очистить();
    КС = Новый КвалификаторыСтроки();
    Массив = Новый Массив;
    Массив.Добавить(Тип("Строка"));
    ОписаниеТиповСтрока = Новый ОписаниеТипов(Массив, , КС);
    Пока нКол <= endCol Цикл
        ИмяКол = "К"+Строка(нкол+1);
        локТабЗнач.Колонки.Добавить(ИмяКол,ОписаниеТиповСтрока);
        нКол = нКол + 1;
    КонецЦикла;
    Range = Sheet.getCellRangeByPosition(begCol, begRow, endCol, endRow);
    МассивКом = Новый COMSafeArray("VT_VARIANT", Range.Columns.Count, Range.Rows.Count);
    МассивКом = Range.getDataArray();
    тмпПростойМассив = МассивКом.Выгрузить();
    Для каждого массив из тмпПростойМассив Цикл
         ит = 0;
         НовСтрока = локТабЗНач.Добавить();
         Для каждого ЭлементМассива из массив цикл
               НовСтрока[ит] = ЭлементМассива;
               ит = ит + 1;
         КонецЦикла;
    КонецЦикла;
    Document.Close(True);
    Document = Неопределено;
    
    ServiceManager = Неопределено;
    Возврат локТабЗнач;

КонецФункции
  
Процедура ВыгрузитьТЗвФайл(ТаблицаРезультата) Экспорт

    //OpenOffice Calc///////////////////////////////////////////////////////////////////////////
    Попытка
        ServiceManager = Новый COMОбъект("com.sun.star.ServiceManager");
    Исключение
        Предупреждение(ОписаниеОшибки() + Символы.ПС + "программа OpenOffice не установлена на данном компьютере!");
        Возврат;
    КонецПопытки;
    Desktop = ServiceManager.createInstance("com.sun.star.frame.Desktop");
    Свойства = ServiceManager.Bridge_GetStruct("com.sun.star.beans.PropertyValue");
    Свойства.Name = "AsTemplate";
    Свойства.Value = Истина;
    Args = Новый COMSafeArray("VT_VARIANT", 3);
    Args.SetValue(0, Свойства);
    Свойства1 = ServiceManager.Bridge_GetStruct("com.sun.star.beans.PropertyValue");
    Свойства1.Name = "Hidden";
    Свойства1.Value = Истина;
    Args.SetValue(1, Свойства1);
    Document = Desktop.LoadComponentFromURL("private:factory/scalc", "_blank", 0, Args);
    Sheets = Document.getSheets();
    Sheet = Sheets.getByIndex(0);
    мИтКол = 0;
    Для каждого кол из ТаблицаРезультата.Колонки Цикл
        Sheet.getCellByPosition(мИтКол,0).setString(кол.Имя);
        мИтКол = мИтКол + 1;
    КонецЦикла;
  
    ВсегоСтрок = ТаблицаРезультата.Количество();
    ВсегоКолонок = ТаблицаРезультата.Колонки.Количество();
    МассивКОМ = Новый COMSafeArray("VT_VARIANT", ВсегоСтрок,ВсегоКолонок);
    иткол = 0;
    итстр = 0;

    Для каждого стр из ТаблицаРезультата Цикл
        Для каждого кол из ТаблицаРезультата.Колонки Цикл
            стрРез = СокрЛП(стр[кол.Имя]);
            МассивКОМ.SetValue(итстр,иткол,стрРез);
            иткол = иткол+1;
         КонецЦикла;
        иткол = 0;
        итстр = ?(итстр=ВсегоСтрок,0,итстр+1);
    КонецЦикла;
    begCol = 0;
    begRow = 1;
    endCol = ВсегоКолонок-1;
    endRow = ВсегоСтрок;
    Range = Sheet.getCellRangeByPosition(begCol, begRow, endCol, endRow);
    Range.setDataArray(МассивКОМ);
    //Document.storeToURL(ПривестиФайлКУРЛ(ПутьКФайлу),Args);
    Свойства2 = ServiceManager.Bridge_GetStruct("com.sun.star.beans.PropertyValue");
    Свойства2.Name = "FilterName";
    Свойства2.Value = "MS Excel 97";
    Args.SetValue(2,Свойства2);
    Document.GetCurrentController().GetFrame().GetContainerWindow().SetVisible(Истина);
    //Document.storeToURL(ПривестиФайлКУРЛ(ФайлКартотеки),Args);

КонецПроцедуры


І код з мого власного модуля:
Процедура ДополнитьКолонкиТаблицыЗначений(ТаблицаБазовая,ТаблицаДополнений) Экспорт

    Для каждого Колонка из ТаблицаДополнений.Колонки Цикл

        Если Не(ТаблицаБазовая.Колонки.Найти(Колонка.Имя) = Неопределено) тогда
            //Колонка уже есть
            Продолжить;
        КонецЕсли;

        ТаблицаБазовая.Колонки.Добавить(Колонка.Имя,Колонка.ТипЗначения,Колонка.Заголовок,Колонка.Ширина);

    КонецЦикла;

КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178607 · Ответов: 12 · Просмотров: 1620
 

>  Не могу получить макет
alex_shkut
Отправлено: 23.02.24, 12:16


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


AnryMc @ Сегодня, 11:18 * ,
Нету открытого Обїекта = нету Макета.
Ворос решен = ОбщийМакет;

alex_shkut @ Сегодня, 11:46 * ,
Если на текущий момент документ не открыт (нету ЭтотОбъект) то и печатную форму получить нельзя. Макет.
Для прочих состояний используем общие макеты, которые можно получать независимо от форм.

Цитата(AnryMc @ 23.02.24, 11:18) *
Объект не открыт - макет поглючен

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178475 · Ответов: 9 · Просмотров: 1546
 

>  Не могу получить макет
alex_shkut
Отправлено: 23.02.24, 11:07


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


AnryMc @ Сегодня, 10:34 * ,
Не, это толстый клиент.
В списке добавлена колонка - на Отправку.
Все помеченные надо распечатать водителю в наряд и сменить статус - "В доставке".
Так вот возникла проблема получения макета, который доступен только через Объект.
Решено Общим макетом.

alex_shkut @ Сегодня, 10:49 * ,
Для новичков - получить макет печатной формы документа невозможно ВНЕ открытого Объекта.
Если нужно что-то распечатать когда документ не открыт - используйте Общий макет (произвольный) и туда пихайте все что угодно, на ваш вкус.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178472 · Ответов: 9 · Просмотров: 1546
 

>  Не могу получить макет
alex_shkut
Отправлено: 23.02.24, 9:50


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


volodya1122 @ Сегодня, 9:32 * ,
В модуле списка документов.
Я уже примерно понял - нельзя получить макет вне Объекта.
Нужно вынести его в общие макеты и оттуда вызывать.
Для таких случаев, когда Объекта нет нужно использовать Общие макеты.
Щас проверю и отпишусь.

ДокументОбъект.<Имя документа> (DocumentObject.<Document name>)
ПолучитьМакет (GetTemplate)
Синтаксис:
ПолучитьМакет(<Макет>)
Параметры:
<Макет> (обязательный)

А вот так заработало:
Макет = ПолучитьОбщийМакет("НарядНаПеревозку");

До этого у меня не было таких задач, где из списка документов необходимо печатать что нибудь.
Тут встала задача пометить в списке документы, распечатать этот список и перенести документы в другое состояние.
Ну вроде решилось )
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178468 · Ответов: 9 · Просмотров: 1546
 

>  Не могу получить макет
alex_shkut
Отправлено: 23.02.24, 9:32


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


denis84 @ Сегодня, 9:23 * ,
Та же ошибка - Процедура или функция с указанным именем не определена (ПолучитьМакет)

alex_shkut @ Сегодня, 9:26 * ,
Согласен, ЭтотОбъект тут нету, так как список документов. Но просто получить Макет почему не получается?

МассПечать = НакладнаяСобрано.НайтиСтроки(Новый Структура("Выбрать",истина));
Сообщить(""+МассПечать.Количество());
    
Макет = ПолучитьМакет("Наряд");
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178466 · Ответов: 9 · Просмотров: 1546
 

>  Не могу получить макет
alex_shkut
Отправлено: 23.02.24, 9:21


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


Уже 15 лет работаю с 1С и тут туплю. Переменная не определена (ЭтотОбъект) Процедура или функция с указанным именем не определена (ПолучитьМакет) ЧЯДНТ.
Макет = ЭтотОбъект.ПолучитьМакет("Наряд"); // ошибка.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178464 · Ответов: 9 · Просмотров: 1546
 

>  Як виправити запрос, щоб він правильно відпрацьовував.
alex_shkut
Отправлено: 13.09.23, 8:33


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


ТекстЗапроса = "ВЫБРАТЬ
               |    м_ТранспортныеСредства.Ссылка КАК Ссылка,
               |    ВодителиВТССрезПоследних.Водитель КАК Водитель,
               |    ТехобслуживаниеТССрезПоследних.ДатаТО КАК ДатаТО,
               |    м_ТранспортныеСредства.ОсновноеТопливо КАК ОсновноеТопливо,
               |    м_ТранспортныеСредства.ДополнительноеТопливо КАК ДополнительноеТопливо,
               |    м_ТранспортныеСредства.Грузоподъемность КАК Грузоподъемность,
               |    ЗаправкиТС.Количество КАК ТопливоКоличество,
               |    ЗаправкиТС.Сумма КАК ТопливоСумма
               |ИЗ
               |    Справочник.м_ТранспортныеСредства КАК м_ТранспортныеСредства
               |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ТехобслуживаниеТС.СрезПоследних КАК ТехобслуживаниеТССрезПоследних
               |        ПО м_ТранспортныеСредства.Ссылка = ТехобслуживаниеТССрезПоследних.ТранспортноеСредство
               |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ВодителиВТС.СрезПоследних КАК ВодителиВТССрезПоследних
               |        ПО м_ТранспортныеСредства.Ссылка = ВодителиВТССрезПоследних.ТранспортноеСредство
               |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗаправкиТС КАК ЗаправкиТС
               |        ПО м_ТранспортныеСредства.Ссылка = ЗаправкиТС.ТранспортноеСредство
               |ГДЕ
               |    НЕ м_ТранспортныеСредства.ЭтоГруппа
               |    И НЕ м_ТранспортныеСредства.ПометкаУдаления
              // |    И ЗаправкиТС.Период МЕЖДУ &НачПериод И &КонПериод
               |
               |УПОРЯДОЧИТЬ ПО
               |    м_ТранспортныеСредства.Наименование";


Суть питання - якщо я розкоментую відбір по періоду, таблиця пуста. Що я роблю не так?

alex_shkut @ Сегодня, 9:16 * ,
Переробив запит щоб сумувалася кількість і сума, але результат той самий - таблиця пуста.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #177695 · Ответов: 4 · Просмотров: 996
 

>  Здається, я знайшов ще один глюк 1С
alex_shkut
Отправлено: 24.04.23, 13:21


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


andr_andrey @ 28.09.18, 12:33 * ,
Как бі первое, что приходит на ум - ЭтоНовый()?
Источник.Ссылка; ???
  Форум: С чем мне приходилось сталкиваться... · Просмотр сообщения: #177118 · Ответов: 4 · Просмотров: 2193
 

>  Война с Россией
alex_shkut
Отправлено: 24.04.23, 13:12


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


Vofka @ 03.03.23, 10:34 * ,
Я не він, але у мене там також бан давно.
Інколи, дуже рідко захожу на цей форум, це коли вже зовсім нема думок.
@Vofka, дуже тобі дякую за цей форум.
  Форум: Офф-топик · Просмотр сообщения: #177117 · Ответов: 93 · Просмотров: 42009
 

>  Итоги по столбцу в документе
alex_shkut
Отправлено: 07.12.22, 17:41


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


alex_shkut @ Сегодня, 16:00 * ,
Я уже сам раскопал.
Для колонки устанавливаем ОтображатьИтогиВПодвале = ложь (Чтобы автоматом не пересчитывало сумму) и пишем в Подвал.Текст нужной колонки то, что нужно.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #176621 · Ответов: 10 · Просмотров: 10131
 

>  Итоги по столбцу в документе
alex_shkut
Отправлено: 07.12.22, 15:00


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


sava1 @ 05.05.20, 14:23 * ,
Подниму тему...
Кто подскажет, как вывести результат расчета в подвал Табличного поля? Например - средневзвешенное.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #176619 · Ответов: 10 · Просмотров: 10131
 

>  Расшифровка отчета СКД: отбор по составному типу поля
alex_shkut
Отправлено: 20.08.19, 13:58


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


Constantus @ Сегодня, 13:49 * ,
Можно попробовать
Если 000002222 ТОГДА 000001111
Если 000001111 ТОГДА 000001111
То есть подменяем все ненужное нужным. Но что-то такой подход настораживает, если работа не разовая.
Интуиция подсказывает, что все равно расшифровка покажет регистраторы где 000001111.
Кликая по Коду мы передаем в запрос Параметр - 000001111.
Запрос выполняется правильно.
  Форум: Система компоновки данных · Просмотр сообщения: #154866 · Ответов: 4 · Просмотров: 2215
 

>  Где можно прочитать о написании драйверов для торгового оборудования?
alex_shkut
Отправлено: 20.08.19, 10:12


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


А если совсем точнее: драйверы торгового оборудования
Нужна подписка, или тестовый вариант smile.gif
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #154859 · Ответов: 2 · Просмотров: 1272
 

>  1С УПП 1.3: Отчет Кассовая книга, ошибка формирования Страниц.
alex_shkut
Отправлено: 20.08.19, 8:43


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


В итоге, задача решилась копированием кассовой книги из конфигурации Бухгалтерия с небольшим допиливанием под УПП.
И в Бухгалтерии таки используется дополнительный регистр, но он называется - ПоследниеНомераКассовойКниги smile.gif
Логика та же, что я писал раньше.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154856 · Ответов: 4 · Просмотров: 3367
 

>  Расшифровка отчета СКД: отбор по составному типу поля
alex_shkut
Отправлено: 20.08.19, 8:39


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


Constantus @ Вчера, 10:22 * ,
Если посмотреть на решение, то я бы реализовал все это по принципу регистра Контактная информация.
Один справочник с видами размеров и регистр со значениями.
Номенклатура, ВидРазмера, ЗначениеРазмера.
Потому как замучаешься справочники создавать )

А по вопросу - чуток не понял, что пытаемся получить.
  Форум: Система компоновки данных · Просмотр сообщения: #154855 · Ответов: 4 · Просмотров: 2215
 

>  Игнорируется ограничение прав.
alex_shkut
Отправлено: 20.08.19, 8:25


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


Schlesinger @ Вчера, 16:36 * ,
Для начала надо понять, конфигурация типовая или переписаная. Кто-то мог "подправить" роль. Или демобаза очень старая и роль существенно изменена. Или...
включена еще одна роль.

Насколько я помню, роль Бухгалтер не позволяет только регламентные операции по закрытию периода. Остальное - можно.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #154853 · Ответов: 2 · Просмотров: 1233
 

>  1С УПП 1.3: Отчет Кассовая книга, ошибка формирования Страниц.
alex_shkut
Отправлено: 31.07.19, 22:40


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


Почти все получилось ))), работает на любой зафиксеынй в регистре период. Если записи на дату нет - книга не формируется. Поправим )
Вернемся к регистру НачальныеНомера, и посчитаем.... бред.
Надо поформировать КК и позаписывать номера листов, само устаканится...


А вот и вылезли нюансы. Если сформировать КК за год - нумерация "ползет". Надо контролировать переход через сутки, и записывать в регистр новые номера листов.


В итоге многих размышлений пришло решение - поработать над данным вопросом, он не так-то уж и прост. Много вариаций тут есть. Будет готовое решение - продолжим тему.
Но решить это надо по-любому.

И очень даже интересно, почему в такой конфе как УПП это до сих пор не разрешено?

Вот один из моментов в коде )))
МенеджерЗаписи.Период = ДатаКон+1; //Попытка записать Завтра ), а юзер сфрмировал концом года
//Жопа в том, что данный документ намного раньше ДатаКон - его надо фиксить
Действительно, последний документ в кассе не концом года )
Вот как-то так мыслим...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154276 · Ответов: 4 · Просмотров: 3367
 

>  1С УПП 1.3: Отчет Кассовая книга, ошибка формирования Страниц.
alex_shkut
Отправлено: 31.07.19, 20:37


Общительный
**

Группа: Пользователи
Сообщений: 38
Регистрация: 31.05.11
Из: Сумы
Пользователь №: 9511


alex_shkut @ Сегодня, 20:03 * ,
И тут все портит Функция СформироватьСтруктуруНомеровЛистов
Она выбирает все периоды движений по Датам, и последовательно присваивает номера листов, не учитывая их количество за день.
Просто тупо количество дней работы кассы. Один лист за день - будем бороться...

Цитата(alex_shkut @ 31.07.19, 21:26) *
И тут все портит Функция СформироватьСтруктуруНомеровЛистов
Она выбирает все периоды движений по Датам, и последовательно присваивает номера листов, не учитывая их количество за день.
Просто тупо количество дней работы кассы. Один лист за день - будем бороться...

По большому счету эта функция теперь совсем не нужна - мы будем опираться на "новый" регистр, где в любое время можем поменять нумерацию листов.
Фууухххх, тяжко. Почему УПП-шники не уделили этому внимания?
Кассовая дисциплина, однако!

Вы не удивляйтесь - до утра я должен это сделать.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154275 · Ответов: 4 · Просмотров: 3367
 

2 страниц V   1 2 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 23.05.24, 2:31
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!