Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



8 страниц V   1 2 3 > » 

>  Инвентаризация. Неправильные остатки.
denis84
Отправлено: 13.01.21, 21:51


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Billibons @ Сегодня, 16:10 * ,
Я такую задачу решал перепроведением по хронологии документов. Других вариантов не искал. Как партии исправить не нашел. По каждой позиции перепроводил
  Форум: Остальные конфигурации 1С 8 · Просмотр сообщения: #169735 · Ответов: 6 · Просмотров: 149
 

>  Инвентаризация. Неправильные остатки.
denis84
Отправлено: 12.01.21, 14:17


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Billibons @ Сегодня, 14:01 * ,
Добрый день! А перепровести документы в хронологии по этой номенклатуре не пробовали? У нас такое было когда изменяли дату и время проведения документов движения товара
  Форум: Остальные конфигурации 1С 8 · Просмотр сообщения: #169704 · Ответов: 6 · Просмотров: 149
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
denis84
Отправлено: 12.01.21, 9:30


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Lamozavrik @ Вчера, 17:08 * ,
ФормаСпецификации   = ЭтотОбъект.ПолучитьФорму("ФормаСпецификации");
Для Каждого ТекСтрока Из Товары Цикл  // заполним табличную часть документа, из ТаблицыЗначений
     НС = ФормаСпецификации.Спецификация.Добавить();
     НС.Номенклатура = ТекСтрока.Номенклатура;
КонецЦикла;  
ФормаСпецификации.ОткрытьМодально();


Вот такой вариант у меня работает
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169689 · Ответов: 9 · Просмотров: 241
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
denis84
Отправлено: 11.01.21, 16:53


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Lamozavrik @ Сегодня, 16:48 * ,
Надо смотреть обработку! Может мы разговариваем о разных вещах (не понимаем друг друга). Киньте мне на почту в личку написал адрес
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169662 · Ответов: 9 · Просмотров: 241
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
denis84
Отправлено: 11.01.21, 16:43


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Lamozavrik @ Сегодня, 16:35 * ,

ФормаСпецификации = ЭтотОбъект.ПолучитьФорму("ФормаСпецификации"); //Получаю новую форму
    
    Для каждого ТекСтрока из Товары Цикл //В цикле перебираю данные из табличной части "Товары". В "ТекСтрока" всё присутствует
        СтрокаТабличнойЧасти = ФормаСпецификации.Спецификация.Добавить(); //Добавляю строку в табличную часть "Спецификации"
        СтрокаТабличнойЧасти.НомерЯщика = Число(ТекСтрока.ПорядковыйНомер); //Заполняю значения реквизитов
        СтрокаТабличнойЧасти.НеттоЯщика = Число(ТекСтрока.КоличествоNetto);
    КонецЦикла;

ФормаСпецификации.ОткрытьМодально();
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169660 · Ответов: 9 · Просмотров: 241
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
denis84
Отправлено: 11.01.21, 16:28


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Lamozavrik @ Сегодня, 16:23 * ,
"Товары" табличная часть этой формы? Попробуйте написать "Форма.Товары"
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169658 · Ответов: 9 · Просмотров: 241
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
denis84
Отправлено: 11.01.21, 16:16


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Lamozavrik @ Сегодня, 15:48 * ,
Добрый день! У Вас нет объекта из которого получать данные(т.е. документа из которого необходимо прочитать табличную часть).

   Док = СсылкаНаОбъект;  // реквизит обработки - ссылка на документ из которого надо прочитать табличную часть
  
   Для каждого Стр Из Док.Товары Цикл // Цикл обработки табличной части "Товары"
       НоваяСтр = Форма.Спецификация.Добавить();
       НоваяСтр.НомерСтроки = Стр.НомерСтроки;
       НоваяСтр.Номенклатура = Стр.Номенклатура.Наименование;
       НоваяСтр.Кво = 0;
       НоваяСтр.КвоДокумент = Стр.Количество;
   КонецЦикла;
   Форма.Открыть();


Если я Вас правильно понял
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169656 · Ответов: 9 · Просмотров: 241
 

>  Ощадбанк - поделитесь форматом DBF для экспорта выписок из 1С
denis84
Отправлено: 05.01.21, 11:15


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


eact @ Сегодня, 10:38 * ,
Добрый день! Скачать из сайта "Ощада" можно форму для файла DBF. И заполнять в четкой последовательности поля (очень важно)
  Форум: Тематическое общение · Просмотр сообщения: #169543 · Ответов: 2 · Просмотров: 180
 

>  Запись в регистр сведений более одной записи по регистратору
denis84
Отправлено: 28.12.20, 11:30


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Yevhenii_S @ Сегодня, 11:03 * ,
Добрый день! Есть такая фишка, как версионирование объектов. И если мне не изменяет память, то в регистр пишет каждый раз, как только перезаписали документ. Но эту штуку необходимо настроить, для тех объектов, которые хотите видеть изменения (версии).
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169393 · Ответов: 7 · Просмотров: 249
 

>  Расчет отпускных для Бухгалтерии (управляемые формы)
denis84
Отправлено: 23.12.20, 13:11


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


advokat @ Сегодня, 12:49 * ,
Наверно в модуле обработки нет такой функции

Функция СведенияОВнешнейОбработке


А через файл - открыть работает?
  Форум: 1С:Предприятие 8 · Просмотр сообщения: #169308 · Ответов: 7 · Просмотров: 258
 

>  В журнал регистрации не записываются "Метаданные" и "Данные"
denis84
Отправлено: 18.12.20, 11:20


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Добрый день! Воспользуйтесь во таким сервисом для загрузки картинки

загрузить фото
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #169191 · Ответов: 10 · Просмотров: 327
 

>  Конфигурация собственной разработки . Разработка отчета
denis84
Отправлено: 17.12.20, 12:59


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


TohaMonster @ Сегодня, 12:54 * ,
Спасибо за ответ. Буду пробовать!
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169153 · Ответов: 2 · Просмотров: 190
 

>  Конфигурация собственной разработки . Разработка отчета
denis84
Отправлено: 16.12.20, 11:56


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Добрый день! Есть задача:
Сотрудник в течении месяца может работать на 2-х участках во вредных условиях, т.е. 40 часов работал на участке 3100 и 60 часов на участке 3141. У этих участков «родитель» один «31».
Необходимо посчитать сотрудников по участкам и по верхнему уровню иерархии(родителю) в зависимости от того сколько он получил «вредняка». Т.е. « <=100» столько людей, «>100 и <=200» столько людей и т.д.
Если по участкам считать итоги, то этот сотрудник должен быть и на одном и на другом участке, но в итогах по родителю считаться один раз.
Написал такой запрос:

Запрос.Текст = 
        "ВЫБРАТЬ
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Сотрудник.Ссылка КАК Сотрудник,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Сотрудник.Ссылка КАК СотрудникСсылка,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Сотрудник.Представление,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Подразделение.Ссылка КАК СотрудникПодразделениеСсылка,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Подразделение.Представление,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Профессия КАК Профессия,
        |    СУММА(СредниеИЭффективныеЗначенияОстаткиИОбороты.ВнутреннееОборот) КАК ВнутреннееОборот,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Подразделение.Родитель КАК ПодразделениеРодитель
        |ИЗ
        |    РегистрНакопления.СредниеИЭффективныеЗначения.ОстаткиИОбороты(&НачДата, &КонДата, , , ) КАК СредниеИЭффективныеЗначенияОстаткиИОбороты
        |ГДЕ
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Подразделение.Ссылка.Код <> &Уч
        |
        |СГРУППИРОВАТЬ ПО
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Подразделение.Родитель,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Подразделение.Ссылка,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Сотрудник.Ссылка,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Профессия,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Сотрудник.Ссылка,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Сотрудник.Представление,
        |    СредниеИЭффективныеЗначенияОстаткиИОбороты.Подразделение.Представление
        |
        |УПОРЯДОЧИТЬ ПО
        |    ПодразделениеРодитель,
        |    СотрудникПодразделениеСсылка,
        |    Сотрудник
        |ИТОГИ
        |    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ Сотрудник),
        |    СУММА(ВнутреннееОборот)
        |ПО
        |    ОБЩИЕ,
        |    ПодразделениеРодитель,
        |    СотрудникПодразделениеСсылка,
        |    СотрудникСсылка
        |АВТОУПОРЯДОЧИВАНИЕ";


по нему полкчаю итоговое количество людей в целом по родителю, но посчитать в диапазонах, как описал выше не могу
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169118 · Ответов: 2 · Просмотров: 190
 

>  Курс Подготовка к экзамену 1С:Специалист по платформе 8.3
denis84
Отправлено: 15.12.20, 16:16


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Добрый день! Можете, пожалуйста еще раз выложить
  Форум: Обучающее видео · Просмотр сообщения: #169087 · Ответов: 6 · Просмотров: 591
 

>  Как вывести на печатную форму номер телефона основного менеджера контрагента в расходной накладной?
denis84
Отправлено: 15.12.20, 10:15


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


victor_as @ Вчера, 21:22 * ,
добрый день! Вот такой вариант:
Запрос = Новый Запрос;
Запрос.Текст =
    "ВЫБРАТЬ
    |    КонтактнаяИнформация.Объект Как Контакт,
    |    ПРЕДСТАВЛЕНИЕ(КонтактнаяИнформация.Объект),
    |    КонтактнаяИнформация.Тип,
    |    КонтактнаяИнформация.Вид,
    |    ПРЕДСТАВЛЕНИЕ(КонтактнаяИнформация.Вид),
    |    КонтактнаяИнформация.Представление
    |ИЗ
    |    РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
   |ГДЕ
   |    КонтактнаяИнформация.Объект = &Объект
   |    И КонтактнаяИнформация.Тип = &Тип
   |    И КонтактнаяИнформация.Вид = &Вид";
    
Запрос.УстановитьПараметр("Объект",СсылкаНаОбъект.Контрагент.ОсновноеКонтактноеЛицо);
Запрос.УстановитьПараметр("Тип",Перечисления.ТипыКонтактнойИнформации.Телефон);
Запрос.УстановитьПараметр("Вид",Справочники.ВидыКонтактнойИнформации.МобильныйТелефонКонтактногоЛицаКонтрагента);
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    ОбластьПокупатель.Параметры.Телефон        = Строка(ВыборкаДетальныеЗаписи.Контакт)+",  "+"тел. " + ВыборкаДетальныеЗаписи.Представление;
КонецЦикла;


Если помогло нажмите "спасибо"
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169074 · Ответов: 8 · Просмотров: 416
 

>  Как вывести на печатную форму номер телефона основного менеджера контрагента в расходной накладной?
denis84
Отправлено: 14.12.20, 8:39


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


victor_as @ Вчера, 21:11 * ,
Добрый день! У меня есть такой вариант:

ОбластьПокупатель  = Макет.ПолучитьОбласть("Покупатель");
СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Контрагент, СсылкаНаОбъект.Дата,,,"uk");
ОбластьПокупатель.Параметры.РеквизитыПокупателя        = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе,"Телефоны,",,"uk");
ОбластьПокупатель.Параметры.ПредставлениеПокупателя   = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ПолноеНаименование,",,"uk");
ТабДок.Вывести(ОбластьПокупатель);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169041 · Ответов: 8 · Просмотров: 416
 

>  Как вывести на печатную форму номер телефона основного менеджера контрагента в расходной накладной?
denis84
Отправлено: 13.12.20, 21:32


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


victor_as @ Сегодня, 21:11 * ,
Укажите,какая конфигурации?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169024 · Ответов: 8 · Просмотров: 416
 

>  Как вывести на печатную форму номер телефона основного менеджера контрагента в расходной накладной?
denis84
Отправлено: 12.12.20, 9:07


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


victor_as @ Вчера, 21:39 * ,
Добрый день! Вот здесь почитайте. Сейчас не возле компа,не как глянуть свои печатные формы.
читать здесь
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169007 · Ответов: 8 · Просмотров: 416
 

>  Отчет журнал - ведомость по субконто
denis84
Отправлено: 07.12.20, 18:33


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


aleksandr_n @ Сегодня, 16:40 * ,
Нет,Вам необходимо найти в модуле документа слово глпроводка() и там прописать заполнения субконто. Процедуры типа Проводки строка(). Короче говоря необходимо видеть Ваш модуль документа,чтоб конкретно описать,где анемии изменения. А то что Вы показали,это сохранение реквизита,для использования при последующих открытиях дока. Можете на почту vdv1984@i.ua скинуть модуль документа
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168883 · Ответов: 5 · Просмотров: 217
 

>  Отчет журнал - ведомость по субконто
denis84
Отправлено: 07.12.20, 16:31


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


aleksandr_n @ Сегодня, 15:22 * ,
Цитата(aleksandr_n @ 07.12.20, 15:22) *
Пробовал, в конфигураторе в плане счетов добавить субконто, эффект нулевой, далее в доке "Акт выполненных работ" в табличной части добавлял столбец, для выбора из справочника адресов. Всеравно суммы по адресам не выбираются.

Добрый день! Если Вы все это сделали, то необходимо в обработке проведения документа "Акт выполненных работ" прописать в глПроводке() заполнения места хранения (адреса)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168880 · Ответов: 5 · Просмотров: 217
 

>  Запись не верна! Значение поля "Пользователь" не может быть пустым!: НастройкиПользователей
denis84
Отправлено: 02.12.20, 9:33


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


lina1982 @ Сегодня, 9:22 * ,
Добрый день! У Вас не видет "пользователь". Попробуйте вставить вместо "Пользователь", такую конструкцию
Пользователи.ТекущийПользователь();
. Такую инструкцию использовал при программной установке автора в документах.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168758 · Ответов: 3 · Просмотров: 307
 

>  Ошибка при записи элемента справочника Пользователи в УНФ через внешнее подключение
denis84
Отправлено: 01.12.20, 15:04


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


info230a02 @ Сегодня, 14:28 * ,
Добрый день! Почитать можно здесь тут или здесь

форум. Вот здесь описано,хорошо здесь
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168724 · Ответов: 3 · Просмотров: 179
 

>  Условия сохранения определенного документа (1с 7.7.27)
denis84
Отправлено: 25.11.20, 19:53


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 18:57 * ,
При записи тоже есть такая процедура там и проверьте заполняемость реквизита

призаписи()

И вот тут полезно почитать:
тут
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168587 · Ответов: 6 · Просмотров: 234
 

>  Условия сохранения определенного документа (1с 7.7.27)
denis84
Отправлено: 25.11.20, 17:54


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 16:58 * ,
Добрый день! Если "сотрудник" в шапке документа то в модуле документа пишем:

// ===========================
Функция ПроверкаШапки()
    глВсеВыбрано = 1;
    глВыбранЛи(сотрудник,"сотрудник");
    //глВыбранЛи(Цех,"Цех");
    Возврат глВсеВыбрано;
КонецФункции


А если в строке, то так:
// ===========================
Функция ПроверкаСтроки()
    глВсеВыбрано = 1;
    глВыбранЛи(сотрудник,"сотрудник",НомерСтроки);
    Возврат глВсеВыбрано;
КонецФункции


А потом в обработке проведения проверяем:
// ===========================
Процедура ОбработкаПроведения()


Если ПроверкаШапки() = 0 Тогда
    глНеПроводить(Контекст);
    Возврат;
КонецЕсли;


ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
    Если ПроверкаСтроки() = 0 Тогда
        глНеПроводить(Контекст);
        Возврат;
    КонецЕсли;
КонецЦикла;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168582 · Ответов: 6 · Просмотров: 234
 

>  Программно цена устанавливается, а руками не получается установить
denis84
Отправлено: 18.11.20, 14:08


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 188
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


sinchik @ Сегодня, 13:51 * ,
Добрый день! А доступность у реквизита цена установлена
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168374 · Ответов: 2 · Просмотров: 157
 

8 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 17.01.21, 13:45
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!