Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику pablo ::: Спасибо сказали: 191 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
11.11.11, 15:10 Как обратиться к родителю элемента
Телепатирую по содержимому всей темы
   Для а=1 по Эл.Количество() цикл
        Обл.Параметры.Підрозділ = Обл.Параметры.Підрозділ+Строка(ПоточнийЕлемент.Значение.Родитель)+", ";      
       КонецЦикла;
Incognito,
11.11.11, 8:49 Как обратиться к родителю элемента
Поправлю предыдущего оратора wink.gif
Спис = ЭлементыФормы.ПолеВвода1.Значение; // ПолеВвода1 ПолеВвода с типом Список значений
Для а=1 По Спис.Количество()  Цикл
       Сообщить(Спис[а-1].Родитель);            
КонецЦикла;
Incognito,
08.11.11, 13:58 Выгрузка в XML
    
        ФайлXML=новый ЗаписьXML;
    ФайлXML.ОткрытьФайл("/var/samba_share/buh/All1.xml","UTF-8");
    ФайлXML.Отступ=Истина;
        
        //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Валюты.Код,
        |    Валюты.Наименование,
        |    Валюты.Ссылка
        |ИЗ
        |    Справочник.Валюты КАК Валюты";

    Результат = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    ФайлXML.ЗаписатьНачалоЭлемента("CatalogObject.Валюты");
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ФайлXML.ЗаписатьНачалоЭлемента("Валюта");
        ФайлXML.ЗаписатьНачалоЭлемента("Наименование");
        ФайлXML.ЗаписатьТекст(ВыборкаДетальныеЗаписи.Наименование);
        ФайлXML.ЗаписатьКонецЭлемента();
        ФайлXML.ЗаписатьНачалоЭлемента("Код");
        ФайлXML.ЗаписатьТекст(ВыборкаДетальныеЗаписи.Код);
        ФайлXML.ЗаписатьКонецЭлемента();
        ЗаписатьXML(ФайлXML,ВыборкаДетальныеЗаписи.Ссылка);
        ФайлXML.ЗаписатьКонецЭлемента();        
    КонецЦикла;
    ФайлXML.ЗаписатьКонецЭлемента();
    ФайлXML.Закрыть();
XBrut,
01.11.11, 11:11 Не редактируется конфигурация
Конфигурация-поддержка-настройка поддержки. А дальше - на свой страх и риск.
vadim007,
28.09.11, 10:36 Регистр остатков комплектов (проект)
Сама постановка задачи противоречит требованиям ФИФО, отсюда вытекает один маленький вопрос: "Что у Вас указано в приказе об учетной политике?" Если ФИФО - то налицо явное расхождение между директивами руководства. Чем это грозит и во что это выльется - без понятия, но когда у меня возникла подобная, но гораздо более простая задача, вопрос решился походом к главбуху и его решением "делать согласно приказу об учетной политике".
bolobol,
15.09.11, 7:31 Мой опыт установки Linux + PostgreSQL + 1C
При работе с такой связкой было выявлено еще одна тонкость (возможно, она описана в указанных ссылках)
В настройках postgres необходимо установить
enable_nestloop=off
Проблема возникла при типовом начислении амортизации в БП с числом ОС порядка 15000 и заключалось в долгом проведении (часы) и одновременном блокировании любых действий по записи в БД (пользователи не могли сохранить ни один документ).
Vofka,
12.09.11, 12:09 Запросы правыльный вывод данных
Цитата
А можно как для "особо одаренного" подсказать как это собрать в конструкторе запросов.

Используйте вкладку ПакетЗапросов для создания подзапросов и вкладку Дополнительно для задания имени временной таблицы.
P.S. Только вот пакетные запросы только в 8.2 появились.
sia_1980,
09.09.11, 13:37 Форум сильно тормозит
Сегодня некоторое время в районе 14-00 вместо форума висела фраза <%Board%>
Vofka,
06.09.11, 15:30 Использование общего модуля 1С 8.2
Диапазон = НовыйДокумент.Range();
Поиск = Диапазон.find;
Поиск.ClearFormatting();
Поиск.Forward = Истина;        
продолжать = Поиск.Execute("<НазваЮридичноїОсоби>");
Пока Продолжать цикл
Диапазон.text = ЭтаФорма.ЭлементыФормы.Заклад.Значение.ЗакладСкорочено;
Диапазон = НовыйДокумент.Range();
Поиск = Диапазон.find;
Поиск.ClearFormatting();
Поиск.Forward = Истина;        
продолжать = Поиск.Execute("<НазваЮридичноїОсоби>");
КонецЦикла;

Здесь все просто организуется без метки smile.gif
vlad_1984_vlad,
31.08.11, 9:43 Обработка ОбменДаннымиЧерезXML
Конфигурацией Конвертация данных
alex040269,
31.08.11, 9:06 Уровень зарплаты 1С программиста
Цитата
Это чистыми или грязными?

Грязными.
Vofka,
04.08.11, 8:42 Работа с таблицей значений.
Виноват, забыл 1 команду
Результат = Запрос.Выполнить().Выбрать();

    Строка = Макет.ПолучитьОбласть("Строка");
    Итог = Макет.ПолучитьОбласть("Итог");
    Подпись = Макет.ПолучитьОбласть("Подпись");
    
    Пока Результат.Следующий() Цикл
        Строка.Параметры.Подразделение=Результат.Подразделение;
        ТабДок.Вывести(Строка);
    КонецЦикла;
Flamepayne,
12.07.11, 14:47 Предприятие 8.2 (8.2.13.25) налоговая накладная
Цитата
Копался в модуле формы, много процедур, не нашел нигде параметры ДатаДоговора и НомерДоговора.

Копайтесь в модуле объекта.
SkyBlue,
06.07.11, 11:04 Проведение по регистрам документа
Цитата
Подскажите по теории как это сделать или где прочитать.

1. Выбираете остатки, отсортированные по дате партии.
2. Перебираем остатки, сравнивая количество единиц по партии с количеством для списания.

Пример. У вас на складе есть 4 яблока. 2 пришло 1 января по цене 20 грн/шт, а 2 - 2 января по 21грн/шт. Сколько будут стоить 3 яблока для списания со склада?
По ФИФО - 61 грн, по ЛИФО - 62грн
meverikxp,
04.07.11, 15:12 Странная работа сортировки в динамическом списке
Ошибки платформы "1С:Предприятие 8.2"

10080577 Сортировка данных динамического списка по колонке составного типа
Проблема:
Если динамический список отображает в колонке реквизит метаданных, который содержит в своём составе какой-либо примитивный тип (число, строка и т.д.), то данные по нему не могут быть правильно упорядочены.
Дата публикации: 2011-05-12

И это в новом релизе sad.gif
DartRomanius,
17.06.11, 7:37 Вы или ты?
Высокие стандарты общения в массы нужно вносить, в том числе и модерированием. Заставить всех обращаться на Вы - достойная задача, несомая командой данного форума. (Проголосовал за Вы).
Vofka,
08.06.11, 11:41 Получение первой записи из дбф файла
О чем мы говорим?
Чтобы спозиционироваться на первую запись, достаточно было
ФайлБД.Первая();

Если после этого вызвать
  Пока (ФайлБД.Следующая()=1) Цикл

то текущей внутри цикла при первой итерации будет уже вторая запись.
Для позиционирования же на последнюю запись такой способ не подходит, и здесь верным будет такой код
  КолЗап = ФайлБД.КоличествоЗаписей();  
    Для ит =1 по КолЗап-1 Цикл
          ФайлБД.Следующая();
    КонецЦикла;
Kutuzov,
08.06.11, 11:30 Получение первой записи из дбф файла
Цитата
Пока (ФайлБД.Следующая()=1) Цикл
Ошибка была здесь!
Правильно:
Пока не ФайлБД.Вконце()=1 Цикл
...
ФайлБД.Следующая();
КонецЦикла;
Vofka,
17.05.11, 7:11 Глюк платформы? Управляемая форма.
Попробуйте использовать не стандартные команды командной панели, а собственные "оболочки" с собственными кнопками. Путь обходной, но действенный.
DartRomanius,
20.04.11, 13:34 Динамический список + сложный запрос
Когда возникла нужда использовать параметр, я таки докопался. laugh.gif
Описываем динамический список произвольным запросом, в тексте которого используем параметры. Затем в коде задаем параметры значением следующим образом:
Список.Параметры.УстановитьЗначениеПараметра("ИмяПараметра",ЗначениеПараметра);
DartRomanius,
05.04.11, 7:40 Ошибки на форуме
Тогда еще 2 орфографические ошибки из разделов smile.gif "Литература, ссылки на полезные ресурсы"; ""Битва экстрасенсов" на украинском форуме 1С"
Vofka,
05.04.11, 7:06 Ошибки на форуме
Не знаю куда запостить, но поскольку ошибка, хоть и мелкая, но относится к форуму, пишу здесь. Название одного из разделов форума "Темматическое общение". Мне одному эта орфографическая ошибка глаз режет?
Vofka,
23.03.11, 11:53 Формирование отчетов
1. Открыть "Настройка параметров учета" (кнопка на закладке Предприятие)
2. Перейти на закладку "План счетов"
3. Снять галку "Использовать классы счетов в качестве групп"
4. Нажать ОК
umnyaxa,
18.03.11, 12:53 Формирование отчетов
Цитата
Сальдо на конец месяца по Дт фактически у меня 10000 по КТ 4500.А в оборотке пишет только по Дт=5500 и КТ=5500.
Как такое может быть?
Если в оборотке у вас присутствует конечное сальдо только по Дт или только по Кт, то это зависит от типа счета (Активный или Пассивный). Одновременно оба типа остатков могут быть только у Активно/Пассивного счета. Но менять конфигурацию Вам не советую, скорее всего Вы ошибаетесь в ведении учета.
umnyaxa,
15.03.11, 11:29 Динамический список + сложный запрос
Есть вариант построить вложенный запрос вида

Выбрать ПЕРВЫЕ 1 
поля заказа
из Документ.Заказ как Заказ
где Заказ.Владелец=&Владелец
Упорядочить по Дата Убыв

Но это не самый лучший вариант, так как привязан к параметру
DartRomanius,

8 страниц V  « < 5 6 7 8 >
RSS Текстовая версия Сейчас: 17.09.21, 14:54
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!