Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Ищем больших автоматизаторов 1С 8.3 Конфигурация УТП 1,2
RSL-1
Отправлено: 14.01.21, 11:50


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


Здравствуйте.
Задача автоматизировать все процессы работы, интегрировать все, что только можно с 1С.
Интеграция с сайтом на Битрикс, OpenCart
Настройка единиц измерения
Нужны автоматизаторы, консультанты. которые не буду предлагать свой лицензионный продукт, а доработают наш!
Прошу писать сюда или на почту
s.rudko@100systems.com
  Форум: Корзина · Просмотр сообщения: #169763 · Ответов: 1 · Просмотров: 46
 

>  Как работают дополнительные единицы измерения?
RSL-1
Отправлено: 11.01.21, 13:15


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


One @ 06.01.21, 16:54 * ,
Вы верно поняли.
Какую единицу не ставь, пересчитывается количество, цена.

1С:Предприятие 8.3 (8.3.12.1595)
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #169652 · Ответов: 2 · Просмотров: 209
 

>  Функции единицы измерения УТП 8.3 Конф. 1.2 УТП
RSL-1
Отправлено: 04.01.21, 16:16


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


Кто знает точную формулу, как рассчитывается количество и цена единицы измерения в документах?
Суть в чем, я хочу ввести несколько единиц измерения для каждой номенклатуры.
Проблема вся в том, что в одной единице измерения мы измеряем обьем, а дрогой единицей площадь, а третьей количество.
м3, м2, пачка
Базовая единица Пачка = количеству в м3 - Она подтягивается на сайт
Единица хранения м3 = 1 коэф. - Единица в которой регистрируют поставщики товар
Единица для отчетов м2 = м3 / толщину изделия
Если Базовой единицей считать Пачка, то остаток отображается не верно (в Ведомостях Пачка = остатку 10, хотя это остаток в м3)
Если же Базовой единицей поставить м3, то это не удобно в плане учета и выписывания документов.
// Процедура выполняет стандартные действия при изменении единицы цены
// в строке табличной части документа.
//
// Параметры:
//  СтрокаТабличнойЧасти - строка табличной части документа,
//  ДокументОбъект       - объект редактируемого документа
//
Процедура ПриИзмененииЕдиницыТабЧасти(СтрокаТабличнойЧасти, ДокументОбъект) Экспорт

    ИмяТабличнойЧасти   = ОбщегоНазначения.ПолучитьИмяТабличнойЧастиПоСсылкеНаСтроку(СтрокаТабличнойЧасти);
    МетаданныеДокумента = ДокументОбъект.Метаданные();

    Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ЕдиницаИзмеренияМест", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
        Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("КоличествоМест", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда

            Если НЕ ЗначениеЗаполнено(СтрокаТабличнойЧасти.ЕдиницаИзмерения)
               И ЗначениеЗаполнено(СтрокаТабличнойЧасти.Номенклатура) Тогда
                ОбщегоНазначения.СообщитьОбОшибке("Для " + СокрЛП(СтрокаТабличнойЧасти.Номенклатура) + " не выбрана единица измерения цены!
                                 |Пересчет количества невозможен.");
            Иначе
                СтароеЗначениеКоэффициента = СтрокаТабличнойЧасти.Коэффициент;
                НовоеЗначениеКоэффициента  = СтрокаТабличнойЧасти.ЕдиницаИзмерения.Коэффициент;

                СтрокаТабличнойЧасти.Коэффициент = НовоеЗначениеКоэффициента;

                Если НовоеЗначениеКоэффициента <> СтароеЗначениеКоэффициента
                   И СтароеЗначениеКоэффициента <> 0 Тогда
                    

                    Если ЗначениеЗаполнено(СтрокаТабличнойЧасти.ЕдиницаИзмеренияМест) Тогда
                        СтрокаТабличнойЧасти.Количество  = СтрокаТабличнойЧасти.Количество * СтароеЗначениеКоэффициента
                                                           / НовоеЗначениеКоэффициента;
                    КонецЕсли;

                    РассчитатьКоличествоМестТабЧасти(СтрокаТабличнойЧасти, ДокументОбъект);




                    Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("Цена", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
                        СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Цена *НовоеЗначениеКоэффициента
                                                    / СтароеЗначениеКоэффициента;
                    КонецЕсли;
                    
                    
                    Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ЦенаНоминальная", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
                        СтрокаТабличнойЧасти.ЦенаНоминальная = СтрокаТабличнойЧасти.ЦенаНоминальная *НовоеЗначениеКоэффициента
                                                    / СтароеЗначениеКоэффициента;
                    КонецЕсли;
                    
                    Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ПлановаяСтоимость", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
                        СтрокаТабличнойЧасти.ПлановаяСтоимость = СтрокаТабличнойЧасти.ПлановаяСтоимость *НовоеЗначениеКоэффициента
                                                    / СтароеЗначениеКоэффициента;
                    КонецЕсли;
                                                
                                                
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    Иначе
        
        Если НЕ ЗначениеЗаполнено(СтрокаТабличнойЧасти.ЕдиницаИзмерения) Тогда
            ОбщегоНазначения.СообщитьОбОшибке("Для " + СокрЛП(СтрокаТабличнойЧасти.Номенклатура) + " не выбрана единица измерения цены!
                             |Пересчет количества невозможен.");
        Иначе
            СтароеЗначениеКоэффициента = СтрокаТабличнойЧасти.Коэффициент;
            НовоеЗначениеКоэффициента  = СтрокаТабличнойЧасти.ЕдиницаИзмерения.Коэффициент;

            СтрокаТабличнойЧасти.Коэффициент = НовоеЗначениеКоэффициента;

            Если НовоеЗначениеКоэффициента <> СтароеЗначениеКоэффициента Тогда

                // если в табличной части есть реквизит КоличествоМест, то цена задается не за ЕдиницуИзмерения,
                // а за базовую единицу хранения остатков. Т.е. цену пересчитывать не нужно
                Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("КоличествоМест", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
                    // надо обновить изменение к-ва в документе
                    РассчитатьКоличествоТабЧасти(СтрокаТабличнойЧасти, ДокументОбъект);
                Иначе
                    // ПересчитатьЦену
                    Если СтароеЗначениеКоэффициента > 0
                        И ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("Цена", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
                        СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Коэффициент
                        / СтароеЗначениеКоэффициента;
                    КонецЕсли;

                    Если СтароеЗначениеКоэффициента > 0
                        И ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ЦенаВРознице", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
                        СтрокаТабличнойЧасти.ЦенаВРознице = СтрокаТабличнойЧасти.ЦенаВРознице * СтрокаТабличнойЧасти.Коэффициент
                        / СтароеЗначениеКоэффициента;
                    КонецЕсли;
                    
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;

    КонецЕсли;

КонецПроцедуры // ПриИзмененииЕдиницыТабЧасти
  Форум: Корзина · Просмотр сообщения: #169512 · Ответов: 1 · Просмотров: 50
 

>  Как работают дополнительные единицы измерения?
RSL-1
Отправлено: 29.12.20, 11:47


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


Здравствуйте.
Дополнительно для номенклатуры создал единицу измерения, верно рассчитал коэффициент и установил как единицу мест.
При добавлении единицы измерения в документ подтягивается единица хранения со своей стоимостью.
Но когда я меняю единицу измерения в документе, то пересчитывается стоимость, но не количество. А у некоторой номенклатуры четко пересчитывается количество и стоимость соответсвенно.
Почему так может происходить, вроде все понятно и логично, но не понимаю, как так.
Однажды было, что тоже количество не пересчитывалось по коэффициенту, поклацал что-то от фонаря и сработало как должно, хотя ничего не изменял в номенклатуре.
Подскажите, может кто в курсе.

П.С. На документы не планируется выводить единицу мест.
Можно, конечно, но эта единица используется для других нужд.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #169428 · Ответов: 2 · Просмотров: 209
 

>  Коэффициент единицы измерения. 1С УТП 8.3 Конфигурация 1.2
RSL-1
Отправлено: 24.12.20, 16:14


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


Moloko @ 17.12.20, 21:41 * ,
Цитата(Moloko @ 17.12.20, 21:41) *
Вы посмотрите карточку товара, когда при списании 28-го счета будет округление в "количестве" до 3-го знака, а не до 5-го, и поймете, что были неправы.
Я все это проходил.

У бухгалтерии движение всегда в своей единице измерения, которая всегда равна коэффициенту "1". Поэтому там не должно быть ошибок.
Приход/остаток/расход всегда равен коэффициенту "1"
Это бухгалтерский учет.
А вот вопросы уже в управленческом учете, где у той же номенклатуры единица измерения "шт" = коэффициенту 0,273333333
Тогда в анализе доступности зависают не округленные цифры, хотя товар уже фактически отгружен по управленческому учету.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #169344 · Ответов: 12 · Просмотров: 328
 

>  Не отображаются актуальные остатки на складах
RSL-1
Отправлено: 24.12.20, 10:04


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


awp @ Вчера, 20:30 * ,
Цитата(awp @ 23.12.20, 20:30) *
Возможно у кладовщика есть запрос при проведении с использованием РАЗРЕШЕННЫЕ ?

Нет, такого нет. Но было бы круто. Это функионал типового решения?
Возможно что-то такое включено, а я не в курсе.
Цитата(awp @ 23.12.20, 20:30) *
Принскрин журнала регистрации выложить можете с проведением от кладовщика? Цвет в журнале не серый?

Нет смысла сбрасывать скрин журнала, поскольку я его в первую очередь проверил.
Сразу после проведения была произведена регистрация данных, журнал зафиксировал движение.

Vofka @ Сегодня, 9:01 * ,
Цитата(Vofka @ 24.12.20, 9:01) *
На самом деле это не сильно сложно: это проведенные расходные ордера, у которых нету движений по определенному регистру. Это не решение проблемы, просто как дополнительный пункт, который можно использовать в расследовании.

Нашел регистр. Спасибо большое.
Натолкнули на работу)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169336 · Ответов: 5 · Просмотров: 238
 

>  Не отображаются актуальные остатки на складах
RSL-1
Отправлено: 23.12.20, 17:37


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


sava1 @ Сегодня, 16:00 * ,
Цитата(sava1 @ 23.12.20, 16:00) *
А до этого кто/что проводит?

Я не совсем понял вопрос.
Проводится, реализация товаров и услуг, на основании ее проводится расходный ордер.
Расходный ордер проводит кладовщик по факту отгрузки.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169313 · Ответов: 5 · Просмотров: 238
 

>  Не отображаются актуальные остатки на складах
RSL-1
Отправлено: 23.12.20, 15:43


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


1С 8.3 УТП, Конф. 1.2
После проведения расходного ордера товар не списывается со склада.
Движения нет в ведомости по товарам и в подборе виден остаток без учета этого расходного ордера.
Но движение в журнале регистрации происходит.
После ручного перепроведения документа остаток списывается со склада.
А вся штука в том, что в целом все прекрасно работает, но бывают залетные такие ордера.
И расходные ордера, которые проведены, но остаток не списан, очень сложно найти в базе.

Подскажите, пожалуйста, где искать ошибку?

П.С. склады, организации и тому подобное верно указаны.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169311 · Ответов: 5 · Просмотров: 238
 

>  Коэффициент единицы измерения. 1С УТП 8.3 Конфигурация 1.2
RSL-1
Отправлено: 17.12.20, 17:02


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


Moloko @ Сегодня, 12:32 * ,
sava1 @ Сегодня, 12:56 * ,
29a @ Сегодня, 13:28 * ,
sava1 @ Сегодня, 16:23 * ,
Я изменил все коэффициенты в "Точности" с 3 символов до 5, где было написано, "Товары" и все получилось, кроме отчетов.
Цитата(Moloko @ 17.12.20, 12:32) *
регистры бухгалтерии, регистры накопления,

У бухгалтерии своя единица измерения, по умолчанию Единица хранения, и все документы по бухгалтерии проводятся верно 100%.
А вот по управленческому учету у нас беда, поскольку с единицей измерения играемся.
Еще попробую исправить данные в отчетах и посмотрим что будет.

Спасибо большое за ответы.

Кстати, а что если, потом все равно коэффициенты не будут округлятся, как хотелось бы?)
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #169156 · Ответов: 12 · Просмотров: 328
 

>  Коэффициент единицы измерения. 1С УТП 8.3 Конфигурация 1.2
RSL-1
Отправлено: 16.12.20, 16:17


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


Цитата(RSL-1 @ 16.12.20, 15:36) *
Здравствуйте
Работаем с такими единицами как м. кв. и м. куб., рулоны или упаковки.
1 рулон = 0,0278 м. кв
Но в 1С нельзя прописать значение больше трех символов после комы, пишу 0,028.
Тогда если расходный ордер сделать в другой единице измерения, то в анализе зависает 0,02 "К реализации", хотя она проведена
Может кто-то знает, можно ли увеличить количество цифр после комы?

Ед. мест К. мест Мест Количество Ед. К. Качество
лист 0,034 91 3,080 м3 1,000 Новый
Хотя по факту отгрузили мест 90 листов

sava1 @ Сегодня, 15:53 * ,
Я верно понимаю, что если изменить эти значения, то получится настроить коэффициенты номенклатуры?

  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #169123 · Ответов: 12 · Просмотров: 328
 

>  Коэффициент единицы измерения. 1С УТП 8.3 Конфигурация 1.2
RSL-1
Отправлено: 16.12.20, 15:36


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.12.20
Пользователь №: 71320


Здравствуйте
Работаем с такими единицами как м. кв. и м. куб., рулоны или упаковки.
1 рулон = 0,0278 м. кв
Но в 1С нельзя прописать значение больше трех символов после комы, пишу 0,028.
Тогда если расходный ордер сделать в другой единице измерения, то в анализе зависает 0,02 "К реализации", хотя она проведена
Может кто-то знает, можно ли увеличить количество цифр после комы?
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #169121 · Ответов: 12 · Просмотров: 328
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 16.01.21, 5:14
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!