Версия для печати темы (https://pro1c.org.ua/index.php?s=b9adaf1d1f138f1c11656a38422761c2&showtopic=58943)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ быстрый поиск документа

Автор: 4andriy 13.05.20, 18:46

1с 7.7 Предприятие
создаю документ, например счет. в счете добавил кнопку сохранения ссылки на документ

Процедура быстросохранить()
Если ПустоеЗначение(ТекущийЭлемент())=1 Тогда
Возврат;
КонецЕсли;  
Если ТекущийЭлемент().ЭтоГруппа()=1 Тогда
Возврат;
КонецЕсли;        
Элемент=СоздатьОбъект("Справочник.Контрагенты");
Элемент.найтиЭлемент(ТекущийЭлемент());
//сдесь не работает
вар 1) Элемент.быстдоступ=ТекущийДокумент();
вар 2) Элемент.быстдоступ=ТекущийЭлемент();
вар 3) Элемент.быстдоступ=этотдокумент();
//
КонецПроцедуры


как мне передать реквизиту "быстдоступ" ссылку на этот документ который открыт, причем вручную сам документ могу выбрать их всего журнала, а програмно нет

Автор: denis84 13.05.20, 19:12

4andriy @ Сегодня, 19:46 * ,
А реквизит быстдоступ какого типа?

Автор: 4andriy 13.05.20, 19:18

denis84 @ Сегодня, 20:12 * ,
тип значение Документ.счет но сейчас даже со счетом не работает в трех вариантах

Автор: denis84 13.05.20, 19:22

4andriy @ Сегодня, 20:18 * ,
Если не ошибаюсь документ этот надо записать,а потом передать ссылку на этот документ. Элемент.быстдоступ= ТекущийДокумент();

Автор: 4andriy 13.05.20, 19:45

denis84 @ Сегодня, 20:22 * ,
добавил

Записать();


4andriy @ Сегодня, 20:24 * ,
проблема в передаче параметра документа в реквизит

Функция не обнаружена (ТекущийДокумент)


4andriy @ Сегодня, 20:28 * ,
да, после записи работает лучше... но как записать открытый документ програмно

Автор: denis84 13.05.20, 19:48

4andriy @ Сегодня, 20:28 * ,
Элемент это справочник контрагентов?

Автор: 4andriy 13.05.20, 19:48

denis84 @ Сегодня, 20:48 * ,
да, я в справочник контрагентов добавил реквизит

Автор: denis84 13.05.20, 19:54

4andriy @ Сегодня, 20:48 * ,
в справочнике контрагентов после счет.Записать(); Написать быстдоступ=счет.ТекущийДокумент():- это будет ссылка в справочнике на ваш созданный документ счёт. Ссылка появится только записи самого документа. Завтра попробую у себя,если у Вас не получится,то сообщу результат. Счёт через создать объект создаёте?

Автор: 4andriy 13.05.20, 20:15

denis84 @ Сегодня, 20:54 * ,
нет, вручную
после записи документа начинает работать ТекущийДокумент, но програмно не делает запись

4andriy @ Сегодня, 20:59 * ,
уже понял, Записать(); не там написал) тестирую

4andriy @ Сегодня, 21:04 * ,
заработало)

Автор: denis84 13.05.20, 20:23

4andriy @ Сегодня, 21:15 * ,
Ок. Значит все получилось?

Автор: 4andriy 13.05.20, 20:54

denis84 @ Сегодня, 21:23 * ,
да, спасибо)

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua