Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Ошибка при отмене сохранения документа          
inna.innainna84 Подменю пользователя
сообщение 03.03.16, 1:24
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 108
Спасибо сказали: 2 раз
Рейтинг: 0

 //**************************************
Процедура НоваяЗаявка()
    Если Вопрос("Создать заявку для текущего клиента?","Да+Нет")="Да" Тогда
        ОбнаруженнаяЗаявка=ПроверитьЗаявкиПоКлиенту();
        Если ПустоеЗначение(ОбнаруженнаяЗаявка)=0 Тогда
            Если Вопрос("Внимание! Для данного клиента в указанный день уже была сформирована заявка"+РазделительСтрок+
            "Вы всё равно хотите ввести новую заявку?","Да+Нет")="Да" Тогда
                СписокПараметров=СоздатьОбъект("СписокЗначений");
                СписокПараметров.ДобавитьЗначение(1,"Новый");
                СписокПараметров.ДобавитьЗначение(ДатаДок,"ДатаДок");
                СписокПараметров.ДобавитьЗначение(Клиент,"Клиент");
                СписокПараметров.ДобавитьЗначение(глВзятьКонтекст(Контекст));
                ОткрытьФорму("Документ.РасходнаяНакладная",СписокПараметров,);
                //ОткрытьФорму("Документ.РасходнаяНакладная",СписокПараметров,ТекущийДокумент());
            Иначе
                Если Вопрос("Открыть обнаруженную заявку для просмотра?","Да+Нет")="Да" Тогда
                    ОткрытьФорму(ОбнаруженнаяЗаявка.ТекущийДокумент());
                    Возврат;
                КонецЕсли;
            КонецЕсли;        
        Иначе    
            СписокПараметров=СоздатьОбъект("СписокЗначений");
            СписокПараметров.ДобавитьЗначение(1,"Новый");
            СписокПараметров.ДобавитьЗначение(ДатаДок,"ДатаДок");
            СписокПараметров.ДобавитьЗначение(Клиент,"Клиент");
            СписокПараметров.ДобавитьЗначение(глВзятьКонтекст(Контекст));
            ОткрытьФорму("Документ.РасходнаяНакладная",СписокПараметров);
        КонецЕсли;    
    Иначе
        Возврат;
    КонецЕсли;    
КонецПроцедуры

Только я создаю док с помощью этой процетуры и не сохраняю его выдает :
Ошибка ----"Прекращена работа программы 1с:v7 starter program (multi-user)"


 ! 

Правила, п.4
 


Сообщение отредактировал logist - 03.03.16, 10:46

Naghual Подменю пользователя
сообщение 03.03.16, 8:49
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 99
Из: Днепропетровск
Спасибо сказали: 21 раз
Рейтинг: 21

В отладчике ищем конкретную строку на которой возникает ошибка.
Хотя скорее поможет простое исправление ИБ.


Signature
Я желаю всем Счастья!

Pepe Подменю пользователя
сообщение 03.03.16, 9:20
Сообщение #3

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1404
Из: Ужгород
Спасибо сказали: 749 раз
Рейтинг: 220

Похоже, что шибка не в коде, а в системе или базе. Раньше работало?, операционка какая?, что показывает тестирование в конфигураторе на наличие логических или физических проблем?

inna.innainna84 Подменю пользователя
сообщение 03.03.16, 22:37
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 108
Спасибо сказали: 2 раз
Рейтинг: 0

Pepe @ Сегодня, 9:20 *,
Тестирование и исправление не помогло. Операционка нормальная. Посмотрела по всем копиям баз эта ошибка была постоянно.

Naghual Подменю пользователя
сообщение 03.03.16, 23:05
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 99
Из: Днепропетровск
Спасибо сказали: 21 раз
Рейтинг: 21

В какой строке валится?


Signature
Я желаю всем Счастья!

logist Подменю пользователя
сообщение 04.03.16, 10:15
Сообщение #6

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2466 раз
Рейтинг: 0

Цитата(inna.innainna84 @ 03.03.16, 2:24) *
Ошибка ----"Прекращена работа программы 1с:v7 starter program (multi-user)"

Давайте полную информацию об ошибке, там должно быть имя модуля (библиотеки) в котором произошла ошибка. Какие: версия платформы 1С, версия ОС, какие SP в ней стоят. Давайте больше информации.

Сообщение отредактировал logist - 04.03.16, 10:16


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Vofka Подменю пользователя
сообщение 04.03.16, 11:59
Сообщение #7

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13401
Из: Киев
Спасибо сказали: 4141 раз
Рейтинг: 3287.8

Джентльменский набор советов: тестирование и исправление сделать (на копии), переустановить 1С, выключить антивирус, почистить кеш (если он в 7.7 есть) и что-то в таком духе.

logist Подменю пользователя
сообщение 04.03.16, 12:17
Сообщение #8

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2466 раз
Рейтинг: 0

А потом окажется что там Win2008, которой не хватает какого-то патча ОС, без которого 77 нормально не работет smile.gif


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Pepe Подменю пользователя
сообщение 04.03.16, 14:13
Сообщение #9

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1404
Из: Ужгород
Спасибо сказали: 749 раз
Рейтинг: 220

Цитата(logist @ 04.03.16, 12:17) *
А потом окажется что там Win2008, которой не хватает какого-то патча ОС, без которого 77 нормально не работет

Цитата(inna.innainna84 @ 03.03.16, 22:37) *
Операционка нормальная


logist Подменю пользователя
сообщение 04.03.16, 14:30
Сообщение #10

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2466 раз
Рейтинг: 0

Pepe, а нормальная эта какая? smile.gif


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

nysysimara Подменю пользователя
сообщение 04.03.16, 14:39
Сообщение #11

Оратор
Иконка группы
Группа: Местный
Сообщений: 307
Из: Бердянск
Спасибо сказали: 109 раз
Рейтинг: 0

inna.innainna84, вы лентяйка,
погуглите фразу "Прекращена работа программы 1с:v7 starter program (multi-user)"
первые же несколько ссылок содержат кучу советов, после которых вопрошающие отвечают "спасибо получилось"


Signature
1С Предприятие 7.7: Бух. учет для Украины (активно дописанная) + самописка (учет производства и ЗП)
1С Предприятие 8.3: Бух.предприятия 3.0 + самописка
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Кроме высшего образования, нужно иметь хотя бы среднее соображение

Pepe Подменю пользователя
сообщение 04.03.16, 16:25
Сообщение #12

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1404
Из: Ужгород
Спасибо сказали: 749 раз
Рейтинг: 220

Цитата(logist @ 04.03.16, 14:30) *
а нормальная эта какая?
Я только цитировал автора 09000000.gif 32000000.gif

sava1 Подменю пользователя
сообщение 04.03.16, 16:36
Сообщение #13

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2384
Из: Проскуров
Спасибо сказали: 575 раз
Рейтинг: 559

В 7ке по-моему нельзя открыть форму незаписанного документа. Было какое-то извращение (через СтатусВозврата) .

TipsyKID Подменю пользователя
сообщение 04.03.16, 17:32
Сообщение #14

Оратор
Иконка группы
Группа: Местный
Сообщений: 408
Из: Киев
Спасибо сказали: 160 раз
Рейтинг: 0

Цитата(nysysimara @ 04.03.16, 14:39) *
inna.innainna84, вы лентяйка,


inna.innainna84
,
не обижайтесь на коменты в этой теме,
женщины-программисты они такие
ссылка на причину моего плоского юмора

Сообщение отредактировал Vofka - 04.03.16, 18:47


Signature
Специалист : Технологическая платформа 8.х, Бухгалтерия для Украины, Управление торговлей для Украины, Зарплата и Управление Персоналом для Украины

Спасибо сказали: nysysimara,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 26.11.20, 14:30
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!