Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



18 страниц V   1 2 3 > » 

>  Руководство пользователя для BAS for small company (Малий бізнес)
denis84
Отправлено: 14.05.24, 10:10


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


barabambler @ Сегодня, 10:49 * ,
а ну спробуйте за цим посиленням: https://turbobita.net/download/folder/23372...domain=turbo.to

перший пункт побачите - "BAS SmallCompany.dokum.zip"
  Форум: Литература, ссылки на полезные ресурсы · Просмотр сообщения: #178833 · Ответов: 1 · Просмотров: 136
 

>  Вызвать фоновое задание с методом в модуле внешней обработки
denis84
Отправлено: 08.05.24, 10:39


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


AnryMc @ Сегодня, 11:20 * ,
вот такой вариант еще нащел:
//Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.
//Не буду растекаться мыслью по дереву и тянуть кота за все известные места, так как надеюсь, все согласятся, что фоновое выполнение это хорошо. Есть простой путь запускать любой код в фоне. Специалисты скорее //всего такой способ используют, но что-то в инете я описания не встретил, решил выложить.

//Перво-наперво создаем общий модуль с именем например "ФоновоеВыполнение" с галкой "Сервер". Добавим туда пару процедур:

Функция ЗапуститьФоновоеВыполнение(ТекстПроцедуры,СтруктураПараметров=Неопределено) Экспорт
    УникальныйИдентификатор = Новый УникальныйИдентификатор;
    ПараметрыВыполнения = Новый Массив;
    ПараметрыВыполнения.Добавить(ТекстПроцедуры);
    ПараметрыВыполнения.Добавить(СтруктураПараметров);
    
    ФоновыеЗадания.Выполнить("ФоновоеВыполнение.ФоноваяПроцедура",ПараметрыВыполнения,УникальныйИдентификатор);
    Возврат УникальныйИдентификатор;
КонецФункции

Процедура ФоноваяПроцедура(ТекстМодуля,ПараметрыВыполнения) Экспорт
    ПолныйТекстМодуля = "";
    Для Каждого ТекПараметр Из ПараметрыВыполнения Цикл
        ПолныйТекстМодуля = ПолныйТекстМодуля+ТекПараметр.Ключ+"=ПараметрыВыполнения."+ТекПараметр.Ключ+";"+Символы.ПС;
    КонецЦикла;
    ПолныйТекстМодуля = ПолныйТекстМодуля + ТекстМодуля;
    Выполнить(ПолныйТекстМодуля);
КонецПроцедуры
//И готово!

//Теперь для выполнения когда в любой момент мы можем поместить любую процедуру в текстовую переменную:

ТекстФоновойПроцедуры = "
|//Тут передаем текст фоновой процедуры, это может быть вызов каких то процедур или полноценный код
|//вызов процедур проще, т.к. тупо легче отлаживать, т.к. код в этой процедуре обычной отладке не поддастся,
|//а при вызове процедуры или функции мы ставим там точку останова и включаем в отладке автоматическое
|//подключение  фоновых заданий. Запускать можно любые методы для выполнения на сервере.
|
|ОбщийМодульСервер.ВыполнитьНужнуюЗадачу(Парметр1,Парметр2);"
И вызывать ее выполнение:

ФоновоеВыполнение.ЗапуститьФоновоеВыполнение(ТекстФоновойПроцедуры,Новый Структура("Параметр1,Параметр2",Параметр1,Параметр2));
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178830 · Ответов: 3 · Просмотров: 295
 

>  Вызвать фоновое задание с методом в модуле внешней обработки
denis84
Отправлено: 08.05.24, 9:52


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


AnryMc @ Сегодня, 9:20 * ,
Я делал когда-то обработку в фоновом режиме "корректировка ответственных в документах РТиУ"
Может и не то что Вам надо, но делал так и подключал в 1с 8 в фоновых заданиях запуск обработки по времени(получилось, то что надо заказчику;
Функция СведенияОВнешнейОбработке() Экспорт
    ВерсияБСП = СтандартныеПодсистемыСервер.ВерсияБиблиотеки();
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке(ВерсияБСП);
    ПараметрыРегистрации.Информация = НСтр("Корректировка Ответственных в документах");
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
    ПараметрыРегистрации.Версия = "2.0";
    ПараметрыРегистрации.БезопасныйРежим = Ложь;
    
    Команда = ПараметрыРегистрации.Команды.Добавить();
    Команда.Представление = НСтр("Корректировка Ответственных в документах");
    Команда.Идентификатор = "КорректировкаОтветственныхВДокументах";
    Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    Команда.ПоказыватьОповещение = Ложь;
    Команда.Модификатор = "";
    
    Возврат ПараметрыРегистрации;
КонецФункции

Процедура ВыполнитьКоманду(Идентификатор,ОбъектыНазначения) Экспорт
    Если Идентификатор =   "КорректировкаОтветственныхВДокументах" ТОгда
        КорректировкаОтветственныхВДокументах();
    КонецЕсли;    
КонецПроцедуры

&НаСервере
Процедура КорректировкаОтветственныхВДокументах() Экспорт
              //тут был текст запросов и т.д.
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178827 · Ответов: 3 · Просмотров: 295
 

>  Как програмно установить шрифт в форматированом документе
denis84
Отправлено: 02.05.24, 15:46


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 15:32 * ,
//Новый Шрифт(<ИмяШрифта>, <Размер>, <Полужирный>, <Наклонный>, <Подчеркнутый>, <Зачеркнутый>, <Масштаб>)

Шрифт = Новый Шрифт("robota", 11, Истина);

Элемент.Шрифт = Шрифт;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178808 · Ответов: 3 · Просмотров: 365
 

>  Как програмно установить шрифт в форматированом документе
denis84
Отправлено: 02.05.24, 14:08


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 14:34 * ,
//Обработка элементов форматированного документа, входящего в состав параграфа, может оказаться полезной в том случае, 
//если нужно, например, убрать все оформление в виде курсива или полужирного шрифта.

//Пример:

Полужирный = Новый Шрифт(, , Истина);
Курсив = Новый Шрифт(, , , Истина);
Обычный = Новый Шрифт;
Для каждого Элемент Из Параграф.Элементы Цикл
     Если ТипЗнч(Элемент) = Тип("ПереводСтрокиФорматированногоДокумента") Тогда        
           Продолжить;
     КонецЕсли;
     Если Элемент.Шрифт = Полужирный Или Элемент.Шрифт = Курсив Тогда          
           Элемент.Шрифт = Обычный
     КонецЕсли;
КонецЦикла;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178805 · Ответов: 3 · Просмотров: 365
 

>  Запись нового элемента справочника в определенную группу
denis84
Отправлено: 29.04.24, 9:00


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 9:39 * ,
//Данная обработка заполняет справочник Места Хранения из файла ДБФ
//******************************
Процедура Выполнить()
СпрМеста    = СоздатьОбъект("Справочник.МестаХранения");

Попытка
    ДБФ=СоздатьОбъект("XBase");
Исключение
    Предупреждение("Не удачная попытка создания файла.","!");
    Возврат;
КонецПопытки;

ДБФ.ОткрытьФайл(ИмяФайла);
Если ДБФ.Открыта()=0 тогда
    Предупреждение("Не могу открыть базу");
    Возврат;
КонецЕсли;

Если ДБФ.Открыта()=1 Тогда  
    ДБФ.ДобавитьИндекс("sklad","kod",0,0,"");
    ДБФ.СоздатьИндексныйФайл("C:\user\1c\dbf\sklad.CDX");
    ДБФ.ТекущийИндекс("sklad");
    //**устанавливаем указатель на первую запись
    ДБФ.Первая();
    Пока ДБФ.ВКонце() = 0 Цикл
        
    код  = Строка(ДБФ.KOD);
    наим = ДБФ.NAME;

    СтрокаПоиска1=Лев(код,2);
    //=================Создание групп
    Если СпрМеста.НайтиПоКоду(СтрокаПоиска1, 0)=0 Тогда
        СпрМеста.НоваяГруппа();
        СпрМеста.Код = СтрокаПоиска1;
        СпрМеста.Наименование = наим;
        СпрМеста.Записать();
    КонецЕсли;

    //=================В созданой группе создаем элементы
    СтрокаПоиска=Лев(код,4);
    Если спрМеста.НайтиПоКоду(СтрокаПоиска, 0) <> 1 Тогда
        СпрМеста.Новый();
        Босс = СоздатьОбъект("Справочник.МестаХранения");
        Босс.НайтиПоКоду(СтрокаПоиска1, 0);

        СпрМеста.Родитель     = Босс.ТекущийЭлемент();
        СпрМеста.Код          = СтрокаПоиска;
        СпрМеста.Наименование = ДБФ.Name;
        СпрМеста.ВидСклада    = Перечисление.ВидыСкладов.Оптовый;
        СпрМеста.Тип          = Перечисление.ТипыМестХранения.Склад;
        СпрМеста.Записать();
    КонецЕсли;    
    
    ДБФ.Следующая();
КонецЕсли;  

ДБФ.ЗакрытьФайл();
Предупреждение("Склады заведены!");
КонецЦикла;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178788 · Ответов: 10 · Просмотров: 493
 

>  Off: Часто ли Вам приходилось переписывать учёт ОС в типовых конфигурациях?
denis84
Отправлено: 24.04.24, 13:58


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


AnryMc @ Сегодня, 14:35 * ,
Доброго дня! В 1с 8 нічого не змінював. А ось в 1с:7.7, яка і досі в нас працює на підприємстві, багато чого доробляли але все під забаганки нашоїх бухгалтерії (нові документи, зміна проводок і таке інше).
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178779 · Ответов: 5 · Просмотров: 731
 

>  У звіті "Продажі" відображать і суми у валюті USD
denis84
Отправлено: 19.04.24, 12:04


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


marchela @ Сегодня, 11:53 * ,
Можливо і помиляюся - тоді мабуть тільки доопрацювання звіту!
  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #178766 · Ответов: 4 · Просмотров: 387
 

>  У звіті "Продажі" відображать і суми у валюті USD
denis84
Отправлено: 19.04.24, 9:52


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


marchela @ Сегодня, 10:42 * ,
Доброго дня, а в налаштуваннях звіту дивилися?



а в налаштуваннях валют, що у Вас стоїть?
  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #178764 · Ответов: 4 · Просмотров: 387
 

>  Сборник отчетов для 7.7.
denis84
Отправлено: 17.04.24, 13:20


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Svetlana DGI @ Сегодня, 12:09 * ,
Прочитайте правила форуму, там все описано пункт 14
  Форум: Отчеты / Обработки · Просмотр сообщения: #178760 · Ответов: 61 · Просмотров: 79134
 

>  УФ после выбора из списка задать вопрос - не работает
denis84
Отправлено: 12.04.24, 8:26


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


AnryMc @ Вчера, 16:35 * ,
Працює - платформа 8.3.16.1148, конфігурація Business automation software for accounting CORP, edition 2.1 (2.1.9.2)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178746 · Ответов: 16 · Просмотров: 1564
 

>  УФ после выбора из списка задать вопрос - не работает
denis84
Отправлено: 12.04.24, 7:46


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


AnryMc @ Вчера, 16:35 * ,


Вам не задавалося питання?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178744 · Ответов: 16 · Просмотров: 1564
 

>  УФ после выбора из списка задать вопрос - не работает
denis84
Отправлено: 11.04.24, 12:18


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


AnryMc @ Сегодня, 12:50 * ,
&НаКлиенте
Процедура ДопКомплектацияПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    
    Отказ = Истина;
    Оповещение = Новый ОписаниеОповещения("ПослеОтветаПользователя", ЭтотОбъект);
    ТекстВопроса = НСтр("ru = 'Для выполнения этой операции необходимо записать документ. Записать?'");
    ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
    
КонецПроцедуры

&НаКлиенте
Процедура ПослеОтветаПользователя(Ответ, ДополнительныеПараметры) Экспорт
    
    Если Ответ = КодВозвратаДиалога.Да Тогда
        Записать();
        Объект.ДопКомплектация.Добавить();
    КонецЕсли;
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178732 · Ответов: 16 · Просмотров: 1564
 

>  раскраска строки FormEX
denis84
Отправлено: 01.04.24, 14:07


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


4andriy @ Сегодня, 14:26 * ,
в мене це приклад для журнала надходження ТМЦ, а у Вас
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178674 · Ответов: 6 · Просмотров: 906
 

>  раскраска строки FormEX
denis84
Отправлено: 01.04.24, 11:27


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


ось функція з глобал.модулю
Функция глПолучитьЦвет(Красный = 0,Зеленый = 0,Синий = 0) Экспорт
        // функция для формирования значения цвета из составляющих (RGB)
    Возврат Макс(0,Синий)*65536+Макс(0,Зеленый)*256+Макс(0,Красный);
КонецФункции

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178670 · Ответов: 6 · Просмотров: 906
 

>  раскраска строки FormEX
denis84
Отправлено: 01.04.24, 9:03


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


4andriy @ Сегодня, 9:05 * ,
Доброго дня, в журналі документів розфарбована ТЧ за ознакою "КонтрольДокументів", якщо контролюємо контрагента:
//==========================================
Функция ПроверитьВид()
    Если ПустоеЗначение(ТекущийДокумент) = 0 Тогда
        //Если ТекущийДокумент.ЗапретРедактирования = 1 Тогда
        //    Возврат "BRUSH["+глПолучитьЦвет(204,204,204)+"]";      //серый фон
        Если ((ТекущийДокумент.Контрагент.КонтрольДокументов = 1) И (ТекущийДокумент.Проверен = 1)) Тогда
            Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(255,255,255)+"]"; //белый  фон
        ИначеЕсли ((ТекущийДокумент.Контрагент.КонтрольДокументов = 1) И (ТекущийДокумент.Проверен = 0)) Тогда
            Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(255, 222, 179)+"]"; //красный  фон
        КонецЕсли;
    КонецЕсли;
    Возврат "";
КонецФункции
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178666 · Ответов: 6 · Просмотров: 906
 

>  Реализация ОСВ на регистрах
denis84
Отправлено: 29.03.24, 20:19


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 13:58 * ,
Це ви хочете робити в 1с 7? А що задачу з допомогою регістру хочете вирішити?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178657 · Ответов: 4 · Просмотров: 3923
 

>  список элементов без каталогов
denis84
Отправлено: 28.03.24, 8:52


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


4andriy @ Вчера, 17:45 * ,
Если Сотрудники.ЭтоГруппа() = 0 Тогда
       СписокЭлементов.ДобавитьЗначение(Сотрудники.ТекущийЭлемент());
КонецЕсли;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178648 · Ответов: 1 · Просмотров: 757
 

>  Как вывести на печать штрих код?
denis84
Отправлено: 25.03.24, 15:24


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 13:57 * ,

Посмотрите как в стандартных обработках "печать этикеток и ценников", это реализовано
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178633 · Ответов: 2 · Просмотров: 450
 

>  Загрузка документа в Excel. Формат файла не поддерживается
denis84
Отправлено: 15.03.24, 14:35


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


а якщо спробувати перейменовувати(копыювати) файл, а потым выдкривати ы считувати
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178598 · Ответов: 12 · Просмотров: 1600
 

>  Ошибка в печатной форме счета. :((((
denis84
Отправлено: 15.03.24, 10:12


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


babykiev @ Вчера, 22:12 * ,
Готовий допомогти!
  Форум: Платформа 7.7 · Просмотр сообщения: #178593 · Ответов: 3 · Просмотров: 340
 

>  Установка время документа в начало дня
denis84
Отправлено: 06.03.24, 15:32


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 14:53 * ,
АвтоВремяНачалоДня();
Синтаксис:
АвтоВремяНачалоДня()
Назначение:
Установить режим записи времени на начало дня для новых документов.
Замечание:
Для новых документов в модуле формы доступно использование методов установки признака автоформирования времени документа и собственно установки времени. Если эти методы использованы, то диалог запроса времени не вызывается и игнорируются пользовательские установки в параметрах системы.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #178537 · Ответов: 2 · Просмотров: 726
 

>  Не могу получить макет
denis84
Отправлено: 23.02.24, 9:23


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


alex_shkut @ Сегодня, 9:21 * ,
ТабДокумент = Новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178465 · Ответов: 9 · Просмотров: 1535
 

>  Нумерация документов в зависимости от вида операции
denis84
Отправлено: 12.02.24, 20:01


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 18:21 * ,
Описать свой алгоритм. У меня например в 1с 7 была организована нумерация от номера склада.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #178394 · Ответов: 3 · Просмотров: 776
 

>  При нажатии на кнопку программно заполнить реквизит Формы
denis84
Отправлено: 12.02.24, 14:35


Оратор
Иконка группы

Группа: Местный
Сообщений: 438
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


url_2l @ Сегодня, 14:31 * ,
Для "дякую" там є спеціальна кнопочка.
  Форум: Прочее 1С 7.7 · Просмотр сообщения: #178390 · Ответов: 3 · Просмотров: 951
 

18 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 20.05.24, 13:17
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!