Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



3 страниц V   1 2 3 >

>  Не изменяется статья ДДС в документе платежные поручения входящие
jojojoba2
Отправлено: 11.09.20, 8:40


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

1C 8.3(8.3.15.1565) УПП

Проблема заключается в том что при фильтрации данных в документе "Платежные поручения входящие" по определенной статье ДДС и дальнейшем выводе этих данных(отфильтрованных по определенной статье ДДС) на печать не выводятся некоторые документы.Хотя в самом документе стоит нужная для фильтрации статья. Если в форме списка документа "Платежные поручения входящие" вывести поле "Статья движения денежных средств" то документ отображается с другой статьей, хотя в самом документе выставлена нужная статья.
Заметил что:
1) в список документов "Платежные поручения входящие" в поле "Статья движения денежных средств" попадает та статья которая в документе была указана первой до сохранения документа. Если поменять то в самом документе статья меняется, а вот в списке отображения нет.

Помогите разобраться в этой проблеме. Это глюк платформы? Или же где-то в настройках 1С это можно починить?

Заранее спасибо.
  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #166347 · Ответов: 0 · Просмотров: 143
 

>  обработка Заполнения табличной части документа при импорте из TXT файла
jojojoba2
Отправлено: 11.05.20, 14:47


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Bernet @ Сегодня, 15:25 * ,

Спасибо.

Bernet @ Сегодня, 15:25 * ,

СтрокаТабЧасти = Объект.Номера.Найти(Значение, "ИмяКолонкиПоКоторойПоиск");

Значение брать с перемменных перебора по теккстовому файлу : "тел","Абонплата","ЗНИЖКИ","ТекСумма":

СтрокаТабЧасти = Объект.Номера.Найти(тел, "ИмяКолонкиПоКоторойПоиск"); ? или может сравнивать с пустым значением(0)?

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #162891 · Ответов: 2 · Просмотров: 230
 

>  обработка Заполнения табличной части документа при импорте из TXT файла
jojojoba2
Отправлено: 11.05.20, 13:44


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите новичку. Делаю обработку импорта. Как заполнить определенные колонки табличной части(данные в остальных не должны пропасть) из строчек TXT?
Скиньте ,если можно пример.

Мне нужно чтобы значения в табличной части колонок "абонплата","Скидка","ТекСумма","ТекСуммаСПДВ" каторые заполнены, при следующем импорте(документ должен создаваться копированием) заменялись новыми(за следующий месяц).Все остальное(в колонках "НомерТелефона","НомерКонтракта","ТарифнийПлан","Подразделение" должно остаться.

Как перезаписать(переввести) определенные данные в табличную часть документа?

При импорте ,когда тч документа пуста я использовал:
СтрТаб = ЭтотОбъект.Номера.Добавить();

СтрТаб.НомерТелефона = Тел;
СтрТаб.НомерКонтракта = Контракт;
СтрТаб.ТарифнийПлан = Тариф;
СтрТаб.Абонплата = АбонплатаСПдв;
СтрТаб.Скидка = ЗНИЖКИ ;
СтрТаб.ТекСумма = ТекСумма;
//ТекСуммаПДВ = ТекСумма*0.2;
//ТекСуммаСПДВ = +ТекСуммаПДВ+ТекСумма;
СтрТаб.ТекСуммаСПДВ = ТекСуммаСПДВ;


Но это просто добавляет строки снизу, а не перезаписывает

Пробовал и так
Т=ЭлементыФормы.Номера.ТекущиеДанные;
Т. Абонплата = АбонплатаСПдв;
Т. Скидка = ЗНИЖКИ ;
Т. ТекСумма = ТекСумма;
Т. ТекСуммаСПДВ = ТекСуммаСПДВ;

но заменяет почемуто данные только в первой строке.

Вот вся обработка импорта :
Процедура ОсновныеДействияФормыЗаполнить(Кнопка)

Перем Стр;
Стр = "";

Режим = РежимДиалогаВыбораФайла.Открытие;
ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
ДиалогОткрытияФайла.ПолноеИмяФайла = "";
Текст = "ru = "" Текст""; en = ""Text""";
Фильтр = Нстр(Текст)+"(*.txt)|*.txt";
ДиалогОткрытияФайла.Фильтр = Фильтр;
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;

Если ДиалогОткрытияФайла.Выбрать() Тогда
ИмяФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;


Сообщить (ИмяФайла);
Иначе
Текст = "ru= ""Файл не выбран!""; en=""File not selected""";
Предупреждение(НСтр(Текст));

КонецЕсли;





Текст = Новый ТекстовыйДокумент();

Текст.Прочитать(ИмяФайла);

Стр = Текст.ПолучитьТекст() ;


Если Найти(Стр,"ТОВАРИСТВО З ОБМЕЖЕНОЮ")>0 тогда
Организация2=Лев(СокрЛП(Сред(Стр,Найти(Стр,"ТОВАРИСТВО З ОБМЕЖЕНОЮ")+42)),20);
КонецЕсли;


Если Найти(Стр,"Особовий рахунок:")>0 тогда
ОсобовийРахунок=Лев(СокрЛП(Сред(Стр,Найти(Стр,"Особовий рахунок:")+18)),13);
КонецЕсли;

Если Найти(Стр,"Номер рахунку:")>0 тогда
НомерРахунку=Лев(СокрЛП(Сред(Стр,Найти(Стр,"Номер рахунку:")+16)),10);
КонецЕсли;

Если Найти(Стр,"Номер рахунку:")>0 тогда
НомерРахункуРозрах=Лев(СокрЛП(Сред(Стр,Найти(Стр,"Номер рахунку:"))),40);
КонецЕсли;

Если Найти(Стр,"Розрахунковий період:")>0 тогда
РозрахунковийПеріод=Лев(СокрЛП(Сред(Стр,Найти(Стр,"Розрахунковий період:"))),45);
КонецЕсли;

Если Найти(Стр,"ЗАГАЛОМ БЕЗ ПОДАТКІВ: ")>0 тогда
СуммаБезПДВ2=Лев(Сред(Стр,Найти(Стр,"ЗАГАЛОМ БЕЗ ПОДАТКІВ: ")+94),11);
КонецЕсли;

Если Найти(Стр,"ЗАГАЛОМ НАРАХОВАНО ЗА ПЕРІОД ЗА ВСІМА КОНТРАКТАМИ РАЗОМ З ПДВ ТА ПФ")>0 тогда
СуммаСПДВ2=Лев(Сред(Стр,Найти(Стр,"ЗАГАЛОМ НАРАХОВАНО ЗА ПЕРІОД ЗА ВСІМА КОНТРАКТАМИ РАЗОМ З ПДВ ТА ПФ")+94),11);
КонецЕсли;





Контракт="";
Тел="";
Пакет="";
Тариф=0;

Загалом=0;



Для а = 1 по Текст.КоличествоСтрок() Цикл
Стр = Текст.ПолучитьСтроку(а);




Если Найти(Стр,"Контракт №")>0 тогда


Тел=Прав(СокрЛП(Сред(Стр,Найти(Стр,"Контракт №")+4)),10);
Контракт=Лев(СокрЛП(Сред(Стр,Найти(Стр,"Контракт №")+10)),12);


ИначеЕсли Найти(Стр,"Тарифний Пакет:")>0 тогда
Тариф= Лев(СокрЛП(Сред(Стр,Найти(Стр,"Тарифний Пакет:")+15)),21);

ИначеЕсли Найти(Стр,"ВАРТІСТЬ ПАКЕТА/ЩОМІСЯЧНА ПЛАТА: ")>0 тогда
Абонплата=Прав(СокрЛП(Сред(Стр,Найти(Стр,"ВАРТІСТЬ ПАКЕТА/ЩОМІСЯЧНА ПЛАТА: ")+4)),9);


ИначеЕсли Найти(Стр,"Знижка на суму особового рахунку ")>0 тогда
ЗНИЖКИ=Прав(СокрЛП(Сред(Стр,Найти(Стр,"Знижка на суму особового рахунку ")+4)),9);



ИначеЕсли Найти(Стр,"ЗАГАЛОМ ЗА КОНТРАКТОМ")>0 тогда
ТекСумма=Прав(СокрЛП(Сред(Стр,Найти(Стр,"ЗАГАЛОМ ЗА КОНТРАКТОМ")+4)),9);


АбонплатаПдв = Абонплата*0.2;
АбонплатаСПдв = АбонплатаПдв+ Абонплата;
ТекСуммаПДВ = ТекСумма*0.2;
ТекСуммаСПДВ = +ТекСуммаПДВ+ТекСумма;

Если Справочники.МобильныеНомераСотрудников.НайтиПоНаименованию(Тел).Пустая() Тогда


СтрТаб = ЭтотОбъект.Номера.Добавить();
СтрТаб.НомерТелефона = Тел;
СтрТаб.НомерКонтракта = Контракт;
СтрТаб.ТарифнийПлан = Тариф;
СтрТаб.Абонплата = АбонплатаСПдв;
СтрТаб.Скидка = ЗНИЖКИ ;
СтрТаб.ТекСумма = ТекСумма;
СтрТаб.ТекСуммаСПДВ = ТекСуммаСПДВ;

Иначе

Т=ЭлементыФормы.Номера.ТекущиеДанные;
Т. Абонплата = АбонплатаСПдв;
Т. Скидка = ЗНИЖКИ ;
Т. ТекСумма = ТекСумма;
Т. ТекСуммаСПДВ = ТекСуммаСПДВ;

КонецЕсли;

Контракт="";
Тел="";
Пакет="";
Тариф=0;
Абонплата = 0;
ЗНИЖКИ = 0;

КонецЕсли;
КонецЦикла;

ЭтотОбъект.СуммаИтого = СуммаБезПДВ2;
ЭтотОбъект.Номер_рахунку =НомерРахунку;
ЭтотОбъект.ОсобовийРахунок = ОсобовийРахунок;
ЭтотОбъект.Организация = Организация2 ;
ЭтотОбъект.СуммаСПдв =СуммаСПДВ2;
ЭтотОбъект.Примечание =НомерРахункуРозрах+" "+РозрахунковийПеріод;


Для Каждого ТабСтр из ЭтотОбъект.Номера Цикл
СправМоб = Справочники.МобильныеНомераСотрудников.СоздатьЭлемент();


Если Справочники.МобильныеНомераСотрудников.НайтиПоНаименованию(ТабСтр.НомерТелефона).Пустая() Тогда


СправМоб.Наименование = ТабСтр.НомерТелефона;
СправМоб.НомерКонтракта = ТабСтр.НомерКонтракта;
СправМоб.ТарифнийПлан = ТабСтр.ТарифнийПлан;
СправМоб.Записать();

КонецЕсли ;
КонецЦикла;
КонецПроцедуры



Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #162889 · Ответов: 2 · Просмотров: 230
 

>  Заполнение данных в колонку табличной части документа
jojojoba2
Отправлено: 07.05.20, 14:29


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


volodya1122 @ Сегодня, 11:31 * ,

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #162799 · Ответов: 4 · Просмотров: 280
 

>  Заполнение данных в колонку табличной части документа
jojojoba2
Отправлено: 06.05.20, 13:34


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите новичку. Делаю обработку в которой нужно импортировать данные в табличную часть документа. Мне нужно, чтобы если, в табличной части уже есть в колонке номенклатура - краска_эмаль_зеленая, то повторно при импорте ее название не попадало,а попадало только значение новой стоимости этой краски. Но если номенклатура - краска_эмаль_красная ,то тогда попадает и название и стоимость. В справочник получилось загрузить и не повторять названия:

Для Каждого ТабСтр из ЭтотОбъект.Номера Цикл
СправМоб = Справочники.МобильныеНомераСотрудников.СоздатьЭлемент();
Если Справочники.МобильныеНомераСотрудников.НайтиПоНаименованию(ТабСтр.НомерТелефона).Пустая() Тогда

СправМоб.Наименование = ТабСтр.НомерТелефона;
СправМоб.НомерКонтракта = ТабСтр.НомерКонтракта;
СправМоб.ТарифнийПлан = ТабСтр.ТарифнийПлан;
СправМоб.Записать();
КонецЕсли;


Как сделать в табличной части документа?
Пожалуйста скиньте подобный пример кода.

Заранее спасибо.


 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #162773 · Ответов: 4 · Просмотров: 280
 

>  импорт txt. Заполнение табличной части документа
jojojoba2
Отправлено: 05.05.20, 15:07


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите разобраться новичку. Создал обработку импорта TXT файла:

Код
Мобильный = ЭтотОбъект.Номера.Найти(,"НомерТелефона");

Если ПустаяСтрока(Мобильный.НомерТелефона) Тогда
СтрТаб = ЭтотОбъект.Номера.Добавить();

СтрТаб.НомерТелефона = Тел;
СтрТаб.НомерКонтракта = Контракт;
СтрТаб.ТарифнийПлан = Тариф;
АбонплатаПдв = Абонплата*0.2;
АбонплатаСПдв = АбонплатаПдв+ Абонплата;
СтрТаб.Абонплата = АбонплатаСПдв;
СтрТаб.Скидка = ЗНИЖКИ;
СтрТаб.ТекСумма = ТекСумма;

ТекСуммаПДВ = ТекСумма*0.2;
ТекСуммаСПДВ = +ТекСуммаПДВ+ТекСумма;
СтрТаб.ТекСуммаСПДВ = ТекСуммаСПДВ;

КонецЕсли;


Контракт="";
Тел="";
Пакет="";
Тариф=0;
Абонплата = 0;
ЗНИЖКИ = 0;
Загалом=0;
КонецЕсли;
КонецЦикла;

ЭтотОбъект.СуммаИтого = СуммаБезПДВ2;
ЭтотОбъект.Номер_рахунку =НомерРахунку;
ЭтотОбъект.ОсобовийРахунок = ОсобовийРахунок;
ЭтотОбъект.Организация = Организация2;
ЭтотОбъект.СуммаСПдв =СуммаСПДВ2;
ЭтотОбъект.Примечание =НомерРахункуРозрах+" "+РозрахунковийПеріод;


Для Каждого ТабСтр из ЭтотОбъект.Номера Цикл
СправМоб = Справочники.МобильныеНомераСотрудников.СоздатьЭлемент();
Если Справочники.МобильныеНомераСотрудников.НайтиПоНаименованию(ТабСтр.НомерТелефона).Пустая() Тогда

СправМоб.Наименование = ТабСтр.НомерТелефона;
СправМоб.НомерКонтракта = ТабСтр.НомерКонтракта;
СправМоб.ТарифнийПлан = ТабСтр.ТарифнийПлан;
СправМоб.Записать();
КонецЕсли;


Хочу чтобы из TXT файла данные заполнялись в табличную часть если строка с номером(мобильной связи) пустая. Если повторение тогда пропуск. Только новые номера из TXT файла. И чтобы старые данные в табличной части документа оставались кроме колонок абонплата,скидка, СуммаИтого и СуммаСПдв.

Вот это не сработало:

Если ПустаяСтрока(Мобильный.НомерТелефона) Тогда
СтрТаб = ЭтотОбъект.Номера.Добавить();

Вообще не заполняет.

Буду рад за любую помощь.

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #162736 · Ответов: 2 · Просмотров: 219
 

>  Импорт данных с TXT файла в 1С с множественными разделителями
jojojoba2
Отправлено: 05.03.20, 12:08


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


volodya1122 @ Сегодня, 11:41 * ,
Спасибо,буду крутить
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161046 · Ответов: 8 · Просмотров: 528
 

>  Импорт данных с TXT файла в 1С с множественными разделителями
jojojoba2
Отправлено: 05.03.20, 10:25


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 9:51 * ,
Vofka @ Сегодня, 9:51 * ,

А можно какой нибудь пример
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161041 · Ответов: 8 · Просмотров: 528
 

>  Импорт данных с TXT файла в 1С с множественными разделителями
jojojoba2
Отправлено: 05.03.20, 9:45


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Поставили задачу сделать импорт TXT файла по мобильной связи в 1С.Я начинающий программист,поетому не судите строго).
1).Суть в том что в файле не нужно перебирать все строки.
2).В нем нужно использовать несколько разделителей.

3).Данные находятся в текстовых блоках
Попробовал создать процедуру,но она перебирает все строки и по 10 раз заполняет номера
Процедура ОсновныеДействияФормыЗаполнить(Кнопка)
    
    Перем Стр;
          Стр = "";
          Режим = РежимДиалогаВыбораФайла.Открытие;
          ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
          ДиалогОткрытияФайла.ПолноеИмяФайла = "";
          Текст = "ru = "" Текст""; en = ""Text""";
          Фильтр = Нстр(Текст)+"(*.txt)|*.txt";
          ДиалогОткрытияФайла.Фильтр = Фильтр;
          ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
          
          Если ДиалогОткрытияФайла.Выбрать() Тогда
              ИмяФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;

          Сообщить (ИмяФайла);
      Иначе
          Текст = "ru= ""Файл не выбран!""; en=""File not selected""";
          Предупреждение(НСтр(Текст));      
      КонецЕсли;
      Текст = Новый ТекстовыйДокумент();
      
    Текст.Прочитать(ИмяФайла);
          Для а = 1 по Текст.КоличествоСтрок() Цикл
                  Стр = Текст.ПолучитьСтроку(а);
          Тел=Прав(СокрЛП(Сред(Стр,Найти(Стр,"Контракт №")+4)),7);
          Стр = Текст.ПолучитьСтроку(а);
          СтрТаб = ЭтотОбъект.Номера.Добавить();
          СтрТаб.НомерТелефона = Тел;           
           КонецЦикла;  
КонецПроцедуры


Пожалуйста,помогите разобраться. Если можно скиньте пример даной релизации.

Спасибо.

jojojoba2 @ Сегодня, 9:44 * ,
Цитата
Контракт № 3954343434 Номер телефону: 380502423420
Тарифний Пакет: RED Business S
ВАРТІСТЬ ПАКЕТА/ЩОМІСЯЧНА ПЛАТА: . . . . . . . . . . . . . . . . . . . . 0.0000 78.4314 78.4314
КОНТЕНТ-ПОСЛУГИ: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13.3333
НАДАНІ КОНТЕНТ-ПОСЛУГИ: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13.3333
Голосові довідкові, розважальні та інші сервіси за спец. цінами . . . . . . . . . . . . . . . 13.3333
ЗНИЖКИ: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . -7.8431
Знижка на суму особового рахунку . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . -7.8431
ЗАГАЛОМ ЗА КОНТРАКТОМ (БЕЗ ПДВ ТА ПФ): . . . . . . . . . . . . . . . . . . . . . . . . . . . 83.9216




Контракт № 3954006243433 Номер телефону: 380504466577
Тарифний Пакет: RED Business ULTRA L
ВАРТІСТЬ ПАКЕТА/ЩОМІСЯЧНА ПЛАТА: . . . . . . . . . . . . . . . . . . . . 0.0000 352.9412 352.9412
ЗНИЖКИ: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . -35.2941
Знижка на суму особового рахунку . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . -35.2941
ЗАГАЛОМ ЗА КОНТРАКТОМ (БЕЗ ПДВ ТА ПФ): . . . . . . . . . . . . . . . . . . . . . . . . . . . 317.6471




Контракт № 395381614342 Номер телефону: 380503459087
Тарифний Пакет: RED Business S
ВАРТІСТЬ ПАКЕТА/ЩОМІСЯЧНА ПЛАТА: . . . . . . . . . . . . . . . . . . . . 0.0000 78.4314 78.4314
КОНТЕНТ-ПОСЛУГИ: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.5686
НАДАНІ КОНТЕНТ-ПОСЛУГИ: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.5686
SMS\USSD\MMS\довідкові\розважальні\контент та інші сервіси за спец. цінами. . . . . . . . . . 1.5686
ЗНИЖКИ: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . -7.8431
Знижка на суму особового рахунку . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . -7.8431
ЗАГАЛОМ ЗА КОНТРАКТОМ (БЕЗ ПДВ ТА ПФ): . . . . . . . . . . . . . . . . . . . . . . . . . . . 72.1569




Контракт № 395381612863 Номер телефону: 380505353433
Тарифний Пакет: RED Business M
ВАРТІСТЬ ПАКЕТА/ЩОМІСЯЧНА ПЛАТА: . . . . . . . . . . . . . . . . . . . . 0.0000 141.1760 141.1760
ЗНИЖКИ: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . -14.1176
Знижка на суму особового рахунку . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . -14.1176
ЗАГАЛОМ ЗА КОНТРАКТОМ (БЕЗ ПДВ ТА ПФ): . . . . . . . . . . . . . . . . . . . . . . . . . . . 127.0584
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161038 · Ответов: 8 · Просмотров: 528
 

>  Вывести счет учета в Документе ЗаказПоставщику в табл. части Товары при добавлении Номенклатуры
jojojoba2
Отправлено: 28.11.19, 9:05


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Подскажите пожалуйста, как в В 1С 8.3 УПП Вывести СчетУчета в Документе ЗаказПоставщику в табл. части Товары при добавлении Номенклатуры.
Как составить запрос, ведь в справочнике Номенклатура нету поля СчетУчета. Может есть какой-то еще метод для данной задачи.

Заранее спасибо.
  Форум: Корзина · Просмотр сообщения: #158043 · Ответов: 2 · Просмотров: 291
 

>  Вывести номер счета из плана счетов хозрасчетный в табличную часть формы документа
jojojoba2
Отправлено: 26.11.19, 18:12


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 18:10 * ,

При заполнении номенклатуры в справочнике не указывается номер счета (в плане счетов хозрасчетный). Как запросом вытащить номер счета для номенклатуры?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157960 · Ответов: 6 · Просмотров: 672
 

>  Вывести номер счета из плана счетов хозрасчетный в табличную часть формы документа
jojojoba2
Отправлено: 26.11.19, 17:59


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 17:39 * ,
А по какому полю связывать номенклатуру и плана счетов хозрасчетный?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157958 · Ответов: 6 · Просмотров: 672
 

>  Вывести номер счета из плана счетов хозрасчетный в табличную часть формы документа
jojojoba2
Отправлено: 26.11.19, 17:22


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

В 1С 8.3 УПП нужно вывести номер счета из плана счетов хозрасчетный в поле СчетУчетаБУ табличной части товары формы документа Заказ Поставщику при добавлении новой номенклатуры. Реквизит в документе уже был создан, но в модулях никаких процедур я не нашел. Подскажите пожалуйста :

---- Какой процедурой и каким методом это лучше реализовать( если можно пример кода)
---- Как связать номенклатуру и план счетов, если в номенклатуре не заполняется номер счета. Как делать запрос?
-----В документе Поступление товаров и услуг в табличной части товары это уже реализовано разработчиками 1С. Пытался скопировать процедуры ,по примеру этого документа ---ничего не получилось(((

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157955 · Ответов: 6 · Просмотров: 672
 

>  Ошибки при импорте файла клиент-банка
jojojoba2
Отправлено: 05.11.19, 10:00


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Конфигурация 1С 8.3 УПП

При импорте данных обработки "Обмен данными с системами клиент-банк" из файла v191104.zzz возникает ошибка:

{ВнешняяОбработка.КлиентБанк.МодульОбъекта(1506)}: Ошибка при вызове метода контекста (Записать)
спрБанкСчет.Записать();
по причине:
Значение "9" поля "Код" не уникально

Помогите исправить.Где и что править?

Спасибо.

Поставил 99, ругается Значение "99" поля "Код" не уникально. В чем прикол?

jojojoba2 @ Сегодня, 10:00 * ,
Поставил 99, ругается Значение "99" поля "Код" не уникально. В чем прикол?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157225 · Ответов: 1 · Просмотров: 1488
 

>  Как в выборке результата запроса сравнить значение(ВалютаДокумента)
jojojoba2
Отправлено: 28.10.19, 19:16


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Всем спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156977 · Ответов: 9 · Просмотров: 683
 

>  Как в выборке результата запроса сравнить значение(ВалютаДокумента)
jojojoba2
Отправлено: 28.10.19, 16:56


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите пожалуйста начинающему программисту. Как сравнить в результате запроса ВалютуДокумента и вывести параметр на макет :
Код
Процедура КнопкаСформироватьНажатие(Кнопка)
    ТабДок = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("Макет");
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ПлатежноеПоручениеВходящее.Ссылка,
        |    ПлатежноеПоручениеВходящее.Номер,
        |    ПлатежноеПоручениеВходящее.Дата,
        |    ПлатежноеПоручениеВходящее.Проведен,
        |    ПлатежноеПоручениеВходящее.ВалютаДокумента,
        |    ПлатежноеПоручениеВходящее.Оплачено,
        |    ПлатежноеПоручениеВходящее.Контрагент,
        |    ПлатежноеПоручениеВходящее.ДатаОплаты,
        |    ПлатежноеПоручениеВходящее.СуммаДокумента,
        |    ПлатежноеПоручениеВходящее.СтатьяДвиженияДенежныхСредств,
        //|    ПлатежноеПоручениеВходящее.Заказ,
        |    ПлатежноеПоручениеВходящее.РасшифровкаПлатежа.(
        |        СуммаНДС
        |    ) как   СуммаНДС
        |ИЗ
        |    Документ.ПлатежноеПоручениеВходящее КАК ПлатежноеПоручениеВходящее
        |ГДЕ
        |    ПлатежноеПоручениеВходящее.ДатаОплаты = &Дата
        |    И ПлатежноеПоручениеВходящее.Проведен =истина
        |    И ПлатежноеПоручениеВходящее.СтатьяДвиженияДенежныхСредств = &СтатьяДвиженияДенежныхСредств
        |    И ПлатежноеПоручениеВходящее.Оплачено = &Оплачено";
          
    Запрос.УстановитьПараметр("Дата", ЗаДату);
    Запрос.УстановитьПараметр("Оплачено", Оплочено);
    //Запрос.УстановитьПараметр("Проведен", "истина");
    Запрос.УстановитьПараметр("СтатьяДвиженияДенежныхСредств", стДвиженияДС);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    Область = Макет.ПолучитьОбласть("Детали");
    РасшифровкаПлатежаОбластьПодвалТаблицы = Макет.ПолучитьОбласть("РасшифровкаПлатежаПодвалТаблицы");
    РасшифровкаПлатежаОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("РасшифровкаПлатежаДетали");
    ТабДок.Очистить();
    ОбластьЗаголовок.Параметры.ДатаОплаты=ЗаДату;
    Номер="ФСМ " +Лев(Строка(ЗаДату),2)+"_" +Сред(Строка(ЗаДату),4,2)+ "/"+Сред(Строка(ЗаДату),9,2);
    ОбластьЗаголовок.Параметры.Номер=Номер;
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    //ТабДок.НачатьАвтогруппировкуСтрок();
    Выборка = РезультатЗапроса.Выбрать();
    СуммаСОбщ=0; СуммаБезОбщ=0; СуммаВознОбщ=0;
    Пока Выборка.Следующий() Цикл
        Область.Параметры.Заполнить(Выборка);
        Область.Параметры.Заказ=Выборка.Ссылка.РасшифровкаПлатежа[0].Сделка;
        НДС =  Выборка.Ссылка.РасшифровкаПлатежа[0].СуммаНДС;
        
        
        
        Если  Область.Параметры.ВалютаДокумента = "дол" Тогда  
            СуммаС = Выборка.СуммаДокумента * 24;
         Иначе
        
        СуммаС = Выборка.СуммаДокумента+НДС;
        КонецЕсли;
        
        
        СуммаВозн= Выборка.СуммаДокумента*ПроцентВН/100;
        СуммаСОбщ=СуммаСОбщ+СуммаС;
        СуммаБезОбщ= СуммаБезОбщ+ Выборка.СуммаДокумента;
        СуммаВознОбщ=СуммаВознОбщ+СуммаВозн;
        Область.Параметры.СуммаВозн=СуммаВозн;
        Область.Параметры.СуммаС=СуммаС;
        //Область.Параметры.СуммаС=СуммаС;
        ТабДок.Вывести(Область, Выборка.Уровень());
        ТабДок.НачатьГруппуСтрок();
        ТабДок.ЗакончитьГруппуСтрок();
    КонецЦикла;
    ОбластьПодвал.Параметры.СуммаСОбщ=СуммаСОбщ;
    ОбластьПодвал.Параметры.СуммаБезОбщ=СуммаБезОбщ;
    ОбластьПодвал.Параметры.СуммаВознОбщ=СуммаВознОбщ;
    ТабДок.Вывести(ОбластьПодвал);
    ТабДок.Показать();
КонецПроцедуры


Это не заработало:
Если  Область.Параметры.ВалютаДокумента = "дол" Тогда  
    СуммаС = Выборка.СуммаДокумента * 24;
Иначе
    СуммаС = Выборка.СуммаДокумента+НДС;
КонецЕсли;


Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156971 · Ответов: 9 · Просмотров: 683
 

>  Вывод реквизитов табличной части формы списка на печатную форму.
jojojoba2
Отправлено: 24.10.19, 11:34


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите разобраться с выводом реквизитов табличной части на печатную форму. В документе(реквизиты каторого тянутся с другого ДокументСписок-Платежное поручениеВходящее) на форме списка есть колонки в которые выводятся данные с табличных частей документа :

Код
Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
   Если ДанныеСтроки = Неопределено Тогда
        Возврат;
   КонецЕсли;
   Если ДанныеСтроки.Ссылка.РасшифровкаПлатежа.Количество() > 0 Тогда
        ОформлениеСтроки.Ячейки.ОстатокПоЗаказу.Значение = ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].Сделка;
        ОформлениеСтроки.Ячейки.Сумма.Значение = ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].СуммаВзаиморасчетов + ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].СуммаНДС;

   Конецесли;
КонецПроцедуры

Пытаюсь создать печатную форму с выводом реквизитов с табличной части -  сделка , данные не выводятся.Выводятся только реквизиты документа.


Процедура Печать1(Элемент,ДанныеСтроки)
ТабДок = Новый ТабличныйДокумент;
Макет = Документы.ПлатежноеПоручениеВходящее.ПолучитьМакет("СчетЗаказ");
        
Выборка = Документы.Справки_расчеты_роялти.Выбрать();
Реквизиты = Макет.ПолучитьОбласть("Реквизиты");
Пока Выборка.Следующий() Цикл
Реквизиты.Параметры.Заполнить(Выборка);

ТабДок.Вывести(Реквизиты);
КонецЦикла;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
КонецПроцедуры


Как вывести на печать данные со всех колонок формы списка документа?
Можно ли как - то прикрутить что-то подобное на "вывести список" из меню документа?
И как сделать вывод документов с отбором по дате?

Спасибо.


 ! 

Правила: 9
 
  Форум: Корзина · Просмотр сообщения: #156848 · Ответов: 1 · Просмотров: 487
 

>  Запрос вывода данных с табличной части в форму списка документа
jojojoba2
Отправлено: 18.10.19, 11:15


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

1с8.3 УПП. Необходимо создать запрос чтобы вывести информацию о заказе покупателя (документ-Платежное поручение исходящее) в колонку формы списка.



МассивЗаказов = Новый Массив;
Для Каждого Стр Из ОформленияСтрок Цикл
МассивЗаказов.Добавить(Стр.ДанныеСтроки.Ссылка);
КонецЦикла;
// Формируем запрос к остаткам заказов
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Справки_расчеты_роялти.РасшифровкаПлатежа.(
| Сделка
| )
|ИЗ
| Документ.Справки_расчеты_роялти.РасшифровкаПлатежа КАК Справки_расчеты_роялти
|ГДЕ
| Справки_расчеты_роялти.Сделка В(&МассивСсылок)";



Запрос.УстановитьПараметр("МассивСсылок", МассивЗаказов);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Выборка.Следующий();

Для Каждого Стр Из ОформленияСтрок Цикл
Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка;
КонецЦикла

КонецПроцедуры


1С ругается - поле Сделка не найдено.



--- может кто знает Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка; правильно ли для вывода данных в ячейку с запроса.

--- как правильно составить запрос для табличной части и механизм вывода в колонку

---Для Каждого Стр Из ОформленияСтрок Цикл
Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка;
КонецЦикла

Этого достаточно или еще нужны какие-то параметры


Программист я начинающий, помогайте кто чем может.
Спасибо.



  Форум: Корзина · Просмотр сообщения: #156641 · Ответов: 1 · Просмотров: 278
 

>  Вывод данных из поля табличной части в дополнительное поле формы списка документа
jojojoba2
Отправлено: 17.10.19, 13:14


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 14:00 * ,

Я тестирую вывод данных конкретно в ячейку , и мне интересно ТекОформление.Ячейки.ЗП.Значение(правильное значение) вообще выведет информацию? ТекОформление.Ячейки.ЗП.правильный метод
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156598 · Ответов: 6 · Просмотров: 1191
 

>  Вывод данных из поля табличной части в дополнительное поле формы списка документа
jojojoba2
Отправлено: 17.10.19, 12:45


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 13:28 * ,


А можно пожалуйста пример вывода данных , у меня подозрение что :

ТекОформление.Ячейки.ЗП.Значение(ВыборкаЗП.НайтиСледующий(ОтборВыборки)); - неправильно

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156593 · Ответов: 6 · Просмотров: 1191
 

>  Вывод данных из поля табличной части в дополнительное поле формы списка документа
jojojoba2
Отправлено: 17.10.19, 12:16


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Есть задача в 1С8.3 в форму списка документа Платежное поручение входящее добавить новое поле ЗаказПокупателя и в него вывести данные с табличной части РасшифровкаПлатежа из поля сделка(в котором отображается заказ покупателя). Помогите пожалуйста разобратся начинающему програмисту :

Код
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
     ЭтотОбъект = Документы.ПлатежноеПоручениеИсходящее;
    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
                  |    ЗаказПокупателя.Ссылка
                  |ИЗ
                  |    Документ.ЗаказПокупателя КАК ЗаказПокупателя
                  |ГДЕ
                  |    ЗаказПокупателя.Ссылка = &ТекущийДокумент";
    
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);
    Результат = Запрос.ВыполнитьПакет();
    ВыборкаЗП = Результат.Выбрать();
    
    ОтборВыборки = Новый Структура("Заказ");
    Для Каждого ТекОформление Из ОформленияСтрок Цикл
        ОтборВыборки.ЗаказПокупателя = ТекОформление.ДанныеСтроки.Ссылка;
        
         ТекОформление.Ячейки.ЗП.Значение(ВыборкаЗП.НайтиСледующий(ОтборВыборки));
        
    КонецЦикла;
КонецПроцедуры


ЗП ---это колонка в форме списка в которую нужно вывести данные


При запуске выдает ошибку:


Документ.Справки_расчеты_роялти.Форма.ФормаСписка.Форма(132)}: Поле объекта не обнаружено (СсылкаНаОбъект)
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);

----- Как правильно задать параметры колонки ЗП (поле ввода или указать данные реквизита )
----- Правильный запрос вывода значения с табличной части этого документа(я попытался через ссылку на заказ покупателя)
----- Правильный метод вывода значения в колонку формы списка.


Если можно , сбросьте пример.

Заранее всем спасибо.


 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156590 · Ответов: 6 · Просмотров: 1191
 

>  Редактирование печатной формы счета в1с7.7
jojojoba2
Отправлено: 08.10.19, 11:54


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


nik389 @ Сегодня, 12:53 * ,
Спасибо.Буду пробовать.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156319 · Ответов: 4 · Просмотров: 1828
 

>  Редактирование печатной формы счета в1с7.7
jojojoba2
Отправлено: 08.10.19, 11:44


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


nik389 @ Сегодня, 12:19 * ,

Если можно напишите,пожалуйста, пример.


jojojoba2 @ Сегодня, 12:35 * ,

Дело в том, что реквизита Р/р и Найменование банка нету в документе счет-фактура. Его нужно "подвязать" из справочника контрагенты.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156316 · Ответов: 4 · Просмотров: 1828
 

>  Редактирование печатной формы счета в1с7.7
jojojoba2
Отправлено: 08.10.19, 10:56


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите начинающему программисту и просьба не судить строго))). Я изучаю программирование в 1С 8 . Поставили задачу по 1с 7.7 Предприятие (Бухгалтерский учет по Украине) - доработать печатную форму документа счет-фактура. Начал разбиратся и увидел что 7 очень сильно отличается от 8. Есть внешний макет каторый лежит в \1cv77_db\Management\ExtForms\PrnForms SF3_ukr.mxl. В печатной форме нужно вывести р/р и банк контрагента. В документе счет-фактура нашел процедуру ПЕЧАТЬ

Код
Процедура Печать()
    //----
    Ф=_глПолучитьИмяФайлаПечатнойФормы("SF3",Метаданные.Документ(Вид()).Представление());
    
    ЕстьСкидка = 1;
    фУкр = ?(Константа.ФормыНаУкраинском = Да, 1, 0);
    Если (Константа.ИспользоватьСкидку<>Да) Или (ЧтоПродаем<>Перечисление.ЧтоПродаем.ТМЦ) Тогда
        ЕстьСкидка = 0;
    КонецЕсли;
    
    Таб = СоздатьОбъект("Таблица");
    Если ПустоеЗначение(Ф)=0 Тогда
        Таб.ИсходнаяТаблица(КаталогИБ()+"ExtForms\PrnForms\"+Ф);
    Иначе
        Таб.ИсходнаяТаблица("Таблица"+?(Константа.ФормыНаУкраинском = Да,"_Укр",""));
    КонецЕсли;
    
    Если Заказ.Выбран() = 1 Тогда
        Номер = Заказ.НомерДок;
        Если Заказ.Вид() = "Договор" Тогда
            Если ПустоеЗначение(Заказ.НомерДоговора) = 0 Тогда
                Номер = Заказ.НомерДоговора;
            КонецЕсли;
        КонецЕсли;
        тЗаказ = глУкр(Заказ.ПредставлениеВида()) + " № " +СокрЛП(Номер) + ?(фУкр = 1, " від "," от ") + Заказ.ДатаДок;;
    Иначе
        тЗаказ = ?(фУкр = 1,"Без замовлення","Без заказа");
    КонецЕсли;

    глУстПропись(Валюта);
    Таб.ВывестиСекцию("Шапка");
    Ном = 1;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
        ЕдИзм = ?(ТМЦ.Вид()="ТМЦ",Ед,ТМЦ.БазЕдиница);
        Таб.ВывестиСекцию("Строка");
        Если ФКомп = 1 Тогда
            СпрКомп = СоздатьОбъект("Справочник.СоставКомплекта");
            СпрКомп.ИспользоватьВладельца(ТМЦ);
            СпрКомп.ВыбратьЭлементы();
            Пока СпрКомп.ПолучитьЭлемент() = 1 Цикл
                Таб.ВывестиСекцию("Составляющая");        
            КонецЦикла;
        КонецЕсли;
        Ном = Ном+1;
    КонецЦикла;
    Если ЕстьСкидка=1 Тогда
        Таб.ВывестиСекцию("Скидка");
    КонецЕсли;
    Если (ВидНДС.Код = "БезНДС") Тогда      
        Таб.ВывестиСекцию("БезНДС");        
    Иначе
        Таб.ВывестиСекцию("ДноНДС");        
    КонецЕсли;
    Таб.ВывестиСекцию("Дно");
    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,,);
    Таб.Показать("ПЕЧАТЬ: Счет-фактура","");
КонецПроцедуры


Я не могу понять где в коде и в каких модулях выводятся параметры и шаблоны печатной формы каторые есть на форме . Где код с запросами по выводу данных. Искал во всех модулял в конфигурации,не нашел. Может есть какой-то внешний модуль?Где он может находиться? Как правильно в 1с7.7 прописать новый параметр в коде?

Помогите разобраться.Если можно скиньте примеры или какую-то инструкцию. Смотрел видео - там редактируют печатную форму вместе с макетом и с модулем *.ert . У меня внешний только макет *.xml.

Заранее спасибо.


 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156312 · Ответов: 4 · Просмотров: 1828
 

>  Как вывести значение булево(да или нет) в колонку Формы списка документа
jojojoba2
Отправлено: 13.09.19, 16:04


Говорящий
***

Группа: Пользователи
Сообщений: 56
Регистрация: 18.02.19
Пользователь №: 64372


Добрый деннь!
1С8.3 УПП

Подскажите подалуйста, как вывести значение булево(да или нет) в колонку Формы списка(обычную) документа.
Я создал реквизит типа булево. На форме списка создал колонку,подвязал реквизит к колонке. Выводит в строках формы значение - "Нет".

Как сделать чтобы при определенных условиях(если в структуре подчиненных документов есть НалоговаяНакладная) выводилось значение "Да".

Я в событии формы списка при открытии Создал процедуру :

Процедура ПриОткрытии(ОформленияСтрок)    
    МасЗаказы = Новый Массив;
    Для Каждого Стр Из ОформленияСтрок Цикл
        ДанныеСтроки = Стр.ДанныеСтроки;
        МасЗаказы.Добавить(ДанныеСтроки.Ссылка);
    КонецЦикла;
    //
    зЗапрос = Новый Запрос;
    Запрос.Текст =

          "ВЫБРАТЬ
          |    СвязанныеДокументы.Ссылка
          |ИЗ
          |    КритерийОтбора.СвязанныеДокументы(&ЗначениеКритерияОтбора) КАК СвязанныеДокументы";
    
          Запрос.УстановитьПараметр("ЗначениеКритерияОтбора",ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока);
                                                                
    Результат = Запрос.Выполнить();  
    
  
    Для Каждого Стр Из ОформленияСтрок Цикл
        тд = Стр.ДанныеСтроки;        
        Выборка.Сбросить();
        Если Выборка.НайтиСледующий(тд.Ссылка, "НалоговаяНакладная") Тогда


   ОформлениеСтроки.Ячейки.Флаг = Истина;     как правильно написать эту строку ???????????????? Выдает ошибку :


Документ.ЗаказПокупателя.Форма.ФормаСписка.Форма(104)}: Значення не є значенням об`єктного типу (Ячейки)

Подскажите пожалуйста как правильно написать код : если значение запроса = нужное значение то в строке напротив документа поставить значение "ДА"

Спасибо за любую помощь.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155609 · Ответов: 1 · Просмотров: 1332
 

3 страниц V   1 2 3 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 02.12.20, 17:05
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!