Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику denis84 ::: Спасибо сказали: 47 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
02.12.20, 9:33 Запись не верна! Значение поля "Пользователь" не может быть пустым!: НастройкиПользователей
lina1982 @ Сегодня, 9:22 * ,
Добрый день! У Вас не видет "пользователь". Попробуйте вставить вместо "Пользователь", такую конструкцию
Пользователи.ТекущийПользователь();
. Такую инструкцию использовал при программной установке автора в документах.
lina1982,
01.12.20, 15:04 Ошибка при записи элемента справочника Пользователи в УНФ через внешнее подключение
info230a02 @ Сегодня, 14:28 * ,
Добрый день! Почитать можно здесь тут или здесь

форум. Вот здесь описано,хорошо здесь
info230a02,
25.11.20, 19:53 Условия сохранения определенного документа (1с 7.7.27)
andrew76 @ Сегодня, 18:57 * ,
При записи тоже есть такая процедура там и проверьте заполняемость реквизита

призаписи()

И вот тут полезно почитать:
тут
andrew76,
25.11.20, 17:54 Условия сохранения определенного документа (1с 7.7.27)
andrew76 @ Сегодня, 16:58 * ,
Добрый день! Если "сотрудник" в шапке документа то в модуле документа пишем:

// ===========================
Функция ПроверкаШапки()
    глВсеВыбрано = 1;
    глВыбранЛи(сотрудник,"сотрудник");
    //глВыбранЛи(Цех,"Цех");
    Возврат глВсеВыбрано;
КонецФункции


А если в строке, то так:
// ===========================
Функция ПроверкаСтроки()
    глВсеВыбрано = 1;
    глВыбранЛи(сотрудник,"сотрудник",НомерСтроки);
    Возврат глВсеВыбрано;
КонецФункции


А потом в обработке проведения проверяем:
// ===========================
Процедура ОбработкаПроведения()


Если ПроверкаШапки() = 0 Тогда
    глНеПроводить(Контекст);
    Возврат;
КонецЕсли;


ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
    Если ПроверкаСтроки() = 0 Тогда
        глНеПроводить(Контекст);
        Возврат;
    КонецЕсли;
КонецЦикла;
КонецПроцедуры
andrew76,
29.10.20, 8:20 Добавить поле ручного ввода. Бухгалтерский учёт для Украины 7.70.252
graf.vorontsov @ Вчера, 23:02 * ,
1.Открываем конфигурацию.
2.Находим наш документ, в его табличной части добавляем реквизит с типом строкам.
3.Открываем форму документу.
4.Меню "вставить" - "реквизиты".
5.Потом в "реквизитах табличной части" находим наш реквизит. Отмечаем его галочкой и жмем "вставить".
6.Сохраняем конфигурацию и проверяем в предприятии.

У меня по такому плану действий - реквизит доступен для редактирования. Вы что его добавили как текст, а не реквизит? Сделайте так, как я Вам написал. Потому, что "текст" добавляется "не доступным" для редактирования.
graf.vorontsov,
12.10.20, 13:28 1с 8 БП 3.0 ВПФ при отправки на почту получаю ошибку
Тема закрыта. Необходимо было в "Функция ПечатьДокумента(МассивОбъектов, ОбъектыПечати)" добавить строку

УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, 
                НомерСтрокиНачало, ОбъектыПечати, Шапка.Документ);


После этого стало формировать печатные формы для отправки по электронной почте
Vofka,
14.07.20, 20:00 Как вытянуть значения измерений из регистра ? (1c 7.7.027)
andrew76 @ Сегодня, 20:43 * ,
Надо вспоминать))

ОстаткиТоваров.Количество = ОстТоваров.Остаток(Фирма,ТекТов,Склад,"ОстатокТовара");
        
ОстаткиТоваров.Количество = ОстТоваров.СводныйОстаток(Фирма,ТекТов,,"ОстатокТовара");


А вот пример в виде запроса, как получить остатки и обороты товаров по складам

//*******************************************
Процедура Сформировать()
    Запр = СоздатьОбъект("Запрос");
    Таб = СоздатьОбъект("Таблица");
    ПечФорма = "ТаблицаШир_НеБУ";
    Таб.ИсходнаяТаблица(ПечФорма);

    ТекстЗапр = "";
    Заг = "";
    Заг1 = "";
    Заг2 = "";

    ПозицияОтчета = ДатаПо;
        
    ТекстЗапр = "
    |Период с ДатаС по ДатаПо;
    |Фир = Регистр.Остатки.Фирма;
    |Скл = Регистр.Остатки.МестоХранения;
    |ТМЦ = Регистр.Остатки.ТМЦ;";
    |Док = Регистр.Остатки.ТекущийДокумент;
    |Кво = Регистр.Остатки.ОстатокТовара;;
    |Условие (Фир = выбФирма);";
    |Условие (Скл в ВыбСклад);
    |Условие (Скл.Тип = Перечисление.ТипыМестХранения.Склад);
    |Условие (ТМЦ в ВыбТМЦ);
    |Группировка Скл;
    |Группировка ТМЦ упорядочить по ТМЦ.Код без групп;
    |Функция НОКво = НачОст(Кво);
    |Функция КОКво = КонОст(Кво);
    |Функция ПКво = Приход(Кво);
    |Функция РКво = Расход(Кво);";
    Если ВыбТМЦ.РазмерСписка() = 0 Тогда
        Заг1 = Заг1 + "По всім ТМЦ. ";
    Иначе
        Заг1 = Заг1 + "По ТМЦ зі списку: " + ВыбТМЦ.ВСтрокуСРазделителями() + ". ";
    КонецЕсли;
    Если ВыбСклад.Выбран() = 0 Тогда
        Заг2 = Заг2 + "По всім складам.";
    Иначе
        Заг2 = Заг2 + "По складу " + СокрЛП(ВыбСклад.ИсторическоеНаименование.Получить(ДатаПо)) + ".";
    КонецЕсли;

    Если Запр.Выполнить(ТекстЗапр) = 0 Тогда
        Возврат;
    КонецЕсли;

    Таб.ВывестиСекцию("Шапка");
    Пока Запр.Группировка("Скл") = 1 Цикл
        Таб.ВывестиСекцию("Скл");
        текНом = 0;
        Пока Запр.Группировка("ТМЦ") = 1 Цикл
            Если Запр.ТМЦ.Выбран() = 0 Тогда
                Продолжить;
            КонецЕсли;
            Если Запр.ТМЦ.ЭтоГруппа() = 1 Тогда
            Иначе
                текНом = текНом + 1;
                УчЦена = Запр.ТМЦ.УчетнаяЦена.Получить(ДатаПо);
                Таб.ВывестиСекцию("ТМЦ");
            КонецЕсли;
        КонецЦикла;
        
        Если Запр.Скл.ЭтоГруппа() = 0 Тогда
            Таб.ВывестиСекцию("ИтСклад");
            ИтКво = ИтКво + текНом;
            текНом = 0;
        КонецЕсли;
    КонецЦикла;
    Таб.ВывестиСекцию("Итог");
    Таб.Опции(0,0,Таб.ВысотаСекции("Шапка"),0);
    Таб.ТолькоПросмотр(1);    
    Таб.ПараметрыСтраницы(2,95,,3,3,3,3,,,,,);
    Таб.Показать("Оборотка ТМЦ по складам");
КонецПроцедуры
andrew76,
08.07.20, 12:18 Отрицательные остатки ОСВ
Татьяна92 @ Сегодня, 12:31 * ,
Добрый день! Разрешаете списывать со склада в минус. Посмотрите в константах (настройки параметров учета) у вас отключен контроль отрицательных остатков.
Татьяна92,
25.06.20, 15:16 Выбор минимальной даты в ТаблицеЗначений 1С 7.70.003 торговля склад для Украины?
Цитата(Sharzem @ 25.06.20, 16:08) *
На ДБФ відпрацює однаково. Мала затримка на виборці.

Согласен
ZUBR,
24.06.20, 14:23 Помощь при выборе конфигурации 1С
Цитата(Bernet @ 24.06.20, 14:42) *
denis84 @ Сегодня, 13:09 ,
Здравствуйте. Огромное спасибо.

Для этого есть специальная кнопка "спасибо".
premiumMagnolia,
24.06.20, 12:09 Помощь при выборе конфигурации 1С
premiumMagnolia @ Сегодня, 12:50 * ,
Добрый день! Установить платформу 1С 8.3.13, добавить новую информационную базу, зайти в конфигуратор из файла ET191031_8313.cf загрузить и сохранить конфигурацию. Потом можно начать работу - заполнение справочников, ввод документов движения ТМЦ и т. д.
premiumMagnolia,
19.06.20, 21:17 Как программно заполнить табличную часть документа 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 21:29 * ,
Если элемент помечен на удаление ищем следующий.

Результат - это и есть цена. Напишите у себя это. Подставьте свои переменные. Проверьте через сообщить(). Это кусок кода из торговли и склад 7.7. Вы спрашивали,как выбрать из подчинённого справочник а цены получить цену товар,вот этот код Вам поможет. Только замените на свои переменные, вот ту строку "продолжить" можете выбросить.
ZUBR,
19.06.20, 10:40 Яка краща версія платформи з 8.3?
o.broshko @ Сегодня, 11:33 * ,
Добрый день! Я использую сейчас 8.3.13.1513.
o.broshko,
16.06.20, 20:02 Как программно заполнить табличную часть документа 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 19:52 * ,
Для подбора есть процедура в глобальном модуле прописана. Можете там посмотреть. Но смысл такой же
ZUBR,
16.06.20, 10:25 Как программно заполнить табличную часть документа 1с 7.7 конф 7.7.00
denis84 @ Сегодня, 9:04 * ,
Процедура ПриИзмПривыд()
Акс.цена = товар.цена;
Акс.Количество=Ак;
Акс. Сумма = Акс.количество*акс.цена;

Акс.Записать();
Что такое надо написать и установить эту процедуру на реквизит привыд
ZUBR,
16.06.20, 8:04 Как программно заполнить табличную часть документа 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 1:43 * ,
Добрый день! Для остальных реквизитов - прописать эти процедуры изменения т.е. при изменении ПриВыд и т.д. должна отрабатывать процедура

denis84 @ Сегодня, 8:47 * ,
Т. е. на реквизит ПриВыд назначить процедуру изменения остальных реквизитов.
ZUBR,
12.06.20, 11:16 Модификации товара
Михрутка @ Сегодня, 12:01 * ,
Добрый день! А "дополнительные свойства объектов" для каждой номенклатуры не подойдут Вам? Я так реализовывал когда коэффициенты пересчетов для номенклатуры (для рос. 1с 8:бухгалтерии)
Михрутка,
11.06.20, 12:19 Налаштування типової операції
tomol22 @ Сегодня, 12:36 * ,
Ось є такі посилання: Типовые операции і також типовые операции 2
tomol22,
11.06.20, 10:41 Налаштування типової операції
tomol22 @ Сегодня, 11:07 * ,
Тобто ви хочите,щоб у циклі Вам пропонувало заповнювати переметри проводки?. Але здається, що для окремої проводки потрібно вводити параметри заново. Схиляюся до того, що тільки програмування вирішить Вашу проблему. Можливо і помиляюся, але іншого виходу не бачу
tomol22,
02.06.20, 13:29 Как изменить назначение кнопки - Новая строка (Ins) в окне Журнала Счета-фактуры.
F.U.T.U. @ Сегодня, 11:41 * ,
Добрый день! Измените состав документов для этого журнала. Оставьте в нем счёт-фактуру. А остальным докам назначьте другой журнал
F.U.T.U.,
27.05.20, 18:37 Условия отбора во внешних обработках
SemenYU @ Сегодня, 19:11 * ,
Понятно,так сразу не скажу надо глянуть. В УТ в печати прайса,есть отборы.

denis84 @ Сегодня, 19:22 * ,
В УТ есть такое, может натолкнет Вас на мысль:
Функция ПолучитьСписокВидовСравненияПоТипу(ОпТипов) Экспорт
    
    ТаблицаДоступныхЗначений = Новый ТаблицаЗначений;
    ТаблицаДоступныхЗначений.Колонки.Добавить("ВидСравнения");
    ТаблицаДоступныхЗначений.Колонки.Добавить("ЧислоВида");
    
    Для каждого ТипОписания Из ОпТипов.Типы() Цикл
    
        НоваяСтрокаТаблицы = ТаблицаДоступныхЗначений.Добавить();
        НоваяСтрокаТаблицы.ВидСравнения = ВидСравнения.Равно;
        НоваяСтрокаТаблицы.ЧислоВида = 1;
        
        НоваяСтрокаТаблицы = ТаблицаДоступныхЗначений.Добавить();
        НоваяСтрокаТаблицы.ВидСравнения = ВидСравнения.НеРавно;
        НоваяСтрокаТаблицы.ЧислоВида = 1;
        
        НоваяСтрокаТаблицы = ТаблицаДоступныхЗначений.Добавить();
        НоваяСтрокаТаблицы.ВидСравнения = ВидСравнения.ВСписке;
        НоваяСтрокаТаблицы.ЧислоВида = 1;
        
        НоваяСтрокаТаблицы = ТаблицаДоступныхЗначений.Добавить();
        НоваяСтрокаТаблицы.ВидСравнения = ВидСравнения.НеВСписке;
        НоваяСтрокаТаблицы.ЧислоВида = 1;

        Если Справочники.ТипВсеСсылки().СодержитТип(ТипОписания) И Метаданные.НайтиПоТипу(ТипОписания).Иерархический Тогда
            
            НоваяСтрокаТаблицы = ТаблицаДоступныхЗначений.Добавить();
            НоваяСтрокаТаблицы.ВидСравнения = ВидСравнения.ВСпискеПоИерархии;
            НоваяСтрокаТаблицы.ЧислоВида = 1;
            
            НоваяСтрокаТаблицы = ТаблицаДоступныхЗначений.Добавить();
            НоваяСтрокаТаблицы.ВидСравнения = ВидСравнения.НеВСпискеПоИерархии;
            НоваяСтрокаТаблицы.ЧислоВида = 1;
            
            НоваяСтрокаТаблицы = ТаблицаДоступныхЗначений.Добавить();
            НоваяСтрокаТаблицы.ВидСравнения = ВидСравнения.ВИерархии;
            НоваяСтрокаТаблицы.ЧислоВида = 1;
            
            НоваяСтрокаТаблицы = ТаблицаДоступныхЗначений.Добавить();
            НоваяСтрокаТаблицы.ВидСравнения = ВидСравнения.НеВИерархии;
            НоваяСтрокаТаблицы.ЧислоВида = 1;
КонецЕсли;
конецфункции
SemenYU,
27.05.20, 7:57 Как правильно сравнивать два строковых реквизита? 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 2:27 * ,
Добрый день! Вот пример:

Мистер =СоздатьОбъект("Справочник.Контрагенты");    
Изм=0;
Мистер.НайтиПоКоду(Контр.Код,0);       //контр - реквизит на форме
КК = Мистер.ТекущийЭлемент();

Если  ВРЕГ(СокрЛП(КК.ПочтовыйАдрес))<>ВРЕГ(СокрЛП(Адрес)) Тогда
    изм = 0;
    сообщить(изм);
Иначе  
    Изм=1;
    сообщить(изм);
КонецЕсли;
ZUBR,
26.05.20, 15:08 Как программно выбрать и изменить один документ 1с 7.7 конф 7.7.00
ZUBR @ Вчера, 23:33 * ,
Добрый день! Вот пример как надо написать:
Процедура Изменить()
    Расх=СоздатьОбъект("Документ.РасходнаяНакладная");
    Расх.НайтиДокумент(СсылкаДокумент);
    Расх.Получил = "Получил товар 26/05/2020 от водителя Иванова П.С.";
    Расх.Записать();
КонецПроцедуры

ZUBR,
23.05.20, 8:57 Как программно закрыть таблицу печатной формы 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 1:20 * ,
Доброе утро! Вот ссылка https://forum.mista.ru/topic.php?id=153547#message_2. Там в "показать", есть активизировать с параметром "-1"
ZUBR,
21.05.20, 9:07 нажатие на поле ввода програмно
denis84 @ Вчера, 22:28 * ,
Добрый день!
Процедура ПоказатьОбъект(Объект,конт)
    Если Объект = "" Тогда
    Иначе
    ОткрытьФорму(Объект,конт);
    КонецЕсли;
КонецПроцедуры

Процедура ПоказатьДок()
Перем конт;
ДокументЖурнала = Доверенность.ТекущийДокумент();
ПоказатьОбъект("Журнал.Доверенности",конт);
конт.УстановитьИнтервал(ДокументЖурнала.Датадок,ДокументЖурнала.Датадок, 0);
Конт.АктивизироватьОбъект(ДокументЖурнала);
конецпроцедуры


Процедура ПоказатьДок() установлена на кнопке в справочнике. Код рабочий.
4andriy,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 04.12.20, 22:33
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!