Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



13 страниц V   1 2 3 > » 

>  Шукаю обробку завантаження виписок Укрсіббанк для 1с7
denis84
Отправлено: 26.11.22, 22:35


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


3y6il0 @ Сегодня, 14:33 * ,

Могу Вам помочь! Не безплатно, есть наработки
  Форум: Прочее 1С 7.7 · Просмотр сообщения: #176571 · Ответов: 1 · Просмотров: 39
 

>  Как добавить новую ставку НДС?
denis84
Отправлено: 23.11.22, 8:10


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Ledi29 @ Вчера, 22:46 * ,
Перечисление "СтавкиНДС". В конфигураторе добавить новое значение перечисления. Но этого мало потом, необходимо еще в общих модулях (или модулях документов) описать расчет ставки НДС.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176569 · Ответов: 1 · Просмотров: 659
 

>  Подсчет количества строк в ДокументСписок без использования запроса
denis84
Отправлено: 22.11.22, 20:33


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Myhasik @ Сегодня, 18:32 * ,
Построитель = Новый ПостроительЗапроса;
Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ДокументСписок);
КоличествоДокументов = Построитель.Результат.Выгрузить().Количество();
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176567 · Ответов: 1 · Просмотров: 89
 

>  опишите пожалуйста, как производить отладку через COM
denis84
Отправлено: 21.11.22, 13:14


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


https://pro1c.org.ua/index.php?showtopic=25057
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176562 · Ответов: 4 · Просмотров: 129
 

>  як користуватися функцією Ценообразование.ПолучитьЦенуКонтрагента() ?
denis84
Отправлено: 21.11.22, 11:17


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


berest.andriy@gmail.com @ Сегодня, 10:23 * ,
// Функция возвращает цену контрагента для требуемой номенклатуры в указанном типе цен , 
// на заданную дату, за заданную единицу измерения, пересчитанную в требуемую валюту по заданному курсу.
//
// Параметры:
//  Номенклатура               - ссылка на элемент справочника "Номенклатура", для которого надо получить цену,
//  ХарактеристикаНоменклатуры - ссылка на элемент справочника "Характеристики номенклатуры",
//  Контрагент                 - ссылка на элемент справочника "Контрагенты", для которого надо получить цену,
//  ТипЦен                     - ссылка на элемент справочника "Типы цен", опредедяет цену какого типа надо получить,
//  Дата                       - дата, на которую надо получить цену, если не заполнено, то берется рабочая дата
//  ЕдиницаИзмерения           - ссылка на элемент справочника "Единицы измерения", определяет для какой единицы надо получить
//                               цену, если не заполнен, то заполняется единицей цены
//  Валюта                     - ссылка на элемент справочника "Валюты", определяет валюту. в которой надо вернуть цену,
//                               если не заполнен, то заполняется валютой цены
//  Курс                       - число, курс требуемой валюты, если не заполнен, берется курс из регистра
//                               сведений "Курсы валют".
//  Кратность                  - число, кратность требуемой валюты, если не заполнена, берется курс из регистра
//                               сведений "Курсы валют".
//
// Возвращаемое значение:
//  Число, рассчитанное значение цены.
//
Функция ПолучитьЦенуКонтрагента(Номенклатура, ХарактеристикаНоменклатуры = Неопределено, Контрагент,
                                ТипЦен, Дата = Неопределено, ЕдиницаИзмерения = Неопределено,
                                Валюта = Неопределено, Курс = 0, Кратность = 1,
                                ДоговорКонтрагента = Неопределено, УсловиеПродаж = Неопределено) Экспорт

    ХарактеристикиНоменклатуры = ПолучитьМассивХарактеристик(ХарактеристикаНоменклатуры);

    Дата = ПолучитьАктуальнуюДатуРасчетаЦен(Дата);

    ПолученнаяЦена = 0;

    Если ДоговорКонтрагента <> Неопределено Тогда
        Запрос = Новый Запрос;
        Запрос.УстановитьПараметр("Дата", Дата);
        Запрос.УстановитьПараметр("Договор", ДоговорКонтрагента);
        Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
        Запрос.УстановитьПараметр("ХарактеристикиНоменклатуры", ХарактеристикиНоменклатуры);

        ТекстЗапроса = "
        |ВЫБРАТЬ ПЕРВЫЕ 1
        |    УсловияПоставок.Цена                  КАК Цена,
        |    ВЫБОР    КОГДА сНоменклатура.Услуга И УсловияПоставок.ЕдиницаИзмерения = ЗНАЧЕНИЕ(Справочник.ЕдиницыИзмерения.ПустаяСсылка)
        |            ТОГДА сНоменклатура.ЕдиницаХраненияОстатков
        |            ИНАЧЕ УсловияПоставок.ЕдиницаИзмерения
        |    КОНЕЦ                                 КАК ЕдиницаИзмерения,
        |    УсловияПоставок.ВалютаЦены            КАК ВалютаЦены
        |ИЗ
        |    РегистрСведений.УсловияПоставокПоДоговорамКонтрагентовПоНоменклатуре.СрезПоследних(&Дата,
        |       ДоговорКонтрагента = &Договор И Номенклатура = &Номенклатура
        |       И ХарактеристикаНоменклатуры В (&ХарактеристикиНоменклатуры)) КАК УсловияПоставок
        |ВНУТРЕННЕЕ СОЕДИНЕНИЕ
        |    Справочник.Номенклатура КАК сНоменклатура
        |ПО
        |    сНоменклатура.Ссылка = УсловияПоставок.Номенклатура
        |ГДЕ
        |    УсловияПоставок.Цена <> 0 И сНоменклатура.Ссылка = &Номенклатура
        |УПОРЯДОЧИТЬ ПО
        |    УсловияПоставок.ХарактеристикаНоменклатуры УБЫВ
        |";

        Запрос.Текст = ТекстЗапроса;

        Выборка = Запрос.Выполнить().Выбрать();
        Если Выборка.Следующий() Тогда
            ПолученнаяЦена = ПересчитатьЦенуПриИзмененииЕдиницы(Выборка.Цена, Выборка.ЕдиницаИзмерения, ЕдиницаИзмерения);
            ПолученнаяЦена = ПересчитатьЦенуПриИзмененииВалюты(ПолученнаяЦена, Выборка.ВалютаЦены, Валюта, Курс, Кратность, Дата);
        КонецЕсли;
    КонецЕсли;

    Если ПолученнаяЦена = 0 Тогда // особых условий нет
        Запрос = Новый Запрос;
        Запрос.УстановитьПараметр("Дата", Дата);
        Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
        Запрос.УстановитьПараметр("ХарактеристикиНоменклатуры", ХарактеристикиНоменклатуры);
        Запрос.УстановитьПараметр("ТипЦен", ТипЦен);

        Запрос.Текст = "
        |ВЫБРАТЬ ПЕРВЫЕ 1
        |    ЦеныНоменклатурыКонтрагентов.Цена           КАК Цена,
        |    ВЫБОР    КОГДА сНоменклатура.Услуга И ЦеныНоменклатурыКонтрагентов.ЕдиницаИзмерения = ЗНАЧЕНИЕ(Справочник.ЕдиницыИзмерения.ПустаяСсылка)
        |            ТОГДА сНоменклатура.ЕдиницаХраненияОстатков
        |            ИНАЧЕ ЦеныНоменклатурыКонтрагентов.ЕдиницаИзмерения
        |    КОНЕЦ                                       КАК ЕдиницаИзмерения,
        |    ЦеныНоменклатурыКонтрагентов.Валюта         КАК Валюта
        |ИЗ
        |    РегистрСведений.ЦеныНоменклатурыКонтрагентов.СрезПоследних(&Дата, Номенклатура = &Номенклатура И ТипЦен = &ТипЦен
        |       И ХарактеристикаНоменклатуры В(&ХарактеристикиНоменклатуры)) КАК ЦеныНоменклатурыКонтрагентов
        |ВНУТРЕННЕЕ СОЕДИНЕНИЕ
        |    Справочник.Номенклатура КАК сНоменклатура
        |ПО
        |    сНоменклатура.Ссылка = ЦеныНоменклатурыКонтрагентов.Номенклатура
        |ГДЕ
        |    сНоменклатура.Ссылка = &Номенклатура
        |УПОРЯДОЧИТЬ ПО
        |    ХарактеристикаНоменклатуры УБЫВ
        |";

        Выборка = Запрос.Выполнить().Выбрать();
        Если Выборка.Следующий() Тогда
            ПолученнаяЦена = ПересчитатьЦенуПриИзмененииЕдиницы(Выборка.Цена, Выборка.ЕдиницаИзмерения, ЕдиницаИзмерения);
            ПолученнаяЦена = ПересчитатьЦенуПриИзмененииВалюты(ПолученнаяЦена, Выборка.Валюта, Валюта, Курс, Кратность, КонецДня(Дата));
        КонецЕсли;
    КонецЕсли;

    ИзменитьЦенуПоУсловиюПродаж(Дата, Номенклатура, УсловиеПродаж, ПолученнаяЦена);

    Возврат ПолученнаяЦена;

КонецФункции // ПолучитьЦенуКонтрагента()


Цена = Ценообразование.ПолучитьЦенуКонтрагента(Номенклатура, Характеристика, Контрагент, ТипЦен, Дата, ЕдиницаХранения, Валюта);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176556 · Ответов: 5 · Просмотров: 130
 

>  Відновленння обміну УРІБ
denis84
Отправлено: 19.11.22, 17:01


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Pashaboston @ Сегодня, 10:33 * ,
Обміняти конфігурації, а не дані
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176549 · Ответов: 1 · Просмотров: 104
 

>  Проведения документа по ссылке
denis84
Отправлено: 14.11.22, 15:53


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 15:15 * ,
Иногда необходимо при проведении документа, перепровести связанные с текущим, другие документы. В 1С:7.7 существует ограничение на проведение документов из модуля проведения, обойти ограничение можно следующим образом:
Иногда необходимо при проведении документа, перепровести связанные с текущим, другие документы. В 1С:7.7 существует ограничение на проведение документов из модуля проведения, обойти ограничение можно следующим образом:

    
//документ с которого хотим провести другой
Процедура ОбработкаПроведения()

Док = СоздатьОбъект("Документ");
Если Док.НайтиДокумент(ДокументОснование) = 1 Тогда
       ОткрытьФормуМодально(Док.ТекущийДокумент(),"ПровестиИЗакрыть",0);
КонецЕсли;

КонецПроцедуры

//Документ2, Модуль формы документа основание

Процедура ПриОткрытии()
       Если Форма.Параметр="ПровестиИЗакрыть" Тогда
         Провести();
         СтатусВозврата(0)
       КонецЕсли;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176538 · Ответов: 1 · Просмотров: 151
 

>  Ошибка печатати товарного чека
denis84
Отправлено: 11.11.22, 15:53


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Максон @ Сегодня, 15:26 * ,
для спасибо есть специальная кнопка
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #176534 · Ответов: 16 · Просмотров: 219
 

>  Ошибка печатати товарного чека
denis84
Отправлено: 11.11.22, 15:15


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Максон @ Сегодня, 14:38 * ,
В конфигураторе. Находите свой документ. Открываете его форму и там есть макеты печатных форм. И там уже их правите, как хотите. Но если не сильно ориентируетеся в 1с, лучше обращаться к программистам 1с
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #176532 · Ответов: 16 · Просмотров: 219
 

>  Ошибка печатати товарного чека
denis84
Отправлено: 11.11.22, 11:51


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Pepe @ Сегодня, 11:07 * ,
так, то й так
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #176530 · Ответов: 16 · Просмотров: 219
 

>  Ошибка печатати товарного чека
denis84
Отправлено: 11.11.22, 10:57


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Pepe @ Сегодня, 10:56 * ,
та что-то Максон конфигурацию не хочет дать, а то по тексту тяжело понять
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #176528 · Ответов: 16 · Просмотров: 219
 

>  Ошибка печатати товарного чека
denis84
Отправлено: 11.11.22, 10:02


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Максон @ Сегодня, 9:32 * ,
скиньте файл 1с7.md (это чисто конфигурации, без данных) с каталога вашей конфигурации на почту vdv1984@i.ua
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #176526 · Ответов: 16 · Просмотров: 219
 

>  Ошибка печатати товарного чека
denis84
Отправлено: 11.11.22, 8:33


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Максон @ Сегодня, 8:24 * ,
Сначала смотрите в модуле формы документа РасходнаяНакладная.
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #176523 · Ответов: 16 · Просмотров: 219
 

>  Ошибка печатати товарного чека
denis84
Отправлено: 11.11.22, 8:23


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Максон @ Сегодня, 8:14 * ,
Надо смотреть в колнфигуратор что там напсано, в модуле документа
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #176521 · Ответов: 16 · Просмотров: 219
 

>  Ошибка печатати товарного чека
denis84
Отправлено: 10.11.22, 20:56


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Максон @ Сегодня, 20:30 * ,
Отсутствкет файл печатной формы. Посмотрите в конфигураторе. На строку 693. Надо смотреть модуль документа. Больше всего что печатная форма чека подключалась как внешняя
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #176519 · Ответов: 16 · Просмотров: 219
 

>  Вывод факсимилей и печати на каждом листе печатной формы документа
denis84
Отправлено: 09.11.22, 9:52


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Цитата(Bernet @ 08.11.22, 17:42) *
Проверьте влазит ли картинка в вашу область (не выходит ли за рамки области)

не выходят за рамки области.

В макете всего 2 области "ТелоДоговора" и "ПечатьИПодписи". в области "ПечатьИПодписи" 2 картинки "печать" и "подпись" организации. Хочу добиться чтобы на каждом листе договора выводило эти картинки. ПроверитьВывод почему то не дает результата, выводит на последнем листе.

Вот код:

ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.АвтоМасштаб            = Истина;
    ТабличныйДокумент.ОриентацияСтраницы    = ОриентацияСтраницы.Портрет;

    Макет = ПолучитьМакет("ПФ_MXL_ДоговорБезНДС");

    ПервыйДокумент = Истина;
    
    Для каждого Ссылка Из МассивОбъектов Цикл    
        
        Если Не ПервыйДокумент Тогда
            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        ПервыйДокумент = Ложь;
        // Запомним номер строки, с которой начали выводить текущий документ.
        НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
        
        ЗапросШапка.УстановитьПараметр("ТекущийДокумент", Ссылка);
        Шапка = ЗапросШапка.Выполнить().Выбрать();
        Шапка.Следующий();
        
        УчитыватьНДС = УчетнаяПолитика.ПлательщикНДС(Шапка.Организация, Шапка.Дата);
        ОбластьТелоДоговора    = Макет.ПолучитьОбласть("ТелоДоговора");

        ОбластьТелоДоговора.Параметры.НомерДок        = Формат(Шапка.ДоговорКонтрагента.Номер,"Л=uk; ДЛФ=DD" );
        ОбластьТелоДоговора.Параметры.ДатаРеализации      = Формат(Шапка.ДоговорКонтрагента.Дата,"Л=uk; ДЛФ=DD" );

        СведенияОПоставщике = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата,,,);
        СведенияОПокупателе = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Покупатель, Шапка.Дата,,,);
        
        ОбластьТелоДоговора.Параметры.НаимПокупателя        = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе, "/,ПолноеНаименование,",,);
        ОбластьТелоДоговора.Параметры.НаимОрганизации    = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "/,ПолноеНаименование,",,);
        
        РуководителиОрганизации = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.Дата);
        РуководителиКонтрагента = ОтветственныеЛицаБП.ОтветственныеЛицаКонтрагента(Шапка.Покупатель, Шапка.Дата);
        
        Если ЗначениеЗаполнено(РуководителиОрганизации.РуководительФИО) Тогда
            ОбластьТелоДоговора.Параметры.ФИОРуководитель             = ОбщегоНазначенияБПВызовСервера.ПолучитьФамилиюИмяОтчество(РуководителиОрганизации.РуководительФИО.Фамилия,
                                                                                                                            РуководителиОрганизации.РуководительФИО.Имя, РуководителиОрганизации.РуководительФИО.Отчество, Ложь);
        КонецЕсли;
        Если ЗначениеЗаполнено(РуководителиКонтрагента.РуководительФИО) Тогда
            ОбластьТелоДоговора.Параметры.ФИОРуководительПокупателя  = ОбщегоНазначенияБПВызовСервера.ПолучитьФамилиюИмяОтчество(РуководителиКонтрагента.РуководительФИО.Фамилия,
                                                                                                                             РуководителиКонтрагента.РуководительФИО.Имя, РуководителиКонтрагента.РуководительФИО.Отчество, Ложь);
        КонецЕсли;

        ОбластьТелоДоговора.Параметры.ПочтаОрганизации    = БухгалтерскийУчетПереопределяемый.ПолучитьEmailИзКонтактнойИнформации(Шапка.Организация);
        ОбластьТелоДоговора.Параметры.ПочтаПокупателя    = БухгалтерскийУчетПереопределяемый.ПолучитьEmailИзКонтактнойИнформации(Шапка.Покупатель);        

        ОбластьТелоДоговора.Параметры.НаимПокупателя            = Шапка.Покупатель.Наименование;
        ОбластьТелоДоговора.Параметры.НаимОрганизации            = Шапка.Организация.Наименование;

        ОбластьТелоДоговора.Параметры.ПочтовыйАдресПокупателя    = БухгалтерскийУчетПереопределяемый.ПолучитьАдресИзКонтактнойИнформации(Шапка.Покупатель,"Почтовый");
        ОбластьТелоДоговора.Параметры.ПочтовыйАдрес            = БухгалтерскийУчетПереопределяемый.ПолучитьАдресИзКонтактнойИнформации(Шапка.Организация,"Почтовый");
        
        ОбластьТелоДоговора.Параметры.ЮрАдресПокупателя        = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе, "/,ЮридическийАдрес,",,);
        ОбластьТелоДоговора.Параметры.ЮрАдрес                = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "/,ЮридическийАдрес,",,);
        ОбластьТелоДоговора.Параметры.ЕДРПОУПокупателя        = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе, "/,КодПоЕДРПОУ,",,);
        ОбластьТелоДоговора.Параметры.ЕДРПОУ                          = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "/,КодПоЕДРПОУ,",,);
        
        ОбластьТелоДоговора.Параметры.БанкПокупателя          = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе,  "/,НомерСчета,Банк,МФО,",,);
        ОбластьТелоДоговора.Параметры.Банк                            = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике,  "/,НомерСчета,Банк,МФО,",,);
        
        ОбластьТелоДоговора.Параметры.Телефон                = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе,  "/,Телефоны,",,);

        ОбластьТелоДоговора.Параметры.ИПН                    = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе,  "/,ИНН,",,);
        ОбластьТелоДоговора.Параметры.ИПНПокупателя           = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике,  "/,ИНН,",,);
        
        ОбластьТелоДоговора.Параметры.ПочтаОрганизации        = БухгалтерскийУчетПереопределяемый.ПолучитьEmailИзКонтактнойИнформации(Шапка.Организация);
        ОбластьТелоДоговора.Параметры.ПочтаПокупателя        = БухгалтерскийУчетПереопределяемый.ПолучитьEmailИзКонтактнойИнформации(Шапка.Покупатель);        
        //ТабличныйДокумент.Вывести(ОбластьТелоДоговора);
        
        ОбластьПодписи          = Макет.ПолучитьОбласть("ПечатьИПодпись");

        ДанныеКартинкиПечать  = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Шапка.ФайлФаксимильнаяПечать);
        ДанныеКартинкиПодпись = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Шапка.ФайлФаксимильнаяПодпись);
    
        Если Не ДанныеКартинкиПечать = Неопределено Тогда
            ОбластьПодписи.Области.Печать.Картинка = Новый Картинка(ДанныеКартинкиПечать.ДвоичныеДанные);    
        КонецЕсли;
        
        Если Не ДанныеКартинкиПодпись = Неопределено Тогда
            ОбластьПодписи.Области.Подпись.Картинка    = Новый Картинка(ДанныеКартинкиПодпись.ДвоичныеДанные);
        КонецЕсли;

        Если ЗначениеЗаполнено(РуководителиОрганизации.РуководительФИО) Тогда
            ОбластьПодписи.Параметры.Руководитель             = Лев(РуководителиОрганизации.РуководительФИО.Имя,1)+". "+Лев(РуководителиОрганизации.РуководительФИО.Отчество,1)+". "+РуководителиОрганизации.РуководительФИО.Фамилия;
        КонецЕсли;
        
        Если ЗначениеЗаполнено(РуководителиКонтрагента.РуководительФИО) Тогда
            ОбластьПодписи.Параметры.РуководительПокупателя  = Лев(РуководителиКонтрагента.РуководительФИО.Имя,1)+". "+Лев(РуководителиКонтрагента.РуководительФИО.Отчество,1)+". "+РуководителиКонтрагента.РуководительФИО.Фамилия;
        КонецЕсли;            
                
        СтрокаСПодвалом = Новый Массив; // создадим массив для проверки вывода
        СтрокаСПодвалом.Добавить(ОбластьТелоДоговора);
        СтрокаСПодвалом.Добавить(ОбластьПодписи);
        
        Если  НЕ ТабличныйДокумент.ПроверитьВывод(СтрокаСПодвалом)  Тогда
            ТабличныйДокумент.Вывести(ОбластьТелоДоговора);

            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент,НомерСтрокиНачало, ОбъектыПечати, Ссылка);
    КонецЦикла;
    Возврат ТабличныйДокумент


натолкните на мысль. Знаю одно что, что-то делаю не так
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176513 · Ответов: 3 · Просмотров: 251
 

>  Вывод факсимилей и печати на каждом листе печатной формы документа
denis84
Отправлено: 08.11.22, 14:05


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Доброго дня! Занимаюсь разработкой ВПФ договора из документа "Реализация товаров и услуг" в конфигурации "Бухгалтерия для Украины 2.0.22.1. Добавил 2 картинки куда помещаються печать и подпись организации.

В макете есть области "телодоговора" и "подвал" так вот в подвале выводит, а вот в "телодоговора" не отображает эти картинки! Подскажите, как это побороть?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176508 · Ответов: 3 · Просмотров: 251
 

>  проста задача, забрати пропуски з числа більше 999, вернути рядком без пропусків
denis84
Отправлено: 05.11.22, 20:16


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


slavikdr @ Сегодня, 18:03 * ,
Замініть в значенні символ нпп. Вже не пам'ятаю синтаксис повністю. Але це точно символ нпп. Розділяє на тріади.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176502 · Ответов: 4 · Просмотров: 233
 

>  Як видалити всі документі із бази так щоб зилишки по регістрах залашилися
denis84
Отправлено: 04.11.22, 21:01


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 13:16 * ,
Є різні варіанти. Вручну, вигрузититв файл і загрузити в документи. Є ще таке як "свертка базы". Специальная обработка есть
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176500 · Ответов: 4 · Просмотров: 421
 

>  Як видалити всі документі із бази так щоб зилишки по регістрах залашилися
denis84
Отправлено: 04.11.22, 13:09


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kostya77 @ Сегодня, 13:04 * ,
Завести залишки по ТМЦ, взаєморозрахункам та інше на обрану дату. А потім видалити документи
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176497 · Ответов: 4 · Просмотров: 421
 

>  BAS КУП и обмен с системами Клиент-Банк
denis84
Отправлено: 30.10.22, 11:24


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Доброго дня! За цим посиланням подивіться і задайте питання. Куп це керовані форми,а УТП ні. Вам потрібно адаптувати ваші обробки формату по банкам. Посилання: https://pro1c.org.ua/topic/obrobka-obmin-z-...2-0-36848/?st=0
  Форум: BAS Комплексное управление предприятием · Просмотр сообщения: #176475 · Ответов: 4 · Просмотров: 90
 

>  Обработка для экспорта накладных в формат ММО
denis84
Отправлено: 26.10.22, 8:32


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


barabambler @ Сегодня, 9:07 * ,
Есть у меня такая обработка, работоспособность нет на чем проверить. Вот кусок кода записи самого файла:

    
    ИмяФайла = "C:\MMO\"+СсылкаНаОбъект.Номер+".mmo";
    Раз = Симв(9); //разделитель  
                
    Текст = СоздатьОбъект("Текст");
    Текст.ДобавитьСтроку("РАСХОДНАЯ_НАКЛАДНАЯ"+Раз+СокрЛП(Фирма.ЕГРПОУ)+Раз+СокрЛП(Контрагент.ЕГРПОУ)+Раз+"версия_3");
    Текст.ДобавитьСтроку(НомерНакл+Раз+СокрЛП(ДатаДок)+Раз+НомерНакл+Раз+СокрЛП(Фирма.ПолнНаименование)+Раз +СокрЛП(Фирма.СчетПоУмолчанию.БанкНазвание)
+Раз+СокрЛП(Фирма.СчетПоУмолчанию.БанкСчет)+Раз+СокрЛП(Фирма.СчетПоУмолчанию.БанкМФО)+Раз+СокрЛП(Фирма.Телефоны)+Раз+СокрЛП(Фирма.ПочтовыйАдрес)+Раз+""+Раз+""+Раз+Итог("СуммаБезНДС")+Раз+Итог("СуммаСНДС")+Раз+""+Раз+"1"+Раз+"1"+Раз+"2");
    Текст.ДобавитьСтроку("");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл    
            Гр = Товар.НоменклатурнаяГруппа;
        Текст.ДобавитьСтроку(СокрЛП(Товар.Код)+Раз+СокрЛП(Товар.ПолнНаименование)+Раз+СокрЛП(Гр.Код)+Раз+СокрЛП(Гр.Наименование)+
            Раз+""+Раз+""+Раз+""+Раз+""+Раз+"20"+Раз+""+Раз+"*"+Раз+""+Раз+""+Раз+""+Раз+
            СокрЛП(Единица)+Раз+СокрЛП(Количество)+Раз+""+Раз+""+Раз+""+Раз+СокрЛП(ЦенаСНДС)+Раз+СокрЛП(СуммаСНДС));
    КонецЦикла;      
    
    Текст.Записать(ИмяФайла);  
    Сообщить("Накладная записана!!!");
  Форум: Вся 1С · Просмотр сообщения: #176456 · Ответов: 1 · Просмотров: 219
 

>  Откатить назад бухгалтерские итоги
denis84
Отправлено: 25.10.22, 10:08


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


MK-61 @ Вчера, 15:59 * ,
Добрый день! Попробовал у себя на конфигурации 1с7.7 "ПУБ" в монополном режиме изменить расчет БИ. Установил расчет бухгалтерских итогов на 4 квартал 2022. Прошло без вопросов. До этого расчет БИ стоял 4 квартал 2030 года.

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176448 · Ответов: 2 · Просмотров: 248
 

>  Ищу подрядчика для настройки BEF 8.3.19.1529 edition 3.2.17.2
denis84
Отправлено: 21.10.22, 17:52


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Smetana @ Сегодня, 17:17 * ,
Вы имеете ввиду платформа BAF 8.3.19.1529,а конфигурация какая?
  Форум: Офф-топик · Просмотр сообщения: #176437 · Ответов: 4 · Просмотров: 242
 

>  Как оформить html-текст для корректного отображения в браузере
denis84
Отправлено: 19.10.22, 12:41


Оратор
Иконка группы

Группа: Местный
Сообщений: 314
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


kserg2012 @ Сегодня, 11:58 * ,

Вот здесь можно прочитать:

ссылка



1С 8.x : Формирование HTML-документа, содержащего ссылки на объекты базы данных
В данной статье рассматривается способ программного формирования HTML документа, содержащего ссылки на объекты базы данных 1С, такие как справочники, документы и т.д. Показан пример построения обработчика события OnClick ПоляHTMLДокумента, для обработки клика на html-ссылке.

Предисловие
Однажды, дописывая обработку, создающую и модифицирующую, не суть важно какие документы, я подумал, что неплохо было бы вывести для пользователя некое резюме:
“Создан документ такой-то”
“Изменен документ такой-то” и т.д.
От обычного, в таких случаях, вывода информации в окно сообщений я сразу отказался, так как не удобно это, сначала читать в окне сообщений “Создан документ … ” а потом запоминать его номер, открывать соответствующий журнал (или форму списка) и искать там этот документ. А если документов много и пользователь хочет посмотреть все документы?(или выборочно) Насколько это неудобно я убедился при отладке обработки …
То, что в форме есть элемент управления именуемый ПолеHTMLДокумента я конечно знал, но вот представилась возможность познакомиться с ним поближе. Было решено реестр обработанных документов выводить в виде html документа содержащего ссылки на эти самые документы, а по клику на ссылке открывать форму соответствующего документа. Здесь мне многие могут возразить: “А почему бы для этих целей не использовать обычный макет, выводимый в табличный документ, а для открытия документов использовать расшифровку? И чем Ваш способ лучше?” Отвечаю: Конечно можно использовать, и мой способ ничем не лучше. Он просто другой. Ведь у хорошего программиста для решения одной задачи должно быть в арсенале несколько инструментов.
Итак, перейдем от слов к делу, в рамках данной статьи рассмотрим следующую задачу: Сформировать html-документ, содержащий ссылки на элементы справочника номенклатура, по клику требуется открывать форму соответствующего элемента. Создаем новый отчет, его форму, на форме размещаем элемент управления ПолеHTMLДокумента.

Текст модуля формы:
Код 1C v 8.х
  Процедура ДобавитьТекстHTML(ТекстHTML, Элемент);
    // Ссылку будем формировать хитро:
    // Предполагаем что символ "-" не входит в имена объектов метаданных,
    // учавствующих в формировании html
    // Тогда ссылка будет иметь следующий вид:
    // Номенклатура-d341d377-b3b1-11dc-a100-0011d85708ff
    // Передавать нашу ссылку будем через атрибут id
    СсылкаНаЭлемент = Элемент.Метаданные().Имя+"-"
    +Элемент.Ссылка.УникальныйИдентификатор();
    ТекстHTML.ДобавитьСтроку("<A id=""" + СсылкаНаЭлемент + """ href= """
    + Элемент + """ >"+Элемент+"</A><BR>");
КонецПроцедуры

Процедура ДействияФормыСформировать(Кнопка)
    Запрос = Новый Запрос("
    |ВЫБРАТЬ
    |    Номенклатура.Ссылка
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура");
    ТекстHTML = Новый ТекстовыйДокумент;
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        ДобавитьТекстHTML(ТекстHTML, Выборка.Ссылка);
    КонецЦикла;
ЭлементыФормы.ПолеHTMLДокумента.УстановитьТекст(ТекстHTML.ПолучитьТекст());
КонецПроцедуры

Ну вот html мы сформировали, теперь чтобы ссылки “ожили” надо написать обработчик события OnClick элемента управления ПолеHTMLДокумента.
Код 1C v 8.х
  // Функция получает элемент - <A> по данному элементу
// Производит поиск элемента <A> среди родительских элементов данного
//
// Параметры:
// Элемент - COMОбъект, элемент HTML документа,
// по которому нужно найти ссылку
//
// Возвращаемое значение:
// COMОбъект - если ссылка обнаружена, иначе - Неопределено

Функция НайтиСсылку(Элемент)
    Врем = Элемент;
    Пока Врем <> Неопределено Цикл
        Если НРег(Врем.tagName) = "a" Тогда
            Возврат Врем;
        КонецЕсли;
        Врем = Врем.parentElement;
    КонецЦикла;
    Возврат Неопределено;
КонецФункции    // НайтиСсылку(Элемент)

Процедура ПолеHTMLДокументаonclick(Элемент, pEvtObj)
    htmlElement = НайтиСсылку(pEvtObj.srcElement);
    // Анализируем если произошло нажание не ссылку
    Если htmlElement <> Неопределено Тогда
        // Если у ссылки есть идентификатор
        Если СокрЛП(htmlElement.id) <> "" Тогда
            // Получаем адрес ссылки из атрибута id
            СсылкаНаЭлемент = htmlElement.id;
            Разделитель = Найти(СсылкаНаЭлемент,"-");
            Если Разделитель > 0 Тогда
                // Получаем тип элемента
                ТипЭлемента = Лев(СсылкаНаЭлемент,Разделитель-1);
                // Получаем УникальныйИдентификатор
                ГУИД = Сред(СсылкаНаЭлемент,Разделитель+1);
                Справочники[ТипЭлемента].ПолучитьСсылку(
             Новый УникальныйИдентификатор(ГУИД)).ПолучитьФорму().Открыть();
            КонецЕсли;
            // Не отработали нажатие
            pEvtObj.returnValue = Ложь;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры


Всё можно пробовать!

Заключение
Обратите внимание что ссылку я формировал следующим образом:
<ИмяОбъектаМетаданных>-<УникальныйИдентификатор> это сделано для того, чтобы в обработчике onclick можно было определить к какому объекту метаданных относится данный УникальныйИдентификатор, потому что имея ТОЛЬКО УникальныйИдентификатор невозможно определить к какому объекту метаданных он относиться. Точнее возможно, но уж слишком долго и неудобно – путем перебора всех метаданных в цикле, для каждого объекта метаданных выполнять попытку <ОбъектМетаданных>.ПолучитьСсылку(Новый УникальныйИдентификатор(НашУникальныйИдентификатор))
Хотя в нашем примере только один справочник, и указывать его вид было необязательно, и так понятно что это УникальныйИдентификатор элемента справочника Номенклатура, но вдруг Вам потребуется работать с несколькими справочниками, вот тут то мой способ задания ссылки Вам и пригодится. Скачивать файлы может только зарегистрированный пользователь!

P.S. Платформа 8.2 имеет встроенный механизм работы со ссылками на объекты БД и данная задача наверняка упростится, но это уже другая тема.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176429 · Ответов: 1 · Просмотров: 294
 

13 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 28.11.22, 11:29
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!