Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику sava1 ::: Спасибо сказали: 561 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
01.08.13, 10:56 Документ с двумя таблицами печатных форм
Если Выбор=1 Тогда
   Таб.ИсходнаяТаблица("Таблица1");
Иначе Если Выбор=2 Тогда
   Таб.ИсходнаяТаблица("Таблица2");
....
КонецЕсли
Aisha12,
31.07.13, 15:23 как запросом выбрать елементы из груп таблицы Справочника
Выбрать (....)
из справочник
где Ссылка в Иерархии (&списокГрупп) и не (ХХХХ.ЭтоГуппа)

в списокГрупп укладываем нужные группы

или (&списокГрупп) заменить Выборкой
Cos,
29.07.13, 11:57 Отловить действие пометки на удаление из списка документов
Пометка - не удаление. Проверяем ПередЗаписью или ПриЗаписи
meverikxp,
24.05.13, 14:08 Активизировать форму открытого документа
Процедура ПриПовторномОткрытии()
и
Формекс.Окна.НаПереднийПлан(<?>)
ZhenyaYa,
21.05.13, 7:43 1c 7.7 и OpenOffice
Цитата(logist @ 20.05.13, 12:47) *
1С не работает с опенофисом.

Наглое заявление.
Просто с костылями - http://infostart.ru/public/20945/
Mikst,
25.04.13, 10:58 Доработка прав пользователей
Если РольДоступна("ПолныеПрава") Тогда
valera_avp,
16.04.13, 13:10 Ошибка при выгрузке Декларации по НДС за 1 кв
Попробовать удалить в схеме.ХСД строки с <!
andreykyiv@bigmir.net,
29.03.13, 15:55 Запрос остатков номеклатуры
Цитата(Petre @ 29.03.13, 15:27) *
выборку из таблицы оборотов РН объединить с выборкой из таблицы остатков РН.


И что получиться?

1. Выбираем из таблицы ОстаткиОбороты все, что имеет остаток 0 и приход Не равный 0 - и все

ВЫБРАТЬ
    ТоварыНаСкладахОстаткиИОбороты.Номенклатура
ИЗ
    РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&Дата1, &Дата2, Период, ДвиженияИГраницыПериода, Склад = &Склад) КАК ТоварыНаСкладахОстаткиИОбороты
ГДЕ
    ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход <> 0
    И ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток = 0
Fabri,
05.03.13, 12:59 Импорт выписки с КБ iFobs (ОТП)
Вот для ХМЛ:

Функция ИмпортXML(Параметры)
    ФайлXML = Новый ЧтениеXML;
    ИмяФайла = Параметры.ИмяФайла;
    
    Попытка
        ФайлXML.ОткрытьФайл(ИмяФайла);
    Исключение
        Предупреждение("Ошибка открытия файла " + ИмяФайла);
        Возврат Неопределено;
    КонецПопытки;        
    
    тзВыписка =  Новый ТаблицаЗначений;
    тзВыписка.Колонки.Добавить("НомерПП");
    тзВыписка.Колонки.Добавить("Приход");
    тзВыписка.Колонки.Добавить("Расход");
    тзВыписка.Колонки.Добавить("ОКПО");
    тзВыписка.Колонки.Добавить("Контрагент");
    тзВыписка.Колонки.Добавить("МФО");
    тзВыписка.Колонки.Добавить("РСчет");
    тзВыписка.Колонки.Добавить("Содержание");
    
    КолвоЗаписей = 0;
    Пока ФайлXML.Прочитать() Цикл
        ИмяТега = ФайлXML.Имя;
        Если ИмяТега = "ROW" И ФайлXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
            
            ДатаВыписки = ФайлXML.ПолучитьАтрибут("DOCUMENTDATE");  // 20081110
            // Проверка на дату выписки
            Если ДатаВыписки <> Формат(Параметры.ДатаДок,"ДФ=yyyyMMdd") И ДатаВыписки <> Формат(Параметры.ДатаДок,"ДФ=dd.MM.yyyy") Тогда
                Продолжить;
            КонецЕсли;    
            
            РСчетА = СокрЛП(ФайлXML.ПолучитьАтрибут("ACCOUNTNO"));
            РСчетБ = СокрЛП(ФайлXML.ПолучитьАтрибут("CORRACCOUNTNO"));
            
            Если РСчетБ = Параметры.РСчет Тогда // дебет
                НовСтрока = тзВыписка.Добавить();
                НовСтрока.Приход        = Число(ФайлXML.ПолучитьАтрибут("AMOUNT"))/100;
                НовСтрока.Расход        = 0;
                
                НовСтрока.РСчет            = СокрЛП(Формат(РСчетА,"ЧГ=0"));
                    
                //НовСтрока.ОКПО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRIDENTIFYCODE"),"ЧГ=0"));
                //НовСтрока.МФО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("BANKID"),"ЧГ=0"));
                //НовСтрока.Контрагент    = СокрЛП(ФайлXML.ПолучитьАтрибут("CORRCONTRAGENTSNAME"));
                
            ИначеЕсли РСчетА = Параметры.РСчет Тогда // кредит    
                НовСтрока = тзВыписка.Добавить();
                НовСтрока.Приход        = 0;
                НовСтрока.Расход        = Число(ФайлXML.ПолучитьАтрибут("AMOUNT"))/100;
                
                НовСтрока.РСчет            = СокрЛП(Формат(РСчетБ,"ЧГ=0"));
                    
                //НовСтрока.ОКПО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRIDENTIFYCODE"),"ЧГ=0"));
                //НовСтрока.МФО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRBANKID"),"ЧГ=0"));
                //НовСтрока.Контрагент    = СокрЛП(ФайлXML.ПолучитьАтрибут("CORRSNAME"));
            Иначе
                Продолжить;
            КонецЕсли;    
            
            НовСтрока.ОКПО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRIDENTIFYCODE"),"ЧГ=0"));
            НовСтрока.МФО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRBANKID"),"ЧГ=0"));
            НовСтрока.Контрагент    = СокрЛП(ФайлXML.ПолучитьАтрибут("CORRSNAME"));
            
                
            НовСтрока.Содержание     = СокрЛП(ФайлXML.ПолучитьАтрибут("DETAILSOFPAYMENT"));
            НовСтрока.НомерПП         = СокрЛП(ФайлXML.ПолучитьАтрибут("DOCUMENTNO"));
            
            КолвоЗаписей = КолвоЗаписей + 1;
            
        Иначе
            Продолжить;    
        КонецЕсли;    
        
    КонецЦикла;      
    
    
    Если НЕ тзВыписка.Количество() И КолвоЗаписей > 0 Тогда
        Предупреждение("В текущем файле нет платежей с данной датой выписки и расчетным счетом!");
    КонецЕсли;
    
    ФайлXML.Закрыть();
    
    Возврат тзВыписка;
Ardi, Ortman_fon_but,
15.02.13, 13:04 Улыбнуло
с мисты

С баша:
ххх: Леша сегодня назвал наших программистов 1С - "женская консультация"
Flexy, volodya1122,
14.02.13, 14:58 Експорт таблиць персоніфікації з 1С 7.7 ЗіК в АРМ Звіт "Єдиний внесок"
ушло
oleg1488,
14.02.13, 12:31 Експорт таблиць персоніфікації з 1С 7.7 ЗіК в АРМ Звіт "Єдиний внесок"
Медок обновите до 119

c\Documents and Settings\All Users\Application Data\Medoc\Medoc\help\manuals
Структура файлов импорта таблиц (5-9) Додатка 4, ЕСВ (DBF).pdf
oleg1488,
13.02.13, 16:52 Перенести Движения документа
Значение Регистратора надо-бы поменять

Цитата(alex040269 @ 13.02.13, 16:49) *
можно перебрать коллекцию

Для Каждого НаборЗаписейРегистра из Движения Цикл
    НаборЗаписейРегистра.Прочитать();

    Для Каждого Запись из НаборЗаписейРегистра Цикл    

        // Чтение и модификация очередного движения.

    КонецЦикла;

КонецЦикла;
Домовик,
31.01.13, 15:58 Убрать контроль отрицательных остатков
1. Первую проверку убираем (комментируем)
2. Вторая часть сохраняется (в части списания наличных партий)
3. После списания существ. партий остается некоторое количество (КоличествоНадоСписать). Вот его списываем без партии и без стоимости - уходим в минуса по количеству. потом эту ситуацию можно найти анализом регистра или тупым перепроведением расходных документов.
alexkhua,
21.12.12, 13:01 Ошибка при переборе записей в таблице значений
Или получать в ТЧ поле Штрихкод (левое соединение по номенклатуре) или отдельно заполнять ТЧ с отбором в запросе

Пример отбора по полю ТМЦ
тОтбор = ЭлементыФормы.тФил.ОтборСтрок;
    Если тОтбор.Найти("ТМЦ") = Неопределено Тогда тОтбор.Добавить("ТМЦ");
    КонецЕсли;
    тОтбор["ТМЦ"].Значение = текТМЦ;
    тОтбор["ТМЦ"].ВидСравнения  = ВидСравнения.Равно;
    тОтбор["ТМЦ"].Использование = Истина;


Для этого нужно чтобы поле Штрихкод было в ТЧ (точне наличиеШтрихкода=1/0)
Fabri,
21.12.12, 11:48 Ошибка при переборе записей в таблице значений
что есть Товары ?
Если ТаблПоле проще установить отбор чем удалять.
Fabri,
20.12.12, 11:59 РаспрЕдЕление ролей
Для каждого пользователя своя роль
mavrik,
18.12.12, 7:46 Табличный документ
ПоказатьУровеньГруппировокСтрок(<Уровень>)
alex040269, Ardi,
10.12.12, 14:39 Удалить историю значений реквизита
Объект "Периодический"
ZhenyaYa,
31.10.12, 14:36 Ошибка при создании Левого Соединения
БРЕД....
zay,
23.10.12, 9:10 Заповнення ТЗ з регистра
Да. Добавить в запрос Функция Мин = Сумма(Минуты)

может проще использовать СводныеИтоги(<Измерение1>,<Измерение2>...)
Циган,
17.10.12, 12:59 Групировка в запросе
Читаем - ОбходРезультатаЗапроса.ПоГруппировкам а заодно Запрос.Итоги
Fabri,
11.10.12, 10:29 Условие Между
Итак:
1.Запрос надо будет формировать динамически (по-большому счету) ;
секции запроса через Объединить
количество секций равно количеству тарифов.
Приблизительно так: (для двух тарифов)

выбрать
     // здесь лирика
     (&КонецТарифа1 - выбрать когда НачалоРаботы<&НачалоТарифа1 тогда  &НачалоТарифа1 иначе НачалоРаботы конец ) как ПродолжительностьРаботы
из документа
где док.НачалоРаботы<&Конецтарифа1 или конецРаботы>&началоТарифа1    

объединить

выбрать
     // здесь лирика
     (&КонецТарифа2 - выбрать когда НачалоРаботы<&НачалоТарифа2 тогда  &НачалоТарифа2 иначе НачалоРаботы конец ) как ПродолжительностьРаботы
из документа
где док.НачалоРаботы<&Конецтарифа2 или конецРаботы>&началоТарифа2


и т.д . до упора

итог:
выбираем из регистра все тарифы
проходя по выборке, строим текст запроса, устанавливаем параметры
выполняем запрос, получаем И-строк (по количеству тарифов)
если не надо И-строк - группируем инфо в запросе
VolandMaster,
19.09.12, 7:07 Отчет по всем счетам и всем субконто развернуто
Прямой запрос по проводкам (для примера (по 3 субконто)):

    ВсеСубконто = ""; ВсСкД=""; ВсСкК="";
    Для ъ = 1 По 3 Цикл
        ВсСкД=ВсСкД+",DTSC"+(ъ-1)+" [СубкД"+ъ+" :Subconto],VDTSC"+(ъ-1)+" СубкД"+ъ+"_вид";
        ВсСкК=ВсСкК+",KTSC"+(ъ-1)+" [СубкК"+ъ+" :Subconto],VKTSC"+(ъ-1)+" СубкК"+ъ+"_вид";
    КонецЦикла;
    ВсеСубконто = ВсСкД+ВсСкК;

    запрос = БазаД.НовыйЗапрос();        
    текст="
    |select date ДатаПр,sum [Сум :Number.19.2], amount [Кво :Number.19.3], accdtid [СчД :Счет.Основной], accktid [СчК :Счет.Основной]"+ВсеСубконто+"
    |from __1s_entry
    |where Date BETWEEN @НачДата AND @КонДата     
    |and sp4373 = @OurFirm    
    |and accktid = @СчВД
    |and ktsc1 = @пВД" + УслДт +"
    |and amount<>0";    
    запрос.Подготовить(текст);



 ! 

Выделяйте код!
 
awp,
18.09.12, 15:57 Отчет по всем счетам и всем субконто развернуто
Прямой запрос к таблицам - там по-фигу какого типа и т.д
awp,

17 страниц V  « < 14 15 16 17 >
RSS Текстовая версия Сейчас: 20.09.20, 6:09
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!