Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Не получается создать форму обработки и заполнить её табличную часть данными
Lamozavrik
Отправлено: 11.01.21, 17:08


Молчаливый
*

Группа: Пользователи
Сообщений: 5
Регистрация: 11.01.21
Пользователь №: 71503


denis84 @ Сегодня, 16:53 * ,
Сейчас выгружу и кину

denis84 @ Сегодня, 16:53 * ,
Спасибо. Кинул
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169663 · Ответов: 9 · Просмотров: 494
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
Lamozavrik
Отправлено: 11.01.21, 16:48


Молчаливый
*

Группа: Пользователи
Сообщений: 5
Регистрация: 11.01.21
Пользователь №: 71503


denis84 @ Сегодня, 16:43 * ,
Пишет что Поле объекта не найдено (НомерЯщика), хотя реквизиты формы есть, реквизиты табличной части есть...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169661 · Ответов: 9 · Просмотров: 494
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
Lamozavrik
Отправлено: 11.01.21, 16:35


Молчаливый
*

Группа: Пользователи
Сообщений: 5
Регистрация: 11.01.21
Пользователь №: 71503


denis84 @ Сегодня, 16:16 * ,
Сиситема такая: оператор взвешивает товар, вес и номер ящика заполняются в табличную часть "Товары", и эти данные выводятся в форме "Товары". Далее я беру эти данные с табличной части "Товары" и перебираю в цикле. И вот "ТекСтрока" - Это одна строка этих данных. Мне этими данными нужно заполнить другую табличную часть (Спецификация) и вывести эти данные в форме "ФормаСпецификации". Только вот при открытии эта табличная часть пустая. Не заполняется

Цитата(denis84 @ 11.01.21, 16:28) *
"Товары" табличная часть этой формы? Попробуйте написать "Форма.Товары"

Данные оттуда берутся, всё нормально. Выводятся в цикле через "Сообщить". Проблема в том, что не выходит заполнить этими данными другую таблицу
ФормаСпецификации = Обработки.ИнтерфейсМаркировки.ПолучитьФорму("ФормаСпецификации"); //Получаю новую форму
    
    Для каждого ТекСтрока из Товары Цикл //В цикле перебираю данные из табличной части "Товары". В "ТекСтрока" всё присутствует
        СтрокаТабличнойЧасти = Спецификация.Добавить(); //Добавляю строку в табличную часть "Спецификации"
        СтрокаТабличнойЧасти.НомерЯщика = Число(ТекСтрока.ПорядковыйНомер); //Заполняю значения реквизитов
        СтрокаТабличнойЧасти.НеттоЯщика = Число(ТекСтрока.КоличествоNetto);
    КонецЦикла;

ФормаСпецификации.ОткрытьМодально(); //Вывожу форму, но табличная часть пустая


При этом ошибок никаких нет
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169659 · Ответов: 9 · Просмотров: 494
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
Lamozavrik
Отправлено: 11.01.21, 16:23


Молчаливый
*

Группа: Пользователи
Сообщений: 5
Регистрация: 11.01.21
Пользователь №: 71503


denis84 @ Сегодня, 16:16 * ,
Простите, не совсем понимаю. Данные у меня берутся с другой формы. Если формировать документ с макета, то всё ок.
Товары - это тоже табличная часть. Если выводить в цикле через "Сообщить", то всё нормально выводится. Я просто её строки перебираю в цикле и хочу этими данными заполнить табличную часть другой формы.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169657 · Ответов: 9 · Просмотров: 494
 

>  Не получается создать форму обработки и заполнить её табличную часть данными
Lamozavrik
Отправлено: 11.01.21, 15:48


Молчаливый
*

Группа: Пользователи
Сообщений: 5
Регистрация: 11.01.21
Пользователь №: 71503


Здравствуйте всем, уважаемые форумчане. Заранее прошу прощения и не кидаться камнями, потому что знаю что задача плёвая, но не могу решить, так как в программировании 1С совсем чайник. Собственно сама задача. Мне нужно создать форму обработки, заполнить её табличную часть данными в цикле и открыть её модально. Вроде всё просто, но не выходит заполнить табличную часть.
1С 8.2.19.130, Форма обработки обычная. Создал я эту форму с названием ФормаСпецификации. В этой форме есть табличная часть (Спецификация). Далее создаю табличную часть, называю её Спецификация, там всего 2 реквизита (НомерЯщика и НеттоЯщика), и в свойствах формы в табличной части, в поле "Данные" выбираю её. Необходимо при нажатии кнопки чтобы эта форма вывелась модально и заполнились данные табличной части. Вот процедура при нажатии кнопки.
Процедура СформироватьСпецификацию(Элемент)
        
        ФормаСпецификации = Обработки.ИнтерфейсМаркировки.ПолучитьФорму("ФормаСпецификации");
    
    Для каждого ТекСтрока из Товары Цикл
        СтрокаТабличнойЧасти = Спецификация.Добавить();
        СтрокаТабличнойЧасти.НомерЯщика = Число(ТекСтрока.ПорядковыйНомер);
        СтрокаТабличнойЧасти.НеттоЯщика = Число(ТекСтрока.КоличествоNetto);
    КонецЦикла;
    
    ФормаСпецификации.ОткрытьМодально();

КонецПроцедуры


Форма открывается, но табличная часть пустая. Не понимаю что не так. Заранее спасибо!
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #169654 · Ответов: 9 · Просмотров: 494
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 26.07.21, 6:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!